Subject: [KEYPROV] [PSKC] 10/04/08 Conf call minutes

From: "Philip Hoyer" <[email-masked]>
Date: Thu, 10 Apr 2008 17:56:04 +0200

Attendees: Phillip Hallam-Baker, Salah Macchani, Ming Pei, Philip Hoyer

*	Discussion around IANA considerations with Phillip Hallam Baker
to create new proposal to add to PSKC spec around URLs for algorithm
identifiers and URLs for Key Data semantic definitions
*	Discussion around KeyType (CommonKeyProperties), Philip to
create proposal in terms of schema. Need to agree on a name currently we
have:

	*	KeyTemplate - proposed by Philip Hoyer
	*	KeyHeader - proposed by Andrea Doherty
	*	CommonKeyProperties (discussed on call)
	*	Others?

*	Salah to review use case section - based on comments from
Andrea, himself and document received from Sean Turner - to send by
beginning of next week
*	Ming to work on terminology section - to send beginning of next
week
*	Philip and address general comments from Andrea

Proposal from Philip to have a new version of the Draft by 18th of
April.

Philip will aggregate changes.

To be able to see where we are there will be a sync up call on Tuesday
15th at 4:30 GMT. Currently only Ming is available hence Philip is
proposing to call Ming directly.

Thanks for all the hard work,

________________________________

Philip Hoyer 

Senior Architect - Office of CTO

ActivIdentity (UK)

109 Borough High Street

London SE1 1NL

Telephone: +44 (0) 20 7744 6248

Direct: +44 (0) 20 7744 6455

Fax: +44 (0) 20 7744 6249

Private and confidential: This message and any attachments may contain

privileged / confidential information. If you are not an intended
recipient,

you must not copy, distribute, discuss or take any action in reliance on
it.

If you have received this communication in error, please notify the
sender

and delete this message immediately.

_______________________________________________
KEYPROV mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/keyprov

---

From: "Pei, Mingliang" <[email-masked]>
Date: Mon, 14 Apr 2008 21:40:18 -0700

Section 2 is revised to include Terminology definitions in addition to
Key Words. Note that section 5 describes XML definitions, which
shouldn't be confused with section 2, for example, "device" is described
in both place. See content below. Also reference sections are revised.
Please review.
 
-----------

2.  Terminology
 
2.1.  Key Words
 
   The key words "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL NOT",
   "SHOULD", "SHOULD NOT", "RECOMMENDED", "MAY", and "OPTIONAL" in this
   document are to be interpreted as described in [RFC2119].
 
2.2.  Definitions
 
   This section defines terms used in this document.  The same terms may
   be defined differently in other documents.
 
   Authentication Token:  A physical device that an authorized user of
      computer services is given to aid in authentication.  The term may
      also refer to software tokens.
 
   Bulk Provisioning:  Provision keys to devices in bulk
 
   Cryptographic Key:  A parameter used in conjunction with a
      cryptographic algorithm that determines its operation in such a
      way that an entity with knowledge of the key can reproduce or
      reverse the operation, while an entity without knowledge of the
      key cannot [NIST-SP800-57]
 
   Cryptographic Token:  See Authentication Token
 
   Device:  A physical piece of hardware, or a software framework, that
      hosts symmetric keys
 
   Device ID (DeviceId):  A unique identifier for the device,
      representing the identifying criteria to uniquely identify a
      device
 
   Dynamic Provisioning:  Provision keys to an end-user's device
 
   Encryption Key:  A key used to encrypt key
 
   Key:  See Cryptographic Key
 
   Hardware Token:  See Authentication Token
 
   Key Algorithm:  A well-defined computational procedure that takes
      variable inputs including a cryptographic key and produces an
      output.

   Key Container:  An object that encapsulates symmetric keys and their
      attributes for set of devices
 
   Key ID (KeyID):  A unique identifier for the symmetric key
 
   Key Issuer:  An organization that issues symmetric keys to end-users
 
   Key Type:  The type of symmetric key cryptographic methods for which
      the key will be used (e.g., OATH HOTP or RSA SecurID
      authentication, AES encryption, etc.)
 
   KeyType:  The XML schema type definition for a key
 
   Secret Key:  The symmetric key data
 
   Software Token:  A type of authentication token that is stored on a
      general-purpose electronic device such as a desktop computer,
      laptop, PDA, or mobile phone
 
   Token:  See Authentication Token
 
   User:  The person or client to whom devices are issued
 
   User ID:  A unique identifier for the user or client
 
2.3.  Notation
 
   In examples, "C:" and "S:" indicate lines sent by the client and
   server respectively.
 
   In the text below, OTP refers to one time password.

- Ming

	From: Philip Hoyer [mailto:[email-masked]] 
	Sent: Thursday, April 10, 2008 8:56 AM
	To: Pei, Mingliang; Hallam-Baker, Phillip;
[email-masked]; [email-masked]
	Cc: [email-masked]; [email-masked]; Turner, Sean P.
	Subject: [PSKC] 10/04/08 Conf call minutes

	Attendees: Phillip Hallam-Baker, Salah Macchani, Ming Pei,
Philip Hoyer

	*	Discussion around IANA considerations with Phillip
Hallam Baker to create new proposal to add to PSKC spec around URLs for
algorithm identifiers and URLs for Key Data semantic definitions 
	*	Discussion around KeyType (CommonKeyProperties), Philip
to create proposal in terms of schema. Need to agree on a name currently
we have: 

	*	Salah to review use case section - based on comments
from Andrea, himself and document received from Sean Turner - to send by
beginning of next week 
	*	Ming to work on terminology section - to send beginning
of next week 
	*	Philip and address general comments from Andrea 

	Proposal from Philip to have a new version of the Draft by 18th
of April.

	To be able to see where we are there will be a sync up call on
Tuesday 15th at 4:30 GMT. Currently only Ming is available hence Philip
is proposing to call Ming directly.

	 

	Philip Hoyer 

	ActivIdentity (UK)

	109 Borough High Street

	London SE1 1NL

	Private and confidential: This message and any attachments may
contain

	privileged / confidential information. If you are not an
intended recipient,

	you must not copy, distribute, discuss or take any action in
reliance on it.

	If you have received this communication in error, please notify
the sender

---

From: "Hannes Tschofenig" <[email-masked]>
Date: Tue, 15 Apr 2008 08:48:09 +0200

Ming, 

a few minor comments. 

>    Bulk Provisioning:  Provision keys to devices in bulk

I would write: 

"
Bulk Provisioning:  Making more then one key container available in a single execution step (e.g., by providing more than a single key container within a PSKC-compliant file).
"

>    Dynamic Provisioning:  Provision keys to an end-user's device
  
Isn't this was you call "online" (in comparison to offline) provisioning in some other places and has not really anything todo with the recipient of the interaction itself. 

Maybe we should therefore say something like:

"
Dynamic Provisioning:  Usage of a protocol, such as DSKPP, to make a key container available to a recipient 
"

>    KeyType:  The XML schema type definition for a key

Why did you put KeyType as the only XML element from the schema into the terminology section? 

Ciao
Hannes

-------- Original-Nachricht --------
> Datum: Mon, 14 Apr 2008 21:40:18 -0700
> Von: "Pei, Mingliang" <[email-masked]>
> An: "Philip Hoyer" <[email-masked]>, "Hallam-Baker, Phillip" <[email-masked]>, [email-masked], [email-masked]
> CC: [email-masked], [email-masked], "Turner, Sean P." <[email-masked]>
> Betreff: RE: [PSKC] 10/04/08 Conf call minutes

---

From: "Pei, Mingliang" <[email-masked]>
Date: Tue, 15 Apr 2008 10:51:24 -0700

Hi Hannes,

Thank you for the comments. Please see comments inline.

- Ming

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Hannes Tschofenig
Sent: Monday, April 14, 2008 11:48 PM
To: [email-masked]
Subject: [KEYPROV] Terminology Section

Ming, 

a few minor comments. 

I would write: 

"
Bulk Provisioning:  Making more then one key container available in a
single execution step (e.g., by providing more than a single key
container within a PSKC-compliant file).
"

MP: I tried to not imply the protocol usage to the task. Bulk
provisioning could be done by other protocol, for example, XKMS. The
meaning would be the same in both context. Your change is better; only
part is about the usage of "Key Container" in context of PSKC where one
key container can contain bulk of keys. So minor changes further here:

"
Bulk Provisioning:  Making more than one keys available in a single
execution step (e.g., by providing one or more key containers in a
PSKC-compliant file).
"

>    Dynamic Provisioning:  Provision keys to an end-user's device
  
Isn't this was you call "online" (in comparison to offline) provisioning
in some other places and has not really anything todo with the recipient
of the interaction itself. 

"
Dynamic Provisioning:  Usage of a protocol, such as DSKPP, to make a key
container available to a recipient "

MP: Agreed.

>    KeyType:  The XML schema type definition for a key

Why did you put KeyType as the only XML element from the schema into the
terminology section? 

MP: It was intended to show the difference between "Key Type" and
"KeyType" - phrases used in use cases vs. XML. It will be removed.

Ciao
Hannes

-------- Original-Nachricht --------
> An: "Philip Hoyer" <[email-masked]>, "Hallam-Baker,
Phillip" <[email-masked]>, [email-masked],
[email-masked]