Subject: Re: [KEYPROV] FW: Key package vs key container

From: [email-masked]
Date: Thu, 29 Jan 2009 09:13:02 -0500

Sean,
For better alignment with PSKC, could it be called Key Container?
Andrea 

-----Original Message-----
From: Sean Turner [mailto:[email-masked]] 
Sent: Thursday, January 29, 2009 9:12 AM
To: Doherty, Andrea
Subject: Re: FW: [KEYPROV] Key package vs key container

The ASN.1 ID can handle multiple keys.

spt

[email-masked] wrote:
> Forgot to cc you...
> 
> -----Original Message-----
> From: Doherty, Andrea 
> Sent: Thursday, January 29, 2009 8:52 AM
> To: 'Pei, Mingliang'; [email-masked]'
> Subject: RE: [KEYPROV] Key package vs key container
> 
> The reason that we chose Key Package over Key Container is because
PSKC
> Key Container may include multiple keys whereas DSKPP only handles
one.
> 
> 
> Sean - did you use Key Package for the same reason?  I thought the
ASN.1
> could handle multiple keys?
> 
> Ming - what does PSKC refer to as the thing that holds a single key?
> What about Token Key Attributes?
> 
> Andrea 
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On
> Behalf Of Pei, Mingliang
> Sent: Wednesday, January 28, 2009 9:39 PM
> To: Doherty, Andrea; [email-masked]
> Subject: Re: [KEYPROV] Key package vs key container
> 
> 
> We have been using "Key xxx" to describe the target that DSKPP and
PSKC
> provision. The specifications deal with key provisioning after all.
> "Token Attributes" seems to be away from "key"; I don't feel that it
is
> better than "Key Package". I can live with "Key Container" in DSKPP -
> the default is PSKC Key Container, and ASN.1 version is KeyPackage.
> 
> - Ming
> 
>> -----Original Message-----
>> From: [email-masked] 
>> [mailto:[email-masked]] On Behalf Of [email-masked]
>> Sent: Wednesday, January 28, 2009 5:47 PM
>> To: [email-masked]
>> Subject: [KEYPROV] Key package vs key container
>>
>> The following comment was provided re our use of 'Key 
>> Package' in DSKPP:
>>           "Key Package", which is slightly confusing name for 
>> something that doesn't include a key, at least in all 
>> protocol variants. PSKC calls it "Key Container".)
>>
>> The suggested change is for DSKPP to change 'Key Package' to 
>> 'Token Attributes'.  Assuming we change 'Cryptographic 
>> Module' to 'Authentication Token', I think 'Token Attributes' 
>> is much clearer and better aligned with PSKC.
>>
>> I'll proceed accordingly unless I hear something to the 
>> contrary within the next day or two.
>> Thanks,
>> Andrea
>> _______________________________________________
>> KEYPROV mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/keyprov
>>
> _______________________________________________
> KEYPROV mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/keyprov
> 
> 

_______________________________________________
KEYPROV mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/keyprov

---

From: "Philip Hoyer" <[email-masked]>
Date: Thu, 29 Jan 2009 15:44:46 +0100

Key Container is a good idea in my opinion.
Philip

________________________________

From: [email-masked] 
To: Philip Hoyer; [email-masked] ; [email-masked] 
Sent: Thu Jan 29 15:38:11 2009
Subject: RE: [KEYPROV] Key package vs key container 

Philip,
We've always used the term 'K_TOKEN', i.e., Key Token.
Our emails crossed...please let me know what you think about using Key Container rather than Key Package in DSKPP and ASN.1 docs (---I agree Token Key Attributes instead of Key Package is not a good idea).
Andrea

________________________________

From: Philip Hoyer [mailto:[email-masked]] 
Sent: Thursday, January 29, 2009 9:36 AM
To: Doherty, Andrea; [email-masked]; [email-masked]
Subject: Re: [KEYPROV] Key package vs key container

Andrea,
I do not think this is a great idea since I am sure people will use DSKPP and PSKC to provision keys that are not authentication related.
Philip

----- Original Message -----
From: [email-masked] <[email-masked]>
To: [email-masked] <[email-masked]>; [email-masked] <[email-masked]>
Sent: Thu Jan 29 14:55:44 2009
Subject: Re: [KEYPROV] Key package vs key container

Ming,
FYI -
Instead of "Key": if we change from crypto module to Authentication
Token and Token Algorithm, we can also refer to Token Key (aka K_TOKEN),
and then Token Attributes (I agree, better to have Key in the label, so
perhaps 'Token Key Attributes').  Please refer to Sec 2.1.1 of the draft
I sent on Tuesday.
Andrea

-----Original Message-----

We have been using "Key xxx" to describe the target that DSKPP and PSKC
provision. The specifications deal with key provisioning after all.
"Token Attributes" seems to be away from "key"; I don't feel that it is
better than "Key Package". I can live with "Key Container" in DSKPP -
the default is PSKC Key Container, and ASN.1 version is KeyPackage.

- Ming