Subject: [KEYPROV] Pre-Shared Secret Based Encryption

From: "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>
Date: Tue, 20 Jan 2009 17:41:43 +0200

Hi all, 

Section 6.1 of
http://www.ietf.org/internet-drafts/draft-ietf-keyprov-pskc-00.txt says:

"
   When protecting the payload with pre-shared keys implementations
   SHOULD set the name of the specific pre-shared key in the <KeyName>
   element inside the <EncryptionKey> element.
"

Whenever there is a SHOULD (instead of a MUST) then it is necessary to
indicate under what conditions the <KeyName> element is present. If the
<KeyName> element is absent then how would the recipient know what key
to select for decryption. 

Ciao
Hannes
_______________________________________________
KEYPROV mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/keyprov

---

From: "Philip Hoyer" <[email-masked]>
Date: Wed, 21 Jan 2009 10:26:55 +0100

Philip

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Tschofenig, Hannes (NSN - FI/Espoo)
Sent: Tuesday, January 20, 2009 3:42 PM
To: [email-masked]
Subject: [KEYPROV] Pre-Shared Secret Based Encryption

Hi all, 

Section 6.1 of

"

Ciao
Hannes

---

From: "Tschofenig, Hannes (NSN - FI/Espoo)" <[email-masked]>
Date: Wed, 21 Jan 2009 13:28:43 +0200

>From: ext Philip Hoyer [mailto:[email-masked]] 
>Sent: 21 January, 2009 11:27
>To: Tschofenig, Hannes (NSN - FI/Espoo); [email-masked]
>Subject: RE: [KEYPROV] Pre-Shared Secret Based Encryption
>
>I am of the opinion that we can change this to MUST.
>
>Philip
>
>From: [email-masked] 
>[mailto:[email-masked]] On Behalf Of Tschofenig, 
>Hannes (NSN - FI/Espoo)
>Whenever there is a SHOULD (instead of a MUST) then it is 
>necessary to indicate under what conditions the <KeyName> 
>element is present. If the <KeyName> element is absent then 
>how would the recipient know what key to select for decryption. 
>
>Ciao
>Hannes

---

From: "Pei, Mingliang" <[email-masked]>
Date: Wed, 21 Jan 2009 14:52:51 -0800

- Ming 

> Sent: Wednesday, January 21, 2009 3:29 AM
> To: ext Philip Hoyer; [email-masked]
> Subject: Re: [KEYPROV] Pre-Shared Secret Based Encryption
> 
> Sounds good to me. 
>  
> 
> Hannes (NSN 
> >- FI/Espoo)
> necessary to