Subject: Re: [KEYPROV] DISCUSS and COMMENT: draft-ietf-keyprov-symmetrickeyformat

From: Sean Turner <[email-masked]>
Date: Sat, 24 Apr 2010 12:38:16 -0400

I got two comments that I was hoping the PSKC authors could help me with 
because they will probably get the exact same DISCUSS and COMMENT from 
Alexey:

> Alexey Melnikov wrote:
>DISCUSS
>> 3.3.5:
>>
>> o pinUsageMode indicates the way the PIN is used during the usage of 
>>      the key.  The following values are defined: Local, Prepend,      
>> Append, Algorithmic.
>>
>> The meaning of the choices is not clear to me. So I don't think
>> they can be used in an interoperable fashion.

Is there some text lounging around that I can use or do we have to come 
up with our own?

 >COMMENT
>> 3.2.7. Algorithm Parameters
>>
>>   o min defines the minimum size of the challenge accepted by the 
>>         device for CR mode.  If encoding is 'DECIMAL', 'HEXADECIMAL' 
>> or         'ALPHANUMERIC' this value indicates the minimum number of 
>>         digits/characters.
>>
>> So just to double check: for a HEXADECIMAL value "ABCD", min is 4, not 2?
>> (The same question about "max", ResponseFormat/"length", 
>> PINPolicy/"minLength" & "maxLength")
>>
>>         If encoding is 'BASE64' or 'BINARY', this         value 
>> indicates the minimum number of bytes of the unencoded         value.

Is he correct or is there some other interpretation?

---

From: Sean Turner <[email-masked]>
Date: Sun, 25 Apr 2010 20:52:43 -0400

> Is there some text lounging around that I can use or do we have to come 

I found the text in PSKC.

> Is he correct or is there some other interpretation?

Still curious about this one.

---

From: "Philip Hoyer" <[email-masked]>
Date: Mon, 26 Apr 2010 10:37:54 +0200

Sean,
SO you found the text about the PIN, good.

About the length he is correct, so HEX 'ABCD' is min 4 as it is the
number of characters (each character can be 0-f in hex).
This is more custom to use length as it is more String or length of
display characters on a device related (LCD for example)

For binary and base64 encoded values it is more custom to put length as
the number of encoded bytes. So 'ABCD' would be 2 as it is 2 bytes
(obviously it would not be ABCD but the B64 or binary form of 'ABCD')

Do you think we need to amend the text with an example for HEX?

Thanks for the work,

Philip

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On
Behalf Of Sean Turner
Sent: Monday, April 26, 2010 1:53 AM
To: KEYPROV
Subject: Re: [KEYPROV] DISCUSS and
COMMENT:draft-ietf-keyprov-symmetrickeyformat

Still curious about this one.
_______________________________________________
KEYPROV mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/keyprov

---

From: Anders Rundgren <[email-masked]>
Date: Mon, 26 Apr 2010 12:00:55 +0200

I don't see that Hex or bas64 differs in this respect, they
are usually only two different ways of representing binary.
The length would then be for the resulting binary.

Anders

---

From: Sean Turner <[email-masked]>
Date: Mon, 26 Apr 2010 08:16:23 -0400

> SO you found the text about the PIN, good.

My hope is that he's not really saying the text in PSKC is vague.  I'm 
hoping to just point there as opposed to copying it.

> Do you think we need to amend the text with an example for HEX?

No, I think he was just asking a simple question.  But, he might ask for 
this when he reviews PSKC - we'll have to wait and see.

---

From: "Pei, Mingliang" <[email-masked]>
Date: Tue, 27 Apr 2010 16:36:23 -0700

Agreed. Thanks Philip. - Ming 

> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Philip Hoyer
> Sent: Monday, April 26, 2010 1:38 AM
> To: Sean Turner; KEYPROV
> Subject: Re: [KEYPROV] DISCUSS 
> andCOMMENT:draft-ietf-keyprov-symmetrickeyformat
> 
> Sean,
> About the length he is correct, so HEX 'ABCD' is min 4 as it 
> is the number of characters (each character can be 0-f in hex).
> This is more custom to use length as it is more String or 
> length of display characters on a device related (LCD for example)
> 
> For binary and base64 encoded values it is more custom to put 
> length as the number of encoded bytes. So 'ABCD' would be 2 
> as it is 2 bytes (obviously it would not be ABCD but the B64 
> or binary form of 'ABCD')
> 
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Sean Turner
> >>> The meaning of the choices is not clear to me. So I don't 
> think they 
> >>> can be used in an interoperable fashion.
> > 
> >>> So just to double check: for a HEXADECIMAL value "ABCD", 
> min is 4, 
> >>> not 2?