Subject: [kitten] Clarification on use of per-message tokens

From: "Cantor, Scott" <[email-masked]>
Date: Wed, 23 Nov 2011 15:42:56 +0000

Sam's helping me with some pointers on getting key derivation added to the
SAML-EC draft, but I had a general question. Am I correct in assuming that
one of the purposes of channel binding is to obviate the need for doing
sign/seal at the message layer?

Just trying to think about the use cases a bit.

-- Scott

---

From: Nico Williams <[email-masked]>
Date: Wed, 23 Nov 2011 10:42:23 -0600

> sign/seal at the message layer?

Yes, but there are a number of standards-track Internet protocols that use
the GSS-API and its per-message tokens (DNS GSS-TSIG, SSHv2, RPCSEC_GSSv1,
SASL/GS1, ...).

Nico
--