Subject: [kitten] Consensus Calls for draft-ietf-kitten-aes-cts-hmac-sha2

From: Shawn M Emery <[email-masked]>
Date: Wed, 19 Feb 2014 22:01:22 -0700

The WG is making the following consensus calls on draft-ietf-kitten-aes-cts-hmac-sha2:

1. Do we adopt CTS mode for this draft?
     a. Yes
     b. No
     c. Don't care or need more information

2. Do we use the confounder algorithm as specified in RFC 3961/3962 for this draft?
     a. Yes
     b. No
     c. Don't care or need more information

If you answered "no" to any of the above, please state your objections and/or alternatives.

Please provide your input before March 6th.  Thank you.

Shawn.
--
kitten co-chair

---

From: Greg Hudson <[email-masked]>
Date: Thu, 20 Feb 2014 00:21:52 -0500

> 1. Do we adopt CTS mode for this draft?

Yes.

> 2. Do we use the confounder algorithm as specified in RFC 3961/3962 for

Yes.

You didn't ask for rationale for positive answers, but the first two
responses in
http://www.ietf.org/mail-archive/web/kitten/current/msg04498.html
summarize my reasoning.

---

From: Bill Mills <[email-masked]>
Date: Wed, 19 Feb 2014 21:27:52 -0800

1 C
2 C

Sorry, but I haven't been keeping up on that draft.  If you need another serious read on it I can take a look but I'm kinda slammed.

-bill

--------------------------------
William J. Mills
"Paranoid" MUX Yahoo!

On Wednesday, February 19, 2014 9:02 PM, Shawn M Emery <[email-masked]> wrote:

Shawn.
--
kitten co-chair

_______________________________________________
Kitten mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/kitten

---

From: Nico Williams <[email-masked]>
Date: Wed, 19 Feb 2014 23:33:02 -0600

>     c. Don't care or need more information

a.  Yes.

>     c. Don't care or need more information

c.  No opinion.  Getting a secure AES-SHA2 enctype is more important
than optimizing one block operation away.

Nico
--

---

From: Simo Sorce <[email-masked]>
Date: Thu, 20 Feb 2014 09:05:50 -0500

>      c. Don't care or need more information

Yes

>      c. Don't care or need more information

Yes

Simo.

-- 
Simo Sorce * Red Hat, Inc * New York

---

From: Benjamin Kaduk <[email-masked]>
Date: Thu, 20 Feb 2014 13:16:11 -0500 (EST)

>    c. Don't care or need more information

(a)

>    c. Don't care or need more information

(a)

-Ben

---

From: Tom Yu <[email-masked]>
Date: Thu, 20 Feb 2014 18:38:38 -0500

Yes

>     c. Don't care or need more information

Yes, because of possible security benefits I've described earlier, and
the other reasons Greg described.

---

From: Jeffrey Altman <[email-masked]>
Date: Fri, 21 Feb 2014 00:59:25 -0500

1. Yes

2. Yes

---

From: Jeffrey Hutzelman <[email-masked]>
Date: Fri, 21 Feb 2014 15:19:49 -0500

Yes.

>      c. Don't care or need more information

I'm inclined to lean toward "yes".

-- Jeff