Subject: Re: [kitten] next steps on oauth sasl draft?

From: Jamie Nicolson (倪志明) <[email-masked]>
Date: Wed, 3 Sep 2014 14:36:21 -0700

Hope this isn't too late:

Section 3.2.2 describes the "status" portion of the error response as being
an error code from the OAuth Extensions Error Registry. That registry lists
codes like "invalid_request", "invalid_token", etc. However, in section
4.3, there is an example of an error response that has "status":"401". I
don't see any way of mapping between the OAuth string error codes and
numeric, http-style codes like 401. Am I missing something or is this a
typo?

On Thu, Aug 7, 2014 at 1:25 PM, Bill Mills <[email-masked]> wrote:

> The OAuth SASL draft was in WGLC, but we made significant changes.  We've
> had one brief review of it since -15, that doesn't seem like enough to say
> it might be close to WGLC eligible again.  I'd especially like it if one or
> more of the folks at Google could take a look as they're the major
> implementor so far.
>
> Hoping to wrap this up.
>
> Thanks,
>
> -bill
>
> _______________________________________________
> Kitten mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/kitten
>
>

---

From: Bill Mills <[email-masked]>
Date: Fri, 5 Sep 2014 15:29:41 -0700

Yep, 401 is wrong.  Changed to "invalid_token" in the example (pending -16).

Thanks!

-bill

On Wednesday, September 3, 2014 2:36 PM, Jamie Nicolson (倪志明) <[email-masked]> wrote:

Section 3.2.2 describes the "status" portion of the error response as being an error code from the OAuth Extensions Error Registry. That registry lists codes like "invalid_request", "invalid_token", etc. However, in section 4.3, there is an example of an error response that has "status":"401". I don't see any way of mapping between the OAuth string error codes and numeric, http-style codes like 401. Am I missing something or is this a typo?

The OAuth SASL draft was in WGLC, but we made significant changes.  We've had one brief review of it since -15, that doesn't seem like enough to say it might be close to WGLC eligible again.  I'd especially like it if one or more of the folks at Google could take a look as they're the major implementor so far.