Subject: [kitten] I-D Action: draft-ietf-kitten-aes-cts-hmac-sha2-08.txt

From: [email-masked]
Date: Wed, 09 Dec 2015 05:15:57 -0800

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Common Authentication Technology Next Generation Working Group of the IETF.

        Title           : AES Encryption with HMAC-SHA2 for Kerberos 5
        Authors         : Michael J. Jenkins
                          Michael A. Peck
                          Kelley W. Burgin
	Filename        : draft-ietf-kitten-aes-cts-hmac-sha2-08.txt
	Pages           : 17
	Date            : 2015-12-09

Abstract:
   This document specifies two encryption types and two corresponding
   checksum types for Kerberos 5.  The new types use AES in CTS mode
   (CBC mode with ciphertext stealing) for confidentiality and HMAC with
   a SHA-2 hash for integrity.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-kitten-aes-cts-hmac-sha2/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-kitten-aes-cts-hmac-sha2-08

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-kitten-aes-cts-hmac-sha2-08

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Peck, Michael A" <[email-masked]>
Date: Wed, 9 Dec 2015 13:19:37 +0000

This -08 draft hopefully addresses Greg’s feedback (random-to-key function, cipherstate definition).

Thanks,
Mike

On 12/9/15, 8:15 AM, "Kitten on behalf of [email-masked]" <[email-masked] on behalf of [email-masked]> wrote:

>_______________________________________________
>Kitten mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/kitten

---

From: Greg Hudson <[email-masked]>
Date: Wed, 9 Dec 2015 17:46:57 -0500

> This -08 draft hopefully addresses Greg’s feedback (random-to-key function, cipherstate definition).

I think these changes are correct and address my feedback.

---

From: Luke Howard <[email-masked]>
Date: Sun, 20 Dec 2015 11:43:12 +1100

So, what’s the next step for this? I can only speak to Heimdal, but would be great to get the implementation integrated.

— Luke

> On 10 Dec 2015, at 9:46 AM, Greg Hudson <[email-masked]> wrote:
> 

--
www.lukehoward.com
soundcloud.com/lukehoward

---

From: Jeffrey Altman <[email-masked]>
Date: Sat, 19 Dec 2015 20:37:28 -0500

> So, what’s the next step for this? I can only speak to Heimdal, but would be great to get the implementation integrated.

The document editor(s) request the Working Group chair(s) initiate
another Working Group Last Call.

Jeffrey Altman

---

From: "Peck, Michael A" <[email-masked]>
Date: Sat, 26 Dec 2015 14:55:13 +0000

Thanks all for the feedback and the efforts put in to implement the draft and verify the test vectors.
We request that the chairs initiate another Working Group Last Call for draft-ietf-kitten-aes-cts-hmac-sha2.

Mike Peck

---

From: Benjamin Kaduk <[email-masked]>
Date: Sat, 26 Dec 2015 17:19:29 -0500 (EST)

Thanks for all the updates; the diff between the -06 and the -08 looks
good.  I expect that the chairs will be able to start a new WGLC soon.

-Ben