Subject: Re: On packet reordering... (was Nr in data packets)

From: Vernon Schryver <[email-masked]>
Date: Fri, 28 Jan 2000 11:00:36 -0700 (MST)

> From: David Chen <[email-masked]>

> ...
> My argument is that "the Ns bit in L2tp data channel is not needed".
> Here is my analysis:
>  From LAC to LNS:
> For those PPP packet sequence 1,2,3,4,5,6,7,8,9,10 arriving at LAC,
> however the delivery from LAC to LNS is out of sequence, if
> 1) L2tp Ns bit is off
> then the PPP in LNS will receive 1,2,4,5,6,7,8,3,9,10  ---> out of sequence
> 2) L2tp Ns bit is on
> then the PPP in LNS will receive 1,2,4,5,6,7,8,9,10 ---> packet 3 is droped
>
> The question is "Does any protocol that is encapsulated by the PPP
> will not break if a packet is dropped (case 2)
> but will break if the packet delivery sequence is out of order (case 1) ?"

Yes, as I've repeatedly pointed out, LCP, CCP, ECP, BCP, and a host
of others will break.

> Are you suggesting those protocol other than IP that encapsulated by PPP
> satisfy this question?

I'm not just suggesting it, I'm saying it,
and yet again for the umpteenth time.

With this, I'll stop repeating myself.

Vernon Schryver    [email-masked]

---

From: Bill Palter <[email-masked]>
Date: Fri, 28 Jan 2000 10:47:16 -0800

> At 11:00 AM 1/28/00 -0700, you wrote:
> All these protocol you mentioned here are not the protocols that encapsulated
> by PPP but PPP's control protocol.
> 

  PPP control protocols are encapsulated just like any data packets running 
over PPP. Also I beleive the that in the cases of CCP, ECP and BCP the mention
referes to the data packets as well as the the control protocol.

> Although this is not my question, It is interest to me to
> understand the LCP will break if the packet delivery is out of sequence but 
> will not
> if a packet(s) is dropped in the sequence.
> 
> ?In what state that the LCP state machine (p.12 rfc1661) will break
> (i.e. can not handle the incoming event)
> if the incoming packets (must be more than one) is out of sequence.
> Also, it will not break if the incoming packets has at least one of them is 
> dropped.
> Please note that in some state can send out two packets but
> line 6 page 2. says that "multiple actions may be implemented in any 
> convenient order".
> 
> 
> Let's look at LCP (I assume you mean
> 
> 
> 
> ========================================
> David Chen
> Indus River Networks, Inc.
> 31 Nagog Park
> Acton, MA 01720
> U.S.A.
> [email-masked]
> (978) 266-8141
> ========================================
--
Bill Palter ([email-masked])

---

From: David Chen <[email-masked]>
Date: Fri, 28 Jan 2000 13:46:01 -0500