Subject: Nr in data packets

From: "W. Mark Townsley" <[email-masked]>
Date: Thu, 20 Jan 2000 15:41:33 -0800

While we are all so active on the list, I thought I might bring up the
subject of Nr in data packets. Without flow control, this field is
pretty much useless. If there are no objections, I was planning on
stating that its use is deprecated and that its value should be ignored. 

- Mark

---

From: David Chen <[email-masked]>
Date: Thu, 20 Jan 2000 09:50:54 -0500

Does PPP needs L2TP's guarantee of packet ordering in data channel?
It is due to PPP uses stateful compression.
--- David

>stating that its use is deprecated and that its value should be ignored.

========================================
David Chen
Indus River Networks, Inc.
31 Nagog Park
Acton, MA 01720
U.S.A.
[email-masked]
(978) 266-8141
========================================

---

From: "W. Mark Townsley" <[email-masked]>
Date: Fri, 21 Jan 2000 09:12:44 -0800

> Does PPP needs L2TP's guarantee of packet ordering in data channel?

Ns is used for packet ordering, I am proposing deprecation of Nr.

---

From: "W. Mark Townsley" <[email-masked]>
Date: Fri, 21 Jan 2000 09:54:53 -0800

David Chen wrote:
> 
> Is the Nr for acknowledging to the sender by the receiver what
> has been received  so far?

Yes, that was its intent with flow control.

> Similar to HDLC if the difference between Ns and Nr is larger than
> presetted window
> then it will require peers to resync/retransmit packets.

L2TP does not provide lossless transmission of data packets. If you
really, really, want this, do PPP reliable transmission (RFC1663).

> Does the PPP's compression require lossless compression?

Some PPP compression is stateful, thus losing a packet will cause a
reset for all packets already in transit. Best idea is to simply
disallow stateful compression at the LNS.

> If so, we may not only need Ns for ordering but Nr for lossless transmission.
> --- David
> 
> At 09:12 AM 1/21/00 -0800, you wrote:
> 
> >David Chen wrote:
> > >

---

From: David Chen <[email-masked]>
Date: Thu, 20 Jan 2000 12:48:55 -0500

---

From: David Chen <[email-masked]>
Date: Thu, 20 Jan 2000 14:57:33 -0500

If PPP wants flow control in data channel,
then it should implement rfc1663 and...
L2tp can drop both Ns and Nr in data channel?
--- David

---

From: David Chen <[email-masked]>
Date: Fri, 21 Jan 2000 10:37:51 -0500

Since PPP was evolved from serial link connection,
the PPP assumes the underlining protocol layer/media is serial.
However, the PPP is for encapsulating protocol's packet.
These protocols do not demand PPP or underlining layer's transmission is 
serial.
It seems that PPP does not require the underlining layer transmission is 
serial unless
other reason as compress which the PPP is aware of it and can use flow 
control within
itself.
In this view, the Ns for emulate the serial link connection is rational but
is not used by PPP.
What is the circumstance that the Ns is demanded by PPP?
--- David

At 02:04 PM 1/21/00 -0800, you wrote:

>There is no officially sactioned way to do flow control with L2TP now.
>1663 is PPP reliablility. two different things.
>
>Ns is still useful for sequencing (unreliable sequencing).
>
> > --- David
> >

---

From: "W. Mark Townsley" <[email-masked]>
Date: Sat, 22 Jan 2000 08:58:30 -0800

> What is the circumstance that the Ns is demanded by PPP?

RFC 1661 states that all packets are assummed to be delivered in order.
Some protocols (VJ header compression, PPP payload compression and
encryption) were designed with this in mind. Further, the CPs that run
on PPP may have a problem with out of order packets, though given their
stop and wait nature and relatively long default timeout between
retransmissions, it is unlikely. 

The bottom line is, PPP has an in-order delivery assumption, thus L2TP
must have some way of not breaking this. It is optional, so if the user
understands the risks then sequence numbers may be omitted. We have
found that, w/o the stateful protocols listed above, operating w/o
guaranteed delivery order reduces L2TP overhead, and does not adversly
affect the PPP stream.