Subject: ZLB Ack.

From: HOULLIER Francis FTRD/DMI/CAE <[email-masked]>
Date: Fri, 14 Apr 2000 10:08:16 +0200

What is the condition to send a ZLB Ack (see the example below), is this a
timer or something else ? The rfc says only that "the ZLB Ack is sent if
there are no futher messages waiting in the queue".

LAC						LNS

SCCRQ ---->
					<----SCCRP
SCCCN ---->
					<----ZLB ACK

But generally after the SCCCN, the LAC sends an ICRQ and the LNS can't send
the ZLB ACK.
Thank you for your help.

---

From: [email-masked]
Date: Sun, 16 Apr 2000 13:47:32 -0700

Greetings,

> But generally after the SCCCN, the LAC sends an ICRQ and the LNS can't send

For what it's worth, my implementation would generally send a ZLB after
the SCCRQ as there was an authentication delay. More generally, anytime
the input path was complete, if no other messages have been queued for
output, send a ZLB.

-- 
Kyle A. York
Subordinate Grunt
CLOB

---

From: "W. Mark Townsley" <[email-masked]>
Date: Wed, 19 Apr 2000 12:18:10 -0400

---

From: "W. Mark Townsley" <[email-masked]>
Date: Wed, 19 Apr 2000 12:18:14 -0400

> > But generally after the SCCCN, the LAC sends an ICRQ and the LNS can't send

This certainly does not prohibit the LNS from sending a ZLB ack, as I
think has already been answered.

> the input path was complete, if no other messages have been queued for

Also FWIW, the cisco IOS implementation will always send a ZLB ACK after
receipt of an SCCCN, and never after receipt of an SCCRQ.

- Mark

---

From: "W. Mark Townsley" <[email-masked]>
Date: Wed, 19 Apr 2000 12:18:10 -0400

---

From: "W. Mark Townsley" <[email-masked]>
Date: Wed, 19 Apr 2000 13:50:34 -0400

- Mark

---

From: "W. Mark Townsley" <[email-masked]>
Date: Wed, 19 Apr 2000 12:18:10 -0400

---

From: "W. Mark Townsley" <[email-masked]>
Date: Wed, 19 Apr 2000 13:50:46 -0400

---

From: "W. Mark Townsley" <[email-masked]>
Date: Wed, 19 Apr 2000 12:18:10 -0400

---

From: "W. Mark Townsley" <[email-masked]>
Date: Wed, 19 Apr 2000 12:18:10 -0400