Subject: RE: L2TP charter

From: Danny McPherson <[email-masked]>
Date: Thu, 27 Jul 2000 07:57:09 -0700

> Can you please summarize just what features are needed 
> that are not present in GRE (or pick your other favorite 
> tunneling scheme)? This has always been a bit of a gray 
> area to me in that different folks have different ideas 
> about what is really needed.

The dynamic call capabilities are the most obvious benefit.

>I ask also because there are a number of tunneling 
>technologies in place, yet every WG seems seems to 
>want to tweak its own favorite rather than fixing one 
>of the more general ones so that it works properly 
>for a broad range of applications. Case in point, GRE was
>recently put on standards track because it was favored by 
>UDLR over something like IP in IP (which was already on 
>Standards Track). A big argument for GRE was that it was 
>widely deployed/available.

>I can assure you that lots of folks with tunneling needs 
>will never use L2TP to tunnel (say IP).  I would love to 
>see an effort to clean up/extend an existing tunneling 
>mechanism to make it generally useful to lots of applications. 
>But I do wonder whether L2TP is the right starting point for this.

L2TP seems to be the most obvious place, primarily
because of it's dynamic call capabilities.  It
clearly requires the least amount of work to become
the IP tunneling protocol of choice.  The work
into existing protocol such as GRE are simply because
of current deployment in static environments, and 
existing code.  

A number of folks without the legacy baggage have 
selected L2TP for this purpose, simply because it's
clearly already closest to the end goal.

-danny

---

From: Evan Caves <[email-masked]>
Date: Thu, 27 Jul 2000 16:32:02 -0700

Danny McPherson wrote:
> > [snip...]

what do you mean by "dynamic call capabilities"?

evan
-