Subject: Strange AVP's from RedBack DSLAM

From: "Mike Wronski" <[email-masked]>
Date: Tue, 22 Aug 2000 21:23:34 -0500

I am attempting to get a RedBack DSLAM (SMS1000) acting as LAC to terminate sessions on a 3Com HiPer ARC (LNS). The Session open coming from the DSLAM has AVP's 43,44,& 46.. I found 44 & 46 in a extension draft written by a member of RedBack.. I cant figure out what 43 is but it is causing the HiPer ARC to attempt to renegotiate SPI.. When this happens the Redback complains about invalid lenght of AVP's.. After looking at the packet sent from the HARC I can see no problem with the lengths in any of the data fields..  Can anyone shed some light on what AVP #43 is and where it is documented? Also if you have had some success with redback and 3com HiPer ARC please forward that along as well..

-M

---

From: Motonori Shindo <[email-masked]>
Date: Thu, 24 Aug 2000 10:10:53 +0900 (JST)

Mike,

From: "Mike Wronski" <[email-masked]>
Subject: Strange AVP's from RedBack DSLAM
Date: Tue, 22 Aug 2000 21:23:34 -0500

> I am attempting to get a RedBack DSLAM (SMS1000) acting as LAC to
> terminate sessions on a 3Com HiPer ARC (LNS). The Session open
> coming from the DSLAM has AVP's 43,44,& 46.. I found 44 & 46 in a
> extension draft written by a member of RedBack.. I cant figure out
> what 43 is but it is causing the HiPer ARC to attempt to renegotiate
> SPI.. When this happens the Redback complains about invalid lenght
> of AVP's.. After looking at the packet sent from the HARC I can see
> no problem with the lengths in any of the data fields..  Can anyone
> shed some light on what AVP #43 is and where it is documented? Also
> if you have had some success with redback and 3com HiPer ARC please
> forward that along as well..

I don't know what Redback's AVP 43 is. But it is interesting to see
that 3Com's VendorID is coincidentally 43! Are you really seeing
Redback's (VendorID = 2352) AVP 43? If you can send me a raw tcpdump
trace data, I might be able to help you figure out what's happening.

BTW, are you using IPsec with L2TP? If so, why don't you turn off
IPsec and see if exactly the same thing happen or not.

=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=
 +----+----+     
 |.. .|    |     Motonori Shindo
 |_~__|    |     
 | .. |~~_~|     Sr. Systems Engineer
 | .  |    |     CoSine Communications Inc.
 +----+----+     
 C o S i n e     e-mail:  [email-masked] 
Communications
=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=

---

From: David Phillips <[email-masked]>
Date: Fri, 25 Aug 2000 19:28:19 -0700

At 07:23 PM 8/22/00, Mike Wronski wrote:
>terminate sessions on a 3Com HiPer ARC (LNS). The Session open coming from 
>the DSLAM has AVP's 43,44,& 46.. I found 44 & 46 in a extension draft 
>written by a member of RedBack.. I cant figure out what 43 is but it is 
>causing the HiPer ARC to attempt to renegotiate SPI.. When this happens 
>the Redback complains about invalid lenght of AVP's.. After looking at the 
>packet sent from the HARC I can see no problem with the lengths in any of 
>the data fields..  Can anyone shed some light on what AVP #43 is and where 
>it is documented? Also if you have had some success with redback and 3com 
>HiPer ARC please forward that along as well..

L2TP attribute 43 is a Redback VSA and it's documented in the, um, 
documentation ;-)  Check the configuration guide and look at the L2TP 
attributes section at the end.

It is the NAS Port Type AVP.  It tells you what the port type on the LAC is.

BTW, The Redback SMS is not a DSLAM.  It's just an SMS.

/// Dave ///