Subject: Re: Reliable delivery of control Messages

From: Sridhar Malarothu <[email-masked]>
Date: Wed, 30 Aug 2000 20:19:51 +0530

Shindo,

   Thanks for the Information.

   If suppose an implementation cannot immediately decide whether
the Tunnel/Call Request is acceptable or not (May be it has to 
get the request verified by someone else). Then It will be better, if
the packet could be acknowledged immediately (by ZLB ack) and send 
response later.

   Regarding the next question, I want to know whether any charecter stuffing
(Async Control Charecter MAP) will be done by PPP for synchronous lines.

Best Regards
Sridhar

At 08:37 PM 8/30/00 +0900, you wrote:
>Sridhar,
>
>From: Sridhar Malarothu <[email-masked]>
>Subject: Reliable delivery of control Messages
>Date: Wed, 30 Aug 2000 13:33:40 +0530
>
>> Hi All,
>> 
>>    Should Acknowledgement for a control message (if it has been 
>> received in order) be always piggy-backed on to the repsonse 
>> message (if one exists exists) ? 
>
>It should but it's not mandatory.
>
>> If not then its better to start 
>> timers when replies for some control messages are awaited.
>
>Whenever a control message is sent, a timer associated with it should
>be started. The only exception to this rule is a ZLB. Since ZLB
>doesn't consume a sequence number space, timer invocation is not
>necessary. As a consequence, ZLB will not be retransmitted.
>
>>    I want some clarification on synchronous framing for PPP. PPP
>> will not add link framing (flags 0x7e) and crc bytes. 
>
>True.
>
>> but what 
>> about the async mapping for synchronous lines? 
>
>Sorry, I don't understand your question. Someone else will shed more
>light on this.
>
>Regards,
>
>=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=
> +----+----+     
> |.. .|    |     Motonori Shindo
> |_~__|    |     
> | .. |~~_~|     Sr. Systems Engineer
> | .  |    |     CoSine Communications Inc.
> +----+----+     
> C o S i n e     e-mail:  [email-masked] 
>Communications
>=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=
>

---

From: James Carlson <[email-masked]>
Date: Wed, 30 Aug 2000 16:06:46 -0400 (EDT)

> the packet could be acknowledged immediately (by ZLB ack) and send 

Right.  This can be done by a timer.

> (Async Control Charecter MAP) will be done by PPP for synchronous lines.

No.  This is documented in RFC 1662.  Synchronous lines use
bit-stuffing, not octet-stuffing.

-- 
James Carlson                                  <[email-masked]>
"PPP Design and Debugging" --- http://people.ne.mediaone.net/carlson/ppp