Subject: draft-l2tpext-l2tp-mib-00.txt

From: Ignacio Goyret <[email-masked]>
Date: Thu, 07 Sep 2000 10:04:31 -0700

Finally, I figured out how to send messages to the list. :-)
Cheers,
-Ignacio

>Date: Tue, 05 Sep 2000 16:04:47 -0700
>To: [email-masked]
>From: Ignacio Goyret <[email-masked]>
>Subject: draft-l2tpext-l2tp-mib-00.txt
>Cc: [email-masked]
>
>Hi Evan,
>I sent this email a few weeks ago but for some reason, I haven't seen it
>posted on the L2TP list. Sending it again just in case.
>
>-----------------------------------
>Hi Evan,
>I've just noticed a little discrepancy between your draft and rfc2661.
>
>* 'l2tpSessionStatsAuthMethod' has a value for EAP (pppEap, 5) but no
>   value for Microsoft CHAP v1.
>
>   l2tpSessionStatsAuthMethod OBJECT-TYPE
>           SYNTAX          INTEGER {
>                               none(1),
>                               text(2),
>                               pppChap(3),
>                               pppPap(4),
>                               pppEap(5)
>                           }
>     ...
>
>Since we are talking about missing values, rfc2661 failed to mention EAP:
>
>   Proxy Authen Type (ICCN)
>
>      The Proxy Authen Type AVP, Attribute Type 29, determines if proxy
>      authentication should be used.
>   ...
>
>      Defined Authen Type values are:
>         0 - Reserved
>         1 - Textual username/password exchange
>         2 - PPP CHAP
>         3 - PPP PAP
>         4 - No Authentication
>         5 - Microsoft CHAP Version 1 (MSCHAPv1)
>
>Of course, there are other authentication methods that are not mentioned
>such as DNIS or CLID authentication. From conversations with customers and
>other manufacturers, it looks that everyone has done it just a little bit
>different.
>
>Let me suggest a solution:
>
>* On the L2TP MIB draft, change:
>      l2tpSessionStatsAuthMethod OBJECT-TYPE
>           SYNTAX          INTEGER {
>                               none(1),
>                               text(2),
>                               pppChap(3),
>                               pppPap(4),
>                               pppEap(5)
>                           }
>  to:
>      l2tpSessionStatsAuthMethod OBJECT-TYPE
>           SYNTAX          INTEGER {
>                               none(1),
>                               text(2),
>                               pppChap(3),
>                               pppPap(4),
>                               pppMsChap(5),        <<<
>                               pppEap(6)            <<<
>                           }
>
>
>* For RFC 2661-bis, add:
>
>      Defined Authen Type values are:
>         0 - Reserved
>         1 - Textual username/password exchange
>         2 - PPP CHAP
>         3 - PPP PAP
>         4 - No Authentication
>         5 - Microsoft CHAP Version 1 (MSCHAPv1)
>         6 - PPP EAP                                 <<<<
>
>Any thoughts?

Needless to say, I'll be happy with pppMsChap(6) and pppEap(5) as well. :-)

>Cheers,
>-Ignacio

---

From: Evan Caves <[email-masked]>
Date: Mon, 11 Sep 2000 10:12:39 -0700

Hi Ignacio,

   No problem. I can add a enum for pppMsChap to the statsAuthMethod
object however should the enum reflect 'v1' (ie: pppMsChapV1)? At
the same time I should also add a 'other' enum as a place holder for
other types of authentication methods that may be employed but not
enmumerated.

evan
-

---

From: Ignacio Goyret <[email-masked]>
Date: Mon, 11 Sep 2000 11:08:04 -0700

Hi Evan,

At 10:12 AM 9/11/00 -0700, Evan Caves wrote:
>object however should the enum reflect 'v1' (ie: pppMsChapV1)?

That's probably a good idea. Since you are at it, you might as well
add a value for v2 (ie, pppMsChapV2). The RFC references are 2433 (v1)
and 2759 (v2).

>At

Sounds good to me.

Thanks,
-Ignacio

---

From: Evan Caves <[email-masked]>
Date: Mon, 11 Sep 2000 12:20:19 -0700

Ignacio Goyret wrote:
> 
> Just to round up the issue, is this what you have in mind for numbers and names?
> 
>                              pppEap(5),
>                              pppMsChapV1(6),        <<<
>                              pppMsChapV2(7),        <<<
>                              other(8),              <<<

I think I prefer this one, that is add to the end of the
enum list, instead of reordering enums at this stage of MIB
development.

evan
-
>                          }
> 
> or this one (that agrees a little better with the values in the Authen Type AVP):
> 
>                              pppMsChapV1(5),        <<<  (in Authen Type AVP)
>                              pppMsChapV2(6),        <<<  (not in Authen Type AVP)
>                              pppEap(7),             <<<  (not in Authen Type AVP)
>                              other(8),              <<<  (not in Authen Type AVP)
>                          }
> 
> Sorry to bother you, but I need to finish this today :-(
> -Ignacio
> 
> At 11:08 AM 9/11/00 -0700, Ignacio Goyret wrote:
> >Hi Evan,
> >

---

From: Ignacio Goyret <[email-masked]>
Date: Mon, 11 Sep 2000 12:05:24 -0700

---

From: Ignacio Goyret <[email-masked]>
Date: Mon, 11 Sep 2000 12:17:39 -0700

>enum list, instead of reordering enums at this stage of MIB

Ok, it sounds good to me.
Thanks for the prompt answer :-)
-Ignacio