Subject: RE: Qos and L2TP (was: Do we want a new L2TP Header?)

From: "Umesh Sirsiwal" <[email-masked]>
Date: Mon, 4 Jun 2001 19:17:30 -0400

> This is exactly what I like to know how this can happen since the l2tp
> session
> header is not visible to the PHB?
> 

I am afraid you are missing the complete point here. The complete
argument
is not about inner IP header but is about outer IP header. To enable
differentiation of service between different type of traffic in the
same PPP session we need to have different DS bits in the "OUTER" IP
header. And that is subject to all packet re-routing issues and QoS
degradation
issues discussed in this thread so far.

-Umesh

---

From: Elwin Eliazer <[email-masked]>
Date: Mon, 4 Jun 2001 23:19:31 -0700 (PDT)

Chen David,

Take for example 4 packets, A, B, C, D.
And 2 QOS values: p, q

When there is one L2TP session,
when the LAC sends packets: Ap1, Bq2, Cp3, Dq4
  where the last digit is sequence number,
the LNS receives it as: Ap1, Cp3, Bq2, Dq4
since the intermediate DS domain reorders and
gives more priority to traffic type 'p'.
LNS when it processes these packets from a session
will drop Bq2 since it has come out of order.

THIS WILL NOT HAPPEN WHEN THERE ARE TWO SEPARATE
L2TP SESSIONS FOR 'p' and 'q'.

regards,
Elwin.

--- Umesh Sirsiwal <[email-masked]>
> issues discussed in this thread so far.

=====
-------
Elwin Stelzer Eliazer
Corona Networks
-------

__________________________________________________
Do You Yahoo!?
Get personalized email addresses from Yahoo! Mail - only $35 
a year!  http://personal.mail.yahoo.com/