Subject: RE: Qos and L2TP (was: Do we want a new L2TP Header?)

From: "Chen, David" <[email-masked]>
Date: Fri, 15 Jun 2001 11:34:01 -0400

Jeff,
It seems
"it has no way of knowing that they are out of order" 
can be also,
"it has no way of knowing that they are droped"?
Regards,

--- David

-----Original Message-----
From: Jeff Mcadams [mailto:[email-masked]]
Sent: Friday, June 15, 2001 11:30 AM
To: Chen, David
Cc: 'James Carlson'; 'Evan Caves'; [email-masked]
Subject: Re: Qos and L2TP (was: Do we want a new L2TP Header?)

Also sprach Chen, David
>If PPP state machine can recover from its packet drop, it seems able to
>treat out-of-order pakcets the same way?

No, as it has no way of knowing that they are out of order, and could
therefor trigger a state transition that shouldn't happen.
-- 
Jeff McAdams                            Email: [email-masked]
Head Network Administrator              Voice: (502) 966-3848
IgLou Internet Services                        (800) 436-4456

---

From: James Carlson <[email-masked]>
Date: Fri, 15 Jun 2001 11:39:32 -0400 (EDT)

> "it has no way of knowing that they are droped"?

Correct.  It doesn't know either.  So it *ASSUMES* only a drop could
possibly occur.  The entire state machine design was based on the
premise that ONLY drops could occur -- no duplicates (other than
retransmits, of course) and no reordering.

-- 
James Carlson, Internet Engineering       <[email-masked]>
SUN Microsystems / 1 Network Drive         71.234W   Vox +1 781 442 2084
MS UBUR02-212 / Burlington MA 01803-2757   42.497N   Fax +1 781 442 1677

---

From: Jeff Mcadams <[email-masked]>
Date: Fri, 15 Jun 2001 11:42:09 -0400

Also sprach Chen, David
>It seems "it has no way of knowing that they are out of order" can be
>also, "it has no way of knowing that they are droped"?

Sure...but the state machine is designed such that drops don't cause it
harm...re-ordering can.

And, as Mr. Carlson also pointed out...PPP can carry non-IP payloads as
well which can be fatally harmed by re-ordering.

No, packet sequencing capability is decidedly necessary in L2TP.
-- 
Jeff McAdams                            Email: [email-masked]
Head Network Administrator              Voice: (502) 966-3848
IgLou Internet Services                        (800) 436-4456