Subject: L2TP Outgoing Calls in RFC 2661

From: Nurit Sprecher <[email-masked]>
Date: Wed, 22 Aug 2001 14:08:46 +0200

Hi all,
1.	I wondered if L2TP outgoing calls may be used in order to perform a
call back to a (PPP) subscriber. 
a.	Is it popular to perform a call back in case of PPP sessions?
b.	Is such a call back performed by a LNS using a L2TP outgoing call?
i.	In such a case, the LAC should establish an outbound call. In case
of PPP, the telephone called number is irrelevant. What parameters should
the LNS send the LAC in order to establish a new PPP session? I guess the
sub-address AVP is used for this. Is it so? I know that in the new draft on
L2TP there is a new AVP, named End Identifier. What about 2661?
2.	L2TP outgoing calls are used in the L2TP multicast application. Are
there more applications that use the L2TP outgoing calls? 
Thanks in advance, Nurit.

---

From: "Ralf Bialozyt" <[email-masked]>
Date: Wed, 22 Aug 2001 14:09:39 +0200

Hello Nurit,

here my two chents.

>1.  I wondered if L2TP outgoing calls may be used in order to perform a call
back to a (PPP) subscriber.
>a.  Is it popular to perform a call back in case of PPP sessions?
Yes, in Europe it one part of dial-up security to use call back to assure the
remote client location.
>b.  Is such a call back performed by a LNS using a L2TP outgoing call?
This depends from the application
- in case of the LAC is in hand of the LNS providing Customer  - NO
-in case of a LAC provide from a Carrier and an LNS from the Customer - YES
>L2TP there is a new AVP, named End Identifier. What about 2661?
The called number is the number for dial out (back). For security reasons this
need to be specified.
>there more applications that use the L2TP outgoing calls?
I know about an Carrier providing PPP dial-out for it's clients using an L2TP
outgoing call

Regards,
Ralf

---

From: Ignacio Goyret <[email-masked]>
Date: Wed, 22 Aug 2001 12:04:14 -0700

At 02:08 PM 8/22/01 +0200, Nurit Sprecher wrote: 
>
>
>Hi all,
>
>1.      I wondered if L2TP outgoing calls may be used in order to perform a call back to a (PPP) >subscriber. 

That's one of the purposes of L2TP outgoing calls.

>a.      Is it popular to perform a call back in case of PPP sessions? 

It depends.

>b.      Is such a call back performed by a LNS using a L2TP outgoing call? 

Yes.

>i.      In such a case, the LAC should establish an outbound call. In case of PPP,
>        the telephone called number is irrelevant. What parameters should the LNS
>        send the LAC in order to establish a new PPP session? I guess the sub-address
>        AVP is used for this. Is it so? I know that in the new draft on L2TP there is
>        a new AVP, named End Identifier. What about 2661?

The telephone number is most certainly important. What number will the LAC dial?

Note that the LAC does NOT establish the PPP session: the LNS will do that.
The LAC just connects to the PSTN.

The subaddress AVP is to pass ISDN subaddress information. This is required for
some BRI configurations.

>2.      L2TP outgoing calls are used in the L2TP multicast application.
>        Are there more applications that use the L2TP outgoing calls? 

L2TP multicast is a horrible kludge IMHO, but that's another story.

There are many reasonable applications for outgoing calls. Callback is
just one of them.

---

From: Klausberger Walter <[email-masked]>
Date: Thu, 23 Aug 2001 13:06:47 +0200

Another possible use for outgoing calls is ML-PPP. Consider a corperate
access via L2TP, where the corperate decides wether an additional link to
raise bandwidth is granted or not. If there is already a link available an
outgoing call can be used to add additional links triggered from LNS side.

Teleworkers that are called from some servers in case something happened
(eg. service personal). If this connection is going over L2TP to save costs
of a long distance call, you certainly need an outgoing call.

All these scenarios certainly depend on an agreement between LAC and LNS
that the PSTN costs for the dial out are paid by someone.

regards
- walter

-----Original Message-----
From: Nurit Sprecher [mailto:[email-masked]]
Sent: Thursday, August 23, 2001 9:54 AM
To: 'Ignacio Goyret'
Cc: L2tp (E-mail)
Subject: RE: L2TP Outgoing Calls in RFC 2661

Thanks for your response. It is helpful. 
Can you give me more examples for the use of outgoing calls? 
Can I assume that an outgoing call relates to some incoming call (that may
be already tear down but was first established before the outgoing one?).

-----Original Message----- 
From: Ignacio Goyret [mailto:[email-masked]] 
Sent: Wednesday, August 22, 2001 9:04 PM 
To: Nurit Sprecher 
Cc: (E-mail) 
Subject: Re: L2TP Outgoing Calls in RFC 2661 
>1.      I wondered if L2TP outgoing calls may be used in order to perform a
call back to a (PPP) >subscriber. 
That's one of the purposes of L2TP outgoing calls. 
It depends. 
Yes. 
>i.      In such a case, the LAC should establish an outbound call. In case
of PPP, 
>        a new AVP, named End Identifier. What about 2661? 
The telephone number is most certainly important. What number will the LAC
dial? 
Note that the LAC does NOT establish the PPP session: the LNS will do that. 
The LAC just connects to the PSTN. 
The subaddress AVP is to pass ISDN subaddress information. This is required
for 
some BRI configurations.