Subject: Comments on draft-aissaoui-l2vpn-vpws-iw-oam-00.txt

From: "Hunt, Douglas H (Douglas)" <[email-masked]>
Date: Fri, 27 Feb 2004 09:59:00 -0500

Here are comments on draft-aissaoui-l2vpn-vpws-iw-oam-00.txt, regarding (1) some of the terminology being used, and (2) concerns that the draft is unnecessarily limiting the set of relevant network scenarios.

Regarding the terminology, the l2vpn framework draft (draft-ietf-l2vpn-l2-framework-03) refers to "heterogeneous transport" in section 3.2.2 and to "heterogeneous pseudowires" in section 3.3.3. In both cases, the framework draft is describing a characteristic of a given pseudowire. The transport or the pseudowire is defined to be homogeneous if the 2 ACs are of the same technology, and heterogeneous otherwise.

Draft-aissaoui uses the terms "heterogeneous" and "homogeneous" in some different ways -- to characterize ACs (section 2), or a VPWS itself (section 3.2), or a VPWS OAM model (section 3.2). In the case of section 2, it appears that the terms "homogeneous AC" and "heterogeneous AC" can be replaced by "homogeneous PW" and "heterogeneous PW" respectively and still convey the intended meaning.

However it is not clear how to reconcile the use of "homogeneous VPWS" and "heterogeneous VPWS" in Section 3.2 with the use of these terms in the framework draft. In particular it is not clear whether a VPWS constructed from a network that contains some homogeneous PWs as well as some heterogeneous PWs would be regarded as a homogeneous VPWS or a heterogeneous VPWS. It may be helpful to remove the terms "homogeneous VPWS" and "heterogeneous VPWS", as they do not seem necessary in defining an OAM model, since the homogeneous and heterogeneous VPWS OAM models defined in section 3.2 are in terms of procedures that apply to a single pseudowire.

Regarding the set of network scenarios addressed, the draft currently restricts the set of PW types being considered for some of the VPWS scenarios, and this in turn restricts the set of VPWS OAM models considered. In particular, the draft does not consider a likely scenario in which a network evolves from one with just FR and ATM ACs to one with FR, ATM, and/or Ethernet ACs.  In the case where the VPWS ACs are either ATM or FR (section 5.1), the draft allows for either FR or ATM PW types, and for either the homogeneous or heterogeneous VPWS OAM models to be used. Specifically, section 5.1.2 indicates that when the PW type is ATM, the homogeneous VPWS OAM procedures may be used. However in the case where the VPWS ACs may be ATM, FR, or Ethernet, the draft considers only the cases where a PW is of type Ethernet (section 5.2) or of type IP (section 5.3), and the heterogeneous VPWS OAM model is proposed for both these PW types. The OAM models in the draft can be more broadly ap!
 plicable if PWs of type ATM (as well as Ethernet and IP) are considered, as some service providers may evolve networks that are entirely FR or ATM at the edges to networks with some Ethernet ACs at the edge. An example evolution might be to add gigE ACs at some locations in a corporate customer's VPN. In this scenario, a service provider that had implemented its VPWS service using PWs of type ATM may continue to do so. Considering this case in the draft would support the operational requirements of these service providers.

---

From: Mustapha Aissaoui <[email-masked]>
Date: Sat, 28 Feb 2004 08:06:42 -0500

Doug,
thanks for the comments. See my response below prepended by MA.

Regards,
Mustapha.
-----------
> However it is not clear how to reconcile the use of "homogeneous VPWS" and "heterogeneous VPWS" in Section 3.2 with the use of these terms in the framework draft. In particular it is not clear whet…

MA> I can see there is a terminology issue. A VPWS is a collection
of CE's attached through a set of <AC, PW, AC>. It is this latter
that can be charaterized as "homogeneous" or "heterogeneous". This
set is referred to in the L2 VPN framework as a "virtual circuit" in
Section 3.3. 
OAM can be applied to a segment of the virtual circuit or
end-to-end. That is why, the draft does not use the the terminology
such as "heterogeneous PW", since the PW is just a segment of the
end-to-end circuit.
So, one possible way out is to refer to them as "homogeneous
circuit" and "heterogeneous circuit". Let me know what you think. 
I will also change the terminology of "homogeneous/heterogeneous
VPWS model" to "homogeneous/heterogeneous circuit OAM model".

> Regarding the set of network scenarios addressed, the draft currently restricts the set of PW types being considered for some of the VPWS scenarios, and this in turn restricts the set of VPWS OAM models considered. In particular, the draft does not consider a likely scenario in which a network evolves from one with just FR and ATM ACs to one with FR, ATM, and/or Ethernet ACs.  In the case where the VPWS ACs are either ATM or FR (section 5.1), the draft allows for either FR or ATM PW types, and for either the homogeneous or heterogeneous VPWS OAM models to be used. Specifically, section 5.1.2 indicates that when the PW type is ATM, the homogeneous VPWS OAM procedures may be used. However in the case where the VPWS ACs may be ATM, FR, or Ethernet, the draft considers only the cases where a PW is of type Ethernet (section 5.2) or of type IP (section 5.3), and the heterogeneous VPWS OAM model is proposed for both these PW types. The OAM models in the draft can be more broadly !
 ap!
>  plicable if PWs of type ATM (as well as Ethernet and IP) are considered, as some service providers may evolve networks that are entirely FR or ATM at the edges to networks with some Ethernet ACs a…

MA> This is a good point. In general, if you extend a ATM PW to a
remote Ethernet AC, then this is still a "heterogeneous circuit".
But, as in the case of FR-ATM in section 5.1.2, you can use what the
draft refer to as "homogeneous OAM model". The key point is the
following: if the link layer of the AC is terminated at the PE, then
the link layer OAM is also terminated. I will add this example into
section 5 of the draft.