Subject: RE: Changing the FEC for VPLS to generalized PWid FEC

From: "Hamid Ould-Brahim" <[email-masked]>
Date: Mon, 2 Feb 2004 14:36:29 -0500

Vach,

> 
> There is still no discussion on changing the FEC type from 
> 128, as it stands today, to the generalized PW FEC type 
> (129), as suggested by Eric Rosen.  

Actually I thought there were some discussions before on 
this item on the mailing list and in ietf meetings
(for both Vienna and  Minneapolis meetings). My understanding 
is there was no technical issue to move to generalized PW FEC.

>I think this is a good 
> idea, and I know that several vendors have implemented the 
> old style, so it will put a crimp in your implementations, 
> but can we make some progress here?
> 

Agreed. Anyway, I reiterate my support for moving from a four octets 
VCID to the AGI as specified by the Generalized ID FEC. 

Hamid.

---

From: "Paul Unbehagen" <[email-masked]>
Date: Thu, 5 Feb 2004 12:09:04 -0500

I agree with Hamid.

-----Original Message-----
From: Ould-Brahim, Hamid [CAR:1A00:EXCH] 
Sent: Monday, February 02, 2004 2:36 PM
To: [email-masked]; [email-masked]
Subject: RE: Changing the FEC for VPLS to generalized PWid FEC

Vach,

Hamid.

---

From: [email-masked]
Date: Fri, 6 Feb 2004 09:35:40 +0000

Vach,

I also agree that we should move from FEC 128 to FEC 129.

However, I think FEC 129 also needs to have an equivalent of the grouping
mechanism. This is needed to group label withdrawl and PW status signalling
messages, addressing scalability requirements when there are large numbers
of changes that must be propagated.

Best regards,

Matthew

|---------+--------------------------->
|         |           "Vach Kompella" |
|         |           <vkompella@timet|
|         |           ra.com>         |
|         |           Sent by:        |
|         |           l2vpn-admin@ietf|
|         |           .org            |
|         |                           |
|         |                           |
|         |           02/02/2004 18:47|
|         |           Please respond  |
|         |           to Vach.Kompella|
|         |                           |
|---------+--------------------------->
  >-------------------------------------------------------------------------------------------------------------------------------|
  |                                                                                                                               |
  |        To:      <[email-masked]>                                                                                              |
  |        cc:                                                                                                                    |
  |        Subject: Changing the FEC for VPLS to generalized PWid FEC                                                             |
  >-------------------------------------------------------------------------------------------------------------------------------|

Folks,

There is still no discussion on changing the FEC type from 128, as it
stands today, to the generalized PW FEC type (129), as suggested by Eric
Rosen.  I think this is a good idea, and I know that several vendors
have implemented the old style, so it will put a crimp in your
implementations, but can we make some progress here?

The main reason for moving forward is to address future issues with
VPLSen by using a structured name and 32 bits just isn't good enough for
that.  This will assist in auto-discovery, inter-regional VPLSen, and
adequate name-space size.

-Vach