Subject: Re: wg last call - draft-ietf-l2vpn-vpls-ldp-05.txt

From: Du Wenhua <[email-masked]>
Date: Tue, 05 Oct 2004 17:24:05 +0800

Loa, Rick and Vach

My comment:
   When non-bridging device use Q-in-Q as spoke VC, the PE-rs
needs map many P-VLAN to one VPLS instance, not only "one to one".

In "8.1.3 Spoke connectivity for non-bridging devices", the draft gives
only the example of LSP tunnel as spoke VC. But, when the non-bridge
device chooses Q-in-Q as spoke VC. The PE-rs need map many P-VLAN to
one VPLS instance.
This "many to one" scenario conflicts with the sentence in chapter "9.
Hierarchical VPLS model using Ethernet Access Network": "Therefore,
there is a one to one correspondence between a P-VLAN and a VPLS
instance."

In the flowing example, both CE-1, CE-2 and CE-3 belongs to one VPLS
instance. So PE1-rs map PVLAN-101 and PVLAN-102 to one VPLS instance.
                                                      
Figure 1: non-bridge device use Q-in-Q as spoke vc                                                        
                                                          PE2-rs
                                                          ------
                                                         /      \
                                                        |   --   |
                                                        |  /  \  |
    CE-1                                                |  \B /  |
     \                                                   \  --  /
      \   MTU-r(non-bridging)                            /------
       \  PE-r(non-bridging)              PE1-rs        /   |
        \ ------                          ------       /    |  
         /      \                        /      \     /     |    
        | \      |     PVLAN-101        |   --   |---/      |
        |  ------|- - - - - - - - - - - |--/  \  |          |  
        |   -----|- - - - - - - - - - - |--\B /  |          | 
         \ /    /      PVLAN-102         \  --  / ---\      |  
          ------                          ------      \     |   
         /                                             \    |
       ----                                             \------
      | Agg|                                            /      \    
       ----                                            |  --    |
      /    \                                           | /  \   |
     CE-2  CE-3                                        | \B /   |
                                                        \ --   /
                                                         ------ 
                                                         PE3-rs

Give an example of non-bridging device: IP-DSLAM

In the past, DSLAM have ATM uplink port. One ADSL CE have at least one
ATM PVC on the uplink port. When a CE belongs to one VPLS, it use
RFC1483B PVC. Different ADSL CEs use different RFC1483B PVCs, no mater
they belong to one VPLS or not.

At recently, many carrier move to IP-DSLAM, which replaces ATM uplink
port with Ethernet uplink port. Many of these IP-DSLAMs just have
Ethernet
uplink port, but have no bridging function.
In these IP-DSLAMs, one ADSL CE map to one P-VLAN (use Q-in-Q
technologies, because maybe the CE have VLAN tag already) on the
Ethernet unplink port.
Different ADSL CEs map to different P-VLAN tags, no mater they belong to
one VPLS or not. Since IP-DSLAM has no bridging function, it can not map
many CEs to one P-VLAN.
So, the PE-rs needs to map many P-VLAN to one VPLS instance.

IP-DSLAM have Ethernet uplink port. The device just map one DSL to one
VLAN, as the same way to map one DSL CE site to one 1483 PVC,
have no bridging function.
                                  
Figure 2: IP-DSLAM with Ethernet uplink port
   CE-1(ADSL PVC 1)
     \                              
      \          
       \  IP-DSLAM(non-bridging)        
        \ ------                    
         /      \                   
        | \      |      PVLAN-101    
        |  ------|- - - - - - - - - - (Ethernet uplink port)
        |   -----|- - - - - - - - - -
         \ /    /       PVLAN-102    
          ------                    
         /                          
        /
       /
     CE-2(ADSL PVC 2)                  

Figure 3: DSLAM with ATM uplink port
   CE-1(ADSL PVC 1)
     \                              
      \          
       \  IP-DSLAM(non-bridging)        
        \ ------                    
         /      \                   
        | \      |      PVC-101 RFC1483B
        |  ------|- - - - - - - - - -  (ATM uplink Port)
        |   -----|- - - - - - - - - -
         \ /    /       PVC-102 RFC1483B
          ------                    
         /                          
        /
       /
     CE-2(ADSL PVC 2)                                      

Yours   
　　　　　　　　Du Wenhua
　　　　　　　　　　2004-10-05

>-----Original Message-----
>From: Loa Andersson <[email-masked]>
>Sent: 14:46:00,2004-09-30
>To: L2VPN <[email-masked]>
>Subject: wg last call - draft-ietf-l2vpn-vpls-ldp-05.txt

>Working group,
>
>this mail is to initiate a working group last call
>on draft-ietf-l2vpn-vpls-ldp-05.txt.
>
>Please send comments to the l2vpn mailing list and
>to the working co-chairs.
>
>The last call ends end of business day October 15 PST.
>
>Loa, Rick and Vach
>
>
>-- 
>Loa Andersson
>
>Principal Networking Architect
>Acreo AB                           phone:  +46 8 632 77 14
>Isafjordsgatan 22                  mobile: +46 739 81 21 64
>Kista, Sweden                      email:  [email-masked]
>                                            [email-masked]
= = = = = = = = = = = = = = = = = = = =

---

From: "Marc Lasserre" <[email-masked]>
Date: Wed, 6 Oct 2004 17:46:49 +0200

Du,

Section 8.1.3 describes how a router (PE-r) that does not support VPLS
bridging functions can participate in the VPLS service. PE-r devices do not
have the ability to add P-VLAN tags (this is a provider bridge function),
and hence must use PWs on a per physical port basis.

A P-VLAN as defined in the IEEE 802.1ad represents a unique customer domain
within the provider network, which is mapped to a unique VSI. In your DSLAM
example, P-VLANs are used as circuit identifiers instead. The ability for
PE-rs devices to be able to treat such P-VLANs as virtual ports in order to
make them part of the same VPLS domain would be implementation specific.

Thanks,
Marc

----- Original Message ----- 
From: "Du Wenhua" <[email-masked]>
To: "Loa Andersson" <[email-masked]>; "L2VPN" <[email-masked]>
Cc: "Thomas Narten" <[email-masked]>; "Alex Zinin" <[email-masked]>
Sent: Tuesday, October 05, 2004 11:24 AM
Subject: Re: wg last call - draft-ietf-l2vpn-vpls-ldp-05.txt

Loa, Rick and Vach

My comment:

Yours
　　　　　　　　Du Wenhua
　　　　　　　　　　2004-10-05