Subject: Re: Query on draft draft-ietf-l2vpn-vpls-bgp-08

From: Ramesh Huliyar <[email-masked]>
Date: Tue, 14 Nov 2006 11:37:57 +0530 (IST)

Hello Abhay,

VPLS is basically a service which emulate LAN for the customers. It does this by having a point to point pseudowire from every PE to every other PE which has customer site and L2 switching capabilites for proper forwarding. Hence it is important that when a packet is recieved over a pseudowire, it should associate the MAC with that psuedowire, so that the reverse traffic is sent only to that PE.

Regards
Ramesh Huliyar

----- Original Message ----
From: Abhay D.S <[email-masked]>
To: [email-masked]
Sent: Tuesday, 14 November, 2006 7:41:55 AM
Subject: Query on draft draft-ietf-l2vpn-vpls-bgp-08

hi Group,

In this draft-ietf-l2vpn-vpls-bgp-08 draft, 

3.2.  Signaling

    Once discovery is done, each pair of PEs in a VPLS must be able to

    establish (and tear down) pseudowires to each other, i.e., exchange

    (and withdraw) demultiplexors.  This process is known as signaling.

    Signaling is also used to transmit certain characteristics of the

    pseudowires that a PE sets up for a given VPLS.

    Recall that a demultiplexor is used to distinguish among several

    different streams of traffic carried over a tunnel, each stream

    possibly representing a different service.  In the case of VPLS, the

    demultiplexor not only says to which specific VPLS a packet belongs,

    but also identifies the ingress PE.  

    "The former information is used

    for forwarding the packet; the latter information is used for

    learning MAC addresses."   The demultiplexor described here is
an MPLS

    label.  However, note that the PE-to-PE tunnels need not be MPLS

    tunnels.

    The information in quotes latter information is used for learning
MAC address , Im not very clear about this , why to lean the macaddress
?

    Thank you,

    Abhay

begin:vcard
fn:Abhay  Rao
n:Rao;Abhay 
email;internet:[email-masked]
version:2.1
end:vcard

__________________________________________________________
Yahoo! India Answers: Share what you know. Learn something new
http://in.answers.yahoo.com/

---

From: "Abhay D.S" <[email-masked]>
Date: Tue, 14 Nov 2006 17:51:47 +0800

hi ramesh,
The PW learns the MAC address from the Ethernet Frame it received on the 
Forwarder side. But the draft  mentions this in the signaling of 
de-multiplexors section.
Here no MAC address is learnt.
Am I right.
Abhay

Ramesh Huliyar wrote:
> Hello Abhay,
>
> VPLS is basically a service which emulate LAN for the customers. It 
> does this by having a point to point pseudowire from every PE to every 
> other PE which has customer site and L2 switching capabilites for 
> proper forwarding. Hence it is important that when a packet is 
> recieved over a pseudowire, it should associate the MAC with that 
> psuedowire, so that the reverse traffic is sent only to that PE.
>
> Regards
> Ramesh Huliyar
>
>     "*The former information is used
>     learning MAC addresses.*"   The demultiplexor described here is an 
> MPLS
> MAC address , Im not very clear about this , why to lean the macaddress ?
>
>     Thank you,
>     Abhay
>   
>
>
> begin:vcard
> fn:Abhay  Rao
> n:Rao;Abhay
> ------------------------------------------------------------------------
> Find out what India is talking about on - Yahoo! Answers India 
> <http://us.rd.yahoo.com/mail/in/yanswers/*http://in.answers.yahoo.com/>
> Send FREE SMS to your friend's mobile from Yahoo! Messenger Version 8. 
> Get it NOW 
> <http://us.rd.yahoo.com/mail/in/messengertagline/*http://in.messenger.yahoo.com>