Subject: Active/Standby Status Bit

From: "AISSAOUI Mustapha" <[email-masked]>
Date: Mon, 6 Nov 2006 19:03:57 -0600

Luca,
Here is the description of the "PW not forwarding" bit as per RFC 4447:

"The presence of the lowest bit (PW Not Forwarding) acts only as a
generic failure indication when there is a link-down event for which
none of the other bits apply."

So, we still need a bit to indicate a failure which is not explicilty
indicated by the AC and PSN failure bits. A good example of using this
bit is when an LSP switches its path and if the new path MTU does not
match anymore that signaled in the PW FEC, this bit is used to signal
the remote PE. There may be other types of failures which could use this
bit.

I can only conclude that we need a separate bit for the "Active/Standby"
status.

Mustapha.

---

From: Luca Martini <[email-masked]>
Date: Mon, 06 Nov 2006 20:06:18 -0700

Yes,
I think that the question  here is as follows:
Does the status needs to have a different effect then "administratively
down " on the remote AC ?
If so , then what happens if there is an LDP session failure ? or label
withdraw ?

One case I think would require this bit , is SONET aps. In that case the
remote PE should set the standby bit , as opposed to sending an AIS
alarm.  In this case , why can't we figure out what to do based on the
received SONET K1,K2 bytes ?

Any other cases ?

If we need one, I would suggest having a separate very short document
only on the definition and semantics of a new status bit without all the
application text that we have seen in the multiple documents on this
subject.

Then those documents can more clearly reference the "standby status bit"
document , and describe possible different schemes to achieve PW 
redundancy.

Luca

---

From: "DOLGANOW Andrew" <[email-masked]>
Date: Tue, 7 Nov 2006 12:34:41 -0600

All,

After further discussions with Luca it seems that the best way forward
seems to be a short draft that defines the new bit. 

In a nutshell, we want an indication that a given pseudowire is
established and has no failure that would prevent traffic forwarding
once the PW is elected to become operationally up. The "standby"
pseudowire must not result in any alarm/OAM indications towards ACs. The
case to handle as wells is what to do when one end receives the
"standby" indication but does not support the active/standby bit.

Andrew 

> -----Original Message-----
> From: Luca Martini [mailto:[email-masked]] 
> Sent: Monday, November 06, 2006 10:06 PM
> To: AISSAOUI Mustapha
> Cc: [email-masked]
> Subject: Re: Active/Standby Status Bit
> 
> Yes,
> Does the status needs to have a different effect then 
> "administratively down " on the remote AC ?
> If so , then what happens if there is an LDP session failure 
> ? or label withdraw ?
> 
> One case I think would require this bit , is SONET aps. In 
> that case the remote PE should set the standby bit , as 
> opposed to sending an AIS alarm.  In this case , why can't we 
> figure out what to do based on the received SONET K1,K2 bytes ?
> 
> Any other cases ?
> 
> If we need one, I would suggest having a separate very short 
> document only on the definition and semantics of a new status 
> bit without all the application text that we have seen in the 
> multiple documents on this subject.
> 
> document , and describe possible different schemes to achieve 
> PW redundancy.
> 
> Luca
> 
> AISSAOUI Mustapha wrote:
> > Luca,
> > the remote PE. There may be other types of failures which could use 
> > this bit.
> >

---

From: "Sasha Vainshtein" <[email-masked]>
Date: Tue, 7 Nov 2006 20:42:52 +0200

Hi all,
IMHO such a draft (once prepared) should be handled by the PWE3 WG. Did I miss something
 
Regards,
                       Sasha

________________________________

From: DOLGANOW Andrew [mailto:[email-masked]]
Sent: Tue 11/7/2006 06:34
To: Luca Martini; AISSAOUI Mustapha; Marc Lasserre
Cc: [email-masked]
Subject: RE: Active/Standby Status Bit

All,

Andrew

---

From: "DOLGANOW Andrew" <[email-masked]>
Date: Tue, 7 Nov 2006 12:48:36 -0600

I agree. 
 
Andrew

	From: Sasha Vainshtein [mailto:[email-masked]] 
	Sent: Tuesday, November 07, 2006 1:43 PM
	To: DOLGANOW Andrew; Luca Martini; AISSAOUI Mustapha; Marc
Lasserre
	Cc: [email-masked]; [email-masked]; [email-masked]
	Subject: RE: Active/Standby Status Bit

	Hi all,
	IMHO such a draft (once prepared) should be handled by the PWE3
WG. Did I miss something
	 
	Regards,
	                       Sasha

	All,
	
	After further discussions with Luca it seems that the best way
forward
	seems to be a short draft that defines the new bit.
	
	In a nutshell, we want an indication that a given pseudowire is
	established and has no failure that would prevent traffic
forwarding
	once the PW is elected to become operationally up. The "standby"
	pseudowire must not result in any alarm/OAM indications towards
ACs. The
	case to handle as wells is what to do when one end receives the
	"standby" indication but does not support the active/standby
bit.
	
	Andrew

---

From: "Dutta, Pranjal" <[email-masked]>
Date: Wed, 8 Nov 2006 00:42:35 +0530

Hi Andrew,
                          We have addressed the backward compatibility issue with PW standby bit in "Section 7. PW state machine" in the draft. As per current proposal we don't do anything when standby bit is not understood by the receiver. We made that way as it solves the purpose in H-VPLS application (PE-rs doesn't block the PW groups to MTU-s if standby bit not understood).
 
Thanks,
Pranjal 

From: DOLGANOW Andrew [mailto:[email-masked]]
Sent: Wed 11/8/2006 12:04 AM
To: Luca Martini; AISSAOUI Mustapha; Lasserre, Marc
Cc: [email-masked]
Subject: RE: Active/Standby Status Bit

All,

Andrew