Subject: draft-ietf-l2vpn-evpn

From: "Ali Sajassi (sajassi)" <[email-masked]>
Date: Tue, 12 Mar 2013 14:53:51 +0000

In preparation for WG last call of this draft, our L2VPN chairs have asked us to solicit comments on the BGP section of this document (section 8).

http://www.ietf.org/id/draft-ietf-l2vpn-evpn-03.txt

Please kindly review this draft and post your comments by Friday March/29.

Thanks,
Ali

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 12 Mar 2013 13:48:40 -0400

Ali:

Thanks for sending the draft.  

Please consider IPv6 in your draft. You may want to talk to the authors of
draft-ietf-idr-bgp-ipv6-rt-constrain. 

https://datatracker.ietf.org/doc/draft-ietf-idr-bgp-ipv6-rt-constrain/

Sue 

From: [email-masked] [mailto:[email-masked]] On Behalf Of
Ali Sajassi (sajassi)
Sent: Tuesday, March 12, 2013 10:54 AM
To: [email-masked]
Cc: [email-masked]; Giles Heron (giheron)
Subject: draft-ietf-l2vpn-evpn

In preparation for WG last call of this draft, our L2VPN chairs have asked
us to solicit comments on the BGP section of this document (section 8).

Thanks,

Ali

---

From: Satya Mohanty <[email-masked]>
Date: Fri, 15 Mar 2013 22:16:14 +0000

Few comments,

1. Sec 8.3: Please consider putting in a line stating that the per ESI Route (type 4) carries a label with all 0s (like the Type 1 mandatory route) in the MP-Reach NLRI.

2. This is not explicitly sec 8 but I think there may be a discrepancy in the draft.  Page 27, top paragraph

   An PE may advertise the same single E-VPN label for all MAC addresses
   in a given EVI. This label assignment methodology is referred to as a
   per EVI label assignment. Alternatively, an PE may advertise a unique
   E-VPN label per <ESI, Ethernet Tag> combination. This label
   assignment methodology is referred to as a per <ESI, Ethernet Tag>
   label assignment. As a third option, an PE may advertise a unique E-
   VPN label per MAC address. All of these methodologies have their
   tradeoffs.

I see a problem with the third option (per-prefix allocation mode), related to aliasing in the Active/Active case.
In such a label allocation mode, what label will be associated with the per EVI AD route ?

Let's say PE1 and PE2 share the same ESI, PE1 and PE1 uses per prefix label  allocation mode, and PE2 uses either per EVI or per <ESI, Ethernet-tag> label allocation mode. As per the aliasing behavior, a mac route (say p1 with label l1) advertised from PE1, should be reachable from PE3 via PE2, irrespective of whether PE2 advertised p1 or not.  If PE2 did not advertise p1, but PE3 sends traffic to PE2, what label does PE3 slap on frames? As per the draft, it will slap the label what was received in the per EVI AD route. Moot question is what does it correspond to here ?

Should per-prefix label allocation be allowed? If it is, I think then the concept of aliasing will be lost, and all macs with the same EVI, ESI need to be advertised from each of the PEs configured to the same ES.

       PE1 -- --- --|
    /                       |_______
CE                         ________ RR-------PE3
   \                        |
      PE2 ---------|

Thanks,
--Satya

From: [email-masked] [mailto:[email-masked]] On Behalf Of Ali Sajassi (sajassi)
Sent: Tuesday, March 12, 2013 7:54 AM
To: [email-masked]
Cc: [email-masked]; Giles Heron (giheron)
Subject: draft-ietf-l2vpn-evpn

Thanks,
Ali

---

From: Jakob Heitz <[email-masked]>
Date: Fri, 15 Mar 2013 23:17:09 +0000

The egress PE can allocate MAC labels anyway it likes
as long as it can deliver the frame when it arrives
with that label. It is not necessarily the same
as the alias label. A frame arriving with the alias
label will most likely undergo a MAC/VLAN lookup.
This does not prevent it from using a different
label allocation scheme for MAC labels than for
alias labels.

--
Jakob Heitz. x25475. 510-566-2901

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of Satya Mohanty
Sent: Friday, March 15, 2013 3:16 PM
To: Ali Sajassi (sajassi); [email-masked]
Cc: [email-masked]; Giles Heron (giheron)
Subject: RE: draft-ietf-l2vpn-evpn

Few comments,

       PE1 -- --- --|
    /                       |_______
CE                         ________ RR-------PE3
   \                        |
      PE2 ---------|

Thanks,
--Satya

Thanks,
Ali

---

From: Satya Mohanty <[email-masked]>
Date: Sat, 16 Mar 2013 00:04:48 +0000

I am guessing you mean the 'alias label"  to be the label in the per EVI AD route ?

I understand that "PE can allocate MAC labels anyway it likes as long as it can deliver the frame when it arrives
with that label." In the case I am mentioning, the frame is not coming with "that" label, PE2 did not advertise the mac route p1, at all to PE3, so PE3 does not know  the per prefix label allocated by PE2. So, it will only have to use the per EVI AD label from PE2. At the egress (PE2), yes, this will defaults to a mac/vlan lookup, but this is like a per vrf or per CE (per esi per evi) behavior.

Also, I was not aware that one can use different allocation scheme for MAC labels and "alias" labels.
So, what I infer is you are suggesting that label allocation mode could be also per NLRI type?

Thanks
--Satya

From: Jakob Heitz [mailto:[email-masked]]
Sent: Friday, March 15, 2013 4:17 PM
To: Satya Mohanty; Ali Sajassi (sajassi); [email-masked]
Cc: [email-masked]; Giles Heron (giheron)
Subject: RE: draft-ietf-l2vpn-evpn

________________________________
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Satya Mohanty
Sent: Friday, March 15, 2013 3:16 PM
To: Ali Sajassi (sajassi); [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; Giles Heron (giheron)
Subject: RE: draft-ietf-l2vpn-evpn
Few comments,

       PE1 -- --- --|
    /                       |_______
CE                         ________ RR-------PE3
   \                        |
      PE2 ---------|

Thanks,
--Satya

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Ali Sajassi (sajassi)
Sent: Tuesday, March 12, 2013 7:54 AM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; Giles Heron (giheron)
Subject: draft-ietf-l2vpn-evpn

Thanks,
Ali