Subject: Fwd: Improving and Restructuring the Routing Area

From: Giles Heron <[email-masked]>
Date: Tue, 10 Jun 2014 21:43:46 +0100

please do read this.	

Begin forwarded message:

> Resent-From: <[email-masked]>
> From: Alia Atlas <[email-masked]>
> Subject: Fwd: Improving and Restructuring the Routing Area
> Date: 10 June 2014 21:14:10 BST
> Resent-To: <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>, <[email-masked]>
> To: "[email-masked]" <[email-masked]>
> 
> Could you please forward to your working groups for those not on routing-discussion?
> 
> Thanks,
> Alia
> 
> ---------- Forwarded message ----------
> From: Alia Atlas <[email-masked]>
> Date: Tue, Jun 10, 2014 at 3:57 PM
> Subject: Improving and Restructuring the Routing Area
> To: [email-masked]
> 
> 
> To all participants in the Routing Area,
> 
> Adrian and I are working on improving the quality, speed, and
> experience of getting work done in the IETF Routing Area.  There are
> three initiatives that we are working: WG Draft QA, Routing Area
> specific WG chair training, and reorganizing the working groups in the
> area.
> 
> First, we intend to use our Routing Directorate more proactively by
> introducing a Working Group Draft Quality Assurance (WG Draft QA)
> process where the same selected routing directorate member will review
> a draft during WG draft adoption and during WG last call.  The process
> will be documented on the Routing Area wiki
> (http://trac.tools.ietf.org/area/rtg/trac/wiki).  This should allow
> directorate reviews to report technical issues that can actually get
> fixed early in the process (equivalent of bug reports) as opposed to
> just noting the concerns in the drafts (equivalent of release notes).
> 
> Second, as was discussed during the recent IESG retreat, in addition
> to the IETF-wide WG chair training, we intend to have a series of
> training sessions for WG Chairs in the Routing Area addressing topics
> such as judging consensus, project management, motivating volunteers,
> using the datatracker (via a sandbox version that can be played
> with safely), and sharing experiences between WG chairs.
> 
> Third, we intend to reorganize the working groups in the Routing area.
> We feel that it is important to focus on areas where there is active
> interest in standardization and to be open and able to accept new work
> into the area.  As you know, we have had several new working groups
> (nvo3, i2rs, sfc, spring) created in the last few years and we need to
> be open and able to handle more new work as it comes in.  We would
> also like to improve the signal-to-noise ratio experienced by
> participants in the different working groups and improve the quantity
> and quality of discussion and reviews.  It is likely that not all WGs
> in the Routing Area will be directly affected.
> 
> Here is the time-line for reorganizing the WGs.
> 
>    NOW: public discussion on [email-masked] about how to
>    reorganize the working groups to best meet our motivations.
>    Additional focused discussions are expected on the
>    [email-masked] and [email-masked] mailing lists.
> 
>    In Toronto: There will be meetings with the WG chairs and the
>    Routing Directorate to get the ideas described and agreed upon.
> 
>    At the Routing Area Meeting in Toronto: Discuss the set of
>    reorganized WGs and general charter content in the Routing Area
>    meeting.
> 
>    September 2014: Based upon the feedback, suggestions, and
>    discussion, Adrian and I finalize the reorganized WG charters.  We
>    start the internal IESG discussion and public reviews.
> 
>    October 2014: Formal rechartering process completes.
> 
>    In Honolulu: The new set of WGs meet.
> 
>    After Honolulu: Adrian and I deal with any issues and charter
>    updates based upon a few months of experience.
> 
> Here are the motivations that Adrian and I would like to be considered
> when coming up with ideas for how the WGs should be reorganized.
> 
>    1) Move towards organizing working groups on functional
>    responsibilities rather than scoping them to specific protocols.
> 
>    2) Split giant working groups so relevant work is done in one place
>    and there is an improved signal-to-noise ratio for participants who
>    are only interested in a slice of the current working group's work.
> 
>    3) Create synergies for scattered functionality (example ideas:
>    OAM, FRR, traffic-engineering)
> 
>    4) Create a DISPATCH working group for clear new idea discussion;
>    rtgwg serves some of this purpose but doesn't have a clear process
>    and isn't drawing in the new ideas.
> 
>    5) Focus Routing Area time on design centers rather than on far
>    corner cases.
> 
>    6) Each working group should have clear, well defined, and achievable goals.
> 
> Noting that the Routing Area has inherited some of its WG structure
> from the sub-IP area, it is not a goal to force IP routing and MPLS
> routing to remain separated.
> 
> The goal of this reorganization is not closing working groups.  Adrian
> and Alia are perfectly capable of closing working groups without going
> through restructuring.
> 
> For those of you that have read this far, thank you.  Getting this 80%
> right is going to take some serious discussion and thought.  We all
> work in the Routing Area together with different perspectives.  Please
> think carefully and help us have a highly focused discussion.
> 
> Thanks,
> Alia and Adrian
> 
>

---

From: Giles Heron <[email-masked]>
Date: Tue, 10 Jun 2014 21:52:43 +0100

please also note that discussion will happen on [email-masked].  So if you want to participate then please join that list.

Giles