Subject: [L3sm] L3 service model suggestion

From: Lucy yong <[email-masked]>
Date: Thu, 25 Feb 2016 15:59:26 +0000

Hi All,

Current L3vpn service model (the draft) specifies vpn-svc and site containers only. In order to address multiple vpn at one site, we need vpn-svc per site container too. Some attributes under site container should belong to vpn-svc per site container such as vpn-policy, service, etc. The site container needs to have a parameter "multiplexing" to indicate if a site will have single vpn or multiple vpn. This will address the issue of multi-vpn at a site discussed in today's interim meeting.

Not sure why need site-template container.

Regards,
Lucy

---

From: Qin Wu <[email-masked]>
Date: Fri, 26 Feb 2016 03:15:29 +0000

Hi, Lucy:
发件人: L3sm [mailto:[email-masked]] 代表 Lucy yong
发送时间: 2016年2月25日 23:59
收件人: [email-masked]
主题: [L3sm] L3 service model suggestion

Hi All,

Current L3vpn service model (the draft) specifies vpn-svc and site containers only. In order to address multiple vpn at one site, we need vpn-svc per site container too. Some attributes under site container should belong to vpn-svc per site container such as vpn-policy, service, etc.

[Qin]: I believe vpn-policy has already been modeled as vpn-svc per site, see section 5.2.2
https://tools.ietf.org/html/draft-ietf-l3sm-l3vpn-service-model-02#section-5.2.2
For service, what are defined for service are common attributes that are applied to all the VPN service if one site belonging to multiple VPN service.
Please see examples in the section 5.2.6.

The site container needs to have a parameter “multiplexing” to indicate if a site will have single vpn or multiple vpn. This will address the issue of multi-vpn at a site discussed in today’s interim meeting.

[Qin]: For vpn-policy, it is implicitly indicated by the number of policy entries.

[Qin]: Site-templates allow to define configuration blocks that will be  inherited by one or multiple sites in order to speed up
   configuration. See more details in section 5.4 of service model draft.

Regards,
Lucy

---

From: Lucy yong <[email-masked]>
Date: Fri, 26 Feb 2016 15:49:36 +0000

Hi Qin,

Please see below.

From: Qin Wu
Sent: Thursday, February 25, 2016 9:15 PM
To: Lucy yong; [email-masked]
Subject: RE: L3 service model suggestion

Hi, Lucy:
发件人: L3sm [mailto:[email-masked]] 代表 Lucy yong
发送时间: 2016年2月25日 23:59
收件人: [email-masked]<mailto:[email-masked]>
主题: [L3sm] L3 service model suggestion

Hi All,

[[Lucy]] I see the description. But the YANG module in section 5 can not cover the case that a site that attaches to multiple VPNs and different service policies for individual VPNs. I think this is common use case.

[Qin]: For vpn-policy, it is implicitly indicated by the number of policy entries.
[[Lucy]] IMO: whether site attaching to single VPN or multiple VPNs is a major service property,  good to have an attribute to differentiate two cases. This is related to site attribute, not VPN-policy.

[Qin]: Site-templates allow to define configuration blocks that will be  inherited by one or multiple sites in order to speed up
   configuration. See more details in section 5.4 of service model draft.
[[Lucy]] I still don’t know the value of it yet. I will read more and learn. :)

Thanks,
Lucy

Regards,
Lucy

---

From: Qin Wu <[email-masked]>
Date: Sat, 27 Feb 2016 01:49:10 +0000

I believe section 5 covers what you are asking for regardless of single VPN, multiple VPN. I would suggest you need to better understand the model design principle in the current model we have worked for quite a long time and consult with author of service model draft if you have any further questions.
Thanks for your high level review and your proposal on “multiplexing”. Whether we need an explicit parameter to distinct single vpn from multiple vpn, I leave this to authors. Thanks again.

-Qin
发件人: Lucy yong
发送时间: 2016年2月26日 23:50
收件人: Qin Wu; [email-masked]
主题: RE: L3 service model suggestion

Hi Qin,

Please see below.

From: Qin Wu
Sent: Thursday, February 25, 2016 9:15 PM
To: Lucy yong; [email-masked]<mailto:[email-masked]>
Subject: RE: L3 service model suggestion

Hi, Lucy:

Hi All,

Thanks,
Lucy

Regards,
Lucy

---

From: <[email-masked]>
Date: Mon, 29 Feb 2016 08:29:22 +0000

Hi,

I think the “multiplexing” keyword Lucy was mentioning could make sense if WG decide to go with the proposal discussed for subVPN during the call.

Reminder of the proposal :
Use site-network-access to define a subVPN attachment and add a “sub-site-id” leaf in this case.
A “multiplexing” leaf at site level may allow to enforce the presence of the sub-site-id.

Example :

+--rw site
                +--rw site-id
                +--rw (all site properties)
                +--rw vpn-multiplexing                 identityref
                +--rw site-network-accesses [site-network-access-id]
                                +--rw site-network-access-id
                                +--rw sub-site-id                              -> this will be mandatory if vpn-multiplexing identity equals to “sub-vpn”
                                +--rw (all site-network-access properties)

From: L3sm [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Saturday, February 27, 2016 02:49
To: Lucy yong; [email-masked]
Subject: Re: [L3sm] L3 service model suggestion

-Qin
发件人: Lucy yong
发送时间: 2016年2月26日 23:50
收件人: Qin Wu; [email-masked]<mailto:[email-masked]>
主题: RE: L3 service model suggestion

Hi Qin,

Please see below.

From: Qin Wu

Hi, Lucy:

Hi All,

Thanks,
Lucy

Regards,
Lucy

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Qin Wu <[email-masked]>
Date: Mon, 29 Feb 2016 09:20:12 +0000

Good, we haven’t got subVPN issue concluded due to running out of time in the last week interim meeting. Thank for Stephane’s proposal on both subVPN and multiplexing.
It would be great to see a single proposal to address subVPN together with “multiplexing”.

WG, please help review the following proposed change to the base service model and provide your opinion on it.
Thanks!

-Qin
发件人: [email-masked] [mailto:[email-masked]]
发送时间: 2016年2月29日 16:29
收件人: Qin Wu; Lucy yong; [email-masked]
主题: RE: L3 service model suggestion

Hi,

Example :

+--rw site
                +--rw site-id

-Qin
发件人: Lucy yong
发送时间: 2016年2月26日 23:50

Hi Qin,

Please see below.

From: Qin Wu

Hi, Lucy:

Hi All,

Thanks,
Lucy

Regards,
Lucy

Thank you.