Subject: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

From: "Ogaki, Kenichi" <[email-masked]>
Date: Thu, 18 Feb 2016 10:08:30 +0900

Hi Stephane and All,

As for issue #10 itself, the following solution can be acceptable for us.

>One proposal could be to not call this VPN policy, but creating a container "extranet-vpn-policy" at vpn level which will mandate an extranet 
>VPN architecture from a configuration point of view, deducing automatically the appropriate RT rules to add (like creating a new pair of RTs).

What model is in your mind? I can't see what ""extranet-vpn-policy" at vpn" means.
Like this?

<vpn-svc>
   ...
   <vpn-policy>
       <entries>
           <id>1</id>
           <vpn>
               <vpn-id>VPN1</vpn-id>
           </vpn>
           <extranet-vpn-policy>
               <extranet-vpn>
                   <vpn-id>VPN2</vpn-id>
               </extranet-vpn>
           </extranet-vpn-policy>
       </entries>
   </vpn-policy>
   ...
</vpn-svc>

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, December 07, 2015 11:45 PM
To: Ogaki, Kenichi; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi Kenichi,

Regarding your proposal of having a simple VPN policy in the vpn-svc container, I do see an issue. One of the key point of the VPN policy is to express the role of the site in the target VPN topology.
If we do a vpn policy at VPN level, we cannot anymore describe site roles in the target VPN which causes an issue.
In an ideal world where all VPNs are any to any, the site role is always the same and there is no issue, but let's think about someone trying to use the vpn-policy (at vpn level) to connect to a Hub & Spoke VPN, how do you deduce the roles of the sites ?

One proposal could be to not call this VPN policy, but creating a container "extranet-vpn-policy" at vpn level which will mandate an extranet VPN architecture from a configuration point of view, deducing automatically the appropriate RT rules to add (like creating a new pair of RTs). This means that the usage is really limited to "simple" extranet-vpns and it does not replace nor compete with the VPN policy at site level.

Could it be a good compromise ?

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Saturday, December 05, 2015 06:23
To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear Stephane and All,

I don't say that sites *must* move under vpn-svc because I understand stephane's use case.
But we already have vpn-svc and some parameters under this are globally applied to all the sites even in the current model.

It depends on operator's use case which is site-oriented or vpn-oriented service.
Our service is vpn-oriented, site has the native VPN. Then, I would just like you to allow other global options to vpn-svc.

Thanks,
Kenichi

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Friday, December 04, 2015 8:17 PM
To: Aijun Wang; 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: RE: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi,

I'm against this proposal, as I do not want to create any dependency between a particular VPN and a list of sites.
A site can belong to multiple VPNs with any kind of topology, if we attach the site to a single VPN, we come back to the notion of "native VPN" we had at the beginning of the model which was hard to understand and so was removed.

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Friday, December 04, 2015 02:44
To: 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear all:

Can we put the list "sites" within the list "vpn-svc", and define the general vpn policy for all sites that within the corresponding vpn service instance?
If doing so, some entries within the current list "sites" can also be dragged out for general usual purposes, for example, "maximum-routes", "security" etc. These parameters are often all same for every site within one VPN service instance. 

If some sites have special requirements, we can achieve this by using some special "site-vpn-policy" within the corresponding site definition.
Is this more acceptable for customers?

Best Regards.

Aijun Wang

China Telecom Corporation Limited Beijing Research Institute Intelligent Network Product Line

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Friday, December 04, 2015 9:02 AM
To: 'Qin Wu'; [email-masked]
Cc: [email-masked]
Subject: Re: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Dear All,

It was good having discussion.

As for issue#10, the objective and problem we discussed in the meeting as follows.

The objective is to provide per-VPN extranet service which connects two different VPNs (e.g. VPN1 and VPN2). It means that any sites in VPN1 can access to any sites in VPN2.
The problem is that the current model must update vpn-policy under all the sites belong to these two VPNs in order to offer this service. Especially when this model is used as a customer self-control API, it's not good idea to require customers to update the information of all the sites. (It's not abstracted way, a service model should provide what the consumer wants, not how.) If a service or customer requires to control per-site vpn-policy, that of current model should be used without setting per-VPN vpn-polity. It depends on each operator's service.
Stephane proposed to use apply-template, but it still cannot solve the problem. When each VPN already has a large number of sites and want to connect each other for the first time, both VPNs must update these sites to apply apply-template on the current model.

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Friday, December 04, 2015 12:42 AM
To: [email-masked]
Cc: [email-masked]
Subject: [L3sm] L3SM interim meeting minutes on Thursday L3SM interim session

Hi all:

Below is the initial version of draft minutes for Thursday L3SM WG interim session.

Thanks Dan to help take minutes.

Folks, please let us know if you have any correction.

-Qin

===============================================================================

L3SM Working Group Virtual Interim Meeting 

Thursday December 5th, 2015. 8am East Coast Time (New York)

BLUE SHEET

Name                    | Affiliation

------------------------+-----------------------------------------------
------------------------+-

Adrian Farrel           | Old Dog Consulting

Qin Wu                  | Huawei Technologies

Stephane Litkowski      | Orange

Luis Tomotaki           | Verizon

Daniel King             | Old Dog Consulting

Susan Hares             | Huawei Technologies

Scott Mansfield         | Ericsson

Gu Rong                 | China Mobile 

Kenichi Ogaki           | KDDI

Aijun Wang              | China Telecom

Victor Santos           | Ericsson

Ignas Bagdonas          | 

MINUTES

* Meting logiistics https://mailarchive.ietf.org/arch/msg/l3sm/SJub1aHVQGOQW6rWhthX0fB8Ac8 

* Meeting materials https://www.ietf.org/proceedings/interim/2015/12/03/l3sm/proceedings.html 

* Etherpad for minutes (this page) http://etherpad.tools.ietf.org:9000/p/l3sm-interim-2015-12-03

* Jabber using [email-masked]

* Blue sheet http://etherpad.tools.ietf.org:9000/p/l3sm-interim-2015-12-03-bluesheet

Agendaa

- Administrivia (Note Well, etc). a

- Introduction

- Open Issues for YANG Data Model for L3VPNservice delivery (draft-ietf-l3sm-l3vpn-servicemodel)

o Open Issues discussion and resolution– http://trac.tools.ietf.org/wg/l3sm/trac/report/1

For a full list of issues and resolution proposals please see: https://www.ietf.org/proceedings/interim/2015/12/03/l3sm/slides/slides-interim-2015-l3sm-1-2.pdf

Issue#1: When customer-nat-address is used

Resolution #1:  Leaf used when NAT is required to access cloud VPN and customer wants to use its ownIP address. If provider provides the public IP,no need to use the leaf

Status #1:  Closed Pending I-D text review.   

Discussion on #1: 

Aijun asks for more description in the YANG model itself

Stephane shows current model

Agreed OK

Issue#2 : Identify l3vpn svc using id or name or both

Resolution #2:  ID is a string, as per other properties in the model

Status #2: Closed

Discussion on #2: 

Agreed OK

Issue#3: M to N availability support

Resolution #3: Modeling sites using a list with a priority, so include access list with a priority.

Status #3:

Discussion on #3: 

Qin was asking that M to N availability is supported with access and priority number. 

Stephane stated this is suppoted. This new proposal also supports multiple sites, as a list.

Qin also asked if Group I-D was no longer needed, which it is not. Also good solution supported by other operators.

Stephane asked if four priorities was enough, or if more were needed. 

Re: Containers/Properties for Network Access Configuration - Conclusions?

o Location - Different site I-D?

o QoS Policy - Per network access link, or site information? Would QoS (cost) be different per accesslink or site? Example of Primary and Backup links given. 

o Bandwidth - Moved to access link group 

o Maximum Routes - 

Security, routing, and services are duplicated with inheritance

Issue#4: site-service-cloud access as grouping

Resolution #4 Already resilved as a separate grouping

Status #4: Closed

Discussion on #4: 

Issue#5: Multicast support as raised by Eric Rosen

Resolution #5: : New "provider managed" property, and in Site Properties "property-type"  added

Status #5: Solution proposed. 

Discussion on #5: 

Stephane will proviode new property proposals will be provided to Eric for review. 

Issue#6: Inventory operational state

Resolution #6: Include a new container for inventory state, or an RPC call (sitting above the service orchestrator) to retrieve inventory state. 

Status #6: Need to propose to the WG and agree solution.

Discussion on #6: 

Luis asked would this info be collected from provision state? Stephane suggested this would not be availible. 

Adrian observed that the code used to convert the model into a service request may not utilise this inventory information capability. Sue mentioned that others have mentioned by a vendor that it would be useful to have the ability to configure inventory state. This should be clarified by the operators. 

Stephane to take proposals to list and ask anyone who is interested in having the feature to suggest text.

Issue#7: Generic VAS - do we need to create a generic VAS container as VAS are popular in L3VPNs?

Resolution #7: Separate from L3SM

Status #7: Closed

Discussion on #7: 

Gu Rong highlighted Generic VAS model which was presented at IETF 94. 

Issue#8: Who keeps site locationinformation?

Resolution #8: Text has been fixed

Status #8: Closed

Discussion on #8: 

Issue#9: Do we need to model transport constraints, such as: jitter, disjoint, path diversity?

Resolution #9:   Propose a "transport-constraint" group with "constraint-type", "constraint-value" and "constraint-list" (composed of type and values)

Status #9: Authors to propose the resolution in the I-D and provide to the WG

Discussion on #9:    

Luis mentioned that they have multicast transport (multiple sites) and bi-directional traffic applications (financial) that will require transport constraints

Duplicate transport constraints for unicast and multicast to give options for separate configuration.

Keep single list entries for each src/dst pair even in the multicast variant.

DO we need to support multiple constraints or just have a single composite (of multiple constraints), have the ability to specify a constraint-list?

Aijun prfers list of constraints and meeting agrees this is OK

What constraints to offer?

Latency

Path diversty

Site diversty

Jitter

Class of service was proposed but rejected

Luis highlighted they have a current implementation that uses the similar proposal. Luis also mentioned that site diversity might also be required, would this be achievable

Issue#10: VPN "merging"

Resolution #10:    

Status #10:

Discussion on #10:    

VPN is a per site property. 

- A site can belong tomultiple VPNs

- How to handle merging of two VPNs?

- Is this an issue the service model has to deal with?

If VPN merging is required to be seamless, then this would be device specific and not service model related.  

"Merging" is a confusing term. The objective is NOT to merge VPN1 and VPN2.

The objective is to provide an extranet so that some sites in VPN1 can connect to some sites in VPN2 for some traffic.

This can be solved using a per-site property.

Action: Need to update this issue to make it clear what function was being discussed, also Stephane will send options to the working group- list. 

We are specifically looking for people who offer extranet connection between sites from different VPNs

== Other Issues ==    

Modeling Customer Specific Info

- Create appropiate containers for Provider Edge and Customer Site routers

- The current  model contains routing parametres that refer to CE and PE relationships

- General agreement is routing info should be split and current proposal will be sent to the list for Kenichi, and working groups, review. 

== Conclusions ==

- A number of resolutions have been agreed and will be updated in the I-D

- Chairs would like to see revised I-D based on the agreed points

- Plan to have another interim call at the end of January (2016)

- Chairs to add new tracker items, including security for future discussion. 

_______________________________________________
L3sm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/l3sm

_______________________________________________
L3sm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/l3sm

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorization.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange shall not be liable if this message was modified, changed or falsified.
Thank you.

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorization.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange shall not be liable if this message was modified, changed or falsified.
Thank you.

_______________________________________________
L3sm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/l3sm

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Wed, 24 Feb 2016 09:11:15 +0900

Hi Aijun,

See comments inline, please.

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Thursday, February 18, 2016 1:12 PM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Stephane and Ogaki:

I suggested we put the "extranet-vpn-policy" under the list "vpn-svc" directly, not in the container "vpn-policy" that is now under the list "sites" in current model. 

[KO]Like this?

    container l3vpn-svc {
        list vpn-svc {
            key vpn-id;

            leaf vpn-id {
                …
            }
            ...
            list extranet-vpn-policy {
                key vpn-id;
                leaf vpn-id {
                    type svc-id;
                }
            }
            ...
        }
        ...
    }

This can solve the initial scenario that proposed by Kenichi at the beginning of our discussion. When the orchestrator receives the information defined in "extranet-vpn-policy", it can allocate new route-target for the involved VPNs and set them in the configuration stanza of each router.

For the relationship of list "vpn-svc" and list "sites", I still suggest we put the list "site" under the "vpn-svc", the reason for doing this is as below:

1. the service model must be service oriented. If one site belongs to several vpns, we should achieve the goal by defining several service instances.

[KO] I can't agree this. The case that a site belongs to multiple vpns is also a very common service use case, then the service model must design this appropriately.
For easy use of a service model and to avoid the misconfiguration and inconsistency, we have to exclude duplicate configuration for the same information, data node instance, as much as possible. Then, I proposed to remove repetitive definitions of a vpn which can be implicitly uniquely identified in a same transaction. But, that eventually came not to make sense for restconf.
In that sense, I basically prefer the current model.

2. The attributes of "sites", such as "maximum-routes", "security", "service", "routing-protocols","site-netwok-accesses" etc. are all service/site role related, that is to say, if the site role changed, all of these attributed may be changed accordingly.

[KO] I basically agree. The attributes tied to a whole vpn and globally applied to all the sites under the vpn should be defined with the vpn definition.

3.For container "vpn policy" that under list "sites" in current model, there are two information defined, one is "filter" for prefix filtering, another is "site-role". I suggest we split it, put the leaf "site-role" under leaf "site-id" directly, and change the name of "vpn-policy" to "site-prefix-policy". 

The final suggest structure of the L3VPN yang model will be look like the bellow, I underline the changed positions from the current l3vpn Yang Model

Container L3vpn-svc

   List vpn-svc

   Leaf vpn-id

   Leaf customer-name

   Leaf topology

   List extranet-vpn-policy

   Container cloud-access

   List multicast

   Leaf mpls

   List transport-contraints

   List sites

     Leaf site-id

     Leaf site-role

     leaf apply-template

     ... ...

     ... ...

     Container managent

     Container site-prefix-policy

     Container maximum-routes

     Container security

     ... ...

     ... ...

     Site-network-access 

Whether is it more reasonable? 

Best Regards.

Aijun Wang

China Telecom Corporation Limited Beijing Research Institute 

Network Research and Operation Support Department

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Thursday, February 18, 2016 9:08 AM
To: [email-masked]
Subject: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stephane and All,

>One proposal could be to not call this VPN policy, but creating a 

>container "extranet-vpn-policy" at vpn level which will mandate an extranet VPN architecture from a configuration point of view, deducing automatically the appropriate RT rules to add (like creating a new pair of RTs).

Like this?

<vpn-svc>

   ...

   <vpn-policy>

       <entries>

           <id>1</id>

           <vpn>

               <vpn-id>VPN1</vpn-id>

           </vpn>

           <extranet-vpn-policy>

               <extranet-vpn>

                   <vpn-id>VPN2</vpn-id>

               </extranet-vpn>

           </extranet-vpn-policy>

       </entries>

   </vpn-policy>

   ...

</vpn-svc>

Thanks,

Kenichi

-----Original Message-----

From: L3sm [mailto:[email-masked] <mailto:[email-masked]> ] On Behalf Of [email-masked] <mailto:[email-masked]> 

To: Ogaki, Kenichi; 'Aijun Wang'; 'Qin Wu'; [email-masked] <mailto:[email-masked]> 

Cc: [email-masked] <mailto:[email-masked]> 

Hi Kenichi,

Stephane

-----Original Message-----

From: Ogaki, Kenichi [mailto:[email-masked] <mailto:[email-masked]> ]

To: LITKOWSKI Stephane SCE/OINIS; 'Aijun Wang'; 'Qin Wu'; [email-masked] <mailto:[email-masked]> 

Cc: [email-masked] <mailto:[email-masked]> 

Dear Stephane and All,

Thanks,

Kenichi

-----Original Message-----

From: [email-masked] <mailto:[email-masked]>  [mailto:[email-masked] <mailto:[email-masked]> ]

To: Aijun Wang; 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked] <mailto:[email-masked]> 

Cc: [email-masked] <mailto:[email-masked]> 

Hi,

 

-----Original Message-----

From: L3sm [mailto:[email-masked] <mailto:[email-masked]> ] On Behalf Of Aijun Wang

To: 'Ogaki, Kenichi'; 'Qin Wu'; [email-masked] <mailto:[email-masked]> 

Cc: [email-masked] <mailto:[email-masked]> 

Dear all:

 

Best Regards.

Aijun Wang

 

-----Original Message-----

From: L3sm [mailto:[email-masked] <mailto:[email-masked]> ] On Behalf Of Ogaki, Kenichi

To: 'Qin Wu'; [email-masked] <mailto:[email-masked]> 

Cc: [email-masked] <mailto:[email-masked]> 

Dear All,

Thanks,

Kenichi

-----Original Message-----

From: L3sm [mailto:[email-masked] <mailto:[email-masked]> ] On Behalf Of Qin Wu

To: [email-masked] <mailto:[email-masked]> 

Cc: [email-masked] <mailto:[email-masked]> 

Hi all:

 

-Qin

 

BLUE SHEET

Name                    | Affiliation

Luis Tomotaki           | Verizon

Gu Rong                 | China Mobile 

Kenichi Ogaki           | KDDI

Victor Santos           | Ericsson

Ignas Bagdonas          | 

 

 

MINUTES

* Meting logiistics https://mailarchive.ietf.org/arch/msg/l3sm/SJub1aHVQGOQW6rWhthX0fB8Ac8 <https://mailarchive.ietf.org/arch/msg/l3sm/SJub1aHVQGOQW6rWhthX0fB8Ac8>  

* Meeting materials https://www.ietf.org/proceedings/interim/2015/12/03/l3sm/proceedings.html <https://www.ietf.org/proceedings/interim/2015/12/03/l3sm/proceedings.html>  

* Etherpad for minutes (this page) http://etherpad.tools.ietf.org:9000/p/l3sm-interim-2015-12-03 <http://etherpad.tools.ietf.org:9000/p/l3sm-interim-2015-12-03> 

* Jabber using [email-masked] <mailto:[email-masked]> 

* Blue sheet http://etherpad.tools.ietf.org:9000/p/l3sm-interim-2015-12-03-bluesheet <http://etherpad.tools.ietf.org:9000/p/l3sm-interim-2015-12-03-bluesheet> 

Agendaa

- Introduction

o Open Issues discussion and resolution– http://trac.tools.ietf.org/wg/l3sm/trac/report/1 <http://trac.tools.ietf.org/wg/l3sm/trac/report/1> 

For a full list of issues and resolution proposals please see: https://www.ietf.org/proceedings/interim/2015/12/03/l3sm/slides/slides-interim-2015-l3sm-1-2.pdf <https://www.ietf.org/proceedings/interim/2015/12/03/l3sm/slides/slides-interim-2015-l3sm-1-2.pdf> 

Discussion on #1: 

Agreed OK

Status #2: Closed

Discussion on #2: 

Agreed OK

Status #3:

Discussion on #3: 

 

 

o Maximum Routes - 

 

Status #4: Closed

Discussion on #4: 

Discussion on #5: 

 

Discussion on #6: 

 

 

Status #7: Closed

Discussion on #7: 

 

Status #8: Closed

Discussion on #8: 

Discussion on #9:    

 

 

 

Latency

Path diversty

Site diversty

Jitter

 

 

Issue#10: VPN "merging"

Resolution #10:    

Status #10:

Discussion on #10:    

 

 

 

 

== Other Issues ==    

 

== Conclusions ==

 

L3sm mailing list

[email-masked] <mailto:[email-masked]> 

https://www.ietf.org/mailman/listinfo/l3sm <https://www.ietf.org/mailman/listinfo/l3sm> 

L3sm mailing list

[email-masked] <mailto:[email-masked]> 

https://www.ietf.org/mailman/listinfo/l3sm <https://www.ietf.org/mailman/listinfo/l3sm> 

Thank you.

Thank you.

L3sm mailing list

[email-masked] <mailto:[email-masked]> 

https://www.ietf.org/mailman/listinfo/l3sm <https://www.ietf.org/mailman/listinfo/l3sm> 

L3sm mailing list

[email-masked] <mailto:[email-masked]> 

https://www.ietf.org/mailman/listinfo/l3sm <https://www.ietf.org/mailman/listinfo/l3sm>

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Wed, 24 Feb 2016 13:58:55 +0900

Hi Aijun,

>For easy use of a service model and to avoid the misconfiguration and inconsistency, we have to exclude duplicate configuration for the same information, data node instance, as much as possible. >Then, I proposed to remove repetitive definitions of a vpn which can be implicitly uniquely identified in a same transaction. But, that eventually came not to make sense for restconf.
>[Aijun Wang]: for sites that belong to several vpns, because we define "vpn-svc" as list, then it can include different items, each vpn-svc item can define its own sites coverage information. >There is also no duplicate configuration for this solution. What's the problem then for this arrangement?

If a physical customer site connects to two different vpns in this case, the customer must input or update the information about the (physical) site duplicately per vpn-svc. This may cause misconfiguration and bother our customers.
Another concern is the inconsistency with accounting/charging model, when an operator charges the fee for physical access, it becomes inconsistent with the charging model. When we does a traffic accounting not only for logical access per vpn, but also for physical access, we must always take care of the existence of different vpn-svc with the same physical access in order to trigger a polling traffic counter of the interface on PE.

I understand it depends on each operator's service definition, vpn specific or site specific, as Stephane wrote.

To accommodate these different requirements, I think the loose coupled model between the components, vpn and site, seems better.

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Wednesday, February 24, 2016 10:06 AM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Ogaki:

Please see the reply inline.

Best Regards.

Aijun Wang

China Telecom Corporation Limited Beijing Research Institute Network Research and Operation Support Department

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, February 24, 2016 8:11 AM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: RE: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Thursday, February 18, 2016 1:12 PM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Stephane and Ogaki:

[KO]Like this?

    container l3vpn-svc {
        list vpn-svc {
            key vpn-id;

            leaf vpn-id {
                …
            }
            ...
[Aijun Wang]: Yes.

[KO] I can't agree this. The case that a site belongs to multiple vpns is also a very common service use case, then the service model must design this appropriately.
For easy use of a service model and to avoid the misconfiguration and inconsistency, we have to exclude duplicate configuration for the same information, data node instance, as much as possible. Then, I proposed to remove repetitive definitions of a vpn which can be implicitly uniquely identified in a same transaction. But, that eventually came not to make sense for restconf.
In that sense, I basically prefer the current model.
[Aijun Wang]: for sites that belong to several vpns, because we define "vpn-svc" as list, then it can include different items, each vpn-svc item can define its own sites coverage information. There is also no duplicate configuration for this solution. What's the problem then for this arrangement? 

Container L3vpn-svc

   List vpn-svc

   Leaf vpn-id

   Leaf customer-name

   Leaf topology

   List extranet-vpn-policy

   Container cloud-access

   List multicast

   Leaf mpls

   List sites

     Leaf site-id

     Leaf site-role

     leaf apply-template

     ... ...

     ... ...

     Container managent

     Container maximum-routes

     Container security

     ... ...

     ... ...

     Site-network-access 

 

Best Regards.

Aijun Wang

 

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Thursday, February 18, 2016 9:08 AM
To: [email-masked]
Subject: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stephane and All,

Like this?

<vpn-svc>

   ...

   <vpn-policy>

       <entries>

           <id>1</id>

           <vpn>

               <vpn-id>VPN1</vpn-id>

           </vpn>

           <extranet-vpn-policy>

               <extranet-vpn>

                   <vpn-id>VPN2</vpn-id>

               </extranet-vpn>

           </extranet-vpn-policy>

       </entries>

   </vpn-policy>

   ...

</vpn-svc>

Thanks,

Kenichi

-----Original Message-----

Hi Kenichi,

Stephane

-----Original Message-----

Dear Stephane and All,

Thanks,

Kenichi

-----Original Message-----

Hi,

 

-----Original Message-----

Dear all:

 

Best Regards.

Aijun Wang

 

-----Original Message-----

Dear All,

Thanks,

Kenichi

-----Original Message-----

Hi all:

 

-Qin

 

BLUE SHEET

Name                    | Affiliation

Luis Tomotaki           | Verizon

Gu Rong                 | China Mobile 

Kenichi Ogaki           | KDDI

Victor Santos           | Ericsson

Ignas Bagdonas          | 

 

 

MINUTES

 

Agendaa

- Introduction

 

 

Discussion on #1: 

Agreed OK

Status #2: Closed

Discussion on #2: 

Agreed OK

Status #3:

Discussion on #3: 

 

 

o Maximum Routes - 

 

Status #4: Closed

Discussion on #4: 

Discussion on #5: 

 

Discussion on #6: 

 

 

Status #7: Closed

Discussion on #7: 

 

Status #8: Closed

Discussion on #8: 

Discussion on #9:    

 

 

 

Latency

Path diversty

Site diversty

Jitter

 

 

Issue#10: VPN "merging"

Resolution #10:    

Status #10:

Discussion on #10:    

 

 

 

 

== Other Issues ==    

 

== Conclusions ==

 

L3sm mailing list

L3sm mailing list

Thank you.

Thank you.

L3sm mailing list

L3sm mailing list

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Wed, 24 Feb 2016 17:34:08 +0900

Hi Aijun,

>Within the current Yang model, it is not loose coupled for the vpn and sites. Every 
>site is associated with at least one vpn-policy entry.

I wanted to mean by loose coupling that vpn and site should be structurally at the same level. This means that a kind of graph structure is better than a hierarchical structure.
In a VPN service, it’s natural that a site must belong to at least one vpn.

>The reason that I prefer the "vpn-->site" structure to "site-->vpn" structure is 
>that the majority of containers within lists "sites" are vpn-related, as you also 
>confirmed this.

>From the configuration viewpoint in the current model, the link information between vpn and site can be configurable only in sites. That's vpn-policy.
This is reasonable to avoid the inconsistency in the case that both can be configurable. 
This information, which site belongs to which vpn, may be able to be moved under vpn-svc as a list, but I don't think the necessity. It may be useful to define the op-state under vpn-svc as discussed in issue#6.

I agreed with the principle what you wrote, but I didn't carefully discuss each container should be under vpn-svc or site.
IMO, if any container is placed inappropriately, we should just move it to the appropriate place. It's different problem from the model structure discussion.

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Wednesday, February 24, 2016 2:57 PM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Ogaki:

Within the current Yang model, it is not loose coupled for the vpn and sites. Every site is associated with at least one vpn-policy entry. 
The reason that I prefer the "vpn-->site" structure to "site-->vpn" structure is that the majority of containers within lists "sites" are vpn-related, as you also confirmed this. Then it is not enough in current Yang model to correlate only the "vpn-policy" container to different vpn id.
And on the other way, we can also use the site-template to lessen the burden of the customer configuration, as that done in current Yang model.

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]] 
Sent: Wednesday, February 24, 2016 12:59 PM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: RE: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Wednesday, February 24, 2016 10:06 AM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Ogaki:

Best Regards.

Aijun Wang

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, February 24, 2016 8:11 AM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: RE: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Thursday, February 18, 2016 1:12 PM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Stephane and Ogaki:

[KO]Like this?

    container l3vpn-svc {
        list vpn-svc {
            key vpn-id;

            leaf vpn-id {
                …
            }
            ...

Container L3vpn-svc

   List vpn-svc

   Leaf vpn-id

   Leaf customer-name

   Leaf topology

   List extranet-vpn-policy

   Container cloud-access

   List multicast

   Leaf mpls

   List sites

     Leaf site-id

     Leaf site-role

     leaf apply-template

     ... ...

     ... ...

     Container managent

     Container maximum-routes

     Container security

     ... ...

     ... ...

     Site-network-access 

 

Best Regards.

Aijun Wang

 

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Thursday, February 18, 2016 9:08 AM
To: [email-masked]
Subject: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stephane and All,

Like this?

<vpn-svc>

   ...

   <vpn-policy>

       <entries>

           <id>1</id>

           <vpn>

               <vpn-id>VPN1</vpn-id>

           </vpn>

           <extranet-vpn-policy>

               <extranet-vpn>

                   <vpn-id>VPN2</vpn-id>

               </extranet-vpn>

           </extranet-vpn-policy>

       </entries>

   </vpn-policy>

   ...

</vpn-svc>

Thanks,

Kenichi

-----Original Message-----

Hi Kenichi,

Stephane

-----Original Message-----

Dear Stephane and All,

Thanks,

Kenichi

-----Original Message-----

Hi,

 

-----Original Message-----

Dear all:

 

Best Regards.

Aijun Wang

 

-----Original Message-----

Dear All,

Thanks,

Kenichi

-----Original Message-----

Hi all:

 

-Qin

 

BLUE SHEET

Name                    | Affiliation

Luis Tomotaki           | Verizon

Gu Rong                 | China Mobile 

Kenichi Ogaki           | KDDI

Victor Santos           | Ericsson

Ignas Bagdonas          | 

 

 

MINUTES

 

Agendaa

- Introduction

 

 

Discussion on #1: 

Agreed OK

Status #2: Closed

Discussion on #2: 

Agreed OK

Status #3:

Discussion on #3: 

 

 

o Maximum Routes - 

 

Status #4: Closed

Discussion on #4: 

Discussion on #5: 

 

Discussion on #6: 

 

 

Status #7: Closed

Discussion on #7: 

 

Status #8: Closed

Discussion on #8: 

Discussion on #9:    

 

 

 

Latency

Path diversty

Site diversty

Jitter

 

 

Issue#10: VPN "merging"

Resolution #10:    

Status #10:

Discussion on #10:    

 

 

 

 

== Other Issues ==    

 

== Conclusions ==

 

L3sm mailing list

L3sm mailing list

Thank you.

Thank you.

L3sm mailing list

L3sm mailing list

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Thu, 25 Feb 2016 12:25:46 +0900

Hi Aijun,

If we configure the relationship between vpn-svc and sites as follows, we should remove corresponding vpn-policy under sites to avoid the inconsistency.

In this case, when we create new sites, we must configure both sites and vpn-svc, and this bothers our customers.
But, the current model structure only have to configure sites. Then, I prefer the current one.
I don't object the sites list defined under vpn-svc as a *op-state*.

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Thursday, February 25, 2016 10:52 AM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Ogaki:

Based on our discussion, do you think the following proposal are acceptable?

    container l3vpn-svc {
        list vpn-svc {
            key vpn-id;

            leaf vpn-id {
                …
            }
            ...
        
            list sites{
              leaf site-id
              leaf site-role
              leafref path "/l3vpn-svc/site-templates/site-template-id"    
            }
        }

        list site-templates{
        ... 
        }
        ...
    }

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Wednesday, February 24, 2016 4:34 PM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

>Within the current Yang model, it is not loose coupled for the vpn and 
>sites. Every site is associated with at least one vpn-policy entry.

>The reason that I prefer the "vpn-->site" structure to "site-->vpn" 
>structure is that the majority of containers within lists "sites" are 
>vpn-related, as you also confirmed this.

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Wednesday, February 24, 2016 2:57 PM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Ogaki:

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, February 24, 2016 12:59 PM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: RE: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Wednesday, February 24, 2016 10:06 AM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Ogaki:

Best Regards.

Aijun Wang

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, February 24, 2016 8:11 AM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: RE: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Thursday, February 18, 2016 1:12 PM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Stephane and Ogaki:

[KO]Like this?

    container l3vpn-svc {
        list vpn-svc {
            key vpn-id;

            leaf vpn-id {
                …
            }
            ...

Container L3vpn-svc

   List vpn-svc

   Leaf vpn-id

   Leaf customer-name

   Leaf topology

   List extranet-vpn-policy

   Container cloud-access

   List multicast

   Leaf mpls

   List sites

     Leaf site-id

     Leaf site-role

     leaf apply-template

     ... ...

     ... ...

     Container managent

     Container maximum-routes

     Container security

     ... ...

     ... ...

     Site-network-access 

 

Best Regards.

Aijun Wang

 

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Thursday, February 18, 2016 9:08 AM
To: [email-masked]
Subject: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stephane and All,

Like this?

<vpn-svc>

   ...

   <vpn-policy>

       <entries>

           <id>1</id>

           <vpn>

               <vpn-id>VPN1</vpn-id>

           </vpn>

           <extranet-vpn-policy>

               <extranet-vpn>

                   <vpn-id>VPN2</vpn-id>

               </extranet-vpn>

           </extranet-vpn-policy>

       </entries>

   </vpn-policy>

   ...

</vpn-svc>

Thanks,

Kenichi

-----Original Message-----

Hi Kenichi,

Stephane

-----Original Message-----

Dear Stephane and All,

Thanks,

Kenichi

-----Original Message-----

Hi,

 

-----Original Message-----

Dear all:

 

Best Regards.

Aijun Wang

 

-----Original Message-----

Dear All,

Thanks,

Kenichi

-----Original Message-----

Hi all:

 

-Qin

 

BLUE SHEET

Name                    | Affiliation

Luis Tomotaki           | Verizon

Gu Rong                 | China Mobile 

Kenichi Ogaki           | KDDI

Victor Santos           | Ericsson

Ignas Bagdonas          | 

 

 

MINUTES

 

Agendaa

- Introduction

 

 

Discussion on #1: 

Agreed OK

Status #2: Closed

Discussion on #2: 

Agreed OK

Status #3:

Discussion on #3: 

 

 

o Maximum Routes - 

 

Status #4: Closed

Discussion on #4: 

Discussion on #5: 

 

Discussion on #6: 

 

 

Status #7: Closed

Discussion on #7: 

 

Status #8: Closed

Discussion on #8: 

Discussion on #9:    

 

 

 

Latency

Path diversty

Site diversty

Jitter

 

 

Issue#10: VPN "merging"

Resolution #10:    

Status #10:

Discussion on #10:    

 

 

 

 

== Other Issues ==    

 

== Conclusions ==

 

L3sm mailing list

L3sm mailing list

Thank you.

Thank you.

L3sm mailing list

L3sm mailing list

---

From: Qin Wu <[email-masked]>
Date: Thu, 25 Feb 2016 03:47:56 +0000

Aijun:
It looks like you propose to relocate some parameters in the model structure.
But with your proposal, it is hard to describe one site playing different role in different VPN when one site belongs to multiple VPNs.
With VPN-policy under site proposed in the current model, you can easily describe one site with different role in each VPN as follows:
"
    container l3vpn-svc {
        list vpn-svc {
            key vpn-id;

            leaf vpn-id {
                …
            }
            ...
        
            list sites{
              leaf site-id
          container vpn-policy {
            list entries {
                key id;
                leaf id {
                        type svc-id;
                        description
                         "Unique identifier for
                          the policy entry.";
                }
container vpn {
                    leaf vpn {
                        type leafref {
                            path "/l3vpn-svc/vpn-svc/vpn-id";
                        }
                        mandatory true;
                        description
                         "Reference to an IPVPN.";
                    }
                    leaf site-role {
                        type identityref {
                            base site-role;
                        }
                        mandatory true;
                        description
                         "Role of the site in the IPVPN.";
                    }
                    description
                     "List of VPNs the LAN is associated to.";
                }

            }
        }
"
-Qin
-----邮件原件-----
发件人: L3sm [mailto:[email-masked]] 代表 Aijun Wang
发送时间: 2016年2月25日 9:52
收件人: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
主题: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Ogaki:

    container l3vpn-svc {
        list vpn-svc {
            key vpn-id;

            leaf vpn-id {
                …
            }
            ...
        
            list sites{
              leaf site-id
              leaf site-role

        list site-templates{
        ... 
        }
        ...
    }

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Wednesday, February 24, 2016 4:34 PM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Wednesday, February 24, 2016 2:57 PM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Ogaki:

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, February 24, 2016 12:59 PM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: RE: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Wednesday, February 24, 2016 10:06 AM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Ogaki:

Best Regards.

Aijun Wang

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, February 24, 2016 8:11 AM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: RE: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Thursday, February 18, 2016 1:12 PM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Stephane and Ogaki:

[KO]Like this?

    container l3vpn-svc {
        list vpn-svc {
            key vpn-id;

            leaf vpn-id {
                …
            }
            ...

Container L3vpn-svc

   List vpn-svc

   Leaf vpn-id

   Leaf customer-name

   Leaf topology

   List extranet-vpn-policy

   Container cloud-access

   List multicast

   Leaf mpls

   List sites

     Leaf site-id

     Leaf site-role

     leaf apply-template

     ... ...

     ... ...

     Container managent

     Container maximum-routes

     Container security

     ... ...

     ... ...

     Site-network-access 

 

Best Regards.

Aijun Wang

 

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Thursday, February 18, 2016 9:08 AM
To: [email-masked]
Subject: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stephane and All,

Like this?

<vpn-svc>

   ...

   <vpn-policy>

       <entries>

           <id>1</id>

           <vpn>

               <vpn-id>VPN1</vpn-id>

           </vpn>

           <extranet-vpn-policy>

               <extranet-vpn>

                   <vpn-id>VPN2</vpn-id>

               </extranet-vpn>

           </extranet-vpn-policy>

       </entries>

   </vpn-policy>

   ...

</vpn-svc>

Thanks,

Kenichi

-----Original Message-----

Hi Kenichi,

Stephane

-----Original Message-----

Dear Stephane and All,

Thanks,

Kenichi

-----Original Message-----

Hi,

 

-----Original Message-----

Dear all:

 

Best Regards.

Aijun Wang

 

-----Original Message-----

Dear All,

Thanks,

Kenichi

-----Original Message-----

Hi all:

 

-Qin

 

BLUE SHEET

Name                    | Affiliation

Luis Tomotaki           | Verizon

Gu Rong                 | China Mobile 

Kenichi Ogaki           | KDDI

Victor Santos           | Ericsson

Ignas Bagdonas          | 

 

 

MINUTES

 

Agendaa

- Introduction

 

 

Discussion on #1: 

Agreed OK

Status #2: Closed

Discussion on #2: 

Agreed OK

Status #3:

Discussion on #3: 

 

 

o Maximum Routes - 

 

Status #4: Closed

Discussion on #4: 

Discussion on #5: 

 

Discussion on #6: 

 

 

Status #7: Closed

Discussion on #7: 

 

Status #8: Closed

Discussion on #8: 

Discussion on #9:    

 

 

 

Latency

Path diversty

Site diversty

Jitter

 

 

Issue#10: VPN "merging"

Resolution #10:    

Status #10:

Discussion on #10:    

 

 

 

 

== Other Issues ==    

 

== Conclusions ==

 

L3sm mailing list

L3sm mailing list

Thank you.

Thank you.

L3sm mailing list

L3sm mailing list

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Thu, 25 Feb 2016 12:40:36 +0900

Hi Aijun,

I also proposed vpn-policy not only per sites, but also per site-network-access as follows.

https://mailarchive.ietf.org/arch/msg/l3sm/L5dzU-3BaGWRFJ9TBJjYREMAwUE

In that case, it becomes too complex to control this under vpn-svc.

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Thursday, February 25, 2016 12:26 PM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Thursday, February 25, 2016 10:52 AM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Ogaki:

    container l3vpn-svc {
        list vpn-svc {
            key vpn-id;

            leaf vpn-id {
                …
            }
            ...
        
            list sites{
              leaf site-id
              leaf site-role

        list site-templates{
        ... 
        }
        ...
    }

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Wednesday, February 24, 2016 4:34 PM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Wednesday, February 24, 2016 2:57 PM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Ogaki:

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, February 24, 2016 12:59 PM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: RE: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Wednesday, February 24, 2016 10:06 AM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Ogaki:

Best Regards.

Aijun Wang

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, February 24, 2016 8:11 AM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: RE: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Thursday, February 18, 2016 1:12 PM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Stephane and Ogaki:

[KO]Like this?

    container l3vpn-svc {
        list vpn-svc {
            key vpn-id;

            leaf vpn-id {
                …
            }
            ...

Container L3vpn-svc

   List vpn-svc

   Leaf vpn-id

   Leaf customer-name

   Leaf topology

   List extranet-vpn-policy

   Container cloud-access

   List multicast

   Leaf mpls

   List sites

     Leaf site-id

     Leaf site-role

     leaf apply-template

     ... ...

     ... ...

     Container managent

     Container maximum-routes

     Container security

     ... ...

     ... ...

     Site-network-access 

 

Best Regards.

Aijun Wang

 

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Thursday, February 18, 2016 9:08 AM
To: [email-masked]
Subject: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stephane and All,

Like this?

<vpn-svc>

   ...

   <vpn-policy>

       <entries>

           <id>1</id>

           <vpn>

               <vpn-id>VPN1</vpn-id>

           </vpn>

           <extranet-vpn-policy>

               <extranet-vpn>

                   <vpn-id>VPN2</vpn-id>

               </extranet-vpn>

           </extranet-vpn-policy>

       </entries>

   </vpn-policy>

   ...

</vpn-svc>

Thanks,

Kenichi

-----Original Message-----

Hi Kenichi,

Stephane

-----Original Message-----

Dear Stephane and All,

Thanks,

Kenichi

-----Original Message-----

Hi,

 

-----Original Message-----

Dear all:

 

Best Regards.

Aijun Wang

 

-----Original Message-----

Dear All,

Thanks,

Kenichi

-----Original Message-----

Hi all:

 

-Qin

 

BLUE SHEET

Name                    | Affiliation

Luis Tomotaki           | Verizon

Gu Rong                 | China Mobile 

Kenichi Ogaki           | KDDI

Victor Santos           | Ericsson

Ignas Bagdonas          | 

 

 

MINUTES

 

Agendaa

- Introduction

 

 

Discussion on #1: 

Agreed OK

Status #2: Closed

Discussion on #2: 

Agreed OK

Status #3:

Discussion on #3: 

 

 

o Maximum Routes - 

 

Status #4: Closed

Discussion on #4: 

Discussion on #5: 

 

Discussion on #6: 

 

 

Status #7: Closed

Discussion on #7: 

 

Status #8: Closed

Discussion on #8: 

Discussion on #9:    

 

 

 

Latency

Path diversty

Site diversty

Jitter

 

 

Issue#10: VPN "merging"

Resolution #10:    

Status #10:

Discussion on #10:    

 

 

 

 

== Other Issues ==    

 

== Conclusions ==

 

L3sm mailing list

L3sm mailing list

Thank you.

Thank you.

L3sm mailing list

L3sm mailing list

---

From: Qin Wu <[email-masked]>
Date: Thu, 25 Feb 2016 04:36:48 +0000

When one site belongs to different VPNs and have multiple roles, can you describe these roles in the same service model with your proposal?

-Qin
-----邮件原件-----
发件人: Aijun Wang [mailto:[email-masked]] 
发送时间: 2016年2月25日 11:58
收件人: Qin Wu; 'Ogaki, Kenichi'; [email-masked]; [email-masked]
主题: RE: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Qin:

Maybe I do not describe the structure clearly. I put the leaf "site-role" under lists "sites", which is located within the list vpn-svc. Then in different vpn, the site-role can be different.

Best Regards.

-----Original Message-----
From: Qin Wu [mailto:[email-masked]]
Sent: Thursday, February 25, 2016 11:48 AM
To: Aijun Wang; 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: RE: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Aijun:

            leaf vpn-id {
                …
            }
            ...
        
            list sites{
              leaf site-id
          container vpn-policy {
            list entries {
                key id;
                leaf id {
                        type svc-id;
                        description
                         "Unique identifier for
                          the policy entry.";
                }
container vpn {
                    leaf vpn {
                        type leafref {

            }
        }
"
-Qin
-----邮件原件-----
发件人: L3sm [mailto:[email-masked]] 代表 Aijun Wang
发送时间: 2016年2月25日 9:52
收件人: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
主题: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Ogaki:

    container l3vpn-svc {
        list vpn-svc {
            key vpn-id;

            leaf vpn-id {
                …
            }
            ...
        
            list sites{
              leaf site-id
              leaf site-role

        list site-templates{
        ... 
        }
        ...
    }

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Wednesday, February 24, 2016 4:34 PM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Wednesday, February 24, 2016 2:57 PM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Ogaki:

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, February 24, 2016 12:59 PM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: RE: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Wednesday, February 24, 2016 10:06 AM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Ogaki:

Best Regards.

Aijun Wang

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, February 24, 2016 8:11 AM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: RE: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Thursday, February 18, 2016 1:12 PM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Stephane and Ogaki:

[KO]Like this?

    container l3vpn-svc {
        list vpn-svc {
            key vpn-id;

            leaf vpn-id {
                …
            }
            ...

Container L3vpn-svc

   List vpn-svc

   Leaf vpn-id

   Leaf customer-name

   Leaf topology

   List extranet-vpn-policy

   Container cloud-access

   List multicast

   Leaf mpls

   List sites

     Leaf site-id

     Leaf site-role

     leaf apply-template

     ... ...

     ... ...

     Container managent

     Container maximum-routes

     Container security

     ... ...

     ... ...

     Site-network-access 

 

Best Regards.

Aijun Wang

 

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Thursday, February 18, 2016 9:08 AM
To: [email-masked]
Subject: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stephane and All,

Like this?

<vpn-svc>

   ...

   <vpn-policy>

       <entries>

           <id>1</id>

           <vpn>

               <vpn-id>VPN1</vpn-id>

           </vpn>

           <extranet-vpn-policy>

               <extranet-vpn>

                   <vpn-id>VPN2</vpn-id>

               </extranet-vpn>

           </extranet-vpn-policy>

       </entries>

   </vpn-policy>

   ...

</vpn-svc>

Thanks,

Kenichi

-----Original Message-----

Hi Kenichi,

Stephane

-----Original Message-----

Dear Stephane and All,

Thanks,

Kenichi

-----Original Message-----

Hi,

 

-----Original Message-----

Dear all:

 

Best Regards.

Aijun Wang

 

-----Original Message-----

Dear All,

Thanks,

Kenichi

-----Original Message-----

Hi all:

 

-Qin

 

BLUE SHEET

Name                    | Affiliation

Luis Tomotaki           | Verizon

Gu Rong                 | China Mobile 

Kenichi Ogaki           | KDDI

Victor Santos           | Ericsson

Ignas Bagdonas          | 

 

 

MINUTES

 

Agendaa

- Introduction

 

 

Discussion on #1: 

Agreed OK

Status #2: Closed

Discussion on #2: 

Agreed OK

Status #3:

Discussion on #3: 

 

 

o Maximum Routes - 

 

Status #4: Closed

Discussion on #4: 

Discussion on #5: 

 

Discussion on #6: 

 

 

Status #7: Closed

Discussion on #7: 

 

Status #8: Closed

Discussion on #8: 

Discussion on #9:    

 

 

 

Latency

Path diversty

Site diversty

Jitter

 

 

Issue#10: VPN "merging"

Resolution #10:    

Status #10:

Discussion on #10:    

 

 

 

 

== Other Issues ==    

 

== Conclusions ==

 

L3sm mailing list

L3sm mailing list

Thank you.

Thank you.

L3sm mailing list

L3sm mailing list

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Thu, 25 Feb 2016 13:51:30 +0900

Hi Aijun,

>[Aijun Wang]: Within current Yang model, the customer need still to configure both sites and vpn-svc. If we use the site template, some parameters 
>that keep unchanged need not be input by customer.

I'm saying the case just adding a new site to already existing vpn. Does this require to configure the vpn? 

>[Aijun Wang]: If the customer does not input these information, how can you get it from "op-state"?  The operation state should consider only 
>the real time information that gathered from the underlying network dynamically.

In my understanding, it's not only for real time information. I mean the following one.

https://mailarchive.ietf.org/arch/msg/l3sm/6zMiZSlcijda0ts_6NONdmwP3-E

Thanks,
Kenichi

-----Original Message-----
From: Aijun Wang [mailto:[email-masked]] 
Sent: Thursday, February 25, 2016 12:56 PM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: RE: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Ogaki:

Please see the comments inline, wish we can reach an agreement before the interim meeting. :)

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Thursday, February 25, 2016 11:26 AM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: RE: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

If we configure the relationship between vpn-svc and sites as follows, we should remove corresponding vpn-policy under sites to avoid the inconsistency.
[Aijun Wang] Yes, we should redefine the vpn-policy as site-prefix-policy, which defines only what prefix will be advertised by this site, not the relationship among different sites.

In this case, when we create new sites, we must configure both sites and vpn-svc, and this bothers our customers.
But, the current model structure only have to configure sites. Then, I prefer the current one.
[Aijun Wang]: Within current Yang model, the customer need still to configure both sites and vpn-svc. If we use the site template, some parameters that keep unchanged need not be input by customer.

I don't object the sites list defined under vpn-svc as a *op-state*.
[Aijun Wang]: If the customer does not input these information, how can you get it from "op-state"?  The operation state should consider only the real time information that gathered from the underlying network dynamically.

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Thursday, February 25, 2016 10:52 AM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Ogaki:

    container l3vpn-svc {
        list vpn-svc {
            key vpn-id;

            leaf vpn-id {
                …
            }
            ...
        
            list sites{
              leaf site-id
              leaf site-role

        list site-templates{
        ... 
        }
        ...
    }

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Wednesday, February 24, 2016 4:34 PM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Wednesday, February 24, 2016 2:57 PM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Ogaki:

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, February 24, 2016 12:59 PM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: RE: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Wednesday, February 24, 2016 10:06 AM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Ogaki:

Best Regards.

Aijun Wang

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, February 24, 2016 8:11 AM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: RE: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Thursday, February 18, 2016 1:12 PM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Stephane and Ogaki:

[KO]Like this?

    container l3vpn-svc {
        list vpn-svc {
            key vpn-id;

            leaf vpn-id {
                …
            }
            ...

Container L3vpn-svc

   List vpn-svc

   Leaf vpn-id

   Leaf customer-name

   Leaf topology

   List extranet-vpn-policy

   Container cloud-access

   List multicast

   Leaf mpls

   List sites

     Leaf site-id

     Leaf site-role

     leaf apply-template

     ... ...

     ... ...

     Container managent

     Container maximum-routes

     Container security

     ... ...

     ... ...

     Site-network-access 

 

Best Regards.

Aijun Wang

 

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Thursday, February 18, 2016 9:08 AM
To: [email-masked]
Subject: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stephane and All,

Like this?

<vpn-svc>

   ...

   <vpn-policy>

       <entries>

           <id>1</id>

           <vpn>

               <vpn-id>VPN1</vpn-id>

           </vpn>

           <extranet-vpn-policy>

               <extranet-vpn>

                   <vpn-id>VPN2</vpn-id>

               </extranet-vpn>

           </extranet-vpn-policy>

       </entries>

   </vpn-policy>

   ...

</vpn-svc>

Thanks,

Kenichi

-----Original Message-----

Hi Kenichi,

Stephane

-----Original Message-----

Dear Stephane and All,

Thanks,

Kenichi

-----Original Message-----

Hi,

 

-----Original Message-----

Dear all:

 

Best Regards.

Aijun Wang

 

-----Original Message-----

Dear All,

Thanks,

Kenichi

-----Original Message-----

Hi all:

 

-Qin

 

BLUE SHEET

Name                    | Affiliation

Luis Tomotaki           | Verizon

Gu Rong                 | China Mobile 

Kenichi Ogaki           | KDDI

Victor Santos           | Ericsson

Ignas Bagdonas          | 

 

 

MINUTES

 

Agendaa

- Introduction

 

 

Discussion on #1: 

Agreed OK

Status #2: Closed

Discussion on #2: 

Agreed OK

Status #3:

Discussion on #3: 

 

 

o Maximum Routes - 

 

Status #4: Closed

Discussion on #4: 

Discussion on #5: 

 

Discussion on #6: 

 

 

Status #7: Closed

Discussion on #7: 

 

Status #8: Closed

Discussion on #8: 

Discussion on #9:    

 

 

 

Latency

Path diversty

Site diversty

Jitter

 

 

Issue#10: VPN "merging"

Resolution #10:    

Status #10:

Discussion on #10:    

 

 

 

 

== Other Issues ==    

 

== Conclusions ==

 

L3sm mailing list

L3sm mailing list

Thank you.

Thank you.

L3sm mailing list

L3sm mailing list

---

From: Qin Wu <[email-masked]>
Date: Thu, 25 Feb 2016 06:55:47 +0000

Okay, it looks you tweak what was proposed in the current model, move "sites" list under "vpn-svc" list and add site role for each site belonging to specific vpn. In the current model,  "site" list in parallel with "vpn-svc" list is placed at the same level.

-Qin
-----邮件原件-----
发件人: Aijun Wang [mailto:[email-masked]] 
发送时间: 2016年2月25日 14:48
收件人: Qin Wu; 'Ogaki, Kenichi'; [email-masked]; [email-masked]
主题: RE: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Qin:

Yes we can. Because one site has only one role in one vpn. If this site belongs to different vpn, and has different role in different vpn, we need just define different vpn id, and include the relevant sites definition that will describe the different role of the same site in it.

Best Regards.

-----Original Message-----
From: Qin Wu [mailto:[email-masked]]
Sent: Thursday, February 25, 2016 12:37 PM
To: Aijun Wang; 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: RE: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

-Qin
-----邮件原件-----
发件人: Aijun Wang [mailto:[email-masked]]
发送时间: 2016年2月25日 11:58
收件人: Qin Wu; 'Ogaki, Kenichi'; [email-masked]; [email-masked]
主题: RE: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Qin:

Best Regards.

-----Original Message-----
From: Qin Wu [mailto:[email-masked]]
Sent: Thursday, February 25, 2016 11:48 AM
To: Aijun Wang; 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: RE: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Aijun:

            leaf vpn-id {
                …
            }
            ...
        
            list sites{
              leaf site-id
          container vpn-policy {
            list entries {
                key id;
                leaf id {
                        type svc-id;
                        description
                         "Unique identifier for
                          the policy entry.";
                }
container vpn {
                    leaf vpn {
                        type leafref {

            }
        }
"
-Qin
-----邮件原件-----
发件人: L3sm [mailto:[email-masked]] 代表 Aijun Wang
发送时间: 2016年2月25日 9:52
收件人: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
主题: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Ogaki:

    container l3vpn-svc {
        list vpn-svc {
            key vpn-id;

            leaf vpn-id {
                …
            }
            ...
        
            list sites{
              leaf site-id
              leaf site-role

        list site-templates{
        ... 
        }
        ...
    }

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Wednesday, February 24, 2016 4:34 PM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Wednesday, February 24, 2016 2:57 PM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Ogaki:

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, February 24, 2016 12:59 PM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: RE: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Wednesday, February 24, 2016 10:06 AM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Ogaki:

Best Regards.

Aijun Wang

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, February 24, 2016 8:11 AM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: RE: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Thursday, February 18, 2016 1:12 PM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Stephane and Ogaki:

[KO]Like this?

    container l3vpn-svc {
        list vpn-svc {
            key vpn-id;

            leaf vpn-id {
                …
            }
            ...

Container L3vpn-svc

   List vpn-svc

   Leaf vpn-id

   Leaf customer-name

   Leaf topology

   List extranet-vpn-policy

   Container cloud-access

   List multicast

   Leaf mpls

   List sites

     Leaf site-id

     Leaf site-role

     leaf apply-template

     ... ...

     ... ...

     Container managent

     Container maximum-routes

     Container security

     ... ...

     ... ...

     Site-network-access 

 

Best Regards.

Aijun Wang

 

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Thursday, February 18, 2016 9:08 AM
To: [email-masked]
Subject: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stephane and All,

Like this?

<vpn-svc>

   ...

   <vpn-policy>

       <entries>

           <id>1</id>

           <vpn>

               <vpn-id>VPN1</vpn-id>

           </vpn>

           <extranet-vpn-policy>

               <extranet-vpn>

                   <vpn-id>VPN2</vpn-id>

               </extranet-vpn>

           </extranet-vpn-policy>

       </entries>

   </vpn-policy>

   ...

</vpn-svc>

Thanks,

Kenichi

-----Original Message-----

Hi Kenichi,

Stephane

-----Original Message-----

Dear Stephane and All,

Thanks,

Kenichi

-----Original Message-----

Hi,

 

-----Original Message-----

Dear all:

 

Best Regards.

Aijun Wang

 

-----Original Message-----

Dear All,

Thanks,

Kenichi

-----Original Message-----

Hi all:

 

-Qin

 

BLUE SHEET

Name                    | Affiliation

Luis Tomotaki           | Verizon

Gu Rong                 | China Mobile 

Kenichi Ogaki           | KDDI

Victor Santos           | Ericsson

Ignas Bagdonas          | 

 

 

MINUTES

 

Agendaa

- Introduction

 

 

Discussion on #1: 

Agreed OK

Status #2: Closed

Discussion on #2: 

Agreed OK

Status #3:

Discussion on #3: 

 

 

o Maximum Routes - 

 

Status #4: Closed

Discussion on #4: 

Discussion on #5: 

 

Discussion on #6: 

 

 

Status #7: Closed

Discussion on #7: 

 

Status #8: Closed

Discussion on #8: 

Discussion on #9:    

 

 

 

Latency

Path diversty

Site diversty

Jitter

 

 

Issue#10: VPN "merging"

Resolution #10:    

Status #10:

Discussion on #10:    

 

 

 

 

== Other Issues ==    

 

== Conclusions ==

 

L3sm mailing list

L3sm mailing list

Thank you.

Thank you.

L3sm mailing list

L3sm mailing list

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Thu, 25 Feb 2016 16:20:50 +0900

Hi Aijun,

>1. When we add one new site into one already existing vpn, we need only add one site item within this vpn, because the item sites is one list. 
>This is very easy via the RESTCONF api. No other contents within this vpn will be touched.

For human being, this seems trivial.
But, from a system automation viewpoint, the cost to access two different top-level containers with restconf is not ignorable, because restconf client must access two different URIs by at least two transactions.

>2. If you propose the Yang structure as that described in https://mailarchive.ietf.org/arch/msg/l3sm/6zMiZSlcijda0ts_6NONdmwP3-E, while not 
>keep it consistence with the configuration part?

You mean this cannot solve the problem?
These state are not configurable and should be automatically derived from the configuration of the sites in the current model. 
Am I missing something?

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Thursday, February 25, 2016 3:44 PM
To: 'Ogaki, Kenichi'; 'Aijun Wang'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Ogaki:

1. When we add one new site into one already existing vpn, we need only add one site item within this vpn, because the item sites is one list. This is very easy via the RESTCONF api. No other contents within this vpn will be touched.
2. If you propose the Yang structure as that described in https://mailarchive.ietf.org/arch/msg/l3sm/6zMiZSlcijda0ts_6NONdmwP3-E, while not keep it consistence with the configuration part?

Best Regards.

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Thursday, February 25, 2016 12:52 PM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: RE: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

>[Aijun Wang]: Within current Yang model, the customer need still to 
>configure both sites and vpn-svc. If we use the site template, some parameters that keep unchanged need not be input by customer.

>[Aijun Wang]: If the customer does not input these information, how can 
>you get it from "op-state"?  The operation state should consider only the real time information that gathered from the underlying network dynamically.

Thanks,
Kenichi

-----Original Message-----
From: Aijun Wang [mailto:[email-masked]]
Sent: Thursday, February 25, 2016 12:56 PM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: RE: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Ogaki:

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Thursday, February 25, 2016 11:26 AM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: RE: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Thursday, February 25, 2016 10:52 AM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Ogaki:

    container l3vpn-svc {
        list vpn-svc {
            key vpn-id;

            leaf vpn-id {
                …
            }
            ...
        
            list sites{
              leaf site-id
              leaf site-role

        list site-templates{
        ... 
        }
        ...
    }

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Wednesday, February 24, 2016 4:34 PM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Wednesday, February 24, 2016 2:57 PM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Ogaki:

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, February 24, 2016 12:59 PM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: RE: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Wednesday, February 24, 2016 10:06 AM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Ogaki:

Best Regards.

Aijun Wang

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, February 24, 2016 8:11 AM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: RE: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Thursday, February 18, 2016 1:12 PM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Stephane and Ogaki:

[KO]Like this?

    container l3vpn-svc {
        list vpn-svc {
            key vpn-id;

            leaf vpn-id {
                …
            }
            ...

Container L3vpn-svc

   List vpn-svc

   Leaf vpn-id

   Leaf customer-name

   Leaf topology

   List extranet-vpn-policy

   Container cloud-access

   List multicast

   Leaf mpls

   List sites

     Leaf site-id

     Leaf site-role

     leaf apply-template

     ... ...

     ... ...

     Container managent

     Container maximum-routes

     Container security

     ... ...

     ... ...

     Site-network-access 

 

Best Regards.

Aijun Wang

 

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Thursday, February 18, 2016 9:08 AM
To: [email-masked]
Subject: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stephane and All,

Like this?

<vpn-svc>

   ...

   <vpn-policy>

       <entries>

           <id>1</id>

           <vpn>

               <vpn-id>VPN1</vpn-id>

           </vpn>

           <extranet-vpn-policy>

               <extranet-vpn>

                   <vpn-id>VPN2</vpn-id>

               </extranet-vpn>

           </extranet-vpn-policy>

       </entries>

   </vpn-policy>

   ...

</vpn-svc>

Thanks,

Kenichi

-----Original Message-----

Hi Kenichi,

Stephane

-----Original Message-----

Dear Stephane and All,

Thanks,

Kenichi

-----Original Message-----

Hi,

 

-----Original Message-----

Dear all:

 

Best Regards.

Aijun Wang

 

-----Original Message-----

Dear All,

Thanks,

Kenichi

-----Original Message-----

Hi all:

 

-Qin

 

BLUE SHEET

Name                    | Affiliation

Luis Tomotaki           | Verizon

Gu Rong                 | China Mobile 

Kenichi Ogaki           | KDDI

Victor Santos           | Ericsson

Ignas Bagdonas          | 

 

 

MINUTES

 

Agendaa

- Introduction

 

 

Discussion on #1: 

Agreed OK

Status #2: Closed

Discussion on #2: 

Agreed OK

Status #3:

Discussion on #3: 

 

 

o Maximum Routes - 

 

Status #4: Closed

Discussion on #4: 

Discussion on #5: 

 

Discussion on #6: 

 

 

Status #7: Closed

Discussion on #7: 

 

Status #8: Closed

Discussion on #8: 

Discussion on #9:    

 

 

 

Latency

Path diversty

Site diversty

Jitter

 

 

Issue#10: VPN "merging"

Resolution #10:    

Status #10:

Discussion on #10:    

 

 

 

 

== Other Issues ==    

 

== Conclusions ==

 

L3sm mailing list

L3sm mailing list

Thank you.

Thank you.

L3sm mailing list

L3sm mailing list

---

From: <[email-masked]>
Date: Thu, 25 Feb 2016 08:18:08 +0000

Hi,

I personnaly do not understand the rationales of your proposal. For me, and Kenichi pointed it also, it brings more complexity and requirement of duplicating many configuration.
To say it again, multiVPN is really really common and we have some sites belonging to more than 10 VPNs and we need an easy way to attach a site to a new VPN.

I do not see any site attribute which should be moved to VPN, but if you find one, please state it clearly and explain why because it's not clear for now.

Best Regards,

Stephane

-----Original Message-----
From: Aijun Wang [mailto:[email-masked]] 
Sent: Thursday, February 25, 2016 02:52
To: 'Ogaki, Kenichi'; LITKOWSKI Stephane SCE/OINIS; [email-masked]
Subject: RE: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Ogaki:

    container l3vpn-svc {
        list vpn-svc {
            key vpn-id;

            leaf vpn-id {
                …
            }
            ...
        
            list sites{
              leaf site-id
              leaf site-role

        list site-templates{
        ... 
        }
        ...
    }

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Wednesday, February 24, 2016 4:34 PM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Wednesday, February 24, 2016 2:57 PM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Ogaki:

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, February 24, 2016 12:59 PM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: RE: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Wednesday, February 24, 2016 10:06 AM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Ogaki:

Best Regards.

Aijun Wang

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, February 24, 2016 8:11 AM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: RE: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Thursday, February 18, 2016 1:12 PM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Stephane and Ogaki:

[KO]Like this?

    container l3vpn-svc {
        list vpn-svc {
            key vpn-id;

            leaf vpn-id {
                …
            }
            ...

Container L3vpn-svc

   List vpn-svc

   Leaf vpn-id

   Leaf customer-name

   Leaf topology

   List extranet-vpn-policy

   Container cloud-access

   List multicast

   Leaf mpls

   List sites

     Leaf site-id

     Leaf site-role

     leaf apply-template

     ... ...

     ... ...

     Container managent

     Container maximum-routes

     Container security

     ... ...

     ... ...

     Site-network-access 

 

Best Regards.

Aijun Wang

 

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Thursday, February 18, 2016 9:08 AM
To: [email-masked]
Subject: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stephane and All,

Like this?

<vpn-svc>

   ...

   <vpn-policy>

       <entries>

           <id>1</id>

           <vpn>

               <vpn-id>VPN1</vpn-id>

           </vpn>

           <extranet-vpn-policy>

               <extranet-vpn>

                   <vpn-id>VPN2</vpn-id>

               </extranet-vpn>

           </extranet-vpn-policy>

       </entries>

   </vpn-policy>

   ...

</vpn-svc>

Thanks,

Kenichi

-----Original Message-----

Hi Kenichi,

Stephane

-----Original Message-----

Dear Stephane and All,

Thanks,

Kenichi

-----Original Message-----

Hi,

 

-----Original Message-----

Dear all:

 

Best Regards.

Aijun Wang

 

-----Original Message-----

Dear All,

Thanks,

Kenichi

-----Original Message-----

Hi all:

 

-Qin

 

BLUE SHEET

Name                    | Affiliation

Luis Tomotaki           | Verizon

Gu Rong                 | China Mobile 

Kenichi Ogaki           | KDDI

Victor Santos           | Ericsson

Ignas Bagdonas          | 

 

 

MINUTES

 

Agendaa

- Introduction

 

 

Discussion on #1: 

Agreed OK

Status #2: Closed

Discussion on #2: 

Agreed OK

Status #3:

Discussion on #3: 

 

 

o Maximum Routes - 

 

Status #4: Closed

Discussion on #4: 

Discussion on #5: 

 

Discussion on #6: 

 

 

Status #7: Closed

Discussion on #7: 

 

Status #8: Closed

Discussion on #8: 

Discussion on #9:    

 

 

 

Latency

Path diversty

Site diversty

Jitter

 

 

Issue#10: VPN "merging"

Resolution #10:    

Status #10:

Discussion on #10:    

 

 

 

 

== Other Issues ==    

 

== Conclusions ==

 

L3sm mailing list

L3sm mailing list

Thank you.

Thank you.

L3sm mailing list

L3sm mailing list

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Thu, 25 Feb 2016 17:35:15 +0900

Hi Aijun,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Thursday, February 25, 2016 4:51 PM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Ogaki:

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Thursday, February 25, 2016 3:21 PM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

For human being, this seems trivial.
But, from a system automation viewpoint, the cost to access two different top-level containers with restconf is not ignorable, because restconf client must access two different URIs by at least two transactions.
[Aijun Wang]: why do we need to access two different top-level containers for adding one new site? We have put the list "sites" within the list "vpn-svc", and it exist only once in the Yang model. 

[KO] I may be misunderstanding. My understanding is that your proposal only defines sites list under vpn-svc and still keeps sites container as it is.
If so, when we create one new site, we must configure sites itself and sites list under vpn-svc.

>2. If you propose the Yang structure as that described in 
>https://mailarchive.ietf.org/arch/msg/l3sm/6zMiZSlcijda0ts_6NONdmwP3-E, while not keep it consistence with the configuration part?

You mean this cannot solve the problem?
These state are not configurable and should be automatically derived from the configuration of the sites in the current model. 
Am I missing something?
[Aijun Wang]: What I mean is that we must first define the relationship of vpn and site(site role, site attributes etc.) first, and then reflect it in the op-state. And you have proposed to extract the leaf "site-role" from the "vpn-policy", why not just define it under the list "site", and put the list "site" within the list "vpn-svc"?

[KO] Yes, we must define the relationship between vpn and site, and then reflect it to the op-state.
The problem is where such relationship is defined, and I prefer it under sites as the current model from the api viewpoint abovementioned.

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Thursday, February 25, 2016 3:44 PM
To: 'Ogaki, Kenichi'; 'Aijun Wang'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Ogaki:

Best Regards.

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Thursday, February 25, 2016 12:52 PM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: RE: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

Thanks,
Kenichi

-----Original Message-----
From: Aijun Wang [mailto:[email-masked]]
Sent: Thursday, February 25, 2016 12:56 PM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: RE: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Ogaki:

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Thursday, February 25, 2016 11:26 AM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: RE: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Thursday, February 25, 2016 10:52 AM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Ogaki:

    container l3vpn-svc {
        list vpn-svc {
            key vpn-id;

            leaf vpn-id {
                …
            }
            ...
        
            list sites{
              leaf site-id
              leaf site-role

        list site-templates{
        ... 
        }
        ...
    }

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Wednesday, February 24, 2016 4:34 PM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Wednesday, February 24, 2016 2:57 PM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Ogaki:

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, February 24, 2016 12:59 PM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: RE: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Wednesday, February 24, 2016 10:06 AM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Ogaki:

Best Regards.

Aijun Wang

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, February 24, 2016 8:11 AM
To: 'Aijun Wang'; [email-masked]; [email-masked]
Subject: RE: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Aijun,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Aijun Wang
Sent: Thursday, February 18, 2016 1:12 PM
To: 'Ogaki, Kenichi'; [email-masked]; [email-masked]
Subject: Re: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi, Stephane and Ogaki:

[KO]Like this?

    container l3vpn-svc {
        list vpn-svc {
            key vpn-id;

            leaf vpn-id {
                …
            }
            ...

Container L3vpn-svc

   List vpn-svc

   Leaf vpn-id

   Leaf customer-name

   Leaf topology

   List extranet-vpn-policy

   Container cloud-access

   List multicast

   Leaf mpls

   List sites

     Leaf site-id

     Leaf site-role

     leaf apply-template

     ... ...

     ... ...

     Container managent

     Container maximum-routes

     Container security

     ... ...

     ... ...

     Site-network-access 

 

Best Regards.

Aijun Wang

 

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Ogaki, Kenichi
Sent: Thursday, February 18, 2016 9:08 AM
To: [email-masked]
Subject: [L3sm] Issue #10 RE: L3SM interim meeting minutes on Thursday L3SM interim session

Hi Stephane and All,

Like this?

<vpn-svc>

   ...

   <vpn-policy>

       <entries>

           <id>1</id>

           <vpn>

               <vpn-id>VPN1</vpn-id>

           </vpn>

           <extranet-vpn-policy>

               <extranet-vpn>

                   <vpn-id>VPN2</vpn-id>

               </extranet-vpn>

           </extranet-vpn-policy>

       </entries>

   </vpn-policy>

   ...

</vpn-svc>

Thanks,

Kenichi

-----Original Message-----

Hi Kenichi,

Stephane

-----Original Message-----

Dear Stephane and All,

Thanks,

Kenichi

-----Original Message-----

Hi,

 

-----Original Message-----

Dear all:

 

Best Regards.

Aijun Wang

 

-----Original Message-----

Dear All,

Thanks,

Kenichi

-----Original Message-----

Hi all:

 

-Qin

 

BLUE SHEET

Name                    | Affiliation

Luis Tomotaki           | Verizon

Gu Rong                 | China Mobile 

Kenichi Ogaki           | KDDI

Victor Santos           | Ericsson

Ignas Bagdonas          | 

 

 

MINUTES

 

Agendaa

- Introduction

 

 

Discussion on #1: 

Agreed OK

Status #2: Closed

Discussion on #2: 

Agreed OK

Status #3:

Discussion on #3: 

 

 

o Maximum Routes - 

 

Status #4: Closed

Discussion on #4: 

Discussion on #5: 

 

Discussion on #6: 

 

 

Status #7: Closed

Discussion on #7: 

 

Status #8: Closed

Discussion on #8: 

Discussion on #9:    

 

 

 

Latency

Path diversty

Site diversty

Jitter

 

 

Issue#10: VPN "merging"

Resolution #10:    

Status #10:

Discussion on #10:    

 

 

 

 

== Other Issues ==    

 

== Conclusions ==

 

L3sm mailing list

L3sm mailing list

Thank you.

Thank you.

L3sm mailing list

L3sm mailing list