Subject: Re: [L3sm] Notification support on L3SM

From: Qin Wu <[email-masked]>
Date: Tue, 23 Feb 2016 06:22:16 +0000

Hi, Kenichi:
Notification support is not a new feature in YANG 1.1 and it has already been supported by YANG 1.0.
The difference between YANG 1.1 and YANG 1.0 for Notification is to remove tie with NETCONF, make notification not only applied to NETCONF but also RESTCONF or other transport protocols.

In addition, YANG 1.1 clearly specify location of notification in the schema tree.
See paragraph 2, section 7.16 of rfc6020bis
"
Notification should be defined at the top-level of a module, or
connected to a specific container or list data node in the schema
tree. 
"
It can not be randomly defined at any other place in the schema tree. 
I am wondering whether there is any specific data you want to add in the service model besides "anydata data"?
If there is no specific data that needs to be added, I think we keep service model simple as base model, extend it at any time through augmentation when specific data is needed.

-Qin
-----邮件原件-----
发件人: L3sm [mailto:[email-masked]] 代表 Ogaki, Kenichi
发送时间: 2016年1月5日 13:13
收件人: [email-masked]
主题: [L3sm] Notification support on L3SM

Dear All,

I would like to ask you if a notification support is necessary on the model.
I don't want to stick to this at this phase, but there are some use cases.

Operators must sometimes notify various information to customers under each SLA with them.
-maintenance schedule (planned, in operation) -proactive report when a failure occurred(, even if the customer is not aware)

YANG1.1 will allow notifications to be tied to data nodes.
https://tools.ietf.org/html/draft-ietf-netmod-rfc6020bis-09#section-7.16

https://mailarchive.ietf.org/arch/msg/l3sm/35eO1KXYYBEhQ5TXI0ijWe5Nqj4
--
*notification
How about defining notification node under vpn-svc and site-network-access?
We sometimes have to actively inform our customers of a failure or something.
What kind of the information depends on each operator, then anydata or anyxml suits this.

[SLI] Notification are normally not part of the tree, we can create rpcs or notifications if necessary to retrieve operational infos.
Could you raise a separate thread to discuss the need of notifications ?

ex.)
container site-network-accesses {
    list site-network-access {
        key site-network-access-id;
        ...
        notification info {
            anydata data;
        }
        ...
}
--

--
Kenichi Ogaki
KDDI Corp. | IP Network Dept.
+81-(0)80-5945-9138 | www.kddi.com

_______________________________________________
L3sm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/l3sm

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Wed, 24 Feb 2016 09:09:14 +0900

Hi Qin,

>See paragraph 2, section 7.16 of rfc6020bis "
>Notification should be defined at the top-level of a module, or connected to a specific container or list data node in the schema tree. 
>"

In my understanding, the limitation of notification statement placed only at top-level in YANG 1.0 is relieved to container and list in YANG 1.1.
An example is shown in just before section 7.17 of rfc6020bis.

>I am wondering whether there is any specific data you want to add in the service model besides "anydata data"?

This intends that how to use the notification depends on each operator.

>when specific data is needed.

So, I don't stick to define the notification at this phase, unless a strong requirement.
Augmentation is good enough.

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Tuesday, February 23, 2016 3:22 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Notification support on L3SM

Hi, Kenichi:

In addition, YANG 1.1 clearly specify location of notification in the schema tree.
See paragraph 2, section 7.16 of rfc6020bis "
Notification should be defined at the top-level of a module, or connected to a specific container or list data node in the schema tree. 
"
It can not be randomly defined at any other place in the schema tree. 
I am wondering whether there is any specific data you want to add in the service model besides "anydata data"?
If there is no specific data that needs to be added, I think we keep service model simple as base model, extend it at any time through augmentation when specific data is needed.

-Qin
-----邮件原件-----
发件人: L3sm [mailto:[email-masked]] 代表 Ogaki, Kenichi
发送时间: 2016年1月5日 13:13
收件人: [email-masked]
主题: [L3sm] Notification support on L3SM

Dear All,

ex.)

---

From: Qin Wu <[email-masked]>
Date: Thu, 25 Feb 2016 07:41:56 +0000

-----邮件原件-----
发件人: Ogaki, Kenichi [mailto:[email-masked]] 
发送时间: 2016年2月24日 8:09
收件人: Qin Wu; [email-masked]
主题: RE: [L3sm] Notification support on L3SM

Hi Qin,

[Qin]: Exactly.

[Qin]: Agree.
>If there is no specific data that needs to be added, I think we keep 
>service model simple as base model, extend it at any time through augmentation when specific data is needed.

[Qin]: Sounds good, I think both notification and operational inventory(https://mailarchive.ietf.org/arch/msg/l3sm/6zMiZSlcijda0ts_6NONdmwP3-E) 
can be used to model state data. We need to get consensus before implementing this. 
The author's proposal on operational inventory is:
a.Add three new top container vpn-svc-state sites-state and site-templates-states and 
copy all the parameters in three existing container vpn-svc,sites, site-templates to these new top container
b.Then Define site list under vpn-svc-state container, the site list describes site-id and site role.

For (b), it is quite to similar to what Aijun Wang propose. The difference is Aijun proposed to define site list under vpn-svc list in the current model.

I believe you support operational inventory, we also want to hear
what other think about this?

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Qin Wu
Sent: Tuesday, February 23, 2016 3:22 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Notification support on L3SM

Hi, Kenichi:

-Qin
-----邮件原件-----
发件人: L3sm [mailto:[email-masked]] 代表 Ogaki, Kenichi
发送时间: 2016年1月5日 13:13
收件人: [email-masked]
主题: [L3sm] Notification support on L3SM

Dear All,

ex.)