Subject: [L3sm] Modeling subVPN

From: <[email-masked]>
Date: Fri, 29 Apr 2016 11:59:06 +0000

Hi,

I still have some concern about the current modeling of subVPN that reuses the site-network-access that was defined for multihoming.
Mixing both notions brings IMO confusion while a subVPN is just a regular site that reuses a particular existing physical infrastructure.

I would so propose to rediscuss the point.

My proposal to discuss would be to use regular sites to model subVPN using the following tweak :
We add a new site property which tells what kind of site it is :

-          "Regular" : standard site without subVPN

-          "SubVPN-physical" : physical site that will support subVPN. This kind of site will have a very limited config, as most properties will be on the subVPN sites.

-          "SubVPN-virtual" : define properties of each subVPN slice, it needs a reference to the attached "subVPN-physical"
With this, we keep the site-network-access just for multihoming properties.

Thoughts ?

[Orange logo]<http://www.orange.com/>

Stephane Litkowski
Network Architect
Orange/SCE/EQUANT/OINIS/NET
Orange Expert Future Networks
phone: +33 2 23 28 49 83 <https://monsi.sso.francetelecom.fr/index.asp?target=http%3A%2F%2Fclicvoice.sso.francetelecom.fr%2FClicvoiceV2%2FToolBar.do%3Faction%3Ddefault%26rootservice%3DSIGNATURE%26to%3D+33%202%2023%2028%2049%2083%20>
mobile: +33 6 37 86 97 52 <https://monsi.sso.francetelecom.fr/index.asp?target=http%3A%2F%2Fclicvoice.sso.francetelecom.fr%2FClicvoiceV2%2FToolBar.do%3Faction%3Ddefault%26rootservice%3DSIGNATURE%26to%3D+33%206%2037%2086%2097%2052%20>
[email-masked]<mailto:[email-masked]>

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Sat, 30 Apr 2016 11:16:04 +0900

Hi Stephane,

IMO, it's not good idea to re-open the old discussion. I think the current model is more universal and simpler.
In principle, increase of the number of parameters causes the complexity of the system development.

In your proposal, Regular site is a subset of a SubVPN site, with one site-network-access to a single (or multi) VPN.

The problem is to allow two options for one usecase.
A customer may have no plan whether she/he would use any subVPN or not later, when she/he creates a new site with one site-network-access. In this case, the customer should always choose a SubVPN site, because it must bring some troubles to change a Regular site to a SubVPN site for customers as well as operators. Keeping the existing site-network-access without any disruption, the customer must request to change the site property from Regular to SubVPN and move the access to under SubVPN-virtual, and the operator does so.
I don't want to develop a function to support such specific scenario on our management system.
This means operators who are offering subVPN service will not use Regular site.

We all know one size doesn't fit all, but we shouldn't optimize the model for each specific usecase and must keep it simple.

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, April 29, 2016 8:59 PM
To: [email-masked]
Subject: [L3sm] Modeling subVPN

Hi,

Thoughts ?

Orange logo <http://www.orange.com/> 

Stephane Litkowski 
Network Architect 

phone: +33 2 23 28 49 83 <https://monsi.sso.francetelecom.fr/index.asp?target=http%3A%2F%2Fclicvoice.sso.francetelecom.fr%2FClicvoiceV2%2FToolBar.do%3Faction%3Ddefault%26rootservice%3DSIGNATURE%26to%3D+33%202%2023%2028%2049%2083%20> 
mobile: +33 6 37 86 97 52 <https://monsi.sso.francetelecom.fr/index.asp?target=http%3A%2F%2Fclicvoice.sso.francetelecom.fr%2FClicvoiceV2%2FToolBar.do%3Faction%3Ddefault%26rootservice%3DSIGNATURE%26to%3D+33%206%2037%2086%2097%2052%20> 
[email-masked] <mailto:[email-masked]>