Subject: Re: [L3sm] Modeling subVPN

From: <[email-masked]>
Date: Mon, 2 May 2016 08:35:15 +0000

Hi,

Inline

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]] 
Sent: Saturday, April 30, 2016 04:16
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

IMO, it's not good idea to re-open the old discussion. I think the current model is more universal and simpler.
[SLI] I do not think it is simpler, as we are mixing the usage of the same object for two things that are different which brings IMO more confusion than simplicity.
IMO, what we done works, but more looks as a coder optimization rather than what the service looks like.

In principle, increase of the number of parameters causes the complexity of the system development.

In your proposal, Regular site is a subset of a SubVPN site, with one site-network-access to a single (or multi) VPN.
[SLI] It's independent of multihoming, a regular site can be multihomed and can have multiple site-network-accesses.

The problem is to allow two options for one usecase.
A customer may have no plan whether she/he would use any subVPN or not later, when she/he creates a new site with one site-network-access. In this case, the customer should always choose a SubVPN site, because it must bring some troubles to change a Regular site to a SubVPN site for customers as well as operators. 
[SLI] Regular and subVPN are two different services. In live networks, this kind of migration is never easy and is almost never done by just patching the config, sometimes you have also to change the CPE. In general, customer orders a new site to perform such migration and decommission the previous one.
We can work for sure on something more smooth, but mixing multihoming and subVPN is really cause of troubles.

Keeping the existing site-network-access without any disruption, the customer must request to change the site property from Regular to SubVPN and move the access to under SubVPN-virtual, and the operator does so.
I don't want to develop a function to support such specific scenario on our management system.
This means operators who are offering subVPN service will not use Regular site.

We all know one size doesn't fit all, but we shouldn't optimize the model for each specific usecase and must keep it simple.

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, April 29, 2016 8:59 PM
To: [email-masked]
Subject: [L3sm] Modeling subVPN

Hi,

I still have some concern about the current modeling of subVPN that reuses the site-network-access that was defined for multihoming.

Mixing both notions brings IMO confusion while a subVPN is just a regular site that reuses a particular existing physical infrastructure.

I would so propose to rediscuss the point.

My proposal to discuss would be to use regular sites to model subVPN using the following tweak :

We add a new site property which tells what kind of site it is :

-          "Regular" : standard site without subVPN

-          "SubVPN-physical" : physical site that will support subVPN. This kind of site will have a very limited config, as most properties will be on the subVPN sites.

-          "SubVPN-virtual" : define properties of each subVPN slice, it needs a reference to the attached "subVPN-physical"

With this, we keep the site-network-access just for multihoming properties.

Thoughts ?

Orange logo <http://www.orange.com/> 

Stephane Litkowski 
Network Architect 
Orange/SCE/EQUANT/OINIS/NET

Orange Expert Future Networks

phone: +33 2 23 28 49 83 <https://monsi.sso.francetelecom.fr/index.asp?target=http%3A%2F%2Fclicvoice.sso.francetelecom.fr%2FClicvoiceV2%2FToolBar.do%3Faction%3Ddefault%26rootservice%3DSIGNATURE%26to%3D+33%202%2023%2028%2049%2083%20> 
mobile: +33 6 37 86 97 52 <https://monsi.sso.francetelecom.fr/index.asp?target=http%3A%2F%2Fclicvoice.sso.francetelecom.fr%2FClicvoiceV2%2FToolBar.do%3Faction%3Ddefault%26rootservice%3DSIGNATURE%26to%3D+33%206%2037%2086%2097%2052%20> 
[email-masked] <mailto:[email-masked]>  

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Tue, 3 May 2016 17:23:13 +0900

Hi Stephane,

See more comments inline, please.

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 02, 2016 5:35 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Inline

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]] 
Sent: Saturday, April 30, 2016 04:16
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

[KO] We have different senses to the word "simplicity". 
In the old discussion, we chose the same syntax(model definition) of site(-network-access) to multiple semantics(usecases) for multiVPN and subVPN without optimizing the model for each usecase, because each operator has each usecase and some operators may not use some usecases.
I can't understand what "but more looks as a coder optimization rather than what the service looks like." means.
Could you clarify what's the confusion?

[KO] Does this have to be solved by the site definition?
As I proposed on a different thread, the problem could be solved by duplicating or moving the current site-group-id to under site-network-access? But, I may be still missing something.

[KO] It depends on each operator's service definition. For us, we don't differentiate Regular and subVPN sites, they are just different scenarios under a basic menu service. So, we don't want to create two different entrances for the same service.
You well understand the abovementioned migration must be really avoided, then I want to correctly understand what your concern is and find an alternative way.
Could you elaborate on the problem again?

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, April 29, 2016 8:59 PM
To: [email-masked]
Subject: [L3sm] Modeling subVPN

Hi,

Thoughts ?

Stephane Litkowski 
Network Architect 

_______________________________________________
L3sm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/l3sm

---

From: <[email-masked]>
Date: Wed, 4 May 2016 12:03:40 +0000

Ok I understand your point, we have two different ways of using subVPN.
Now regarding the diversity, having diversity expressed at site level and site-network-access level brings complexity in how both interacts.
Diversity is required into cases :
- multihoming : preventing the two site-network-accesses to be meshed on the same PE
- avoiding too much site connections on the same PE

So globally it's a more a site-network-access property rather than a site property, so why not removing it from site level ?

If we review how the service placement works (without subVPN) :

- Customer requests a VPN using the vpn-svc options
- Customer requests a site :
	- Each site network access will need to be placed in the network (allocating an access media (bearer) and PE). For this we use multiple parameters to constraint or influence the system : diversity, requested-type, bandwidth, always-on ...
	- in case of multihoming multiple site-network-accesses will be ordered leading to allocation of multiple access medias and PEs (depending of parameters)

Now getting back to subVPN :
- for the first subVPN connection, we need a site-network-access with parameters that will allow the SP to place the service (choosing the bearer and meshing to a PE). Diversity may apply here.
- all the next connections that will use the same bearer does not need any placement rule , as we need to tell the system that we want to place the service on an existing bearer (we may be able to use the bearer-reference here to do that).
 BUT here we may have an issue, as the bearer selected by the SP for the first access may not support subVPN ... (that's why asking a migration from traditional site to subVPN is not trivial as it impacts many points : CPE type, bearer, PE ...). If you have a network that has a single access type that supports all services, that's not an issue, but it's usually not the case ... So the provider needs to know that the customer wants a subVPN and this may imply a complete site rebuild. We currently have the site-vpn-flavor leaf at site level to tell that we want to move to subVPN.
- In case of subVPN multihomed, we need x accesses that will be used to place and allocate bearers PEs, then we map the other subVPN to existing bearers with no placement rules except bearer-reference. Having no bearer-reference for other subVPN sites, will be treated as a multihoming case.

This implies that we need to add a RPC to get allocated bearer-reference for a site.

So trying to sum up :
- would be better to move diversity only at site-network-access including a group-id (no more need at site-level)
- multihoming is having multi-network-accesses with placement rules that are not using bearer-reference leaf
- for subVPN, the site-vpn-flavor must be putted to subvpn : a SP may refuse a migration (modify the leaf value). Site-vpn-flavor will influence the service placement : for instance : access media, PE and CE requires subVPN support
- When site-vpn-flavor is subVPN, we need x sites without bearer-reference to place the service, the following one will need to use bearer-reference that can be obtained through RPC

Thoughts ?

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]] 
Sent: Tuesday, May 03, 2016 10:23
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 02, 2016 5:35 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Inline

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]] 
Sent: Saturday, April 30, 2016 04:16
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, April 29, 2016 8:59 PM
To: [email-masked]
Subject: [L3sm] Modeling subVPN

Hi,

Thoughts ?

Stephane Litkowski 
Network Architect

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Thu, 5 May 2016 11:01:08 +0900

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, May 04, 2016 9:04 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

[KO] IMO, the problem can be solved by moving group-id to under site-network-access.
A multihoming is not identified by the bearer, but only has to be identified by the group-id.
But, I think we have to 180-degree change the usage of group-id to be shared by the same fate-sharing group like the same bearer. It's more straight forward way to specify fate-sharing/shared-risk group by the same id. One of confusions is to mix up site-group-id and bearer with the different usages for a diversity.
If we create a new placement-diversity, route-diversity, for multihoming, it's not necessary to get such a bearer-reference. In the current model, we don't get PoP, PE, Linecard reference for diversifying them.

How to use site-vpn-flavor depends on each operator. As I wrote, our service doesn't differentiate site-vpn-flavor, then we may refine site-vpn-flavor constraint to only site-vpn-flavor-sub for the model conformance.
Other operators may provide a bearer which only allows site-vpn-flavor-single or site-vpn-flavor-multi due to their physical equipment constraint, and allow to change site-vpn-flavor, then they have to support the complex migration. But, it's not model problem.
I'm still missing something?

So trying to sum up :

Thoughts ?

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]] 
Sent: Tuesday, May 03, 2016 10:23
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 02, 2016 5:35 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Inline

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]] 
Sent: Saturday, April 30, 2016 04:16
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, April 29, 2016 8:59 PM
To: [email-masked]
Subject: [L3sm] Modeling subVPN

Hi,

Thoughts ?

Stephane Litkowski 
Network Architect

---

From: <[email-masked]>
Date: Fri, 6 May 2016 06:45:09 +0000

I have some issues about just using group-id as discriminator rather than the bearer. There is no way to differentiate a subVPN case (logical links using same bearer) from a site having multiple parallel links for loadbalancing or whatever ... (so having different bearers). We need to differentiate clearly the case where a site network access requests a new access media to be allocated from the case where I can reuse an existing one.

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]] 
Sent: Thursday, May 05, 2016 04:01
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, May 04, 2016 9:04 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

So trying to sum up :

Thoughts ?

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]] 
Sent: Tuesday, May 03, 2016 10:23
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 02, 2016 5:35 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Inline

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]] 
Sent: Saturday, April 30, 2016 04:16
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, April 29, 2016 8:59 PM
To: [email-masked]
Subject: [L3sm] Modeling subVPN

Hi,

Thoughts ?

Stephane Litkowski 
Network Architect

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Fri, 6 May 2016 17:58:51 +0900

Hi Stephane,

As I wrote below, we just have to change the usage of group-id as a fate-sharing group id. If we want to use the same bearer for multiple links, we just put the same group-id to the links. Vice versa, we can just differentiate the group-ids for different bearers.
For this purpose, we may need to introduce a new placement-diversity, for example of route-diversity, loadbalancing or something, to differentiate bearers, also may need to allow multiple placement-diversities for a single group-id.

Here is exercises, the following site-network-access 1 and 2 must be connected to different PEs with different bearers. However, site-network-access 3 and 4 may or may not connect to the same PE, but must have different bearers.
site-network-access 1 : group-id 100 with pe-diversity and route-diversity,
site-network-access 2 : group-id 200 with pe-diversity and route-diversity,
site-network-access 3 : group-id 300 with route-diversity,
site-network-access 4 : group-id 400 with route-diversity.

Am I still missing something?

Thanks,
Kenichi

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]] 
Sent: Thursday, May 05, 2016 04:01
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, May 04, 2016 9:04 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

So trying to sum up :

Thoughts ?

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]] 
Sent: Tuesday, May 03, 2016 10:23
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 02, 2016 5:35 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Inline

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]] 
Sent: Saturday, April 30, 2016 04:16
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, April 29, 2016 8:59 PM
To: [email-masked]
Subject: [L3sm] Modeling subVPN

Hi,

Thoughts ?

Stephane Litkowski 
Network Architect

---

From: <[email-masked]>
Date: Mon, 9 May 2016 12:49:29 +0000

Hi,

I tried to make the exercice on multiple examples.
What I see, is that we need to be able to express that we want to use the same PE or the same bearer, diversity is not enough because not asking for diversity does not mean that you want to use a shared component. We so need an explicit constraint.
We also need a specific group-id per constraint, so a list of group/constraint pair is needed.

The bad thing is that it's easy to create impossible scenarios if the framework is not used correctly.

In the example, I renamed your route-diversity to access-diversity, which means that we want to use another bearer but it can be connected anywhere.

Single homed sites meshed on different PEs
------------------------------------------

Site#1
	Site-net-access#1
		group-id#10
			pe-diversity

Site#2
	Site-net-access#1
		group-id#20
			pe-diversity

Site#3
	Site-net-access#1
		group-id#10
			pe-diversity

Site#4
	Site-net-access#1
		group-id#20
			pe-diversity

Multihomed homed site basic
------------------------------------------

Expected behavior, the two site network accesses are using different bearers

Site#1
	Site-net-access#1
		group-id#10
		access-diversity

	Site-net-access#2
		group-id#20
		access-diversity

Expected behavior, the two site network accesses are using different PEs

Site#1
	Site-net-access#1
		group-id#10
		site-diversity

	Site-net-access#2
		group-id#20
		site-diversity

Parallel links
------------------------------------------

Expected behavior, the two site network accesses are meshed to the same PE

Site#1
	Site-net-access#1
		group-id#10
			same-PE

	Site-net-access#2
		group-id#10	
			same-PE

Multihomed homed site with multiple sites
------------------------------------------

Site#1 wants a different bearer for its two access and also wants to be connected on different PEs compared to the other sites.

Site#1
	Site-net-access#1
		group-id#10
			access-diversity
		group-id#30
			pe-diverse

	Site-net-access#2
		group-id#20
			access-diversity
		group-id#30
			pe-diverse

Site#2
	Site-net-access#1
		group-id#50
			pe-diverse

Site#3
	Site-net-access#1
		group-id#30
			pe-diverse

Site#4
	Site-net-access#1
		group-id#30
			pe-diverse

	Site-net-access#2
		group-id#40
			pe-diverse

SubVPN basic
---------------

Site#1 has 3 subVPN

Site#1
	Site-net-access#1
		group-id#10
			same-access

	Site-net-access#2
		group-id#10
			same-access

	Site-net-access#3
		group-id#10
			same-access

SubVPN multihomed with PE diversity
-----------------------------------

Site#1 has 3 subVPNs which are multihomed on two different PEs.

Site#1
	Site-net-access#1
		group-id#10
			same-access
		group-id#20
			pe-diverse

	Site-net-access#2
		group-id#10
			same-access
		group-id#20
			pe-diverse
	Site-net-access#3
		group-id#10
			same-access
		group-id#20
			pe-diverse

	Site-net-access#1
		group-id#30
			same-access
		group-id#40
			pe-diverse

	Site-net-access#2
		group-id#30
			same-access
		group-id#40
			pe-diverse
	Site-net-access#3
		group-id#30
			same-access
		group-id#40
			pe-diverse

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]] 
Sent: Friday, May 06, 2016 10:59
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Here is exercises, the following site-network-access 1 and 2 must be connected to different PEs with different bearers. However, site-network-access 3 and 4 may or may not connect to the same PE, but must have different bearers.
site-network-access 1 : group-id 100 with pe-diversity and route-diversity, site-network-access 2 : group-id 200 with pe-diversity and route-diversity, site-network-access 3 : group-id 300 with route-diversity, site-network-access 4 : group-id 400 with route-diversity.

Thanks,
Kenichi

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Thursday, May 05, 2016 04:01
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, May 04, 2016 9:04 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

So trying to sum up :

Thoughts ?

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, May 03, 2016 10:23
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 02, 2016 5:35 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Inline

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Saturday, April 30, 2016 04:16
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, April 29, 2016 8:59 PM
To: [email-masked]
Subject: [L3sm] Modeling subVPN

Hi,

Thoughts ?

Stephane Litkowski
Network Architect

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Tue, 10 May 2016 13:15:13 +0900

Hi Stephane,

See more comments inline.

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 09, 2016 9:49 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

[KO] That's semantic. The model should just provide enough discriminators to be used by users(operators). How to use them should depends on each usecase. I agree with providing a basic semantic with the model.
However, we can change the naming of group-id to shared-risk-group-id or something in order to defiintely express the same bearer. Also, change the naming of xxx-diversity to the alternative like xxx-disjoint to express what level the shared-risk-group is disjoint from other groups.

[KO]Based of the above and the rewritten examples below, I think we don't need such pairs.

[KO] I directly rewrote the examples below.

[KO] site-net-accesses of Site#1, #2, #3 and #4 may share the same bearer or physical facilities, but the accesses of Site#1 and Site#3 must be accommodated to the different PE from that of Site#2 and Site#4.

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

Site#2
	Site-net-access#1
		shared-risk-group-id#20
			pe-disjoint

Site#3
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

Site#4
	Site-net-access#1
		shared-risk-group-id#20
			pe-disjoint

[KO] Done.

Site#1
	Site-net-access#1
		shared-risk-group-id#10
		access-disjoint

	Site-net-access#2
		shared-risk-group-id#20
		access-disjoint

[KO]Why not use pe-diversity(disjoint)?

Site#1
	Site-net-access#1
		shared-risk-group-id#10
		pe-disjoint

	Site-net-access#2
		shared-risk-group-id#20
		pe-disjoint

Parallel links

[KO] As wrote above, the same group shares the facility defined by the level of xxx-disjoint.

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#10	
			pe-disjoint

[KO] How to use access-disjoint depends on each operator. If an operator wants to accommodate site-net-access#1 and #2 of Site#1 to the same PE, the operator should do so that access-disjoint always use the same PE. What's requirement for Site#4?

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#20
			access-disjoint

Site#2
	Site-net-access#1
		shared-risk-group-id#30
			pe-disjoint

Site#3
	Site-net-access#1
		shared-risk-group-id#40
			pe-disjoint

Site#4
	Site-net-access#1
		shared-risk-group-id#50
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#60
			pe-disjoint

SubVPN basic
---------------

Site#1 has 3 subVPN

[KO] Done.

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint

	Site-net-access#2
		shared-risk-group-id#10
			access-disjoint

	Site-net-access#3
		shared-risk-group-id#10
			access-disjoint

[KO] A shared-risk-group can have two combined constraint. site-net-accesses#1, #2 and #3 must be disjoint from #4, #5 and #6 per access and PE level.

Site#1
	Site-net-access#1
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint
	Site-net-access#2
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint
	Site-net-access#3
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint

	Site-net-access#4
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint
	Site-net-access#5
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint
	Site-net-access#6
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint

[KO] Am I still missing something?

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Friday, May 06, 2016 10:59
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Thursday, May 05, 2016 04:01
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, May 04, 2016 9:04 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

So trying to sum up :

Thoughts ?

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, May 03, 2016 10:23
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 02, 2016 5:35 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Inline

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Saturday, April 30, 2016 04:16
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, April 29, 2016 8:59 PM
To: [email-masked]
Subject: [L3sm] Modeling subVPN

Hi,

Thoughts ?

Stephane Litkowski
Network Architect

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Fri, 20 May 2016 09:41:19 +0000

Hi,

Sorry for the late reply, I'm busy on other tasks ...

As told, telling that we use the same bearer is not enough, as in the examples below the parallel links model does not work as you use the semantic of common bearer which is different. For parallel links I use two different bearers to the same PE, so I also need to express that.
Moreover we are mixing constraints at different level (shared-group-id => means same bearer while underneath parameters also express constraints). I would like to keep constraints all at the same level.
So  I would like to keep the group-id or shared-group-id significance to tell that constraints do apply only with sites with a different group-id and then describe the constraints.: same-access, same-pe, pe-diverse, access-diverse, pop-diverse
For the "same-x" we need to express : same compared to what.

The semantic of cumulating constraint is also unclear like in the example :
" Site#1 wants a different bearer for its two access and also wants to be connected on different PEs compared to the other sites."

Coming back to requirements :
- we need to express constraints that could be diversity (access, pe, pop) or using a common component (bearer, PE, may be PoP also). 
- we also need to have a semantic when there is no constraint
- no constraint may apply only between a subset of sites as constraints also ...
- there may be multiple constraints applying between different sets of site-network-accesses
- we need to describe a deterministic behavior for each constraint and when there are multiple ones.

I need more time to find something ...

Best Regards,

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]] 
Sent: Tuesday, May 10, 2016 06:15
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 09, 2016 9:49 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

Site#2
	Site-net-access#1
		shared-risk-group-id#20
			pe-disjoint

Site#3
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

Site#4
	Site-net-access#1
		shared-risk-group-id#20
			pe-disjoint

[KO] Done.

Site#1
	Site-net-access#1
		shared-risk-group-id#10
		access-disjoint

	Site-net-access#2
		shared-risk-group-id#20
		access-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#10
		pe-disjoint

	Site-net-access#2
		shared-risk-group-id#20
		pe-disjoint

Parallel links

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#10	
			pe-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#20
			access-disjoint

Site#2
	Site-net-access#1
		shared-risk-group-id#30
			pe-disjoint

Site#3
	Site-net-access#1
		shared-risk-group-id#40
			pe-disjoint

Site#4
	Site-net-access#1
		shared-risk-group-id#50
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#60
			pe-disjoint

SubVPN basic
---------------

Site#1 has 3 subVPN

[KO] Done.

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint

	Site-net-access#2
		shared-risk-group-id#10
			access-disjoint

	Site-net-access#3
		shared-risk-group-id#10
			access-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint
	Site-net-access#2
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint
	Site-net-access#3
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint

	Site-net-access#4
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint
	Site-net-access#5
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint
	Site-net-access#6
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Friday, May 06, 2016 10:59
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Thursday, May 05, 2016 04:01
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, May 04, 2016 9:04 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

So trying to sum up :

Thoughts ?

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, May 03, 2016 10:23
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 02, 2016 5:35 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Inline

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Saturday, April 30, 2016 04:16
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, April 29, 2016 8:59 PM
To: [email-masked]
Subject: [L3sm] Modeling subVPN

Hi,

Thoughts ?

Stephane Litkowski
Network Architect

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Mon, 23 May 2016 12:26:36 +0900

Hi Stephane,

Just my opinion.

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, May 20, 2016 6:41 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

[KO] I can't understand what your requirement is. I already showed a solution for the above requirement, Multihomed homed site with multiple sites, in the previous email.

[KO] No, a shared-risk-group means not only a same bearer, but also whichever level as each operator wants to express by the parameter. In a real-life operation, the level of a fate sharing/diversity depends on the customer's requirement.
As you told the parallel links model case, mixing constraints cases really exist. Also, there are not only the x-diversity mixing only with the access(bearer) diversity, but also mixing two other different level constraints, for example of PE and LC diversities across different sites. Then, we need a general model.

So  I would like to keep the group-id or shared-group-id significance to tell that constraints do apply only with sites with a different group-id and then describe the constraints.: same-access, same-pe, pe-diverse, access-diverse, pop-diverse For the "same-x" we need to express : same compared to what.

[KO]Again, I already showed a solution for the above requirement in the previous email. I understand we need to explicitly describe  what implicit assumption exists behind.

[KO]IMO, to express a diversity with a certain level is the same thing to express a use of a common component. It's two sides of the same coin.

[KO] I can't understand what this means.

Best Regards,

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, May 10, 2016 06:15
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 09, 2016 9:49 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

Site#2
	Site-net-access#1
		shared-risk-group-id#20
			pe-disjoint

Site#3
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

Site#4
	Site-net-access#1
		shared-risk-group-id#20
			pe-disjoint

[KO] Done.

Site#1
	Site-net-access#1
		shared-risk-group-id#10
		access-disjoint

	Site-net-access#2
		shared-risk-group-id#20
		access-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#10
		pe-disjoint

	Site-net-access#2
		shared-risk-group-id#20
		pe-disjoint

Parallel links

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#10	
			pe-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#20
			access-disjoint

Site#2
	Site-net-access#1
		shared-risk-group-id#30
			pe-disjoint

Site#3
	Site-net-access#1
		shared-risk-group-id#40
			pe-disjoint

Site#4
	Site-net-access#1
		shared-risk-group-id#50
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#60
			pe-disjoint

SubVPN basic
---------------

Site#1 has 3 subVPN

[KO] Done.

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint

	Site-net-access#2
		shared-risk-group-id#10
			access-disjoint

	Site-net-access#3
		shared-risk-group-id#10
			access-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint
	Site-net-access#2
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint
	Site-net-access#3
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint

	Site-net-access#4
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint
	Site-net-access#5
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint
	Site-net-access#6
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Friday, May 06, 2016 10:59
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Thursday, May 05, 2016 04:01
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, May 04, 2016 9:04 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

So trying to sum up :

Thoughts ?

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, May 03, 2016 10:23
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 02, 2016 5:35 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Inline

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Saturday, April 30, 2016 04:16
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, April 29, 2016 8:59 PM
To: [email-masked]
Subject: [L3sm] Modeling subVPN

Hi,

Thoughts ?

Stephane Litkowski
Network Architect

---

From: <[email-masked]>
Date: Mon, 23 May 2016 07:29:33 +0000

[SLI]As told, telling that we use the same bearer is not enough, as in the examples below the parallel links model does not work as you use the semantic of common bearer which is different. For parallel links I use two different bearers to the same PE, so I also need to express that.
[KO] I can't understand what your requirement is. I already showed a solution for the above requirement, Multihomed homed site with multiple sites, in the previous email.
[SLI2] What you provided does not work, you are using the same semantic to express parallel links using different bearers to the same PE and subVPN case which implements logical links on the same bearer. Using the same PE and the same bearer is a different constraint.

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]] 
Sent: Monday, May 23, 2016 05:27
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, May 20, 2016 6:41 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Best Regards,

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, May 10, 2016 06:15
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 09, 2016 9:49 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

Site#2
	Site-net-access#1
		shared-risk-group-id#20
			pe-disjoint

Site#3
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

Site#4
	Site-net-access#1
		shared-risk-group-id#20
			pe-disjoint

[KO] Done.

Site#1
	Site-net-access#1
		shared-risk-group-id#10
		access-disjoint

	Site-net-access#2
		shared-risk-group-id#20
		access-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#10
		pe-disjoint

	Site-net-access#2
		shared-risk-group-id#20
		pe-disjoint

Parallel links

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#10	
			pe-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#20
			access-disjoint

Site#2
	Site-net-access#1
		shared-risk-group-id#30
			pe-disjoint

Site#3
	Site-net-access#1
		shared-risk-group-id#40
			pe-disjoint

Site#4
	Site-net-access#1
		shared-risk-group-id#50
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#60
			pe-disjoint

SubVPN basic
---------------

Site#1 has 3 subVPN

[KO] Done.

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint

	Site-net-access#2
		shared-risk-group-id#10
			access-disjoint

	Site-net-access#3
		shared-risk-group-id#10
			access-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint
	Site-net-access#2
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint
	Site-net-access#3
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint

	Site-net-access#4
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint
	Site-net-access#5
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint
	Site-net-access#6
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Friday, May 06, 2016 10:59
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Thursday, May 05, 2016 04:01
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, May 04, 2016 9:04 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

So trying to sum up :

Thoughts ?

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, May 03, 2016 10:23
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 02, 2016 5:35 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Inline

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Saturday, April 30, 2016 04:16
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, April 29, 2016 8:59 PM
To: [email-masked]
Subject: [L3sm] Modeling subVPN

Hi,

Thoughts ?

Stephane Litkowski
Network Architect

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Tue, 24 May 2016 10:27:36 +0900

Hi Stephane,

>[SLI2] What you provided does not work, you are using the same semantic to express parallel links using different bearers to the 
>same PE and subVPN case which implements logical links on the same bearer. Using the same PE and the same bearer is a different 
>constraint.

No, my proposal don't differentiate whichever link in parallel links using different bearers and logical links on the same bearer for subVPN.
Any diversity is just expressed by the combination of (shared-risk-)group and constraint, even in the access(bearer) diversity case.

The challenge is how to model mixing constraints.

Anyway, I think it's better to define a simple single model(syntax) for various use cases(semantics) rather than the specific model for each use case.
As I wrote before, a specific model brings some troubles to customers and operators who don't have the use case, and doesn't cover any new use case which may emerge in the future.

Thanks,
Kenichi

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Monday, May 23, 2016 05:27
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, May 20, 2016 6:41 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Best Regards,

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, May 10, 2016 06:15
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 09, 2016 9:49 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

Site#2
	Site-net-access#1
		shared-risk-group-id#20
			pe-disjoint

Site#3
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

Site#4
	Site-net-access#1
		shared-risk-group-id#20
			pe-disjoint

[KO] Done.

Site#1
	Site-net-access#1
		shared-risk-group-id#10
		access-disjoint

	Site-net-access#2
		shared-risk-group-id#20
		access-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#10
		pe-disjoint

	Site-net-access#2
		shared-risk-group-id#20
		pe-disjoint

Parallel links

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#10	
			pe-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#20
			access-disjoint

Site#2
	Site-net-access#1
		shared-risk-group-id#30
			pe-disjoint

Site#3
	Site-net-access#1
		shared-risk-group-id#40
			pe-disjoint

Site#4
	Site-net-access#1
		shared-risk-group-id#50
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#60
			pe-disjoint

SubVPN basic
---------------

Site#1 has 3 subVPN

[KO] Done.

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint

	Site-net-access#2
		shared-risk-group-id#10
			access-disjoint

	Site-net-access#3
		shared-risk-group-id#10
			access-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint
	Site-net-access#2
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint
	Site-net-access#3
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint

	Site-net-access#4
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint
	Site-net-access#5
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint
	Site-net-access#6
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Friday, May 06, 2016 10:59
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Thursday, May 05, 2016 04:01
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, May 04, 2016 9:04 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

So trying to sum up :

Thoughts ?

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, May 03, 2016 10:23
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 02, 2016 5:35 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Inline

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Saturday, April 30, 2016 04:16
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, April 29, 2016 8:59 PM
To: [email-masked]
Subject: [L3sm] Modeling subVPN

Hi,

Thoughts ?

Stephane Litkowski
Network Architect

---

From: <[email-masked]>
Date: Tue, 24 May 2016 09:07:49 +0000

> No, my proposal don't differentiate whichever link in parallel links using different bearers and logical links on the same bearer for subVPN.

We need to differentiate it, because it's a totally different setup.

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]] 
Sent: Tuesday, May 24, 2016 03:28
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

>[SLI2] What you provided does not work, you are using the same semantic 
>to express parallel links using different bearers to the same PE and 
>subVPN case which implements logical links on the same bearer. Using the same PE and the same bearer is a different constraint.

Thanks,
Kenichi

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Monday, May 23, 2016 05:27
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, May 20, 2016 6:41 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Best Regards,

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, May 10, 2016 06:15
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 09, 2016 9:49 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

Site#2
	Site-net-access#1
		shared-risk-group-id#20
			pe-disjoint

Site#3
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

Site#4
	Site-net-access#1
		shared-risk-group-id#20
			pe-disjoint

[KO] Done.

Site#1
	Site-net-access#1
		shared-risk-group-id#10
		access-disjoint

	Site-net-access#2
		shared-risk-group-id#20
		access-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#10
		pe-disjoint

	Site-net-access#2
		shared-risk-group-id#20
		pe-disjoint

Parallel links

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#10	
			pe-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#20
			access-disjoint

Site#2
	Site-net-access#1
		shared-risk-group-id#30
			pe-disjoint

Site#3
	Site-net-access#1
		shared-risk-group-id#40
			pe-disjoint

Site#4
	Site-net-access#1
		shared-risk-group-id#50
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#60
			pe-disjoint

SubVPN basic
---------------

Site#1 has 3 subVPN

[KO] Done.

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint

	Site-net-access#2
		shared-risk-group-id#10
			access-disjoint

	Site-net-access#3
		shared-risk-group-id#10
			access-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint
	Site-net-access#2
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint
	Site-net-access#3
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint

	Site-net-access#4
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint
	Site-net-access#5
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint
	Site-net-access#6
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Friday, May 06, 2016 10:59
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Thursday, May 05, 2016 04:01
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, May 04, 2016 9:04 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

So trying to sum up :

Thoughts ?

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, May 03, 2016 10:23
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 02, 2016 5:35 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Inline

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Saturday, April 30, 2016 04:16
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, April 29, 2016 8:59 PM
To: [email-masked]
Subject: [L3sm] Modeling subVPN

Hi,

Thoughts ?

Stephane Litkowski
Network Architect

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Wed, 25 May 2016 10:23:52 +0900

Hi Stephane,

>We need to differentiate it, because it's a totally different setup.

I can't understand what " totally different setup" means.
If you say physical or network equipment dependent setup, we should not discuss those in a service model.

We know that the difference exists per level of diversity, but the model should generalize this as possible.
IMO, *this* difference can be absorbed by a single model. Then, could you elaborate on the reason why you don't think so?

Thanks,
Kenichi

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, May 24, 2016 03:28
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Monday, May 23, 2016 05:27
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, May 20, 2016 6:41 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Best Regards,

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, May 10, 2016 06:15
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 09, 2016 9:49 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

Site#2
	Site-net-access#1
		shared-risk-group-id#20
			pe-disjoint

Site#3
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

Site#4
	Site-net-access#1
		shared-risk-group-id#20
			pe-disjoint

[KO] Done.

Site#1
	Site-net-access#1
		shared-risk-group-id#10
		access-disjoint

	Site-net-access#2
		shared-risk-group-id#20
		access-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#10
		pe-disjoint

	Site-net-access#2
		shared-risk-group-id#20
		pe-disjoint

Parallel links

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#10	
			pe-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#20
			access-disjoint

Site#2
	Site-net-access#1
		shared-risk-group-id#30
			pe-disjoint

Site#3
	Site-net-access#1
		shared-risk-group-id#40
			pe-disjoint

Site#4
	Site-net-access#1
		shared-risk-group-id#50
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#60
			pe-disjoint

SubVPN basic
---------------

Site#1 has 3 subVPN

[KO] Done.

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint

	Site-net-access#2
		shared-risk-group-id#10
			access-disjoint

	Site-net-access#3
		shared-risk-group-id#10
			access-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint
	Site-net-access#2
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint
	Site-net-access#3
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint

	Site-net-access#4
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint
	Site-net-access#5
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint
	Site-net-access#6
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Friday, May 06, 2016 10:59
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Thursday, May 05, 2016 04:01
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, May 04, 2016 9:04 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

So trying to sum up :

Thoughts ?

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, May 03, 2016 10:23
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 02, 2016 5:35 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Inline

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Saturday, April 30, 2016 04:16
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, April 29, 2016 8:59 PM
To: [email-masked]
Subject: [L3sm] Modeling subVPN

Hi,

Thoughts ?

Stephane Litkowski
Network Architect

---

From: <[email-masked]>
Date: Wed, 25 May 2016 07:14:01 +0000

The model has to be able to express what the customer wants in term of VPN and access topology.
So we have to provide a model flexible enough to describe any topology (natively or by extension).

The model you are proposing is not able to differentiate two cases :
- a site having two parallel links (different bearers) to the same PE (no subVPN)
- a site having two logical links on the same bearer.

So there is no way with your proposal to be able to model both approach.

Moreover As I already said, there is also no way to express that there is no constraint with a particular set of sites : no constraint meaning that the customer don't care of the service placement regarding this set of sites (they can share some components or not).

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]] 
Sent: Wednesday, May 25, 2016 03:24
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, May 24, 2016 03:28
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Monday, May 23, 2016 05:27
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, May 20, 2016 6:41 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Best Regards,

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, May 10, 2016 06:15
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 09, 2016 9:49 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

Site#2
	Site-net-access#1
		shared-risk-group-id#20
			pe-disjoint

Site#3
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

Site#4
	Site-net-access#1
		shared-risk-group-id#20
			pe-disjoint

[KO] Done.

Site#1
	Site-net-access#1
		shared-risk-group-id#10
		access-disjoint

	Site-net-access#2
		shared-risk-group-id#20
		access-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#10
		pe-disjoint

	Site-net-access#2
		shared-risk-group-id#20
		pe-disjoint

Parallel links

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#10	
			pe-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#20
			access-disjoint

Site#2
	Site-net-access#1
		shared-risk-group-id#30
			pe-disjoint

Site#3
	Site-net-access#1
		shared-risk-group-id#40
			pe-disjoint

Site#4
	Site-net-access#1
		shared-risk-group-id#50
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#60
			pe-disjoint

SubVPN basic
---------------

Site#1 has 3 subVPN

[KO] Done.

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint

	Site-net-access#2
		shared-risk-group-id#10
			access-disjoint

	Site-net-access#3
		shared-risk-group-id#10
			access-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint
	Site-net-access#2
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint
	Site-net-access#3
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint

	Site-net-access#4
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint
	Site-net-access#5
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint
	Site-net-access#6
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Friday, May 06, 2016 10:59
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Thursday, May 05, 2016 04:01
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, May 04, 2016 9:04 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

So trying to sum up :

Thoughts ?

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, May 03, 2016 10:23
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 02, 2016 5:35 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Inline

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Saturday, April 30, 2016 04:16
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, April 29, 2016 8:59 PM
To: [email-masked]
Subject: [L3sm] Modeling subVPN

Hi,

Thoughts ?

Stephane Litkowski
Network Architect

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Thu, 26 May 2016 12:58:35 +0900

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, May 25, 2016 4:14 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

[KO] I put an example from the previous email below.
As I wrote, there are some implicit assumptions/rules behind this. And, that's a semantic which should be allowed to differ depending on each operator's usecase.
The assumptions are:
 0. A shared-risk-group can have mixing constraints.
    Site-net-access#1 of Site#1 must comply with both access-disjoint and pe-disjoint constraints.

 1. Different shared-risk-groups with access-disjoint inside a site must be accommodated to the same PE.
    This correspond to the first case.
    In the example below, both Site-net-access#1 and Site-net-access#2 of Site#1 are accommodated to the same PE.

 2. Different shared-risk-groups are diversified within the same level of diversity, i.e., xx-disjoint.
    Site-net-access#1 of Site#1, Site-net-access#1 of Site#2, Site-net-access#1 of Site#3, Site-net-access#1 of Site#4 and Site-net-access#2 of Site#4 must be accommodated to the different PEs.
 
We can also model the second case as follows. The same shared-risk-group with access-disjoint means the same bearer.

Site#5
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint

	Site-net-access#2
		shared-risk-group-id#10
			access-disjoint

[KO] Isn't enough to expless no constraint just by no shared-risk-group?

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#20
			access-disjoint

Site#2
	Site-net-access#1
		shared-risk-group-id#30
			pe-disjoint

Site#3
	Site-net-access#1
		shared-risk-group-id#40
			pe-disjoint

Site#4
	Site-net-access#1
		shared-risk-group-id#50
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#60
			pe-disjoint

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, May 25, 2016 03:24
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, May 24, 2016 03:28
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Monday, May 23, 2016 05:27
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, May 20, 2016 6:41 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Best Regards,

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, May 10, 2016 06:15
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 09, 2016 9:49 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

Site#2
	Site-net-access#1
		shared-risk-group-id#20
			pe-disjoint

Site#3
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

Site#4
	Site-net-access#1
		shared-risk-group-id#20
			pe-disjoint

[KO] Done.

Site#1
	Site-net-access#1
		shared-risk-group-id#10
		access-disjoint

	Site-net-access#2
		shared-risk-group-id#20
		access-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#10
		pe-disjoint

	Site-net-access#2
		shared-risk-group-id#20
		pe-disjoint

Parallel links

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#10	
			pe-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#20
			access-disjoint

Site#2
	Site-net-access#1
		shared-risk-group-id#30
			pe-disjoint

Site#3
	Site-net-access#1
		shared-risk-group-id#40
			pe-disjoint

Site#4
	Site-net-access#1
		shared-risk-group-id#50
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#60
			pe-disjoint

SubVPN basic
---------------

Site#1 has 3 subVPN

[KO] Done.

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint

	Site-net-access#2
		shared-risk-group-id#10
			access-disjoint

	Site-net-access#3
		shared-risk-group-id#10
			access-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint
	Site-net-access#2
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint
	Site-net-access#3
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint

	Site-net-access#4
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint
	Site-net-access#5
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint
	Site-net-access#6
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Friday, May 06, 2016 10:59
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Thursday, May 05, 2016 04:01
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, May 04, 2016 9:04 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

So trying to sum up :

Thoughts ?

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, May 03, 2016 10:23
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 02, 2016 5:35 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Inline

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Saturday, April 30, 2016 04:16
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, April 29, 2016 8:59 PM
To: [email-masked]
Subject: [L3sm] Modeling subVPN

Hi,

Thoughts ?

Stephane Litkowski
Network Architect

---

From: <[email-masked]>
Date: Thu, 26 May 2016 08:34:04 +0000

Hi 

more inline

Thx

 Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]] 
Sent: Thursday, May 26, 2016 05:59
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, May 25, 2016 4:14 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

 1. Different shared-risk-groups with access-disjoint inside a site must be accommodated to the same PE.
    This correspond to the first case.
    In the example below, both Site-net-access#1 and Site-net-access#2 of Site#1 are accommodated to the same PE.
[SLI] Access-disjoint does not mean same PE, it means that you want at least a different bearer, but the system may decide to place you on another PE depending on internal placing rules.
That's the same for pe-disjoint, this may lead to be placed on another PoP.

Site#5
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint

	Site-net-access#2
		shared-risk-group-id#10
			access-disjoint

[KO] Isn't enough to expless no constraint just by no shared-risk-group?
[SLI] This is restrictive ... because this mean that you do not want constraint at all while you may want to have particular constraint with some sites, while not having constraints with others.

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#20
			access-disjoint

Site#2
	Site-net-access#1
		shared-risk-group-id#30
			pe-disjoint

Site#3
	Site-net-access#1
		shared-risk-group-id#40
			pe-disjoint

Site#4
	Site-net-access#1
		shared-risk-group-id#50
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#60
			pe-disjoint

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, May 25, 2016 03:24
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, May 24, 2016 03:28
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Monday, May 23, 2016 05:27
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, May 20, 2016 6:41 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Best Regards,

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, May 10, 2016 06:15
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 09, 2016 9:49 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

Site#2
	Site-net-access#1
		shared-risk-group-id#20
			pe-disjoint

Site#3
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

Site#4
	Site-net-access#1
		shared-risk-group-id#20
			pe-disjoint

[KO] Done.

Site#1
	Site-net-access#1
		shared-risk-group-id#10
		access-disjoint

	Site-net-access#2
		shared-risk-group-id#20
		access-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#10
		pe-disjoint

	Site-net-access#2
		shared-risk-group-id#20
		pe-disjoint

Parallel links

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#10	
			pe-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#20
			access-disjoint

Site#2
	Site-net-access#1
		shared-risk-group-id#30
			pe-disjoint

Site#3
	Site-net-access#1
		shared-risk-group-id#40
			pe-disjoint

Site#4
	Site-net-access#1
		shared-risk-group-id#50
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#60
			pe-disjoint

SubVPN basic
---------------

Site#1 has 3 subVPN

[KO] Done.

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint

	Site-net-access#2
		shared-risk-group-id#10
			access-disjoint

	Site-net-access#3
		shared-risk-group-id#10
			access-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint
	Site-net-access#2
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint
	Site-net-access#3
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint

	Site-net-access#4
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint
	Site-net-access#5
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint
	Site-net-access#6
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Friday, May 06, 2016 10:59
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Thursday, May 05, 2016 04:01
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, May 04, 2016 9:04 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

So trying to sum up :

Thoughts ?

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, May 03, 2016 10:23
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 02, 2016 5:35 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Inline

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Saturday, April 30, 2016 04:16
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, April 29, 2016 8:59 PM
To: [email-masked]
Subject: [L3sm] Modeling subVPN

Hi,

Thoughts ?

Stephane Litkowski
Network Architect

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Fri, 27 May 2016 13:30:12 +0900

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, May 26, 2016 5:34 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi 

more inline

Thx

 Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Thursday, May 26, 2016 05:59
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, May 25, 2016 4:14 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

[KO2] I know. Then, that's an assumption(restriction) as a semantic depending on each operator.
I'd like to ask you what requirement is behind the same PE constraint. In my understanding, just the different bearers inside a site is enough. Why are these bearers accommodated to the same PE?

Site#5
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint

	Site-net-access#2
		shared-risk-group-id#10
			access-disjoint

[KO2] I can't understand what your requirement is. When any constraint is required to a set of sites(site-network-accesses), we must assign a unique shared-risk-group with the constraint to each site-network-access. If no constraint to the other sets, we don't do so.

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#20
			access-disjoint

Site#2
	Site-net-access#1
		shared-risk-group-id#30
			pe-disjoint

Site#3
	Site-net-access#1
		shared-risk-group-id#40
			pe-disjoint

Site#4
	Site-net-access#1
		shared-risk-group-id#50
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#60
			pe-disjoint

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, May 25, 2016 03:24
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, May 24, 2016 03:28
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Monday, May 23, 2016 05:27
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, May 20, 2016 6:41 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Best Regards,

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, May 10, 2016 06:15
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 09, 2016 9:49 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

Site#2
	Site-net-access#1
		shared-risk-group-id#20
			pe-disjoint

Site#3
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

Site#4
	Site-net-access#1
		shared-risk-group-id#20
			pe-disjoint

[KO] Done.

Site#1
	Site-net-access#1
		shared-risk-group-id#10
		access-disjoint

	Site-net-access#2
		shared-risk-group-id#20
		access-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#10
		pe-disjoint

	Site-net-access#2
		shared-risk-group-id#20
		pe-disjoint

Parallel links

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#10	
			pe-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#20
			access-disjoint

Site#2
	Site-net-access#1
		shared-risk-group-id#30
			pe-disjoint

Site#3
	Site-net-access#1
		shared-risk-group-id#40
			pe-disjoint

Site#4
	Site-net-access#1
		shared-risk-group-id#50
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#60
			pe-disjoint

SubVPN basic
---------------

Site#1 has 3 subVPN

[KO] Done.

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint

	Site-net-access#2
		shared-risk-group-id#10
			access-disjoint

	Site-net-access#3
		shared-risk-group-id#10
			access-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint
	Site-net-access#2
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint
	Site-net-access#3
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint

	Site-net-access#4
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint
	Site-net-access#5
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint
	Site-net-access#6
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Friday, May 06, 2016 10:59
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Thursday, May 05, 2016 04:01
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, May 04, 2016 9:04 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

So trying to sum up :

Thoughts ?

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, May 03, 2016 10:23
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 02, 2016 5:35 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Inline

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Saturday, April 30, 2016 04:16
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, April 29, 2016 8:59 PM
To: [email-masked]
Subject: [L3sm] Modeling subVPN

Hi,

Thoughts ?

Stephane Litkowski
Network Architect

---

From: <[email-masked]>
Date: Fri, 27 May 2016 11:46:25 +0000

I would clearly be in favor of a flexible framework that could be extensible and does not provide restriction. Then it would be up to each SP to use/expose it as he wants.

A way to achieve it would be to decorrelate group-id and constraint, and letting a site-network-access being part of multiple groups and having multiple constraints. Each constraint will also target one or more groups.
We may also have a semantic to express a constraint against all other sites or all other groups.

Site#5
	Site-net-access#1
		Group-ids [1 2 3]
		Constraints
			Pe-diverse groups [ all-other-sites ]
			Pop-diverse [all-other-groups]
			Access-diverse [ 6 5 ]
			Same-access [ 2 ]
			Same-PE [ 1 ]

Using this kind of semantic, we are able to provide any scenario with great flexibility. Moreover we are not linking a group-id to a constraint, it's just a kind of color for a site, letting a site being part of multiple groups.

Coming back to the examples :

Site#1
	Site-net-access#1
		Constraint 
			pe-disjoint all-other-sites

Site#2
	Site-net-access#1
		Constraint 
			pe-disjoint all-other-sites
Site#3
	Site-net-access#1
		Constraint 
			pe-disjoint all-other-sites
Site#4
	Site-net-access#1
		Constraint 
			pe-disjoint all-other-sites

We care about having site-net#1 and #2 on different PEs but we do not care on how they are placed compared to the other sites.

Site#1
	Site-net-access#1
		Group-id 10
		Constraint
			pe-disjoint 10

	Site-net-access#2
		Group-id 10
		Constraint
			pe-disjoint 10

Parallel links

Site#1
	Site-net-access#1
		Group-id 10
		Constraint
			Same-PE 10
	Site-net-access#2
		Group-id 10
		Constraint
			Same-PE 10

Site#1
	Site-net-access#1
		Group-id 10
		constraint
			Access-disjoint 10
			Pe-disjoint all-other-groups
	Site-net-access#2
		Group-id 10
		Constraint
			Access-disjoint 10
			Pe-disjoint all-other-groups

Site#2
	Site-net-access#1
		Group-id 20

Site#3
	Site-net-access#1
		Group-id 30

Site#4
	Site-net-access#1
		Group-id 40

SubVPN basic
---------------

Site#1 has 3 subVPN

Site#1
	Site-net-access#1
		Group-id 10
		Constraint
			Same-access 10

	Site-net-access#2
		Group-id 10
		Constraint
			Same-access 10

	Site-net-access#3
		Group-id 10
		Constraint
			Same-access 10

Site#1
	Site-net-access#1
		Group-id 10
		Constraint
			Same-access 10
			Pe-disjoint 20
	Site-net-access#2
		Group-id 10
		Constraint
			Same-access 10
			Pe-disjoint 20
	Site-net-access#3
		Group-id 10
		Constraint
			Same-access 10
			Pe-disjoint 20

	Site-net-access#4
		Group-id 20
		Constraint
			Same-access 20
			Pe-disjoint 10	
	Site-net-access#5
		Group-id 20
		Constraint
			Same-access 20
			Pe-disjoint 10	
	Site-net-access#6
		Group-id 20
		Constraint
			Same-access 20
			Pe-disjoint 10

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]] 
Sent: Friday, May 27, 2016 06:30
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, May 26, 2016 5:34 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi 

more inline

Thx

 Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Thursday, May 26, 2016 05:59
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, May 25, 2016 4:14 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

 

Site#5
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint

	Site-net-access#2
		shared-risk-group-id#10
			access-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#20
			access-disjoint

Site#2
	Site-net-access#1
		shared-risk-group-id#30
			pe-disjoint

Site#3
	Site-net-access#1
		shared-risk-group-id#40
			pe-disjoint

Site#4
	Site-net-access#1
		shared-risk-group-id#50
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#60
			pe-disjoint

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, May 25, 2016 03:24
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, May 24, 2016 03:28
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Monday, May 23, 2016 05:27
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, May 20, 2016 6:41 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Best Regards,

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, May 10, 2016 06:15
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 09, 2016 9:49 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

Site#2
	Site-net-access#1
		shared-risk-group-id#20
			pe-disjoint

Site#3
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

Site#4
	Site-net-access#1
		shared-risk-group-id#20
			pe-disjoint

[KO] Done.

Site#1
	Site-net-access#1
		shared-risk-group-id#10
		access-disjoint

	Site-net-access#2
		shared-risk-group-id#20
		access-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#10
		pe-disjoint

	Site-net-access#2
		shared-risk-group-id#20
		pe-disjoint

Parallel links

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#10	
			pe-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#20
			access-disjoint

Site#2
	Site-net-access#1
		shared-risk-group-id#30
			pe-disjoint

Site#3
	Site-net-access#1
		shared-risk-group-id#40
			pe-disjoint

Site#4
	Site-net-access#1
		shared-risk-group-id#50
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#60
			pe-disjoint

SubVPN basic
---------------

Site#1 has 3 subVPN

[KO] Done.

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint

	Site-net-access#2
		shared-risk-group-id#10
			access-disjoint

	Site-net-access#3
		shared-risk-group-id#10
			access-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint
	Site-net-access#2
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint
	Site-net-access#3
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint

	Site-net-access#4
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint
	Site-net-access#5
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint
	Site-net-access#6
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Friday, May 06, 2016 10:59
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Thursday, May 05, 2016 04:01
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, May 04, 2016 9:04 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

So trying to sum up :

Thoughts ?

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, May 03, 2016 10:23
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 02, 2016 5:35 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Inline

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Saturday, April 30, 2016 04:16
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, April 29, 2016 8:59 PM
To: [email-masked]
Subject: [L3sm] Modeling subVPN

Hi,

Thoughts ?

Stephane Litkowski
Network Architect

---

From: "Ogaki, Kenichi" <[email-masked]>
Date: Mon, 30 May 2016 11:46:05 +0900

Hi Stephane,

See comments inline, please.

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, May 27, 2016 8:46 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

[KO] I totally agree.

Site#5
	Site-net-access#1
		Group-ids [1 2 3]
		Constraints

[KO] If do so, we should place the table between group and constraint outside site(-network-access) definition. Users easily mistake to create inconsitent definitions across multiple site(-network-accesse)s when they try to apply the same one.

Site#1
	Site-net-access#1
		Constraint 

Site#2
	Site-net-access#1
		Constraint 

Site#1
	Site-net-access#1
		Group-id 10
		Constraint
			pe-disjoint 10

	Site-net-access#2
		Group-id 10
		Constraint
			pe-disjoint 10

[KO] If we want to place them compared to the other group(site)s, do we define as follows? Then, these three site-network-accesses must be placed to three different PEs?

Site#1
	Site-net-access#1
		Group-id 10
		Constraint
			pe-disjoint 10, 20

	Site-net-access#2
		Group-id 10
		Constraint
			pe-disjoint 10, 20

Site#2
	Site-net-access#1
		Group-id 20
		Constraint
			pe-disjoint 10

Parallel links

Site#1
	Site-net-access#1
		Group-id 10
		Constraint
			Same-PE 10
	Site-net-access#2
		Group-id 10
		Constraint
			Same-PE 10

Site#1
	Site-net-access#1
		Group-id 10
		constraint
			Access-disjoint 10

Site#2
	Site-net-access#1
		Group-id 20

Site#3
	Site-net-access#1
		Group-id 30

Site#4
	Site-net-access#1
		Group-id 40

SubVPN basic
---------------

Site#1 has 3 subVPN

Site#1
	Site-net-access#1
		Group-id 10
		Constraint
			Same-access 10

	Site-net-access#2
		Group-id 10
		Constraint
			Same-access 10

	Site-net-access#3
		Group-id 10
		Constraint
			Same-access 10

Site#1
	Site-net-access#1
		Group-id 10
		Constraint
			Same-access 10
			Pe-disjoint 20
	Site-net-access#2
		Group-id 10
		Constraint
			Same-access 10
			Pe-disjoint 20
	Site-net-access#3
		Group-id 10
		Constraint
			Same-access 10
			Pe-disjoint 20

	Site-net-access#4
		Group-id 20
		Constraint
			Same-access 20
			Pe-disjoint 10	
	Site-net-access#5
		Group-id 20
		Constraint
			Same-access 20
			Pe-disjoint 10	
	Site-net-access#6
		Group-id 20
		Constraint
			Same-access 20
			Pe-disjoint 10

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Friday, May 27, 2016 06:30
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, May 26, 2016 5:34 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi 

more inline

Thx

 Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Thursday, May 26, 2016 05:59
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, May 25, 2016 4:14 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

 

Site#5
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint

	Site-net-access#2
		shared-risk-group-id#10
			access-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#20
			access-disjoint

Site#2
	Site-net-access#1
		shared-risk-group-id#30
			pe-disjoint

Site#3
	Site-net-access#1
		shared-risk-group-id#40
			pe-disjoint

Site#4
	Site-net-access#1
		shared-risk-group-id#50
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#60
			pe-disjoint

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, May 25, 2016 03:24
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, May 24, 2016 03:28
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Monday, May 23, 2016 05:27
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, May 20, 2016 6:41 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Best Regards,

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, May 10, 2016 06:15
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 09, 2016 9:49 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

Site#2
	Site-net-access#1
		shared-risk-group-id#20
			pe-disjoint

Site#3
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

Site#4
	Site-net-access#1
		shared-risk-group-id#20
			pe-disjoint

[KO] Done.

Site#1
	Site-net-access#1
		shared-risk-group-id#10
		access-disjoint

	Site-net-access#2
		shared-risk-group-id#20
		access-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#10
		pe-disjoint

	Site-net-access#2
		shared-risk-group-id#20
		pe-disjoint

Parallel links

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#10	
			pe-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#20
			access-disjoint

Site#2
	Site-net-access#1
		shared-risk-group-id#30
			pe-disjoint

Site#3
	Site-net-access#1
		shared-risk-group-id#40
			pe-disjoint

Site#4
	Site-net-access#1
		shared-risk-group-id#50
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#60
			pe-disjoint

SubVPN basic
---------------

Site#1 has 3 subVPN

[KO] Done.

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint

	Site-net-access#2
		shared-risk-group-id#10
			access-disjoint

	Site-net-access#3
		shared-risk-group-id#10
			access-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint
	Site-net-access#2
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint
	Site-net-access#3
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint

	Site-net-access#4
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint
	Site-net-access#5
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint
	Site-net-access#6
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Friday, May 06, 2016 10:59
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Thursday, May 05, 2016 04:01
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, May 04, 2016 9:04 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

So trying to sum up :

Thoughts ?

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, May 03, 2016 10:23
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 02, 2016 5:35 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Inline

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Saturday, April 30, 2016 04:16
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, April 29, 2016 8:59 PM
To: [email-masked]
Subject: [L3sm] Modeling subVPN

Hi,

Thoughts ?

Stephane Litkowski
Network Architect

---

From: <[email-masked]>
Date: Mon, 30 May 2016 07:40:22 +0000

Hi 

Still more inline

Thx 

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]] 
Sent: Monday, May 30, 2016 04:46
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, May 27, 2016 8:46 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

[KO] I totally agree.

Site#5
	Site-net-access#1
		Group-ids [1 2 3]
		Constraints

[KO] If do so, we should place the table between group and constraint outside site(-network-access) definition. Users easily mistake to create inconsitent definitions across multiple site(-network-accesse)s when they try to apply the same one.
[SLI] That's an idea I also had in mind, but the drawback I see is that to some site config/attribute outside the site hierarchy (that we tried to prevent for now).
I agree that may create situations that are not possible to solve. I would tend to say, that any mechanism that involves constraints may allow to create impossible scenarios.
I we go to make the config external (which is not agreed yet :) ), we may keep the group binding within site-network-access and put constraints out.
Like :
	Site-network-access#1
		Group-id 10
	Site-network-access#2
		Group-id 10

Site-placement-constraints (top-level)
	Group-id 10
		Same-PE		=> This tells that all sites with group-id 10 should be meshed on the same PE

Even with this "central config" point, it will still be possible to create impossible scenarios, but we ensure that a particular group of sites has the same config/behavior.

Site#1
	Site-net-access#1
		Constraint 

Site#2
	Site-net-access#1
		Constraint 

Site#1
	Site-net-access#1
		Group-id 10
		Constraint
			pe-disjoint 10

	Site-net-access#2
		Group-id 10
		Constraint
			pe-disjoint 10

[SLI] Right.

Site#1
	Site-net-access#1
		Group-id 10
		Constraint
			pe-disjoint 10, 20

	Site-net-access#2
		Group-id 10
		Constraint
			pe-disjoint 10, 20

Site#2
	Site-net-access#1
		Group-id 20
		Constraint
			pe-disjoint 10

Parallel links

Site#1
	Site-net-access#1
		Group-id 10
		Constraint
			Same-PE 10
	Site-net-access#2
		Group-id 10
		Constraint
			Same-PE 10

Site#1
	Site-net-access#1
		Group-id 10
		constraint
			Access-disjoint 10

Site#2
	Site-net-access#1
		Group-id 20

Site#3
	Site-net-access#1
		Group-id 30

Site#4
	Site-net-access#1
		Group-id 40

SubVPN basic
---------------

Site#1 has 3 subVPN

Site#1
	Site-net-access#1
		Group-id 10
		Constraint
			Same-access 10

	Site-net-access#2
		Group-id 10
		Constraint
			Same-access 10

	Site-net-access#3
		Group-id 10
		Constraint
			Same-access 10

Site#1
	Site-net-access#1
		Group-id 10
		Constraint
			Same-access 10
			Pe-disjoint 20
	Site-net-access#2
		Group-id 10
		Constraint
			Same-access 10
			Pe-disjoint 20
	Site-net-access#3
		Group-id 10
		Constraint
			Same-access 10
			Pe-disjoint 20

	Site-net-access#4
		Group-id 20
		Constraint
			Same-access 20
			Pe-disjoint 10	
	Site-net-access#5
		Group-id 20
		Constraint
			Same-access 20
			Pe-disjoint 10	
	Site-net-access#6
		Group-id 20
		Constraint
			Same-access 20
			Pe-disjoint 10

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Friday, May 27, 2016 06:30
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, May 26, 2016 5:34 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi 

more inline

Thx

 Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Thursday, May 26, 2016 05:59
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, May 25, 2016 4:14 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

 

Site#5
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint

	Site-net-access#2
		shared-risk-group-id#10
			access-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#20
			access-disjoint

Site#2
	Site-net-access#1
		shared-risk-group-id#30
			pe-disjoint

Site#3
	Site-net-access#1
		shared-risk-group-id#40
			pe-disjoint

Site#4
	Site-net-access#1
		shared-risk-group-id#50
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#60
			pe-disjoint

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Wednesday, May 25, 2016 03:24
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, May 24, 2016 03:28
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Monday, May 23, 2016 05:27
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, May 20, 2016 6:41 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Best Regards,

Stephane

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, May 10, 2016 06:15
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 09, 2016 9:49 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

Site#2
	Site-net-access#1
		shared-risk-group-id#20
			pe-disjoint

Site#3
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

Site#4
	Site-net-access#1
		shared-risk-group-id#20
			pe-disjoint

[KO] Done.

Site#1
	Site-net-access#1
		shared-risk-group-id#10
		access-disjoint

	Site-net-access#2
		shared-risk-group-id#20
		access-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#10
		pe-disjoint

	Site-net-access#2
		shared-risk-group-id#20
		pe-disjoint

Parallel links

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#10	
			pe-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#20
			access-disjoint

Site#2
	Site-net-access#1
		shared-risk-group-id#30
			pe-disjoint

Site#3
	Site-net-access#1
		shared-risk-group-id#40
			pe-disjoint

Site#4
	Site-net-access#1
		shared-risk-group-id#50
			pe-disjoint

	Site-net-access#2
		shared-risk-group-id#60
			pe-disjoint

SubVPN basic
---------------

Site#1 has 3 subVPN

[KO] Done.

Site#1
	Site-net-access#1
		shared-risk-group-id#10
			access-disjoint

	Site-net-access#2
		shared-risk-group-id#10
			access-disjoint

	Site-net-access#3
		shared-risk-group-id#10
			access-disjoint

Site#1
	Site-net-access#1
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint
	Site-net-access#2
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint
	Site-net-access#3
		shared-risk-group-id#20
                        access-disjoint
			pe-disjoint

	Site-net-access#4
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint
	Site-net-access#5
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint
	Site-net-access#6
		shared-risk-group-id#40
                        access-disjoint
			pe-disjoint

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Friday, May 06, 2016 10:59
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Thursday, May 05, 2016 04:01
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, May 04, 2016 9:04 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

So trying to sum up :

Thoughts ?

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Tuesday, May 03, 2016 10:23
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, May 02, 2016 5:35 PM
To: Ogaki, Kenichi; [email-masked]
Subject: Re: [L3sm] Modeling subVPN

Hi,

Inline

-----Original Message-----
From: Ogaki, Kenichi [mailto:[email-masked]]
Sent: Saturday, April 30, 2016 04:16
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Modeling subVPN

Hi Stephane,

Thanks,
Kenichi

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, April 29, 2016 8:59 PM
To: [email-masked]
Subject: [L3sm] Modeling subVPN

Hi,

Thoughts ?

Stephane Litkowski
Network Architect