Subject: [L3sm] What is a service model? - An Internet-Draft

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 20 Jul 2016 17:58:05 +0100

L3SM,

Just wanted to draw your attention to
https://datatracker.ietf.org/doc/draft-wu-opsawg-service-model-explained/

This draft (by your servants and chairs) attempts to describe what a service
model is in order to distinguish the work we do in L3SM from the work done
elsewhere in the IETF.

It is inevitably a first attempt at getting this right. We would definitely
appreciate your opinions which would ideally be sent to the OPSAWG mailing list.

Thanks,
Adrian

---

From: "Scharf, Michael (Nokia - DE)" <[email-masked]>
Date: Thu, 21 Jul 2016 10:26:25 +0000

For what it is worth, unless I miss something, I believe that this draft has a more narrow definition of the term "service" than draft-ietf-netmod-yang-model-classification-02 (which defines "service module"). And I have already pointed out potential issues with that narrow definition, e.g., in recursive architectures. 

I observe that the term "service " is used in the IETF also in other context, which is partly due to the fact that "service" is a generic term with quite different meanings to different communities. To me, the term "service model" is not well-defined without further context on the planned use of the model (or YANG module). Also, draft-ietf-netmod-yang-model-classification-02 notes that there can be ambiguities in classification, which may possibly also apply to draft-wu-opsawg-service-model-explained.

Some of the explanation in draft-wu-opsawg-service-model-explained could actually be a valuable addon to the L3SM draft itself, in order to explain the specific (IMHO limited) notion of the term "service" in L3SM context, e.g., in an appendix. In such a case, it would probably have to be spelt out that that the explanation may not be generically applicable in the IETF. However, I do not want to suggest delaying the publication of the L3SM model.

Michael

> -----Original Message-----
> From: L3sm [mailto:[email-masked]] On Behalf Of Adrian Farrel
> Sent: Wednesday, July 20, 2016 6:58 PM
> To: [email-masked]
> Cc: Qin Wu
> Subject: [L3sm] What is a service model? - An Internet-Draft
> 
> L3SM,
> 
> _______________________________________________
> L3sm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/l3sm

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 21 Jul 2016 17:08:48 +0100

Thanks Michael,

In fact, we wanted to described (in this document) only the sub-classification
that perfectly fits L3SM.

So maybe we need some help with explaining this and moving the text in the right
direction. Any suggestions of words would be well received.

Thanks,
Adrian

> From: Scharf, Michael (Nokia - DE) [mailto:[email-masked]]
> Sent: 21 July 2016 11:26
> To: [email-masked]; [email-masked]
> Cc: Qin Wu
> Subject: RE: [L3sm] What is a service model? - An Internet-Draft
> 
> For what it is worth, unless I miss something, I believe that this draft has a
more
> narrow definition of the term "service" than draft-ietf-netmod-yang-model-
> classification-02 (which defines "service module"). And I have already pointed
out
> potential issues with that narrow definition, e.g., in recursive
architectures.
> 
> I observe that the term "service " is used in the IETF also in other context,
which
> is partly due to the fact that "service" is a generic term with quite
different
> meanings to different communities. To me, the term "service model" is not
well-
> defined without further context on the planned use of the model (or YANG
> module). Also, draft-ietf-netmod-yang-model-classification-02 notes that there
> can be ambiguities in classification, which may possibly also apply to
draft-wu-
> opsawg-service-model-explained.
> 
> Some of the explanation in draft-wu-opsawg-service-model-explained could
> actually be a valuable addon to the L3SM draft itself, in order to explain the
> specific (IMHO limited) notion of the term "service" in L3SM context, e.g., in
an
> appendix. In such a case, it would probably have to be spelt out that that the
> explanation may not be generically applicable in the IETF. However, I do not
want
> to suggest delaying the publication of the L3SM model.
> 
> Michael
> 
> 
>

---

From: "Scharf, Michael (Nokia - DE)" <[email-masked]>
Date: Fri, 22 Jul 2016 11:28:14 +0000

I personally believe that one option could be to define more narrowly "XYZ service model" (or "XYZ service module"?).

XYZ could e.g. be some wording like "customer" or "costumer-domain" (I don't claim that this is perfect). One could also dig around what other SDOs use as terminology...

Michael

> Sent: Thursday, July 21, 2016 6:09 PM
> To: Scharf, Michael (Nokia - DE); [email-masked]
> Cc: 'Qin Wu'
> Subject: Re: [L3sm] What is a service model? - An Internet-Draft
> 
> Thanks Michael,
> 
> > > This draft (by your servants and chairs) attempts to describe what
> a
> > > service
> > > model is in order to distinguish the work we do in L3SM from the
> work
> > > done
> > > elsewhere in the IETF.
> > >