Subject: [L3sm] Next steps with draft-wu-l3sm-rfc8049bis-03.txt

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 6 Sep 2017 12:16:00 +0100

All,

We don't have a working group that has to come to consensus, and we will have an IETF last call that the AD can use to gauge wider consensus.
We also have to recall that the scope of this work is to "fix up" RFC 8049 not to make any radical changes to what that RFC does.

I see quite a lot of discussion over the last few revisions collecting and addressing review comments from Jan and David. On the whole it seems to me that most of the comments have resulted in text changes and positive progress with the document. I note that in a small minority of cases the comments resulted in the authors saying something like "No, that's not what we were trying to do with this work," and as far as I am concerned, this is OK within the spirit of RFC 7282 - the comments have been addressed and if we had a WG we would be able to claim *rough* consensus.

I'd like to thank all involved for what has been a great example of pragmatic cooperation advancing this work.

My plan now is to send a document write-up to Benoit and ask him to advance the publication process.

Best,
Adrian

> -----Original Message-----
> From: L3sm [mailto:[email-masked]] On Behalf Of Qin Wu
> Sent: 06 September 2017 11:25
> To: l3sm; David Ball
> Cc: Benoit Claise (bclaise); adrian
> Subject: Re: [L3sm] New Version Notification for draft-wu-l3sm-rfc8049bis-03.txt
> 
> We have incorporated additional comments from David in v-(03).
> https://www.ietf.org/rfcdiff?url2=draft-wu-l3sm-rfc8049bis-03
> Thank David, thanks for L3SM design team help complete this.
> 
> -Qin
> -----邮件原件-----
> 发件人: [email-masked] [mailto:[email-masked]]
> 发送时间: 2017年9月6日 18:18
> 收件人: Qin Wu; Luis Tomotaki; Kenichi Ogaki; Stephane Litkowski
> 主题: New Version Notification for draft-wu-l3sm-rfc8049bis-03.txt
> 
> 
> A new version of I-D, draft-wu-l3sm-rfc8049bis-03.txt has been successfully
> submitted by Qin Wu and posted to the IETF repository.
> 
> Name:		draft-wu-l3sm-rfc8049bis
> Revision:	03
> Title:		YANG Data Model for L3VPN Service Delivery
> Document date:	2017-09-06
> Group:		Individual Submission
> Pages:		181
> URL:            https://www.ietf.org/internet-drafts/draft-wu-l3sm-rfc8049bis-03.txt
> Status:         https://datatracker.ietf.org/doc/draft-wu-l3sm-rfc8049bis/
> Htmlized:       https://tools.ietf.org/html/draft-wu-l3sm-rfc8049bis-03
> Htmlized:       https://datatracker.ietf.org/doc/html/draft-wu-l3sm-rfc8049bis-03
> Diff:           https://www.ietf.org/rfcdiff?url2=draft-wu-l3sm-rfc8049bis-03
> 
> Abstract:
>    This document defines a YANG data model that can be used for
>    communication between customers and network operators and to deliver
>    a Layer 3 provider-provisioned VPN service.  This document is limited
>    to BGP PE-based VPNs as described in RFCs 4026, 4110, and 4364.  This
>    model is intended to be instantiated at the management system to
>    deliver the overall service.  It is not a configuration model to be
>    used directly on network elements.  This model provides an abstracted
>    view of the Layer 3 IP VPN service configuration components.  It will
>    be up to the management system to take this model as input and use
>    specific configuration models to configure the different network
>    elements to deliver the service.  How the configuration of network
>    elements is done is out of scope for this document.
> 
>    If approved, this document obsoletes RFC 8049.  The changes are a
>    series of small fixes to the YANG module, and some clarifications to
>    the text.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 
> _______________________________________________
> L3sm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/l3sm

---

From: Benoit Claise <[email-masked]>
Date: Wed, 6 Sep 2017 13:53:25 +0200

Thanks all for fixing RFC8049. I see many changes in 
https://tools.ietf.org/html/draft-wu-l3sm-rfc8049bis-03#section-1.4.

Fixing a broken RFC should not be perceived negatively. At least this is 
not the way I want to look at it. It just means that more people looked 
at this YANG model and tried to implement it. This RFC bis quick 
publication comes closer to the opensource and github way of working.

I'll progress the document when I receive the write-up.

Regards, Benoit
> .