Subject: Re: [L3sm] New Version Notification for draft-wu-l3sm-rfc8049bis-03.txt

From: "Jan Lindblad (jlindbla)" <[email-masked]>
Date: Tue, 10 Oct 2017 14:57:20 +0000

[DB]
I think you mean "and" here not "or". :)  I'm not an XPath expert but I expect you can write:

    must "!derived-from-or-self(current(), 'l3vpn-svc:slaac') and !derived-from-or-self(current(), 'l3vpn-svc:provider-dhcp-slaac')" {

That would be
must "not(derived-from-or-self(current(), 'l3vpn-svc:slaac')) and not(derived-from-or-self(current(), 'l3vpn-svc:provider-dhcp-slaac'))" {

But perhaps this is a trifle simpler:
must "not(derived-from-or-self(current(), 'l3vpn-svc:slaac') or derived-from-or-self(current(), 'l3vpn-svc:provider-dhcp-slaac'))" {

/jan

---

From: Qin Wu <[email-masked]>
Date: Wed, 11 Oct 2017 04:05:10 +0000

发件人: Jan Lindblad (jlindbla) [mailto:[email-masked]]
发送时间: 2017年10月10日 22:57
收件人: David Ball -X (daviball - ENSOFT LIMITED at Cisco)
抄送: Qin Wu; l3sm
主题: Re: [L3sm] New Version Notification for draft-wu-l3sm-rfc8049bis-03.txt

[DB]

That would be

[Qin]: Thank Jan for the proposed change as an XPATH expert, I prefer the second one you proposed.

/jan

---

From: "Jan Lindblad (jlindbla)" <[email-masked]>
Date: Wed, 11 Oct 2017 08:38:19 +0000

[DB]
Yes, that makes sense.  Should they also be strict inequalities, or is it ok if l4-src-port is equal to lower-port?

[Qin]: Good comment, fixed with
“
must "'.' < '../ipv4-dst-port-range/lower-port' or '.' > '../ipv4-dst-port-range/upper-port'" {
”

I'm afraid this expression will not to what you expect. This compares a constant one letter string to another constant string, or:ed with a constant string compared to another constant string. This will be constantly true or false, and not depend on any configuration data. Also, the dot (.) object is treacherous. Except in some extremely odd cases, what you mean is actually current().

So I would propose
must "current() < ../ipv4-dst-port-range/lower-port or current() > ../ipv4-dst-port-range/upper-port" {

/jan

---

From: Qin Wu <[email-masked]>
Date: Wed, 11 Oct 2017 09:12:50 +0000

发件人: Jan Lindblad (jlindbla) [mailto:[email-masked]]
发送时间: 2017年10月11日 16:38
收件人: Qin Wu
抄送: David Ball -X (daviball - ENSOFT LIMITED at Cisco); l3sm
主题: Re: [L3sm] New Version Notification for draft-wu-l3sm-rfc8049bis-03.txt

[DB]

So I would propose

[Qin]: My bad, you are right, will fix as you suggested, thanks.
/jan

---

From: Qin Wu <[email-masked]>
Date: Fri, 13 Oct 2017 03:29:16 +0000

v-(06) has been posted now.

https://tools.ietf.org/html/draft-wu-l3sm-rfc8049bis-06

-Qin
发件人: L3sm [mailto:[email-masked]] 代表 Qin Wu
发送时间: 2017年10月11日 17:13
收件人: Jan Lindblad (jlindbla)
抄送: l3sm; David Ball -X (daviball - ENSOFT LIMITED at Cisco)
主题: Re: [L3sm] New Version Notification for draft-wu-l3sm-rfc8049bis-03.txt

[DB]

So I would propose