Subject: Re: ABNF tweak for draft-zeilenga-ldapbis-rfc2253-02

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Mon, 18 Dec 2000 16:03:33 -0800

At 11:33 AM 12/10/00 -0600, Ryan Moats wrote:
>I'd suggest
>
>   quotechar = %x00-%x21 / %x23-%x5B / %x5D-7F ; any character except "\" or
>QUOTATION

Note that any character is not restricted to ASCII.

Kurt

---

From: "Salter, Thomas A" <[email-masked]>
Date: Tue, 19 Dec 2000 09:20:06 -0600

Maybe you need to change the wording so that instead of quoting characters,
you quote the octets that make up the characters.

 > -----Original Message-----
 > From: Ryan Moats [mailto:[email-masked]]
 > Sent: Tuesday, December 19, 2000 9:37 AM
 > To: Kurt D. Zeilenga
 > Cc: [email-masked]
 > Subject: RE: ABNF tweak for draft-zeilenga-ldapbis-rfc2253-02
 > 
 > 
 > Please, I understand UNICODE and laud what you are saying here.
 > However, my reading is that the draft covers this already,
 > because quotechar only shows up in:
 > 
 > string     = *( stringchar / pair )
 >              / "#" hexstring
 >              / QUOTATION *( quotechar / pair ) QUOTATION
 > 
 > so quotechar only needs to go to 0xFF as that covers all of the 
 > UTF-8 encoding.
 > 
 > I agree that the ABNF below is more specific, but I don't see
 > how changing quote character to -0xFF (and yes I got that
 > wrong the first time), breaks any of the examples in the draft.
 > 
 > Ryan
 > 
 > -----Original Message-----
 > From: Kurt D. Zeilenga [mailto:[email-masked]]
 > Sent: Monday, December 18, 2000 6:53 PM
 > To: [email-masked]
 > Cc: [email-masked]
 > Subject: Re: ABNF tweak for draft-zeilenga-ldapbis-rfc2253-02
 > 
 > 
 > At 07:47 PM 12/18/00 -0500, [email-masked] wrote:
 > >Ok, I'll bite... what does ASCII have to do with this other 
 > >than extending the last range to FF...
 > 
 > Extending the range to FF is not sufficient.  The ISO-10646-1
 > character code range, IIRC, is 0x000000 - 0x7FFFFFFF.  When
 > presented as UTF-8, each character spans from 1 to 6 octets
 > (derived from RFC2849):
 > 
 > UTF8-CHAR                = ASCII / UTF8-2 / UTF8-3 /
 >                            UTF8-4 / UTF8-5 / UTF8-6
 > UTF8-1                   = %x80-BF
 > UTF8-2                   = %xC0-DF UTF8-1
 > UTF8-3                   = %xE0-EF 2UTF8-1
 > UTF8-4                   = %xF0-F7 3UTF8-1 
 > UTF8-5                   = %xF8-FB 4UTF8-1
 > UTF8-6                   = %xFC-FD 5UTF8-1
 > ASCII                    = %x00-7F
 > 
 > Your original suggestion would limit escaping to only ASCII
 > characters.  With the range extension, the escaping would
 > apply to the first octet of the character, not to the whole
 > character.
 > 
 > Kurt
 > 
 > 
 > 
 > >Ryan
 > >
 > >---- Original message ----
 > >>Date: Mon, 18 Dec 2000 16:03:33 -0800
 > >>From: "Kurt D. Zeilenga" <[email-masked]>
 > >>Subject: Re: ABNF tweak for draft-zeilenga-ldapbis-rfc2253-02
 > >>To: "Ryan Moats" <[email-masked]>
 > >>Cc: <[email-masked]>
 > >>