Subject: matching for facsimileTelephoneNumber

From: Stig Venaas <[email-masked]>
Date: Thu, 21 Dec 2000 11:20:57 +0100

RFC 2256 defines no matching for facsimileTelephoneNumber. I think it's
reasonable to have equality matching at least. Can this be changed, or
do we have to stick to X.520?

Stig

---

From: "Ryan Moats" <[email-masked]>
Date: Thu, 21 Dec 2000 09:05:13 -0600

IMHO... If it isn't in X.520, then its a topic for LDAPEXT.
([email-masked]). No new functionality in LDAPBIS.

Ryan

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Stig Venaas
Sent: Thursday, December 21, 2000 4:21 AM
To: [email-masked]
Subject: matching for facsimileTelephoneNumber

Stig

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Thu, 21 Dec 2000 11:40:55 -0800

>([email-masked]). No new functionality in LDAPBIS.

I note, per our charter, that all schema items which are not
required and/or described by the LDAPv3 "core" technical
specification are not within scope of the LDAPbis WG.

facsimileTelephoneNumber is described by the LDAPv3 "core"
technical specification, so it is within scope.  However,
the proposed change, IMO, would be inappropriate as it
would create, not resolve, interoperability problems.

Kurt

---

From: "Ryan Moats" <[email-masked]>
Date: Thu, 21 Dec 2000 13:49:25 -0600

?!?!  I agree with what you said, but the request was to
specify a matching rule for facsimileTelephoneNumber.
This is not currently done by X.520 so I claim the
matching rule is NOT part of the "core" spec and so is
out of scope.  If we are going to start specifying
matching rules for things in X.520 that don't have them
I claim we've strayed into new functionality.

I think we are in agreement about the approriateness
of this suggestion, but for different reasons.

Ryan

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Kurt D. Zeilenga
Sent: Thursday, December 21, 2000 1:41 PM
To: Ryan Moats
Cc: Stig Venaas; [email-masked]
Subject: RE: matching for facsimileTelephoneNumber

Kurt

---

From: Kathy Dally <[email-masked]>
Date: Wed, 27 Dec 2000 15:53:37 -0500

Hi All!

The bottom line is that the definition of the facsimileTelephoneNumber
attribute can not be changed.  IMHO, specification of a
facsimileTelephoneNumber matching rule and including it in the attribute
specification would change the attribute.  Therefore, there should be no
impact on LDAPv3BIS.  Also, IMHO, a facsimileTelephoneNumber matching
rule, which would not be formally cited by the attribute definition,
would be difficult to implement because the syntax is complex (SEQ). 
So, I do not support this as a new task for LDAPEXT.

Kathy Dally