Subject: quick URL implementation report quiz

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Thu, 29 Mar 2001 07:26:45 -0800

(the URL are examples, not test cases)

Does your implementation support IPv6 literal addresses?
	ldap://[2222::1]

Does your implementation support not processing an URL
with an unrecognized critical extension?
	ldap:///??sub??bindname=cn=Manager%2co=Foo

In particular, when returned by a server in a referral
or search continuation?

Does your implementation support the bindname extension?
	ldap:///??sub??bindname=cn=Bar%2co=Foo

Does your implementation support not continuing the
processing upon failure of a critical bindname extension?
	ldap:///??sub??!bindname=cn=Bar%2co=Foo

Does your implementation support critical bindname with
empty DN?
	ldap:///??sub??bindname
	ldap:///??sub??bindname=

  (there likely should be a clarification added
  noting both are allowed or only one is allowed)

Does your implementation support non-critical bindname with
empty DN? 
	ldap:///??sub??!bindname
	ldap:///??sub??!bindname=

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Thu, 29 Mar 2001 07:32:16 -0800

For OpenLDAP 2.0 (or current release):
>Does your implementation support IPv6 literal addresses?

Yes.

>with an unrecognized critical extension?

A better example:
        ldap:///????!foobar

Yes.

>In particular, when returned by a server in a referral

Yes.

>        ldap:///??sub??bindname=cn=Bar%2co=Foo

No.