Subject: interoperability of ;binary

From: Leif Johansson <[email-masked]>
Date: Thu, 22 Mar 2001 22:35:10 +0100

The recent discussions about ;binary and other subtypes has me wondering
about two things:

1. What are the interoperability-criteria for ;binary?
2. Do we have two independent interoperable implementations
   of this attribute?

I suspect that for reasonable answers to 1 the answer to 2 is "no" and
we should probably think about getting rid of ;binary in favor of using
correct syntaxes in the schema.

	Cheers Leif

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Thu, 22 Mar 2001 16:28:11 -0600

>1. What are the interoperability-criteria for ;binary?

Basically, each place in the protocol where ;binary may
appear, we need to ensure that
        a) the value is transferred between the peers
        correctly, and
        b) all other applicable value requirements are
        supported.

That is, an implementation which does not met general
value requirements for values transferred using ;binary
should not be viewed as having implemented the feature.

>I suspect that for reasonable answers to 1 the answer to 2 is "no"

Yes, depending on the answer to 1, the answer to 2 may be no.
And if no we must remove the feature.  However, until we answer
1 and obtain reports from implementors, it is unclear what the
answer to 2 actually will be. 

>and we should probably think about getting rid of ;binary in favor of using