Subject: RE: Abandon Modify

From: "Ramsay, Ron" <[email-masked]>
Date: Wed, 10 Jul 2002 10:42:10 +1000

Kurt,

I wasn't suggesting a change to the abandon operation. My suggestion was
that all update operations should always be confirmed, which would require
the 'abandoned' error code.

I don't even think that this is a change to the spec as the protocol
document says that servers 'will' return a response (to update operations).

Ron.

-----Original Message-----
From: Kurt D. Zeilenga [mailto:[email-masked]]
Sent: Wednesday, 10 July 2002 3:22
To: Ramsay, Ron
Cc: [email-masked]
Subject: RE: Abandon Modify

At 09:03 PM 2002-07-08, Ramsay, Ron wrote:
>It seems a pity that the document actually precludes sending a search done
>in response to abandon. It makes sense for dumb-terminal applications but
>not for more sophisticated processing - when should you relase the context?

No.  That would be a significant change in semantics of the
Abandon operation.

I think we, minimally, need to:
        a) further restrict reuse of message ids,
        b) clarify that servers are to ignore the abandon request
        where it is unwilling or unable to honor the request, and
        c) clarify that clients may receive responses to
        operations which they requested to be abandoned but
        which the server did not abandoned.

>But to address the issue at hand, I believe that all updates have to be
>confirmed. X.500 doesn't allow updates to be abandoned, and I don't see how
>you can argue against this. But, if you want to allow it, you then have to
>introduce the 'abandoned' error.

I don't believe it appropriate to change the semantics of the
LDAP Abandon operation.  If the DAP Abandon semantics are desired,
an operation which provides these semantics should be introduced
(see draft-zeilenga-ldap-cancel-xx.txt).

I am also concerned that the LDAP Abandon use with update
operations.  I believe this is best addressed by either prohibiting
or recommending against use of the LDAP Abandon to abandon update
operations.

Kurt

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Tue, 09 Jul 2002 19:56:16 -0700

At 05:42 PM 2002-07-09, Ramsay, Ron wrote:
>My suggestion was

Obviously there are no implementations which return this
yet-to-be-defined result code.  I don't see how we can
possible adopt your proposal.

We can only consider changes which are supported by
multiple independently-developed interoperable implementations.

We also cannot add new protocol elements to the technical
specification.

Kurt