Subject: Re: Attribute Name Length Bounds

From: "Chris Apple" <[email-masked]>
Date: Mon, 16 Jun 2003 11:55:51 -0600

I definitely agree that we have both of those problems to deal with when
considering what to do.
Hence my original statement of not really knowing
where it belongs either.

It is not my intent to open a "Pandora's box," but
I am leaning towards wanting something in an LDAPBIS
deliverable to cover this particular need because its
a general problem.

Maybe the other folks who seemed to be expressing a
similar leaning could speak up again now that we've had a bit more
discussion? I'm referring to Rick, Kathy, and Larry. What do you think
about where such
a requirement belongs?

Chris.

>>> Mark C Smith <[email-masked]> 06/16/03 7:12 AM >>>
Chris Apple wrote:

> I maintain my view that this particular issue is of
> sufficiently general nature to justify consideration
> of adding a requirement to one or more standards track
> documents. Some of those could be from this group. That
> question I asked in a separate posting to the WG.

I will be honest and say that I am not sure where such a requirement 
belongs. Lack of a minimum lower bound does make it difficult for anyone

to create and publish schema that may be used with all LDAP 
implementations. That seems like a fairly general problem to me.

I also see Jim and Kurt's point about the problems that will arise if 
the LDAPBis group descends down the path of specifying minimum lengths 
for all of the LDAP protocol elements.

-Mark

---

From: Ryan Moats <[email-masked]>
Date: Mon, 16 Jun 2003 13:45:38 -0500

On Mon, Jun 16, 2003 at 11:55:51AM -0600, Chris Apple wrote:
| I definitely agree that we have both of those problems to deal with when
| considering what to do.
| Hence my original statement of not really knowing
| where it belongs either.
| 
| It is not my intent to open a "Pandora's box," but
| I am leaning towards wanting something in an LDAPBIS
| deliverable to cover this particular need because its
| a general problem.
| 
| Maybe the other folks who seemed to be expressing a
| similar leaning could speak up again now that we've had a bit more
| discussion? I'm referring to Rick, Kathy, and Larry. What do you think
| about where such
| a requirement belongs?
| 
| Chris.
| 
| >>> Mark C Smith <[email-masked]> 06/16/03 7:12 AM >>>
| Chris Apple wrote:
| 
| > I maintain my view that this particular issue is of
| > sufficiently general nature to justify consideration
| > of adding a requirement to one or more standards track
| > documents. Some of those could be from this group. That
| > question I asked in a separate posting to the WG.
| 
| I will be honest and say that I am not sure where such a requirement 
| belongs. Lack of a minimum lower bound does make it difficult for anyone
| 
| to create and publish schema that may be used with all LDAP 
| implementations. That seems like a fairly general problem to me.
| 
| I also see Jim and Kurt's point about the problems that will arise if 
| the LDAPBis group descends down the path of specifying minimum lengths 
| for all of the LDAP protocol elements.
| 
| -Mark

Some technical data points:

1) There are *published, in use* schema that already have attribute and
objectclass names > 48 chars in length.  Therefore, a SHOULD/MUST upper
limit of 48 will break an existing implementation, and that's a no-no.
Further, using IANA considerations to drive such a limit is not appropriate
because of the whole 1.3.6.1.4.1 branch.

2) If I don't have a minimum bound to attribute names, then the only
way I can have interoperability is pairwise testing, which is horribly
inefficient.

Because of the point 1 above, I don't think LDAPBIS can take a pass without
noting the fact that *any* upper limit in the attribute/objectclass name size
runs afoul of the 1.3.6.1.4.1 branch.  That's my proposal for maximal size.

On point 2, if LDAPBIS takes a pass on minimal length, I view it as a
failure to promote interoperability.  I'd propose to see the minimal length
be 48 because of the IANA considerations.

Further, I think both of these are in fact protocol issues because LDAP
can and does use attribute names on the wire.

Ryan