Subject: RE: Fwd: [ldapext] modifyDN.deleteOldRDN and name forms

From: "Ramsay, Ron" <[email-masked]>
Date: Fri, 20 Jun 2003 11:20:25 +1000

Of course, the other possibility is that an auxiliary object class is expected to be included in entries named with the name form.

Then, the other answers will be

a) yes
b) yes
c) normal operation

Ron

-----Original Message-----
From: Kurt D. Zeilenga [mailto:[email-masked]]
Sent: Friday, 20 June 2003 10:59
To: Jim Sermersheim
Cc: [email-masked]
Subject: Re: Fwd: [ldapext] modifyDN.deleteOldRDN and name forms

A few editorial corrections to my post...
        Kurt

At 05:50 PM 6/19/2003, Kurt D. Zeilenga wrote:
>>It appears that X.501 allows name forms to specify attributes that are
>>not allowed by the object class definition that the name form is used
>>for.
>
>Not the "structural" distinction made in the following quote.

s/Not/Note/

>><from Name form definition> "The RDN attribute (or attributes) need
>>not
>>be chosen from the list of permitted attributes of the structural
>>object
>>class as specified in its structural or alias object class
>>definition."
>
>I take this means that the RDN may be chosen from the other
>attributes which are allowed to appear in the entry, such as
>those allowed (directly or indirectly) by a DIT Content Rule.

s/means/to mean/

>>a) Does this also apply to DITContentRules? Meaning, if an attribute
>>is
>>not allowed on the object class definition, or allowed by the DIT
>>Content Rule, can it be specified in the name form?
>
>No.  The naming attributes must be listed from the attributes of the
>entry and those attributes must be allowed either the structural
>object class of the entry or by the controlling DIT content rule.

s/listed/chosen/

>>I can't find answers to a, b, or c, in the X.500 series.
>
>I think the answer is primarily given in X.501.

---

From: "Jim Sermersheim" <[email-masked]>
Date: Thu, 19 Jun 2003 23:11:12 -0600

ok, that's clear enough--I burried myself in the schema sections and
forgot to come up for air.

>>> "Kurt D. Zeilenga" <[email-masked]> 6/19/03 10:48:51 PM >>>
At 09:34 PM 6/19/2003, Jim Sermersheim wrote:
>I still can't find language that says (effectively) that "the
attributes
>of an RDN must be chosen from the set of allowable attributes for an
>entry". Is there such language?

X.501(93):
  distinguished value: An attribute value in an entry which has
  been designated to appear in the relative distinguished name
  of the entry.

  relative distinguished name (RDN): A set of one or more attribute
  type and value pairs, each of which matches a distinct
  distinguished attribute value of the entry.

RFC 2251 said:
   Entries have names: one or more attribute values
   from the entry form its relative distinguished name (RDN), ...

Which attribute values may appear in an entry is controlled by
user (and/or system) schema.

Kurt

>Jim
>
>>>> "Kurt D. Zeilenga" <[email-masked]> 6/19/03 6:58:38 PM >>>

---

From: "Ramsay, Ron" <[email-masked]>
Date: Fri, 20 Jun 2003 15:07:44 +1000

Does it need to be stated? Doesn't the schema section say something like this? That is, just because it is talking about name forms, doesn't mean that the normal rules do not apply. The attributes of an RDN actually form part of the entry. To turn it around, an entry contains attributes; attributes have values; some values are distinguished. That is, the concept of RDN is subordinate to the concept of entry, not orthogonal.

-----Original Message-----
From: Jim Sermersheim [mailto:[email-masked]]
Sent: Friday, 20 June 2003 14:34
To: [email-masked]
Cc: [email-masked]
Subject: Re: Fwd: [ldapext] modifyDN.deleteOldRDN and name forms

I still can't find language that says (effectively) that "the attributes
of an RDN must be chosen from the set of allowable attributes for an
entry". Is there such language?

Jim

s/Not/Note/

s/means/to mean/

s/listed/chosen/