Subject: RE: ldapbis WG Last Call on ldapbis-syntaxes, ldapbis-strprep

From: "Ramsay, Ron" <[email-masked]>
Date: Wed, 25 Jun 2003 19:29:24 +1000

Spaces can only be removed if the equality matching rule is caseIgnoreMatch or caseExactMatch?

-----Original Message-----
From: Hallvard B Furuseth [mailto:[email-masked]]
Sent: Wednesday, 25 June 2003 18:43
To: Ramsay, Ron
Cc: [email-masked]
Subject: RE: ldapbis WG Last Call on ldapbis-syntaxes, ldapbis-strprep

Ramsay, Ron writes:

> Surely you can't do strprep on PrintableString? The choice of
> characters is so limited that there can't be any translation?

There are no UTF-8 characters to translate, but spaces can be removed.

-- 
Hallvard

---

From: Hallvard B Furuseth <[email-masked]>
Date: Wed, 25 Jun 2003 11:50:16 +0200

> caseIgnoreMatch or caseExactMatch?

Any matching rule which ignores space, I should hope.  Including
caseExactIA5Match and caseIgnoreIA5Match.  See [Syntaxes] 5.2.

-- 
Hallvard