Subject: Re: [Syntaxes] Century overflow in Generalized Time

From: John McMeeking <[email-masked]>
Date: Tue, 17 Jun 2003 07:51:55 -0500

Generalized time uses a 4-digit year (YYYYMMDD...) .  Wrap-around won't
occur until date reach the year 10000 (another 7997 years to go).

Do you still have a question in that light?

John  McMeeking

                      Hallvard B Furuseth                                                                                    
                      <[email-masked]        To:       [email-masked]                                        
                      io.no>                      cc:                                                                        
                      Sent by:                    Subject:  [Syntaxes] Century overflow in Generalized Time                  
                      owner-ietf-ldapbis@O                                                                                   
                      penLDAP.org                                                                                            

                      06/17/2003 07:19 AM                                                                                    

How is century overflow/underflow in Generalized Time handled?
That is,
- does generalizedTimeMatch say 9999123120-08 = 0000010104Z?
- how does generalizedTimeOrderingMatch order 9999123120-08
  vs. 2000010100Z?

I suggest to leave it implementation-defined as long as the two matching
rules are consistent, and maybe allow (but not require) such dates to be
invalid.

But if the draft does specify a rule, I think the rule should be silent
wraparound (i.e. century 0 = -100 = +100), since these centuries would
all look the same when expressed as a Generalized Time date.

--
Hallvard

---

From: Hallvard B Furuseth <[email-masked]>
Date: Tue, 17 Jun 2003 15:18:44 +0200

> occur until date reach the year 10000 (another 7997 years to go).

So?  Someone may still put dates far in the future (or the past) in the
directory, or compare with such dates.

Come to think of it, another gray area is dates from before the
Gregorian calendar was used.  But that's so messy that I don't know what
to suggest, except possibly that implementations _may_ be clever about
that if they want to.  Like not having leap years before 1581 or
whatever, and implementing the 'hole' in the calendar that year where
some days were skipped when comparing dates with different time zones
(where the hour may overflow into the hole).

-- 
Hallvard