Subject: RE: Values of matchingRules Attribute

From: "Ramsay, Ron" <[email-masked]>
Date: Fri, 6 Jun 2003 13:49:50 +1000

Hi,

The real question however, as regards the tests being performed, is whether a client can EXPECT that the attribute WILL be returned from an (any) entry if requested.

I think that RFC 2252 (4.5) is pretty clear that the attribute need only be present if additional (beyond those in RFC 2252) matching rules are supported. Even so, it is not clear whether this should be in each entry or only in subentries.

Ron

-----Original Message-----
From: Chris Harding [mailto:[email-masked]]
Sent: Thursday, 5 June 2003 23:25
To: [email-masked]
Subject: Values of matchingRules Attribute

Hi -

We are beta testing The Open Group's VSLDAP test suite, and the following 
question has been raised. Input from ldapbis experts would be much appreciated.

Must a server maintain values of the matchingRules attribute for standard 
matching rules such as presence or equality?

RFC 2252 says:

>   5.1 Standard Operational Attributes
>    Servers MUST maintain values of these attributes in accordance with
>   the definitions in X.501(93)
>   ...
>    5.1.8 matchingRules
>   This attribute is typically located in the subschema entry

It doesn't specify whether the attribute values must include values for 
standard attributes. I took a look at X.501, and couldn't find a clear 
statement there either. I would have assumed, unless it said otherwise, 
that there would be values for the standard rules - but experience has 
taught me that such assumptions are dangerous.

Please give me your views!

Regards,

Chris
+++++

========================================================================
            Dr. Christopher J. Harding
   T H E    Executive Director for the Directory Interoperability Forum
  O P E N   Apex Plaza, Forbury Road, Reading RG1 1AX, UK
G R O U P  Mailto:[email-masked] Phone: +44 118 902 3018
            WWW: http://www.opengroup.org Mobile: +44 774 063 1520
========================================================================

Boundaryless Information Flow - Grid Computing
Boston, MA, USA, July 21st - 25th
http://www.opengroup.org/boston2003

UNIX is a registered trademark of The Open Group in the US and other countries
========================================================================

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Thu, 05 Jun 2003 21:22:51 -0700

>The real question however, as regards the tests being performed, is whether a client can EXPECT that the attribute WILL be returned from an (any) entry if requested.

If one just wanted to test that the server recognized the attribute
type, I suggest using the compare operation instead.

Kurt