Subject: [protocol] and LDAP control criticality

From: John McMeeking <[email-masked]>
Date: Thu, 11 Dec 2003 10:29:54 -0600

What do "always critical" and "always non critical" imply about processing
of controls?  If a control is defined as always critical or always non
critical, does that mean the server should ignore the client specified
criticality?  Should a server reject a control (with which error) that that
has the wrong criticiality?  Is this just guidance to the application?

John  McMeeking

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Thu, 11 Dec 2003 11:09:00 -0800

At 08:29 AM 12/11/2003, John McMeeking wrote:
>of controls?

I view this as a requirement placed upon the generator of the
control and does not imply any requirement upon the receiver
of the control to enforce the criticality flag.   

It requires about criticality semantics only apply to a server
which is not processing the control due to control type being
unrecognized or inappropriate for the operation.  Or to put
it another way, the criticality flag is moot to a server is
making use of the control in processing the operation.  It
would be inappropriate for a control specification to state
requirements that a server should depend its use (and/or
control semantics) of the criticality flag.

>If a control is defined as always critical or always non

I would argue that the control specification should be
clarified that "always (non)critical" imparts only a
requirement upon the control generator.  It may be
appropriate to state this in a separate guidelines for
extension developers document(s).

Kurt