Subject: ABNF of numericoid

From: Hallvard B Furuseth <[email-masked]>
Date: Sun, 7 Dec 2003 23:26:30 +0100

This thread seems to have been forgotten:

[models] and [bcp64] define numericoid as

      numericoid = number *( DOT number )

It should be ( "0" / "1" / "2" ) 1*( DOT number )
with further restrictions on the second component.

In message http://www.OpenLDAP.org/lists/ietf-ldapbis/200307/msg00063.html,
Steven Legg writes:

> X.680 defers to X.660 for the definition of OBJECT IDENTIFIER,
> but notes that an OBJECT IDENTIFIER must have at least two components.
> I don't have a copy of X.660 to check what other requirements
> there are, however it is worth noting that the BER encoding of
> OBJECT IDENTIFIER only supports values where the first component
> is 0, 1 or 2. If the first component is 0 or 1 then the second
> component must be in the range 0 to 39. If the first component
> is 2 then the second component is unlimited.

-- 
Hallvard

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Sun, 07 Dec 2003 18:39:25 -0800

>It should be ( "0" / "1" / "2" ) 1*( DOT number )
(1)
>with further restrictions on the second component.

or (2)
        numericoid = number 1*( DOT number )
or (3)
        numericoid = %x30-31 DOT [ %x31-33 ] DIGIT *( DOT number )
                / %x32 1*( DOT number )

Of these, I dislike (1) because it accounts for some, but not
all, of the X.690 restrictions.  (2) seems reasonable as it
is consistent with objectIdentifier specification provided in
X.680.  (3) incorporates all of the X.660 semantics/X.690
limitations.

Any concerns in going with (3)?

Kurt

---

From: Hallvard B Furuseth <[email-masked]>
Date: Mon, 8 Dec 2003 13:18:58 +0100

Kurt D. Zeilenga writes:
> all, of the X.690 restrictions.

Good point.  Forget (1).

> (3) incorporates all of the X.660 semantics/X.690
> limitations.
> 

Has anyone checked that the second number may have any nonnegative
value when the first number is 2?

Leading zeroes.  (1) and (3) allow the <number> components but not
the spelled-out components to have leading zeroes.  Which is right?

-- 
Hallvard

---

From: Hallvard B Furuseth <[email-masked]>
Date: Mon, 8 Dec 2003 18:05:46 +0100

> the spelled-out components to have leading zeroes.  Which is right?

Sorry, ignore that.  I must have looked cross-eyed on the definition of
<number>.

-- 
Hallvard