Subject: RE: Protocol: Rolling in recent updates

From: "Ramsay, Ron" <[email-masked]>
Date: Wed, 17 Dec 2003 11:59:30 +1100

I wouldn't have a SHOULD against octetStringOrderingMatch - semantically I can't see what sense this makes. Surely only characters strings have the notion of order.

Ron

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of Kurt D. Zeilenga
Sent: Wednesday, 17 December 2003 07:05
To: Hallvard B Furuseth
Cc: [email-masked]
Subject: Re: Protocol: Rolling in recent updates

At 11:03 AM 12/16/2003, Hallvard B Furuseth wrote:
>Kurt D. Zeilenga writes:
>> draft-zeilenga-ldap-user-schema-mr - (mostly) yes
>>   This document includes the "missing" from the
>>   LDAP TS.  Many of them should find there way
>>   into [Syntaxes].  Work here is minimal.
>
>Work on implementation is not minimal.

I meant LDAP work, not implementor work.  Assuming we
don't change the elective status of the features we
roll in, the impact to implementors is the same:
        Those who choose to implement do.
        Those who choose to implement don't.

>[Syntaxes] 4.1 (General Considerations) says:
>
>   Servers SHOULD implement all the matching rules in Section 4.2.
>
>SHOULD they implement the new matching rules too?

I'd like to see most be SHOULD implement, but think it
reasonable that some being MAY implement.  I'd even be
fine with all being SHOULD or MAY.  I recommend:

  SHOULD     booleanMatch
  SHOULD     caseExactMatch
  SHOULD     caseExactOrderingMatch
  SHOULD     caseExactSubstringsMatch
  SHOULD     caseIgnoreListSubstringsMatch
  SHOULD     directoryStringFirstComponentMatch
  SHOULD     integerOrderingMatch
  MAY        keywordMatch
  SHOULD     numericStringOrderingMatch
  SHOULD     octetStringOrderingMatch 
  MAY        storedPrefixMatch
  MAY        wordMatch

Kurt

---

From: Hallvard B Furuseth <[email-masked]>
Date: Wed, 17 Dec 2003 14:50:19 +0100

Ramsay, Ron writes:
> I wouldn't have a SHOULD against octetStringOrderingMatch -
> semantically I can't see what sense this makes.

For octet strings that do not contain further structure, I imagine it
will often give the desired ordering - or at least approximately the
desired ordering.  caseIgnoreOrderingMatch doesn't do any better than
that anyway:

> Surely only characters strings have the notion of order.

They don't.  We assign them an ordering depending on content and usage.
E.g.:
Should '20' sort before or after '5'?
Should 'ä' and 'ö' sort after 'z' as in Swedish, or with 'a' and 'o'
as in German?
Should punctuation sort with space, or by the character set's
arbitrarily assigned character numbers, or by something else?

-- 
Hallvard