Subject: Protocol: control specifications.

From: "Jim Sermersheim" <[email-masked]>
Date: Thu, 18 Dec 2003 13:27:19 -0700

>>> Hallvard B Furuseth <[email-masked]> 12/10/03 4:36:13 AM
>>>
>> 4.1.11. Controls 
>
>> This document does not specify any controls. Controls may be 
>> specified in other documents. The specification of a control
consists 
>> of: 
>> (...)
>> - whether the control is always non critical, always critical, or 
>> optionally critical, 
>
>A request fails if this condition is violated?

The control specification would define server behavior when these
behaviors are violated.

---

From: Hallvard B Furuseth <[email-masked]>
Date: Thu, 18 Dec 2003 22:24:00 +0100

Jim Sermersheim writes:
>>> specified in other documents. The specification of a control consists 
>>> of: 
>>> (...)

Then you need to add ', and the result if this constraint is violated'
to the above text.

-- 
Hallvard

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Thu, 18 Dec 2003 15:57:40 -0800

At 12:27 PM 12/18/2003, Jim Sermersheim wrote:
>>>> Hallvard B Furuseth <[email-masked]> 12/10/03 4:36:13 AM >>>
>>> 4.1.11. Controls 
>>
>The control specification would define server behavior when these behaviors are violated.

The control specification should detail any particular
criticality requirements it has on how controls should be
generated but should not detail any criticality requirements
on how controls should be processed by the receiver.  The
latter needs to be covered in protocol.

Kurt