Subject: Re: rfc2277 compliance

From: "Jim Sermersheim" <[email-masked]>
Date: Sun, 07 Dec 2003 20:22:05 -0700

If this is seen as a impediment to progressing the protocol document, we
could add a mechanism there. Otherwise, we can invent the mechanism
(likely in the form of a control) in another document.
 
Jim

>>> Hallvard B Furuseth <[email-masked]> 11/9/03 10:13:44 AM
>>>
rfc2277 (IETF Policy on Character Sets and Languages) says:

> 4.2. Requirement for language tagging
>
> Protocols that transfer text MUST provide for carrying information
> about the language of that text.

This implies that LDAP needs something like an Accept-Language
extended
operation similar to the HTTP Accept-Language: header. It would
specify
which languages the client prefers for LDAPResult.diagnosticMessage
and
text in unsolicited notifications.

-- 
Hallvard

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Sun, 07 Dec 2003 20:07:48 -0800

It has been noted that RFC 2596 addresses language issues
in LDAP.  Where not, additional extensions can be engineered.
As these would clearly be "new" features, they are beyond our
current scope of work (as defined in our charter).  I encourage
individual pursuit of engineering in this area.

Kurt, LDAPBIS co-chair

At 07:22 PM 12/7/2003, Jim Sermersheim wrote:
>If this is seen as a impediment to progressing the protocol document, we could add a mechanism there.  Otherwise, we can invent the mechanism (likely in the form of a control) in another document.
> 
>Jim
>
>>>> Hallvard B Furuseth <[email-masked]> 11/9/03 10:13:44 AM >>>
>This implies that LDAP needs something like an Accept-Language extended
>operation similar to the HTTP Accept-Language: header. It would specify
>which languages the client prefers for LDAPResult.diagnosticMessage and