Subject: Re: protocol-19 comments

From: "Jim Sermersheim" <[email-masked]>
Date: Thu, 04 Dec 2003 23:42:00 -0700

>>> Hallvard B Furuseth <[email-masked]> 12/4/03 10:45:56 AM
>>>
>[Protocol] says:
>
>> 4.1.7. Attribute and PartialAttribute
>>
>> Attributes and partial attributes consist of an attribute
description
>> and values of that attribute description.
>
>This isn't quite correct. The values are the values of the attribute,
>not of the attribute description. (The value of the attribute
>description is the attribute description:-)

I can change it to say ... and attribute values.

>> Each attribute value is distinct in the set (no duplicates).
>
>...when comparing values with the attribute description's equality
>matching rule, or octet by octet when there is no equality matching
>rule.
>
>[Is that poorly worded? I don't quite know how to put it.]

I can say that no two attribute values are equivalent as described by
Section 2.3 of [Models].

>> 4.2. Bind Operation
>>
>> - authentication: information used to authenticate the name, if
any,
>> (...)
>> resultCode field of the BindResponse.
>
>I suggest a blank line here, to clarify that the rest of the
paragraph
>only applies to simple auth.

I agree.
<snip>

>Why was section 6 (Implementation Guidelines) removed,
 
Two of the guidelines are [Models] material, and the other one
(regarding referrals) was moved to the related section.

>and this sentence in section 4.12 (Extended Operation):
>
>Each request MUST have a unique OBJECT IDENTIFIER assigned to it.

In improving the flow of this section, this sentence was removed
because it was redundant.
 
The current text says: 
"The requestName is a dotted-decimal representation of the unique
OBJECT IDENTIFIER corresponding to the request."
and later in the instructions for extended operation specifications, it
states that a specification assigns the OBJECT IDENTIFIER.
 
Is this insufficient?
 
Jim

---

From: Hallvard B Furuseth <[email-masked]>
Date: Fri, 5 Dec 2003 12:40:30 +0100

Jim Sermersheim writes:
>> [why remove]
>> this sentence in section 4.12 (Extended Operation):
>>
> The current text says:  (..)
>  
> Is this insufficient?

No, you are right.  It's fine.

-- 
Hallvard