Subject: Re: DIGIT in xstring (was: models-09 comments)

From: Hallvard B Furuseth <[email-masked]>
Date: Thu, 8 Jan 2004 22:58:26 +0100

Kurt D. Zeilenga writes:
>At 09:03 AM 1/7/2004, Hallvard B Furuseth wrote:
>>Kurt D. Zeilenga writes:
>>>At 08:45 AM 12/21/2003, Hallvard B Furuseth wrote:
>>>>draft-ietf-ldapbis-models-09.txt says:
>>
>>>>>       xstring = X HYPHEN 1*( ALPHA / HYPHEN / USCORE )
>>> 
>>>>Should xstring allow DIGIT?
> (...)
> Such a change would make older implementations of LDAP
> incompatible with newer implementations of LDAP.

Oh, so it's an 'informal semi-standard'.
Agreed, better to leave that alone.

-- 
Hallvard

---

From: Hallvard B Furuseth <[email-masked]>
Date: Thu, 8 Jan 2004 21:46:32 +0100

Kurt D. Zeilenga writes:
>At 09:39 AM 1/7/2004, Hallvard B Furuseth wrote:
>
>> It would be nice if the LDAPbis documents had more or less
>> the same reference names for the same documents, at least
>> for references to LDAPbis documents.
>
> Yes.  I hope we can leave it to the Editors to determine
> exactly what LDAPBIS style is.

Yes, I'd have posted this to the ietf-ldapbis-editors mailinglist if it
existed:-)

>> I'll post a list of differences between reference names is
>> anyone is interested.
>
> Pointing out differences in style (where it matters) is
> useful.

I don't know what of this matters, but:

Reference name styles:

  [BCP64bis], [LDAPDN], [LDAPURL], [Models], [Roadmap], [Schema],
  [Strprep] use document numbers: [RFC2234], [X.690].

  [Protocol] uses descriptive names: [ABNF], [BER].

  [AuthMeth] prefers document numbers, but also has [ABNF] and [UTF-8].

  [Filters] uses document numbers for RFCs, but also has [ASN.1].

  [Syntaxes] uses descriptive names, except it also needs names like
  [BCP64], [RFC2256] for older documents.

  Nobody call [X.500], [T.50] & co anything interesting:-)

  [Syntaxes] and partly [Schema] use uppercased descriptive names
  for internet-drafts and RFCs.  The other documents do not.

Name conflict:

  [Filters] calls X.690 '[ASN.1]', while [Protocol] and [Syntaxes] call
  X.680 '[ASN.1]'.  That is confusing.  I suggest [Filters] calls X.690
  [BER], as [Protocol] and [Syntaxes] do.

URL styles:

  [LDAPDN] uses the approximate URL <http://www.iana.org/...>.
  [BCP64bis] only refers to the web site <http://www.iana.org/> for the
  registry (outside a reference).  URLs in other places, including IANA
  URLs, are complete.

Other details:

  The [UTF-8] or [UTF8] reference is outdated in many drafts.
  It is now an RFC, not an internet-draft:
      Yergeau, F., "UTF-8, a transformation format of ISO 10646",
      STD 63 and RFC 3629, November 2003.

  Reference descriptions in [LDAPURL], [Filters] and partly [AuthMeth]
  are not indented out from the reference names, which makes searching
  for a reference slower.

  Some reference names are also descriptive words in the text, which
  will be lost if the reference is renamed.  E.g. the phrases '[UTF-8]
  encoded' in [AuthMeth] and '[TLS]-protected' in [Protocol].  I'll
  scan for more if you are interested.

  The reference name [BCP64bis] will have to be renamed, since the
  name implies an unfinished document.  Hopefully it will be finished
  someday:-)

-- 
Hallvard