Subject: Re: I-D ACTION:draft-ietf-ldapbis-strprep-04.txt

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Tue, 08 Jun 2004 13:53:51 -0700

In this revision, the following substantive changes were made.

The term "combining mark" was more clearly defined.

A definitive lists of "all other control code points (e.g., Cc)
or code points with a control function (e.g., Cf)" and
"All other code points with Separator (space, line, or paragraph)
property" are now provided.

The Appendix B table, and mention of it, was removed as redundant.

Lists provided in the Prohibit step were replaced with
references to equivalent tables in [Stringprep].

The above changes clarify, but do not alter, the LDAPprep
algorithms.  Please verify correctness of all lists and
tables used.

Kurt

At 01:11 PM 6/8/2004, [email-masked] wrote:
>A New Internet-Draft is available from the on-line Internet-Drafts directories.
>This draft is a work item of the LDAP (v3) Revision Working Group of the IETF.
>
>        Title           : LDAP: Internationalized String Preparation
>        Author(s)       : K. Zeilenga
>        Filename        : draft-ietf-ldapbis-strprep-04.txt
>        Pages           : 19
>        Date            : 2004-6-8
>        
>The previous Lightweight Directory Access Protocol (LDAP) technical
>specifications did not precisely define how character string matching
>is to be performed.  This lead to a number of usability and
>interoperability problems.  This document defines string preparation
>algorithms for character-based matching rules defined for use in LDAP.
>
>A URL for this Internet-Draft is:
>http://www.ietf.org/internet-drafts/draft-ietf-ldapbis-strprep-04.txt
>
>To remove yourself from the I-D Announcement list, send a message to 
>[email-masked] with the word unsubscribe in the body of the message.  
>You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
>to change your subscription settings.
>
>
>Internet-Drafts are also available by anonymous FTP. Login with the username
>"anonymous" and a password of your e-mail address. After logging in,
>type "cd internet-drafts" and then
>        "get draft-ietf-ldapbis-strprep-04.txt".
>
>A list of Internet-Drafts directories can be found in
>http://www.ietf.org/shadow.html 
>or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>
>
>Internet-Drafts can also be obtained by e-mail.
>
>Send a message to:
>        [email-masked].
>In the body type:
>        "FILE /internet-drafts/draft-ietf-ldapbis-strprep-04.txt".
>        
>NOTE:   The mail server at ietf.org can return the document in
>        MIME-encoded form by using the "mpack" utility.  To use this
>        feature, insert the command "ENCODING mime" before the "FILE"
>        command.  To decode the response(s), you will need "munpack" or
>        a MIME-compliant mail reader.  Different MIME-compliant mail readers
>        exhibit different behavior, especially when dealing with
>        "multipart" MIME messages (i.e. documents which have been split
>        up into multiple messages), so check your local documentation on
>        how to manipulate these messages.
>                
>                
>Below is the data which will enable a MIME compliant mail reader
>implementation to automatically retrieve the ASCII version of the
>Internet-Draft.
>Content-Type: text/plain
>Content-ID:     <[email-masked]>
>
>ENCODING mime
>FILE /internet-drafts/draft-ietf-ldapbis-strprep-04.txt
>
><ftp://ftp.ietf.org/internet-drafts/draft-ietf-ldapbis-strprep-04.txt>

---

From: [email-masked]
Date: Tue, 08 Jun 2004 16:11:14 -0400

Send a message to:
	[email-masked].
In the body type: