Subject: Re: [Models] alias object class

From: "Vithalprasad Gaitonde" <[email-masked]>
Date: Sun, 15 Aug 2004 23:42:43 -0600

From Kathy's and your reply, I gather one couldnt use alias object class
diretcly but would need to have some subclass of it.
The example id [Models] is:
Example:
      dn: cn=bar,dc=example,dc=com
      objectClass: top
      objectClass: alias
      objectClass: extensibleObject
      cn: bar
      aliasedObjectName: cn=foo,dc=example,dc=com

That seems incorrect because extensibleObject is an AUX class.
Comments ?

Prasad

>>> "Kurt D. Zeilenga" <[email-masked]> 8/14/2004 1:43:34 PM >>>
At 05:31 PM 8/13/2004, Vithalprasad Gaitonde wrote:

>An entry with the 'alias' object class must also belong to an object
>  class (or classes), or be governed by a DIT content rule, which
>allows
>  suitable naming attributes to be present.
>
>Since alias is a structural class, an entry belonging to this class
can
>belong to only other auxilliary classes not other sturctural classes.

The entry can be of a subclass of 'alias' (and hence
belong to 'alias' as well).  

>Auxilliary classes cannot have nameforms. Thus the question of what
>naimg attribute to use for an  entry which is an alias is not
>indeterminate.
>
>Comments?
>
>Prasad

---

From: Steven Legg <[email-masked]>
Date: Tue, 24 Aug 2004 16:31:41 +1000

Prasad,

> diretcly but would need to have some subclass of it.

Kurt's answer covers a typical case where structural subclasses of alias
are defined, each of which has an associated name form and structure rule.
However, it does not exclude other possibilities. As Jim pointed out, a particular
structural object class can have multiple name forms (and structure rules)
so the alias object class *can* be used directly. The naming attributes that
the name forms reference would have to be allowed by the content rule for the
alias object class or allowed by an auxiliary object class, in such a case.

> That seems incorrect because extensibleObject is an AUX class.

The example is valid. The extensibleObject class allows any attribute you
would care to use, including the naming attributes referenced by the
name form, or forms, for the alias object class.

Regards,
Steven