Subject: Re: LDAP filter question

From: "Jim Sermersheim" <[email-masked]>
Date: Tue, 16 Nov 2004 08:53:02 -0700

I agree with your assessment and the change.
 
Jim

>>> Mark Smith <[email-masked]> 11/16/04 8:30:24 AM >>>
I'd like to have one vote of agreement on this before I submit the 
revised draft. Anyone?

-Mark

Subject: LDAP filter question
From: Mark Smith <[email-masked]>
To: [email-masked]
Date: Tue, 16 Nov 2004 10:30:24 -0500
List-Id: ietf-ldapbis mailing list <[email-masked]>

I'd like to have one vote of agreement on this before I submit the 
revised draft.  Anyone?

-Mark

Subject: Re: I-D ACTION:draft-ietf-ldapbis-filter-08.txt
From: Mark Smith <[email-masked]>
To: "Kurt D. Zeilenga" <[email-masked]>
Cc: [email-masked]
Date: Fri, 12 Nov 2004 09:47:49 -0500
List-Id: ietf-ldapbis mailing list <[email-masked]>

Mark Smith wrote:

> 
>>>>> ...
>>>>>     lessorequal    = LANGLE EQUALS
>>>>>     extensible     = attr [dnattrs]
>>>>>                            [matchingrule] COLON EQUALS assertionvalue
>>>>>                      / [dnattrs]
>>>>>                             matchingrule COLON EQUALS assertionvalue
>>>>>                      / COLON EQUALS assertionvalue
>>>>
>>>>
>>>>
>>>> The grouping notation should be used here to improve clarity.
>>>> That is, ( ... ) / ( ... ) / ( ... ).  As presented, it
>>>> appears that ":=value" would be a valid extensible production.
> 
> 
> [mcs] Agreed.  I will add the ()s.

There is one more issue here which came to me as I was editing the 
document:  Filter-08 *does* specify that ":=value" is a valid extensible 
production.  I think that is simply an error and that the third option 
within the extensible production should be removed (it was introduced by 
me between the -01 and -02 revisions more than 2 years ago).  Section 
4.5.1 (Search Request) of [Protocol] disallows this:

    If the matchingRule field is absent, the type field MUST be
    present, and an equality match is performed for that type.

As does 2251.  Which makes perfect sense.

-Mark

---

From: Ludovic Poitou <[email-masked]>
Date: Tue, 16 Nov 2004 17:17:01 +0100

I agree with the proposed changes.

Ludovic.

Jim Sermersheim wrote:

> ------------------------------------------------------------------------
>
> Subject:
> LDAP filter question
> From:
> ------------------------------------------------------------------------
>
> Subject:
> Re: I-D ACTION:draft-ietf-ldapbis-filter-08.txt
> From:
> CC:
> [email-masked]
>
>
> Mark Smith wrote:
>
>>
>>>>>> ...
> document:  Filter-08 *does* specify that ":=value" is a valid 
> extensible production.  I think that is simply an error and that the 
> third option within the extensible production should be removed (it 
> was introduced by me between the -01 and -02 revisions more than 2 
> years ago).  Section 4.5.1 (Search Request) of [Protocol] disallows this:
>

-- 
Ludovic Poitou
Directory Architect.
Directory Server Group, Grenoble, France
Sun Microsystems Inc.

Sun Microsystems requires the following notice:
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
NOTICE:  This email message is for the sole use of the intended
recipient(s) and may contain confidential and privileged
information.  Any unauthorized review, use, disclosure or
distribution is prohibited.  If you are not the intended
recipient, please contact the sender by reply email and destroy
all copies of the original message.
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~