Subject: LDAP filter question

From: Mark Smith <[email-masked]>
Date: Tue, 16 Nov 2004 10:30:24 -0500

I'd like to have one vote of agreement on this before I submit the 
revised draft.  Anyone?

-Mark

Subject: Re: I-D ACTION:draft-ietf-ldapbis-filter-08.txt
From: Mark Smith <[email-masked]>
To: "Kurt D. Zeilenga" <[email-masked]>
Cc: [email-masked]
Date: Fri, 12 Nov 2004 09:47:49 -0500
List-Id: ietf-ldapbis mailing list <[email-masked]>

Mark Smith wrote:

> 
>>>>> ...
>>>>>     lessorequal    = LANGLE EQUALS
>>>>>     extensible     = attr [dnattrs]
>>>>>                            [matchingrule] COLON EQUALS assertionvalue
>>>>>                      / [dnattrs]
>>>>>                             matchingrule COLON EQUALS assertionvalue
>>>>>                      / COLON EQUALS assertionvalue
>>>>
>>>>
>>>>
>>>> The grouping notation should be used here to improve clarity.
>>>> That is, ( ... ) / ( ... ) / ( ... ).  As presented, it
>>>> appears that ":=value" would be a valid extensible production.
> 
> 
> [mcs] Agreed.  I will add the ()s.

There is one more issue here which came to me as I was editing the 
document:  Filter-08 *does* specify that ":=value" is a valid extensible 
production.  I think that is simply an error and that the third option 
within the extensible production should be removed (it was introduced by 
me between the -01 and -02 revisions more than 2 years ago).  Section 
4.5.1 (Search Request) of [Protocol] disallows this:

    If the matchingRule field is absent, the type field MUST be
    present, and an equality match is performed for that type.

As does 2251.  Which makes perfect sense.

-Mark

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Tue, 16 Nov 2004 07:48:50 -0800

At 07:30 AM 11/16/2004, Mark Smith wrote:
>I'd like to have one vote of agreement on this before I submit the revised draft.  Anyone?

I believe it should be removed.

>-Mark
>
>
>Return-Path: <[email-masked]>
>Delivered-To: [email-masked]
>Received: from boole.openldap.org (boole.openldap.org [204.152.186.50])
>        by murdock.dreamhost.com (Postfix) with ESMTP id 1771B16D2CB
>        for <[email-masked]>; Fri, 12 Nov 2004 06:52:23 -0800 (PST)
>Received: from boole.openldap.org (smmsp@localhost [IPv6:::1])
>        by boole.openldap.org (8.12.11/8.12.11) with ESMTP id iACEpTOX082626;
>        Fri, 12 Nov 2004 14:51:31 GMT
>        (envelope-from [email-masked])
>Received: from localhost (majordomo@localhost)
>        by boole.openldap.org (8.12.11/8.12.11/Submit) with SMTP id iACEm37D082523;
>        Fri, 12 Nov 2004 14:48:03 GMT
>        (envelope-from [email-masked])
>X-Authentication-Warning: boole.openldap.org: majordomo owned process doing -bs
>Received: by OpenLDAP.org (bulk_mailer v1.13); Fri, 12 Nov 2004 14:48:03 +0000
>Received: from murdock.dreamhost.com ([email-masked] [66.33.205.6])
>        by boole.openldap.org (8.12.11/8.12.11) with ESMTP id iACElwvo082465;
>        Fri, 12 Nov 2004 14:48:00 GMT
>        (envelope-from [email-masked])
>Received: from [127.0.0.1] (pcp04149991pcs.sanarb01.mi.comcast.net [68.41.54.14])
>        by murdock.dreamhost.com (Postfix) with ESMTP
>        id E702516D2EB; Fri, 12 Nov 2004 06:47:55 -0800 (PST)
>Message-ID: <[email-masked]>
>User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040910
>X-Accept-Language: en-us, en
>MIME-Version: 1.0
>References: <[email-masked]> <[email-masked]> <[email-masked]> <[email-masked]>
>In-Reply-To: <[email-masked]>
>Content-Type: text/plain; charset=us-ascii; format=flowed
>Content-Transfer-Encoding: 7bit
>Sender: [email-masked]
>Priority: non-urgent
>X-Loop: OpenLDAP
>Precedence: bulk
>Comment: ietf-ldapbis mailing list <http://www.OpenLDAP.org/lists/>
>List-Archive: <http://www.OpenLDAP.org/lists/ietf-ldapbis/>
>List-Help: <mailto:[email-masked]?body=help>
>List-ID: ietf-ldapbis mailing list <[email-masked]>
>List-Unsubscribe: <mailto:[email-masked]?body=unsubscribe>
>
>Mark Smith wrote:
>
>>
>>>>>>...
>There is one more issue here which came to me as I was editing the document:  Filter-08 *does* specify that ":=value" is a valid extensible production.  I think that is simply an error and that the third option within the extensible production should be removed (it was introduced by me between the -01 and -02 revisions more than 2 years ago).  Section 4.5.1 (Search Request) of [Protocol] disallows this:
>