Subject: Re: I-D ACTION:draft-ietf-ldapbis-protocol-28.txt

From: "Jim Sermersheim" <[email-masked]>
Date: Tue, 30 Nov 2004 14:17:31 -0700

The updates to this version include:
 
- Changes to session/connection/exchange terminology. Please review
section 2 for the definitions and then the rest of the document for
usage. I just noticed that section 2 should say "...of these _five_
terms" (not four).
- Removal of definition of authorization
- Added section numbers below 4.5.1 and re-arranged text so it flows
correctly
- re-associated strongAuthRequired's indication of invalidated
credentials back to being used with Notice of Disconnection
- re-added the SIZE constraint to Filter.and and Filter.or
- removed certain specific imperatives in update operations and more
generally stated that entries must adhere to the data model
- Editorial changes for consistency (mainly to the way operations are
referenced)
 
Jim

>>> <[email-masked]> 11/30/04 1:10:53 PM >>>
A New Internet-Draft is available from the on-line Internet-Drafts
directories.
This draft is a work item of the LDAP (v3) Revision Working Group of
the IETF.

Title: LDAP: The Protocol
Author(s): J. Sermersheim
Filename: draft-ietf-ldapbis-protocol-28.txt
Pages: 62
Date: 2004-11-30

This document describes the protocol elements, along with their 
semantics and encodings, of the Lightweight Directory Access Protocol 
(LDAP). LDAP provides access to distributed directory services that 
act in accordance with X.500 data and service models. These protocol 
elements are based on those described in the X.500 Directory Access 
Protocol (DAP).

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-ldapbis-protocol-28.txt

To remove yourself from the I-D Announcement list, send a message to 
[email-masked] with the word unsubscribe in the body of
the message. 
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce

to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the
username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
"get draft-ietf-ldapbis-protocol-28.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt 

Internet-Drafts can also be obtained by e-mail.

Send a message to:
[email-masked] .
In the body type:
"FILE /internet-drafts/draft-ietf-ldapbis-protocol-28.txt".

NOTE:The mail server at ietf.org can return the document in
MIME-encoded form by using the "mpack" utility. To use this
feature, insert the command "ENCODING mime" before the "FILE"
command. To decode the response(s), you will need "munpack" or
a MIME-compliant mail reader. Different MIME-compliant mail readers
exhibit different behavior, especially when dealing with
"multipart" MIME messages (i.e. documents which have been split
up into multiple messages), so check your local documentation on
how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Tue, 30 Nov 2004 14:23:23 -0800

Please review changes made in this revision to ensure that
they were made in accordance with established WG consensus
and comment prior to 8 December 2004.  In absence of
significant contention, this I-D will be recommended to
the IESG for consideration as a Proposed Standard.

Kurt, as LDAPBIS co-chair

At 01:17 PM 11/30/2004, Jim Sermersheim wrote:
>- Changes to session/connection/exchange terminology. Please review section 2 for the definitions and then the rest of the document for usage. I just noticed that section 2 should say "...of these _five_ terms" (not four).
>- Added section numbers below 4.5.1 and re-arranged text so it flows correctly
>- re-associated strongAuthRequired's indication of invalidated credentials back to being used with Notice of Disconnection
>- removed certain specific imperatives in update operations and more generally stated that entries must adhere to the data model
>- Editorial changes for consistency (mainly to the way operations are referenced)
> 
>Jim
>
>A New Internet-Draft is available from the on-line Internet-Drafts directories.
>This draft is a work item of the LDAP (v3) Revision Working Group of the IETF.
>
><http://www.ietf.org/internet-drafts/draft-ietf-ldapbis-protocol-28.txt>http://www.ietf.org/internet-drafts/draft-ietf-ldapbis-protocol-28.txt 
>
><mailto:[email-masked]>[email-masked] with the word unsubscribe in the body of the message. 
>You can also visit <https://www1.ietf.org/mailman/listinfo/I-D-announce>https://www1.ietf.org/mailman/listinfo/I-D-announce 
>Internet-Drafts are also available by anonymous FTP. Login with the username
><http://www.ietf.org/shadow.html>http://www.ietf.org/shadow.html 
>or <http://ftp://ftp.ietf.org/ietf/1shadow-sites.txt>ftp://ftp.ietf.org/ietf/1shadow-sites.txt 
>
>
><mailto:[email-masked]>[email-masked] .
>In the body type: