Subject: Re: reframing the Empty IA5 string discussion

From: "Jim Sermersheim" <[email-masked]>
Date: Thu, 11 Nov 2004 07:43:10 -0700

After re-reading RFC 2251, I changed my mind, and now I prefer 2B as I
think most people would interpret a space-only string to either be
leading or trailing whitespace, thus ignored.
 
Jim

>>> "Jim Sermersheim" <[email-masked]> 11/10/04 10:23:17 PM >>>

Not being an expert at LDAPprep or the reasons why Directory Strings
have the whitespace and min 1 rules they do, I prefer 2A.

>>> "Kurt D. Zeilenga" <[email-masked]> 11/10/04 9:41:29 PM >>>
I see that there are few reasonable options here:
1) IA5 strings precludes zero-length values
2) IA5 strings allows zero-length values
2A) a zero-length values only matches a zero-length value
2B) a zero-length value matches " " (and all values
equivalent to " ").

I prefer 1 over 2A over 2B (see prior posts for why).

(Regardless of the choice LDAPprep can and should be designed
to be idempotent.)

---

From: Hallvard B Furuseth <[email-masked]>
Date: Fri, 12 Nov 2004 23:27:22 +0100

> leading or trailing whitespace, thus ignored.

Which part of rfc2251?  I can't find a relevant "space" in it.

-- 
Hallvard