Subject: Re: protocol: closing SASL upon Unbind

From: "Jim Sermersheim" <[email-masked]>
Date: Thu, 20 Jan 2005 17:05:12 -0700

Unless there are further issues with this, I will replace the current
instructions for Unbind with Kurts suggested text here.
 
Jim

>>> "Kurt D. Zeilenga" <[email-masked]> 12/7/04 6:43:45 PM >>>
My previous suggestion does not adequately cover the
issue of graceful closure of the LDAP session. That is,
the reason why a particular order was suggested was that
it was thought to be graceful. So while I have no
problem with removing the ordering aspect of the current
text, I'd like to indicate that Unbind/Notice of Disconnect
are intended to affect a graceful closure.

Hence, I suggest:

The client, upon transmission of the UnbindRequest, and
the server, upon receipt of the UnbindRequest are to
gracefully close the LDAP session by ceasing exchange
at the LDAP message layer, tearing down any SASL layer,
tearing down any TLS layer, and closing the transport
connection.

I note that while the 4 actions the implementation might need
to take are stated in the order which the implementation likely
would need to affect graceful closure of the LDAP session,
the text does not actually prescribe a particular order, nor
does it imply that any exchange within the SASL and/or TLS
layer would been necessary.

---

From: Hallvard B Furuseth <[email-masked]>
Date: Mon, 24 Jan 2005 20:22:03 +0100

Ouch.  I lost those threads completely, while trying to unravel some
SASL stuff.  IIRC; after Kurt's last (private) explanation I think
this text will be slightly wrong whatever we do, unless we leave the
details underspecified as in earlier drafts.  Or unless the SASL spec
is modified.  So I guess this text is as good as any.

-- 
Hallvard

---

From: "Jim Sermersheim" <[email-masked]>
Date: Mon, 24 Jan 2005 14:14:23 -0700

For my education, what about this is slightly wrong?
 
Jim

>>> Hallvard B Furuseth <[email-masked]> 1/24/05 12:22:03 PM
>>>

Jim Sermersheim writes:
> >>> "Kurt D. Zeilenga" < [email-masked] > 12/7/04 6:43:45 PM >>>

-- 
Hallvard