Subject: small inconsistency in http://www.openldap.org/ietf/ldapbis/dn.txt

From: "Jim Sermersheim" <[email-masked]>
Date: Mon, 11 Jul 2005 11:29:54 -0600

The last valid DN test is this:
  1.1.1=    // empty value                              [AoO]
  300A31083006060229011300                              [AoO]

Section 2.4 says that when the numeric oid form is used for the attribute value, then the value is #<ber-octets>. It would be less confusing if this example were changed to either of these:

CN=     // empty value
2.5.4.3=#1300     // empty PrintableString value

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Mon, 11 Jul 2005 10:55:51 -0700

At 10:29 AM 7/11/2005, Jim Sermersheim wrote:
>Section 2.4 says that when the numeric oid form is used for the attribute value, then the value is #<ber-octets>.

If we're generating the string per section 2, yes.  But that's
only a SHOULD.  The dn.txt includes parsing tests for OPTIONALly
generated strings. That is,
        1.1.1=
is a valid RDN string per the Section 3 ABNF.

Kurt