Subject: Re: IESG ldapbis-protocol comment

From: "Jim Sermersheim" <[email-masked]>
Date: Wed, 06 Jul 2005 15:05:06 -0600

My last question had to do with the fact that the ASN.1 modules I've seen typically use a form analogous to this {joint-iso-ccitt ds(5) module(1) directoryAbstractService(2) 2}. Do we want IANA to use that form? Will a dotted-numeric OID work for ASN.1 tools?

>>> "Kurt D. Zeilenga" <[email-masked]> 7/6/05 2:27:09 PM >>>
At 01:03 PM 7/6/2005, Jim Sermersheim wrote:
>Sounds good to me. I assume it just looks like this as the first line of the full ASN.1:
> 
>Lightweight-Directory-Access-Protocol-V3 {<IANA-ASSIGNED-ASN.1-OID>}
>
>and then this addition to the IANA considerations:
>It is requested that the IANA update the occurrence of <IANA-ASSIGNED-ASN.1-OID> in Appendix B with an object identifier in order to facilitate IMPORTS by other ASN.1 modules

I suggest:
It is requested that IANA assign upon Standards Action an LDAP
Object Identifier [BCP64bis] to identify the ASN.1 module
defined in this document.

Subject: Request for LDAP Object Identifier Registration
Person & email address to contact for further information:
Jim Sermersheim < [email-masked] >
Specification: RFC XXXX
Author/Change Controller: IESG
Comments: 
Identifies the LDAP ASN.1 module

[[Note to RFC Editor: please replace the occurrence of
<IANA-ASSIGNED-ASN.1-OID> in Appendix B with the IANA
assigned OID.]]

That is, a) request IANA make the assignment, b) request the
RFC Editor to use the assigned OID.

>I'm not sure if we need to provide IANA with guidance as to the arc used to allocate the OID, and/or guidance on the format of the OID.

The suggested text specifically requests an LDAP OID be assigned
under BCP64(bis) procedures.

>Jim
>
>>>> "Kurt D. Zeilenga" < [email-masked] > 6/30/05 8:22:51 PM >>>
>Jim,
>
>One of the IESG comments is:
>> It is recommended that ASN.1 module be named by ab object identifier
>> so that it can be unambiguously referenced from other modules. This
>> facilitates IMPORT by other ASN.1 modules of the types defined here.
>> IANA can assign the ASN.1 module object identifier. 
>
>We should likely do this. Aside from the ASN.1 work, we'll
>need to add an IANA Consideration to get the OID.
>
>Comments?
>
>Kurt

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Wed, 06 Jul 2005 14:24:09 -0700

>My last question had to do with the fact that the ASN.1 modules I've seen typically use a form analogous to this {joint-iso-ccitt ds(5) module(1) directoryAbstractService(2) 2}. Do we want IANA to u…

Okay, to make it easier on IANA/RFC-Editor/Us, use:
        {1 3 6 1 1 IANA-ASSIGNED-DIRECTORY-NUMBER}

Kurt

>Jim Sermersheim < <mailto:[email-masked]>[email-masked] >
>Specification: RFC XXXX
>>>>> "Kurt D. Zeilenga" < <mailto:[email-masked]>[email-masked] > 6/30/05 8:22:51 PM >>>
>>Jim,
>>