Subject: I-D ACTION:draft-ietf-ldapbis-strprep-07.txt

From: [email-masked]
Date: Tue, 24 Jan 2006 15:50:02 -0500

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the LDAP (v3) Revision Working Group of the IETF.

	Title		: LDAP: Internationalized String Preparation
	Author(s)	: K. Zeilenga
	Filename	: draft-ietf-ldapbis-strprep-07.txt
	Pages		: 14
	Date		: 2006-1-24
	
The previous Lightweight Directory Access Protocol (LDAP) technical
  specifications did not precisely define how character string matching
  is to be performed.  This led to a number of usability and
  interoperability problems.  This document defines string preparation
  algorithms for character-based matching rules defined for use in LDAP.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-ldapbis-strprep-07.txt

To remove yourself from the I-D Announcement list, send a message to 
[email-masked] with the word unsubscribe in the body of the message.  
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-ldapbis-strprep-07.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-ldapbis-strprep-07.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Tue, 24 Jan 2006 13:09:55 -0800

This revision is intended to address issues raised during
the IETF wide last call and/or by the IESG.

- made clear that provided/referenced tables of Unicode
  code points are definitive for the purposes of implementing
  the specification.
- StringPrep referenced reverted to RFC 3454 (was bis I-D).
- Note that the six-steps are descriptive of the expected
  behavior not prescriptive of how implementations are to
  code that behavior.
- s/TelexString/TeletexString/
- made clear that appendix B is non-normative, added note
  and reference illustrating basics of LDAP filters

Regards, Kurt

At 12:50 PM 1/24/2006, [email-masked] wrote:
>Content-Type: text/plain
>Content-ID:     <[email-masked]>
>
>ENCODING mime
>FILE /internet-drafts/draft-ietf-ldapbis-strprep-07.txt
>
>
><ftp://ftp.ietf.org/internet-drafts/draft-ietf-ldapbis-strprep-07.txt>