Subject: Re: Schema evolution

From: "Jim Sermersheim" <[email-masked]>
Date: Thu, 19 Aug 1999 11:53:27 -0600

Something that I never see discussed when it comes to extending the schema is the use of the dITStructureRules attribute.  I have to say, I'm not sure why X.500 allows for these schema rules to be defined in multiple places (in the object class definitian as well as the structure rule for that object class), maybe someone can point me in the right direction.  But, one could conceive of using this as a way of extending an object class without really changing its schema definition.

What makes me slightly nervous is that I seriously doubt client applications are taking dITStructureRules, nameForms, and dITContentRules into consideration when examining the schema. (that leads me to my next post).

Jim

>>> "Ashish Kolli" <[email-masked]> 8/19/99 9:57:43 AM >>>
Hi,

As LDAP centric applications evolve, there will definitely be a need to
support slight changes in the schema.
One well known way to do it is to create auxiliary object classes and add
them onto existing entries in the DIT. Another way to do it is to provide
limited support of extending the existing schema in the directory (like
adding additional optional attributes to an objectclass). Is the latter
method a "well-accepted" way of supporting schema evolution?

regards,

Ashish Kolli
OiD Group

---

From: "David Chadwick" <[email-masked]>
Date: Fri, 20 Aug 1999 17:15:23 +0100

Date forwarded: 	Thu, 19 Aug 1999 10:54:00 -0700 (PDT)
Date sent:      	Thu, 19 Aug 1999 11:53:27 -0600
From:           	"Jim Sermersheim" <[email-masked]>
To:             	<[email-masked]>, <[email-masked]>
Subject:        	Re: Schema evolution
Forwarded by:   	[email-masked]

> Something that I never see discussed when it comes to extending the schema
> is the use of the dITStructureRules attribute.  I have to say, I'm not
> sure why X.500 allows for these schema rules to be defined in multiple
> places (in the object class definitian as well as the structure rule for
> that object class), 

Jim

X.500 does not allow structure rules to be defined in multiple places. 
they are defined in just one place, the ditStructureRule itself. Maybe 
you should read Chapter 3 of my online book (URL below) for a 
reasonably clear explanation (I hope) of structure rules.

I guess you may be falling for the classic mistake of confusing 
superior object classes in the object class hierarchy with the 
superior object class in the DIT structure rule (this is mentioned in 
my book as the number one mistake that people make when looking 
at the DIT hierarchy and object class hierarchy and equating them 
one to the other)

David

***************************************************

David Chadwick
IS Institute, University of Salford, Salford M5 4WT
Tel +44 161 295 5351  Fax +44 161 745 8169
Mobile +44 790 167 0359
*NEW* Email [email-masked] *NEW*
Home Page  http://www.salford.ac.uk/its024/chadwick.htm
Understanding X.500  http://www.salford.ac.uk/its024/X500.htm
X.500/LDAP Seminars http://www.salford.ac.uk/its024/seminars.htm
Entrust key validation string MLJ9-DU5T-HV8J

***************************************************