Subject: LDAP references.

From: Pravin Singhal <[email-masked]>
Date: Thu, 05 Aug 1999 03:50:15 -0700

Hi all, 

Is there any document that deals with implementation recommendations other than the core LDAPv3 RFC's and its extensions (something like the "IMAP4 Implementation Recommendations" that exist in the IMAP world. Sorry I am new to LDAP world). 

Also could someone give me pointers on implementating a LDAP server. (books/documents.... other than the RFC's)

Thanks in advance. 

Pravin.

---

From: Pravin Singhal <[email-masked]>
Date: Thu, 05 Aug 1999 14:22:11 -0700

Hi all,

I have more or less gone through the books by Tim Howes. They either
deal at the ldap api

layer or how to deploy the LDAP server and I like those books.

What I am interested is the LDAP protocol on the wire. How client converts
an LDAP

query into protocol primitives using LBER and how the server interprets
this LDAP

protocol primitives? Is there any documents/material that deals with
this using examples.

Thanks in advance,

Pravin.

"Vickers, Randal R" wrote:

Understanding and Deploying LDAP Directory Services
by Tim Howes et al

ISBN: 1-57870-070-1

V/R

MAJ Randal R. Vickers

U.S. Army

Engineer, DOD PKI Directory Services

PKI, IAESO, DISA

[email-masked] <mailto:[email-masked]>

(703)681-2224  Fax: (703)681-2798

DSN: 761-224

-----Original Message-----

From: Pravin Singhal [mailto:[email-masked]]

Sent: Thursday, 05 August, 1999 06:50

To: [email-masked]

Subject: LDAP references.

Hi all,

Is there any document that deals with implementation recommendations
other

than the core LDAPv3 RFC's and its extensions (something like the "IMAP4

Implementation Recommendations" that exist in the IMAP world. Sorry
I am new

to LDAP world).

Also could someone give me pointers on implementating a LDAP server.

(books/documents.... other than the RFC's)

Thanks in advance.

Pravin.

---

From: "Bob Blakley" <[email-masked]>
Date: Thu, 5 Aug 1999 16:37:43 -0500

IETF RFC 2251 describes the LDAP protocol on the wire; it's where you should start.  It's at:

        ftp://ftp.isi.edu/in-notes/rfc2251.txt

--bob

Bob Blakley ([email-masked])
Chief Scientist, Dascom
    -----Original Message-----
    From: Pravin Singhal <[email-masked]>
    To: [email-masked] <[email-masked]>
    Date: Thursday, August 05, 1999 4:28 PM
    Subject: Re: LDAP references.

    Hi all, 
    I have more or less gone through the books by Tim Howes. They either deal at the ldap api 
    layer or how to deploy the LDAP server and I like those books. 

    What I am interested is the LDAP protocol on the wire. How client converts an LDAP 
    query into protocol primitives using LBER and how the server interprets this LDAP 
    protocol primitives? Is there any documents/material that deals with this using examples. 

    Thanks in advance, 

    Pravin. 

        Understanding and Deploying LDAP Directory Services by Tim Howes et al 
            ISBN: 1-57870-070-1 
          
        V/R 

        MAJ Randal R. Vickers 
        U.S. Army 

        -----Original Message----- 
        From: Pravin Singhal [mailto:[email-masked]] 
        Sent: Thursday, 05 August, 1999 06:50 
        To: [email-masked] 
        Subject: LDAP references. 

        Hi all, 

        Is there any document that deals with implementation recommendations other 
        than the core LDAPv3 RFC's and its extensions (something like the "IMAP4 
        Implementation Recommendations" that exist in the IMAP world. Sorry I am new 
        to LDAP world). 

        Thanks in advance. 

        Pravin.