Subject: Listener objects - java-api-11 draft

From: "Steve Sonntag" <[email-masked]>
Date: Mon, 11 Sep 2000 16:31:18 -0600

Since LDAPResponseListener and LDAPSearchListener
objects implement exactly the same set of methods,
does it seem reasonable that an interface be created
named something like LDAPListener that specifies
those four methods, and that LDAPSearchListener
and LDAPResponseListener implement this interface.
This forces those methods to stay the same in both classes.

-Steve

---

From: Steven Sonntag <[email-masked]>
Date: Wed, 13 Sep 2000 11:26:41 -0600

If an LDAPListener interface were created, then
the two methods in LDAPv2.abandon

   public void abandon(LDAPSearchListener listener)
   public void abandon(LDAPResponseListener listener)

Could be combined into one

   public void abandon(LDAPListener listener)

-Steve

Steve Sonntag wrote:

>
> Since LDAPResponseListener and LDAPSearchListenerobjects implement
> exactly the same set of methods,does it seem reasonable that an
> interface be creatednamed something like LDAPListener that
> specifiesthose four methods, and that LDAPSearchListenerand
> LDAPResponseListener implement this interface.This forces those
> methods to stay the same in both classes. -Steve