Subject: RE: [ldapext] Re: Password policy state attributes

From: "Jim Sermersheim" <[email-masked]>
Date: Tue, 03 Dec 2002 19:04:56 -0700

You're right. We need to decide what kinds of attributes to allow. There is also the question of whether or not to allow password policy to support multi-value password attributes. Personally, I'd rather restrict it to single-value attributes. As for values stored with options... I need to think more about it.

Jim

>>> "Andrew Sciberras" <[email-masked]> 12/02 8:59 PM >>>
Hi

I think that it is important to consider whether the Password Policy should
be able to support password values that are stored using options ( Egg.
userPassword;x-exampleOption ).

If it should, then the password policy state attributes must use more than
just the object identifier of the password attribute to make an association
between the state information and the password value which it applies to.

Andrew.

> -----Original Message-----
> From: Kurt D. Zeilenga [mailto:[email-masked]] 
> Sent: Tuesday, 3 December 2002 14:08
> To: Jim Willeke
> Cc: Mark C Smith; Jim Sermersheim; [email-masked];
> [email-masked]; [email-masked]; Alan Clark; Hal
> Henderson
> Subject: Re: [ldapext] Re: Password policy state attributes
>
>
> The example you give is for multiple encodings of the same password,
> not multiple passwords.  I am sure there are real world examples
> of multiple passwords.  I've seen them to manage password transitions.
> That is one might have both the new and old passwords stored in
> userPassword during a transitional period.
>
> Then there is an issue of multiple password attributes (e.g.
> userPassword v. authPassword).
>
> Personally, I think the password policy should minimally support
> multiple values of userPassword...
>
> Kurt
>
> At 06:29 PM 2002-12-02, Jim Willeke wrote:
> >As a "Real" worl example, we are using multiple password as
> one is "sync'd" to an iPlanet server and is stored in sha-1
> format another is" sync'd" to a "home-grown" application and
> is in MD-5 and then the third is the "normal" LDAP password.
> >
> >A reason we store them all in the directory ? The user goes
> to one WEB site to chang e thier password and all passwords
> are updated from the WEB sit eto the directory. Then a
> background process copies the password to the places they
> need to be copied.
> >-jim
> >
> >Mark C Smith wrote:
> >
> >>How common is the "multiple passwords" scenario in real
> world deployments? My impression is that it is very rare. If
> so, I am opposed to doing extensive engineering and adding
> complexity for implementors and users in order to support it.
> I think most people will be happy with a password policy
> specification that only supports one password attribute. But
> if we really need support for more than one, I vote for the:
> >>
> >>    pwdExpirationWarned;pwd-userPassword
> >>    pwdExpirationWarned;pwd-webPassword
> >>
> >>approach. If we require that all attribute types used in
> conjunction with password policy be registered with IANA, I
> don't think there will be any serious interoperability
> problems with this approach.
> >>
> >>-Mark Smith
> >> Netscape
> >>
> >>
> >>Jim Sermersheim wrote:
> >>
> >>>A group of people interested in progressing the password
> policy draft has been growing and exchanging emails off list.
> We're moving discussion here so we have a list and a wider audience.
> >>>
> >>>The current topic has to do with storing password policy
> state information for objects. What is needed is a way to
> store values that represent state information on an object.
> There is the need to associate the state information with a
> password. This is because it's desirable to allow multiple
> passwords per object, and it to be allowed that policy can be
> described and executed separately for each password. Thus, we
> need a way of associating each bit of password policy state
> information with the password it applies to.
> >>>
> >>>For example. There is an attribute called
> pwdExpirationWarned. This holds the timestamp of when the
> client was first warned that the password would expire soon,
> thus it is single-valued. Now, let's say the object that is
> subject to password policy makes use of three password
> attributes due to there being three different hard access
> interfaces: atmPassword, telePassword, and webPassword (think
> bank account access). When the pwdExpirationWarned attribute
> is updated (due to an impending  password expiration), there
> needs to be some way of associating the warning with the
> password that will expire (let's say it's webPassword).
> >>>
> >>>Our first attempt was to use attribute descriptions with a
> new tagging option  called "pwd-". In the example above,
> pwdExpirationWarned;pwd-webPassword would be used to
> store/retrieve the warning time for the webPassword. The
> problem that was brought up with this approach (as I remember
> it) was that since the descr form of attribute types is not
> canonical, we cannot use it in the attribute option. It would
> lead to interoperability problems.
> >>>
> >>>Quickly, it was suggested to just use the oid form of the
> attribute type, like pwdExpirationWarned;pwd-1.2.3.4. While
> this would solve the problem above, it is an illegal
> encoding. Attribute options are defined as consisting of
> ALPHA, DIGIT, and DASH characters.
> >>>
> >>>Then the suggestion of moving the attribute association
> inside the value was put forth say something like
> "webPassword#200210240212Z". This requires new syntaxes which
> some implementors don't like, but worse: 1) It doesn't allow
> the attributes to be defined as single-value. 2) It doesn't
> allow the server to enforce uniqueness among the values. 3)
> It doesn't allow the replace operation (where replace would
> work with single-valued attributes). None of these
> limitations are desirable.
> >>>
> >>>I would now like to suggest returning to the first or
> second suggestion. The first has limitations in a distributed
> environment, and maybe something can be done about it, but
> I'm not sure what. The second would be modified to fit the
> required syntax by replacing dots with dashes. Thus the
> example would change to: pwdExpirationWarned;pwd-1-2-3-4
> >>>
> >>>Jim
> >>>
> >>>p.s. I can provide a set of recent previous discussions on
> this and other issues to anyone that wants them.
> >>>
> >>>_______________________________________________
> >>>Ldapext mailing list
> >>>[email-masked] 
> >>>https://www1.ietf.org/mailman/listinfo/ldapext 
> >>
> >>
> >>
> >>_______________________________________________
> >>Ldapext mailing list
> >>[email-masked] 
> >>https://www1.ietf.org/mailman/listinfo/ldapext 
> >
> >
> >_______________________________________________
> >Ldapext mailing list
> >[email-masked] 
> >https://www1.ietf.org/mailman/listinfo/ldapext 
>
>

_______________________________________________
Ldapext mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ldapext

---

From: Michael Ströder <[email-masked]>
Date: Thu, 05 Dec 2002 15:08:02 +0100

Jim Sermersheim wrote:
> You're right. We need to decide what kinds of attributes to allow. There
> is also the question of whether or not to allow password policy to
> support multi-value password attributes. Personally, I'd rather restrict
> it to single-value attributes.

Personally I'd also like to restrict it to single-value attributes.

This restriction simply should be made clear in the I-D and 99% of the 
people asking for password policy will be happy with it.

Ciao, Michael.

---

From: Michael Ströder <[email-masked]>
Date: Thu, 05 Dec 2002 15:50:25 +0100

Ludovic Poitou wrote:
 > Michael Ströder wrote:
> The restriction is already in the I-D (it's a MUST)

And I appreciate that!

> but I agree that it could be made even more clear.

Especially we have to decide now whether to debate this topic to dead still 
staying without standardized password policy for a long time or whether to 
accept the current draft and its current implementations.

Personally I clearly vote for the second option.

Ciao, Michael.

---

From: Ludovic Poitou <[email-masked]>
Date: Thu, 05 Dec 2002 15:22:07 +0100

The restriction is already in the I-D (it's a MUST) but I agree that it 
could be made even more clear.

Ludovic.

-- 
Ludovic Poitou
Sun Microsystems Inc.
Sun ONE products - Directory Server Group - Grenoble - France

---

From: "Andrew Sciberras" <[email-masked]>
Date: Fri, 6 Dec 2002 08:45:05 +1100

Hi Guys,

Jim, you have stated this in a past email:
> Personally, I'd rather restrict it to single-value attributes.
> Personally I'd also like to restrict it to single-value attributes.
And Ludovic, in your last email you have stated that the I-D already imposes
the above restriction.

I think that these posts use the term 'single-value' a little too loosely.
Surely you don't really mean that the password policy can only be applied to
SINGLE VALUE attributes, as this would rule out the userPassword attribute.

In my opinion I think that Section 3.3 of the I-D clearly specifies how the
password policy should be applied to attributes and their values.
>3.3 Restriction of the Password Policy
>
>The password policy defined in this document can apply to any
>attribute containing a password. Password policy state information
>is held in the user's entry, and applies to a password attribute,
>not a particular password attribute value. Thus the server SHOULD
>enforce that the password attribute subject to password policy,
>contains one and only one password value.

Andrew.