Subject: Re: [ldapext] [Fwd: I-D ACTION:draft-hall-ldap-idn-00.txt]

From: "Eric A. Hall" <[email-masked]>
Date: Wed, 02 Jul 2003 08:15:49 -0500

Any comments on this?

on 6/26/2003 7:08 AM Eric A. Hall wrote:
> FYI. Feedback appreciated.
> 
> I really believe that something like this is needed to fully accomodate
> IDNs in LDAP. The use of client-side transformations are extremely fragile
> and prone to errors (eg, copying the data from one LDAP application and
> pasting it in with another). I also think that nobody here really wants to
> see codec output embedded in the namespace for years to come, but that's
> the only predictable outcome from using client transformations. We need to
> have UTF-8 elements for IDNs in order for them to work reliably.
> 
> The following issues in particular are still unresolved.
> 
>   7.      Open Issues
> 
>      Should a structured domain name sequence be formally defined, with
>      the inetDomainComponent and inetEmail attributes formally
>      incorporating that sequence?
> 
>      Should the inetEmail attribute be formally defined as structured,
>      with the appropriate ASN.1?
> 
>      Should there be extensible matching filters that accept non-
>      normalized input, normalize it, and then search for matching
>      elements and/or attributes?
> 
> Thanks
> 
> 
> 
> ------------------------------------------------------------------------
> 
> Subject: I-D ACTION:draft-hall-ldap-idn-00.txt
> From: [email-masked]
> Date: Wed, 25 Jun 2003 10:52:10 -0400
> To: IETF-Announce: ;
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 
> 	Title		: LDAP Schema Extensions for Internationalized Domain 
>                           Names
> 	Author(s)	: E. Hall
> 	Filename	: draft-hall-ldap-idn-00.txt
> 	Pages		: 16
> 	Date		: 2003-6-24
> 	
> This document defines schema and behavioral rules which are 
> necessary to fully accommodate the use of internationalized domain 
> names as UTF-8 sequences in LDAP. Specifically, this document 
> defines an internationalized domain component attribute, email 
> address attribute, URI syntax, and several related object classes, 
> and also discusses their usage considerations.
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-hall-ldap-idn-00.txt
> 
> To remove yourself from the IETF Announcement list, send a message to 
> ietf-announce-request with the word unsubscribe in the body of the message.
> 
> Internet-Drafts are also available by anonymous FTP. Login with the username
> "anonymous" and a password of your e-mail address. After logging in,
> type "cd internet-drafts" and then
> 	"get draft-hall-ldap-idn-00.txt".
> 
> A list of Internet-Drafts directories can be found in
> http://www.ietf.org/shadow.html 
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
> 
> 
> Internet-Drafts can also be obtained by e-mail.
> 
> Send a message to:
> 	[email-masked].
> In the body type:
> 	"FILE /internet-drafts/draft-hall-ldap-idn-00.txt".
> 	
> NOTE:	The mail server at ietf.org can return the document in
> 	MIME-encoded form by using the "mpack" utility.  To use this
> 	feature, insert the command "ENCODING mime" before the "FILE"
> 	command.  To decode the response(s), you will need "munpack" or
> 	a MIME-compliant mail reader.  Different MIME-compliant mail readers
> 	exhibit different behavior, especially when dealing with
> 	"multipart" MIME messages (i.e. documents which have been split
> 	up into multiple messages), so check your local documentation on
> 	how to manipulate these messages.
> 		
> 		
> Below is the data which will enable a MIME compliant mail reader
> implementation to automatically retrieve the ASCII version of the
> Internet-Draft.

-- 
Eric A. Hall                                        http://www.ehsco.com/
Internet Core Protocols          http://www.oreilly.com/catalog/coreprot/

_______________________________________________
Ldapext mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ldapext

---

From: Thorild Selen <[email-masked]>
Date: Wed, 2 Jul 2003 17:42:25 +0200

This won't allow explicit IPv6 addresses in URLs; RFC 2255 uses the
hostport from RFC 1738. Perhaps RFC 2255 would need an update.

Thorild Selén
Datorföreningen Update / Update Computer Club, Uppsala, SE

---

From: Hallvard B Furuseth <[email-masked]>
Date: Wed, 2 Jul 2003 17:57:34 +0200

> hostport from RFC 1738. Perhaps RFC 2255 would need an update.

Use draft-ietf-ldapbis-url-03.txt, when that is published.

-- 
Hallvard