Subject: Re: [ldapext] Assert I-D.

From: "Vithalprasad Gaitonde" <[email-masked]>
Date: Wed, 23 Jul 2003 08:36:18 -0600

But then assert has to be after the add but Kurt says its BEFORE.

>>> Leif Johansson <[email-masked]> 7/23/2003 7:21:35 PM >>>
Kurt D. Zeilenga wrote:

>
>
>I think that the control should not be applicable to Add.
>I'll update the next revision to reflect this.
>  
>

Hmm, actually it might make sense if you have attributes which are
generated when the entry is added but are not part of the entry sent
from the client.

    MVH leifj

_______________________________________________
Ldapext mailing list
[email-masked] 
https://www1.ietf.org/mailman/listinfo/ldapext

_______________________________________________
Ldapext mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ldapext

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Wed, 23 Jul 2003 21:41:26 +0200

>But then assert has to be after the add but Kurt says its BEFORE.

I concur.  The server is free to incorporate generated attributes
(e.g., createTimestamp) before, after, or during the addition
of the user-specified attributes.  Exactly when is a local matter,
the server just has to do the addition as part of the DIT
modification.  The assertion is to be applied prior to, but
atomically with, the DIT modification.

Kurt