Subject: Re: [ldapext] syntax or matching rule flaw in RFC 3045

From: "Vithalprasad Gaitonde" <[email-masked]>
Date: Mon, 27 Sep 2004 12:31:29 -0600

it seems caseIgnorematch would be more useful than caseExactmatch...so
that a client could match iplanet for iPlanet.
Would there be problems if we change it to caseignore instead of
caseexAct ?

Prasad

>>> Ludovic Poitou <[email-masked]> 9/23/2004 2:52:32 PM >>>

Jim Sermersheim wrote:

>or compared, or used in a filter I guess.
>  
>
Correct. I've never heard of an app doing this so far.
But RFC 3045 is very discreet and customers hardly noticed it.
I don't have any issue with changing it to CaseExactMatch.

Ludovic.

>  
>
>>>>Ludovic Poitou <[email-masked]> 9/22/04 2:59:51 PM >>>
>>>>        
>>>>
>Sun Directory Server has implemented RFC 3045 with the schema as
>defined 
>in the RFC.
>I'm not aware of any application or customer actually using the
>equality 
>matching rule.
>The server itself doesn't (the values cannot be modified).
>
>Ludovic.
>
>
>Jim Sermersheim wrote:
>
>  
>
>>We were looking at implementing this and someone noticed that the
>>    
>>
>syntax
>  
>
>>for the attributes is Directory String
>>    
>>
>(1.3.6.1.4.1.1466.115.121.1.15)
>  
>
>>while the EQUALITY rule is caseExactIA5Match 
>>(1.3.6.1.4.1.1466.109.114.1).
>>
>>I assume the author was at one point using the IA5 String syntax and
>>changed to Directory String but forgot to change the EQUALITY rule
>>    
>>
>(the
>  
>
>>author doesn't work at Novell anymore or I'd ask him). We should
>>probably update the RFC. Do other vendors who have implemented this
>>    
>>
>use
>  
>
>>a caseExactMatch (2.5.13.5) for the EQUALITY?
>>
>>Thanks,
>>
>>Jim
>>
>>_______________________________________________
>>Ldapext mailing list
>>[email-masked] 
>>https://www1.ietf.org/mailman/listinfo/ldapext 
>> 
>>
>>    
>>
>
>  
>

-- 
Ludovic Poitou
Directory Architect.
Directory Server Group, Grenoble, France
Sun Microsystems Inc.

Sun Microsystems requires the following notice:
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
NOTICE:  This email message is for the sole use of the intended
recipient(s) and may contain confidential and privileged
information.  Any unauthorized review, use, disclosure or
distribution is prohibited.  If you are not the intended
recipient, please contact the sender by reply email and destroy
all copies of the original message.
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

_______________________________________________
Ldapext mailing list
[email-masked] 
https://www1.ietf.org/mailman/listinfo/ldapext

_______________________________________________
Ldapext mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/ldapext

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Mon, 27 Sep 2004 12:01:36 -0700

>that a client could match iplanet for iPlanet.

We discussed at great lengths during the engineering of
this schema how it should be used.  The conclusion was
that an exact match was more appropriate.

>Would there be problems if we change it to caseignore instead of

Yes.