Subject: Re: [ldapext] draft charter comment

From: William Brown <[email-masked]>
Date: Thu, 02 Nov 2017 17:53:49 +1000

On Fri, 2017-10-27 at 12:34 +0200, Ludwig Krispenz wrote:
> On 10/27/2017 12:32 PM, Ludwig Krispenz wrote:
> > 
> > On 10/27/2017 10:16 AM, Michael Ströder wrote:
> > > Ludwig Krispenz wrote:
> > > > [..] what I am missing is the topics of
> > > > extending ldap transactions and sync repl - as we discussed in 
> > > > Edinburgh
> > > 
> > > Ludwig, could you come up with some text describing this as
> > > concrete
> > > work items? Then we can discuss whether to add that or not.
> > 
> > ok, one is:
> > extend rfc4533 - Content Synchronization Operation to support ldap 
> > transactions
> 
> and there is a draft: 
> https://docs.ldap.com/specs/draft-spacek-ldapext-syncrepl-transaction
> -01.txt
> > 
> > the other one was raised at ldapcon2015 by ChristianHollenstein to 
> > extend rfc 5805  - LDAP transaction to allow a client to define
> > the 
> > txn id and to allow to omit the txn control after a txn was
> > started. 
> > Howard said he also had the need for some extensions to the
> > protocol, 
> > but I do not remember what exactly. So I have some difficulties to 
> > find the right wording
> > > 
> > > Ciao, Michael.
> > > 
> 

Hey Michael,

Did you want to add these two comments to the charter? 

What date are we calling as the cut off and submission? 

Have we updated our list of glorious participants on the charter?

Thanks so much for pushing this forwards :) 

-- 
Sincerely,

William Brown
Software Engineer
Red Hat, Australia/Brisbane

---

From: Michael Ströder <[email-masked]>
Date: Mon, 6 Nov 2017 18:23:03 +0100

Ludwig Krispenz wrote:
>>> Ludwig, could you come up with some text describing this as concrete
> https://docs.ldap.com/specs/draft-spacek-ldapext-syncrepl-transaction-01.txt

AFAICS this was never submitted as a I-D to IETF.
Or did I overlook something?

@Ludwig: Could you please contact the author and clarify whether he's
still willing to work on this?

Ciao, Michael.

---

From: Andrew Findlay <[email-masked]>
Date: Tue, 7 Nov 2017 09:23:04 +0000

On Fri, Oct 27, 2017 at 09:39:19AM +1000, William Brown wrote:

> https://mailarchive.ietf.org/arch/msg/ldapext/4fEh3Y9adJEl24r2F0598bnXrcg/?qid=f94a915c2574190c029541bc1d190a5e

Looks good to me, and I am certainly willing to do some of the work.
What was inetOrgPerson 2.0 all about?

Andrew
-- 
-----------------------------------------------------------------------
|                 From Andrew Findlay, Skills 1st Ltd                 |
| Consultant in large-scale systems, networks, and directory services |
|     http://www.skills-1st.co.uk/                +44 1628 782565     |
-----------------------------------------------------------------------

---

From: Michael Ströder <[email-masked]>
Date: Tue, 7 Nov 2017 10:53:09 +0100

> Looks good to me, and I am certainly willing to do some of the work.

Glad to hear that.

> What was inetOrgPerson 2.0 all about?

Missing attributes we all add later by defining yet another custom
person object class.

Possible examples:
birthName, birthPlace, buildingName, businessTitle, c (alias
countryName), dateOfBirth, delegatesTo, employeeType, gender, nickName,
organizationalStatus, personalTitle, serialNumber, uniqueIdentifier,
userClass

I'm pretty sure many of us have other attributes to add.
We could try to build up on the schema work in the higher-education
community but should carefully try avoid bloat.

We could also consider to deprecate use of some attributes in new
deployments. As recommendation for local profiles we might even define
DIT content rules with NOT as formal but optional deprecation spec.

Possibe deprecation examples:
internationaliSDNNumber
photo (Fax syntax!)
x500UniqueIdentifier

Ciao, Michael.

---

From: Dieter Klünter <[email-masked]>
Date: Tue, 7 Nov 2017 12:22:32 +0100

> Possibe deprecation examples:
We should have a look at X500 and X520 latest edition (2016) first. 
There are some new attribute types, which might be of interest.

-Dieter

---

From: Michael Ströder <[email-masked]>
Date: Tue, 7 Nov 2017 17:06:24 +0100

> There are some new attribute types, which might be of interest.

The recent 2016 copy is not freely downloadable.
Were these attributes added in 2016 version? Or earlier?
Could you please mention the attributes added?

Ciao, Michael.

---

From: Ludwig Krispenz <[email-masked]>
Date: Wed, 08 Nov 2017 16:21:02 +0100

Hi,

> still willing to work on this?
the author is now longer working in this area and his new employer also 
isn't interested.
But "if" an ldapserver supports ldap transactions and uses syncrepl for 
replication the txn boundaries get lost in replication unless the spec 
for sync repl is extended. So we may want to find another owner.

-- 
Red Hat GmbH, http://www.de.redhat.com/, Registered seat: Grasbrunn,
Commercial register: Amtsgericht Muenchen, HRB 153243,
Managing Directors: Charles Cachera, Michael Cunningham, Michael O'Neill, Eric Shander

---

From: Michael Ströder <[email-masked]>
Date: Wed, 8 Nov 2017 17:35:10 +0100

> the author is now longer working in this area and his new employer also

So it boils down to whether you are willing to be the author/editor of
such an I-D.

> for sync repl is extended. So we may want to find another owner.

Makes sense. But someone has to do the work.

Ciao, Michael.

---

From: Michael Ströder <[email-masked]>
Date: Wed, 8 Nov 2017 19:02:46 +0100

> The recent 2016 copy is not freely downloadable.

FWIW there are also mappings to LDAP names herein:

https://www.itu.int/ITU-T/formal-language/itu-t/x/x520/2016/SelectedAttributeTypes.html

Ciao, Michael.

---

From: Peter Gietz <[email-masked]>
Date: Thu, 23 Nov 2017 12:22:21 +0100

Hi

If we want to standardise new LDAP person attributes, we might also want 
to think about new attributes brought up in SCIM, such as profileURL, 
userType, timeZone, etc. etc.

Cheers,

Peter

Am 08.11.2017 um 19:02 schrieb Michael Ströder:
> _______________________________________________
> Ldapext mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ldapext