Subject: Re: [ledbat] Progress, Agendas and such

From: Murari Sridharan <[email-masked]>
Date: Wed, 1 Jul 2009 18:07:17 -0700

Ping? It would be good to get explicit sign off otherwise I'll have to assume nobody has any objections.

From: [email-masked] [mailto:[email-masked]] On Behalf Of Murari Sridharan
Sent: Friday, June 26, 2009 8:28 AM
To: [email-masked]
Subject: [ledbat] Progress, Agendas and such

Folks, we are getting closer to the Stockholm meeting and we need to make quite a bit of progress. This mail is a summary of where things stand, what action items we have and a proposed plan to move things forward.

We have the following documents and none of these so far are WG items. For starters we need to adopt these as WG items and then continue discussions, here is what we have so far.

draft-shalunov-ledbat-congestion<http://tools.ietf.org/id/draft-shalunov-ledbat-congestion-00.txt>
There have been some fairness concerns raised regarding the algorithm including whether the controller should aim to move delay to a target.
Should the target be a fixed value? Is there a first mover advantage, especially inside a home environment where there are not too many flows for there to be effective statistical multiplexing?

It would be good to get some folks on the list to do a Greenfield implementation. The control algorithm is straightforward and should be easy to study the dynamics in NS for instance.
It would be good to see data on how the algorithm behaves both in simulation and from field trials that Stas performed. Stas do let us know how much of this data you can share, you can of course anonymize any user specific information and show us graphs depicting specific behavior. This definitely calls for reversion of your document answering/clarifying some of the questions raised in the mailing lists.

There is work to do but I think we are ready to adopt this as a WG item and then continue working on improving the algorithm. Right now there is no alternative proposal. We did get a informal (verbal) hum in favor of adopting this as a WG item in SFO. Unless anybody has specific objections we should go ahead with this plan.

draft-penno-ledbat-app-practices-recommendations<http://tools.ietf.org/id/draft-penno-ledbat-app-practices-recommendations-00.txt>
There was a ton of feedback on this I am looking forward to seeing a next version from the authors but I believe this one is also ready to be adopted as a WG item. Reinaldo please let us know when we can see a revised draft incorporating the comments.

draft-welzl-ledbat-survey<http://tools.ietf.org/id/draft-welzl-ledbat-survey-00.txt>
This is a pretty good summary of the related research but many people hadn't read it at the last IETF it would be great if you can send feedback to Michael.

Regarding the agenda for Stockholm. Michael asked for a slot. Each draft above will get one slot. There are a ton of interesting questions/discussions to be had on the ledbat congestion control front. If somebody did a Greenfield implementation or analyzes the algorithm further it would be good to have you come up and present your findings as well.

Thanks
Murari

---

From: Reinaldo Penno <[email-masked]>
Date: Fri, 3 Jul 2009 16:59:15 -0400

I'm working on a new version of
draft-penno-ledbat-app-practices-recommendations-00 based on the feedback I
got during the last meeting.

On 6/26/09 8:28 AM, "Murari Sridharan" <[email-masked]> wrote:

> Folks, we are getting closer to the Stockholm meeting and we need to make
> quite a bit of progress. This mail is a summary of where things stand, what
> action items we have and a proposed plan to move things forward.
>  
> We have the following documents and none of these so far are WG items. For
> starters we need to adopt these as WG items and then continue discussions,
> here is what we have so far.
>  
> draft-shalunov-ledbat-congestion
> <http://tools.ietf.org/id/draft-shalunov-ledbat-congestion-00.txt>
> There have been some fairness concerns raised regarding the algorithm
> including whether the controller should aim to move delay to a target.
> Should the target be a fixed value? Is there a first mover advantage,
> especially inside a home environment where there are not too many flows for
> there to be effective statistical multiplexing?
>  
> It would be good to get some folks on the list to do a Greenfield
> implementation. The control algorithm is straightforward and should be easy to
> study the dynamics in NS for instance.
> It would be good to see data on how the algorithm behaves both in simulation
> and from field trials that Stas performed. Stas do let us know how much of
> this data you can share, you can of course anonymize any user specific
> information and show us graphs depicting specific behavior. This definitely
> calls for reversion of your document answering/clarifying some of the
> questions raised in the mailing lists.
>  
> 
> There is work to do but I think we are ready to adopt this as a WG item and
> then continue working on improving the algorithm. Right now there is no
> alternative proposal. We did get a informal (verbal) hum in favor of adopting
> this as a WG item in SFO. Unless anybody has specific objections we should go
> ahead with this plan.
>  
> draft-penno-ledbat-app-practices-recommendations
> <http://tools.ietf.org/id/draft-penno-ledbat-app-practices-recommendations-00.
> txt> 
> There was a ton of feedback on this I am looking forward to seeing a next
> version from the authors but I believe this one is also ready to be adopted as
> a WG item. Reinaldo please let us know when we can see a revised draft
> incorporating the comments.
>  
> draft-welzl-ledbat-survey
> <http://tools.ietf.org/id/draft-welzl-ledbat-survey-00.txt>
> This is a pretty good summary of the related research but many people hadn¹t
> read it at the last IETF it would be great if you can send feedback to
> Michael. 
>  
> Regarding the agenda for Stockholm. Michael asked for a slot. Each draft above
> will get one slot. There are a ton of interesting questions/discussions to be
> had on the ledbat congestion control front. If somebody did a Greenfield
> implementation or analyzes the algorithm further it would be good to have you
> come up and present your findings as well.
>  
> Thanks
> Murari

---

From: Murari Sridharan <[email-masked]>
Date: Sat, 4 Jul 2009 14:04:39 -0700

Do you have an ETA for when you will have a draft we can review?

Thanks

________________________________________
From: Reinaldo Penno [[email-masked]]
Sent: Friday, July 03, 2009 1:59 PM
To: Murari Sridharan; [email-masked]
Subject: Re: [ledbat] Progress, Agendas and such

---

From: Murari Sridharan <[email-masked]>
Date: Tue, 14 Jul 2009 07:36:13 +0000

We'll go ahead and adopt these as WG documents in Sweden. The agenda should be the same as what i outlined earlier in email.

Stas/Lars, I am sending you a mail regarding this but i thought i'll let the list know so we can prepare accordingly. I had a family emergency and had to rush to India urgently, i also had to withdraw my swedish visa application in the middle so i can get back my passport to travel. Given where things stand i may have to miss the meeting. I'll coordinate with you regarding the same.

Thanks

________________________________
From: Murari Sridharan
Sent: Wednesday, July 01, 2009 6:07 PM
To: Murari Sridharan; [email-masked]
Subject: RE: Progress, Agendas and such

Ping? It would be good to get explicit sign off otherwise I’ll have to assume nobody has any objections.

draft-welzl-ledbat-survey<http://tools.ietf.org/id/draft-welzl-ledbat-survey-00.txt>
This is a pretty good summary of the related research but many people hadn’t read it at the last IETF it would be great if you can send feedback to Michael.

Thanks
Murari