Subject: [lemonade] draft-gulbrandsen-imap-enable-04

From: Ken Murchison <[email-masked]>
Date: Fri, 14 Dec 2007 13:56:58 -0500

A couple of issues, all related to ENABLE now being allowed only in 
non-authenticated state.

- Section 3.1, paragraph 6 (pipelining).  The sentence discussing ENABLE 
before AUTHENTICATE should be removed.

- Section 3.1, examples.  Most of the example text discusses 
pre-authentication use of ENABLE.  This has to be changed.

- Section 5.  Discusses pre-authenticated use of ENABLE.  There probably 
are no security considerations at this point.

-- 
Kenneth Murchison
Systems Programmer
Project Cyrus Developer/Maintainer
Carnegie Mellon University

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade
Supplemental Web Site:
http://www.standardstrack.com/ietf/lemonade

---

From: Dan Karp <[email-masked]>
Date: Fri, 14 Dec 2007 11:02:06 -0800 (PST)

> A couple of issues, all related to ENABLE now being allowed only in 

Really?  ENABLE is now valid only in the NOT AUTHENTICATED state?

Can someone publish a wrapup of the major changes decided on at the last IETF meeting?

---

From: Ken Murchison <[email-masked]>
Date: Fri, 14 Dec 2007 16:15:53 -0500

> Can someone publish a wrapup of the major changes decided on at the last IETF meeting?

Check out the jabbber log

http://www.ietf.org/meetings/ietf-logs/lemonade/2007-12-06.html

starting at 17:26:34

---

From: Dan Karp <[email-masked]>
Date: Fri, 14 Dec 2007 13:46:05 -0800 (PST)

>   http://www.ietf.org/meetings/ietf-logs/lemonade/2007-12-06.html

Sure thing.  But it says the opposite of what you said:

[17:41:57] <cyrus_daboo> Alexey: consensus:
[17:42:05] <cyrus_daboo> - enable is only allowed in auth state.
[17:42:31] <cyrus_daboo> - client must not send enable if ever been in selected state, server does not have to check

---

From: Dave Cridland <[email-masked]>
Date: Sat, 15 Dec 2007 12:02:45 +0000

On Fri Dec 14 21:46:05 2007, Dan Karp wrote:
> > > > > Can someone publish a wrapup of the major changes decided  
> on at the
> > > last IETF meeting?
> [17:42:31] <cyrus_daboo> - client must not send enable if ever been  
> in selected state, server does not have to check

Ken's first sentence appears to be a typo - I read it twice before  
realising. His points all only make sense with the position in the  
jabber log, that is, ENABLE is never used in non-authenticated state.

Dave.
-- 
Dave Cridland - mailto:[email-masked] - xmpp:[email-masked]
  - acap://acap.dave.cridland.net/byowner/user/dwd/bookmarks/
  - http://dave.cridland.net/
Infotrope Polymer - ACAP, IMAP, ESMTP, and Lemonade

---

From: Ken Murchison <[email-masked]>
Date: Sat, 15 Dec 2007 09:23:11 -0500

Dave Cridland wrote:
>> > > > > Can someone publish a wrapup of the major changes decided on 
>> at the
>> > > last IETF meeting?
>> [17:42:31] <cyrus_daboo> - client must not send enable if ever been in 
>> selected state, server does not have to check
> 

Correct.  It was certainly a typo, and it took me several readings 
before I realized my mistake.  I originally wrote the sentence with a 
double negative (not allowed in not-auth) and decided to change it, but 
mistakenly only changed half.  I guess that's what I get for trying to 
eat lunch at the same time.

---

From: Alexey Melnikov <[email-masked]>
Date: Sun, 16 Dec 2007 17:58:07 +0000

Hi Ken,

Ken Murchison wrote:

> - Section 3.1, paragraph 6 (pipelining).  The sentence discussing 
> ENABLE before AUTHENTICATE should be removed.

Fixed (I've changed AUTHENTICATE to SELECT)

> pre-authentication use of ENABLE.  This has to be changed.

I've either removed or updated them. Thanks for spotting that.

> - Section 5.  Discusses pre-authenticated use of ENABLE.  There 
> probably are no security considerations at this point.

Removed, thanks.