Subject: [lemonade] Comments on notify extension

From: Cyrus Daboo <[email-masked]>
Date: Thu, 06 Dec 2007 17:35:16 -0800

Hi,
Some comments on notify:

- does not indicate which other extensions are required - e.g. is LISTEXT 
required?

- "extended LIST" is not used in all places it should be

- Section 5.8 shows an example where a METADATA value is returned in the 
unsolicited response. However METADATA does not include the annotation 
values in its unsolicited extended LIST response. This is inconsistent. I 
suggest notify only return the entry names of the entries changed.

- Why is there no notification for server metadata changes? This would be 
useful if the "message of the day" changed, for example.

-- 
Cyrus Daboo

_______________________________________________
lemonade mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/lemonade
Supplemental Web Site:
http://www.standardstrack.com/ietf/lemonade

---

From: Alexey Melnikov <[email-masked]>
Date: Sat, 08 Dec 2007 20:19:50 +0000

> Some comments on notify:

Hi Cyrus,
Thank you for the comments.

> - does not indicate which other extensions are required - e.g. is 
> LISTEXT required?

Clarified that support for LIST-EXTENDED is not required.

> - "extended LIST" is not used in all places it should be

I am not sure about that.
Obviously the client needs to handle both the standard LIST response and 
the extended LIST response.

> - Section 5.8 shows an example where a METADATA value is returned in 
> the unsolicited response. However METADATA does not include the 
> annotation values in its unsolicited extended LIST response. This is 
> inconsistent.

Right.

> I suggest notify only return the entry names of the entries changed.

Unless people think that METADATA response must return values 
automatically, I will fix the example.

> - Why is there no notification for server metadata changes? This would 
> be useful if the "message of the day" changed, for example.

I will add this.