Subject: [lemonade] Status of the IMAP NOTIFY document

From: Alexey Melnikov <[email-masked]>
Date: Wed, 11 Jun 2008 23:27:48 +0100

I think we have the following open issues in IMAP NOTIFY (ignoring the 
ones that I've addressed while discussing Timo's comments):

1). Decoupling of MessageNew and MessageExpunge events.

2). What happens to message events in the currently selected mailbox if 
NOTIFY SET is used, but SELECTED isn't specified?

I think Timo suggested to use the default behavior (i.e. before NOTIFY 
SET is specified). I tend to think that this might be a reasonable 
choice and would cover some of the use cases proposed by Timo.

Comments?

_______________________________________________
lemonade mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lemonade
Supplemental Web Site:
http://www.standardstrack.com/ietf/lemonade

---

From: Alexey Melnikov <[email-masked]>
Date: Sat, 21 Jun 2008 17:39:34 +0100

Alexey Melnikov wrote:

> 2). What happens to message events in the currently selected mailbox 
> if NOTIFY SET is used, but SELECTED isn't specified?
>

I've changed my mind on this: due to other changes (in particular 
addition of SELECTED-DELAYED) I think it makes more sense to just 
prohibit the server to send any changes for omitted events.

---

From: Timo Sirainen <[email-masked]>
Date: Sun, 22 Jun 2008 02:32:37 +0300

On Jun 21, 2008, at 7:39 PM, Alexey Melnikov wrote:

> Alexey Melnikov wrote:
>
>> 2). What happens to message events in the currently selected  
>> mailbox if NOTIFY SET is used, but SELECTED isn't specified?
>>
>> I think Timo suggested to use the default behavior (i.e. before  
>> NOTIFY SET is specified). I tend to think that this might be a  
>> reasonable choice and would cover some of the use cases proposed by  
>> Timo.
>

Do you mean if NOTIFY SET is used but SELECTED/SELECTED-DELAYED isn't,  
it would default to SELECTED NONE? That'd be fine with me.

---

From: Alexey Melnikov <[email-masked]>
Date: Sun, 22 Jun 2008 15:28:40 +0100

Timo Sirainen wrote:

> Do you mean if NOTIFY SET is used but SELECTED/SELECTED-DELAYED 
> isn't,  it would default to SELECTED NONE?

Yes.

> That'd be fine with me.