Subject: Re: [lemonade] WGLC Notifications

From: Randall Gellens <[email-masked]>
Date: Mon, 9 Jun 2008 17:25:57 -0700

Woops!  Sprry for not sending this earlier.

At 3:07 PM +0100 5/6/08, Alexey Melnikov wrote:

>  Eric Burger wrote:
>
>>Work Group Last Call for Lemonade Notifications Architecture,
>>http://tools.ietf.org/html/draft-ietf-lemonade-notifications-08
>>starts now and ends 5 May 2008.
>>
>  The draft is in much better shape now.
>
>  Some comments below:
>
>>      *    NF and DF:  When internal to the mail store, these are
>>      typically implemented using Sieve and hence a Sieve management
>   >     protocol is used for client modifications.  See [IMAP-SIEVE] and
>   >     [MANAGE-SIEVE] for more information.  When the NF is within a
>>      notification server, it is out of scope of Lemonade.
>
>  I don't think [IMAP-SIEVE] is relevant in case of NF or DF.
>  Unless NF is invoked on message flag changes, etc.

I'm happy deleting the reference to IMAP-SIEVE, however, if a client 
is only interested in some mailboxes, rather than having a main Sieve 
script send notifications for all new mail, it might be better to 
have a per-mailbox Sieve script send notifications.

How about changing
     See [IMAP-SIEVE] and [MANAGE-SIEVE] for more information.

to
     See [MANAGE-SIEVE] for more information.  Per-mailbox
     notifications might be implemented using a per-mailbox Sieve
     script, for example, [IMAP-SIEVE].

>   >     Note that when implementing DF using Sieve, the 'enotify'
>>      [SIEVE-NOTIFY] and 'variables' [SIEVE-VARIABLES] Sieve extensions
>>      are needed.
>
>  If NF is generating notifications on mail delivery, than 'enotify' +
>  'variables' is also needed there.
>  If NF is generating notifications both on mail delivery and IMAP events,
>  then 'enotify' + 'variables' are *only* needed in NF.

I think I should change this to:

     Note that when implementing DF or NF using Sieve, the 'enotify'
     [SIEVE-NOTIFY] and likely the 'variables' [SIEVE-VARIABLES]
     Sieve extensions might be needed.

And move it to be above the line that starts "The filters are 
manageable" (since logically this belongs with the earlier text 
block).

>   > 4.  Push Email
>>    
>>      A good user experience of "push email" requires that when
>>      "interesting" events occur in the mail store, the client is informed
>>      so that it can connect and resynchronize.  The Lemonade Profile
>>      [LEMONADE-PROFILE] contains more information, especially in Section
>>      4.1.2.
>
>  I can't find section 4.1.2 in draft-ietf-lemonade-profile-bis-08.txt.
>  /*
>  */

I suppose the text moved in a prior revision.  I think this should be 
changed to "External Notifications".

-- 
Randall Gellens
Opinions are personal;    facts are suspect;    I speak for myself only
-------------- Randomly-selected tag: ---------------
Genetics explains why you look like your father, and if you don't,
why you should.
_______________________________________________
lemonade mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lemonade
Supplemental Web Site:
http://www.standardstrack.com/ietf/lemonade

---

From: Randall Gellens <[email-masked]>
Date: Mon, 9 Jun 2008 17:26:01 -0700

At 8:16 AM -0400 5/16/08, Eric Burger wrote:

>  Nit: When I read this, I had no idea what "it" is.  Here is my guess.
>
>  Section 5.2
>
>  OLD
>
>  notification system; it then becomes
>
>  NEW
>
>  notification system.  Thus the security relationship then becomes

Yes, this is better.

-------------- Randomly-selected tag: ---------------
Eleanor Rigby
Sits at the keyboard and waits for a line on the screen
Lives in a dream
Waits for a signal,
  finding some code that will make the machine do some thing,
What is it for?
All the lonely users, where do they all come from?
All the lonely users, why does it take so long?
_______________________________________________
lemonade mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lemonade
Supplemental Web Site:
http://www.standardstrack.com/ietf/lemonade

---

From: Randall Gellens <[email-masked]>
Date: Mon, 9 Jun 2008 17:26:58 -0700

At 8:16 AM -0400 5/16/08, Eric Burger wrote:

>  I have written up the shepherd document.  Is this OK?

Sorry for being dense, but where is the shepherd document?

-------------- Randomly-selected tag: ---------------
The early bird catches the worm, but what does the early worm get?
                                                 --Randall Gellens
_______________________________________________
lemonade mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lemonade
Supplemental Web Site:
http://www.standardstrack.com/ietf/lemonade

---

From: Alexey Melnikov <[email-masked]>
Date: Sat, 14 Jun 2008 16:32:45 +0100

> Woops!  Sprry for not sending this earlier.

Hi Randy,

> script send notifications for all new mail, it might be better to have 
> a per-mailbox Sieve script send notifications.

Per mailbox scripts are not invoked on message delivery, so IMAP-Sieve 
is not going to help.
IMAP-Sieve will only matter for IMAP APPEND, but I think this is a less 
common case than message delivery using SMTP/LMTP. Also APPENDs are 
likely to be caused by the user herself, so there would be no much point 
in notifying about them.

> manageable" (since logically this belongs with the earlier text block).

Ok.

> changed to "External Notifications".

This is reasonable.