Subject: Re: [lemonade] CONTEXT

From: Dan Karp <[email-masked]>
Date: Fri, 6 Jun 2008 14:34:52 -0700 (PDT)

> > modifier-partial    = "PARTIAL" SP seq-range
> >        ;; <seq-range> from [IMAP]
> 
> '*' is allowed in [IMAP] seq-range. I'm guessing it shouldn't be used
> though? Or if it is allowed, is it returned as '*' or as
> highest-sequence in ret-data-partial?

Similarly, <seq-range> returns BAD for message sequence numbers greater
than the number of messages in the mailbox.  That's contrary to the
specified behavior in section 4.4:

   Where a PARTIAL search return option references results which do not
   exist, by using a range which starts or ends higher than the current
   number of results, then the server returns those results which are in
   the set.  This yields a PARTIAL return data item which has, as
   payload, the original range and a potentially missing set of results
   which may be shorter than the extent of the range.
_______________________________________________
lemonade mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lemonade
Supplemental Web Site:
http://www.standardstrack.com/ietf/lemonade

---

From: Timo Sirainen <[email-masked]>
Date: Sat, 07 Jun 2008 00:51:11 +0300

On Fri, 2008-06-06 at 14:34 -0700, Dan Karp wrote:
> than the number of messages in the mailbox.

seq-range is specified to contain either message sequences or UIDs, but
modifier-partial contains "search-sequences" which is neither of them.
So I guess it should instead be:

modifier-partial = "PARTIAL" SP nz-number ":" nz-number
  ;; a) First nz-number <= second nz-number
  ;; b) Ordering between nz-numbers doesn't matter

I don't really care if a) or b) is used.

---

From: Alexey Melnikov <[email-masked]>
Date: Mon, 09 Jun 2008 10:37:14 +0100

>I don't really care if a) or b) is used.
(b), to make it more or less consistent with ranges.

Similarly, ret-data-partial should also be updated:
OLD:
   ret-data-partial    = "PARTIAL"
                         SP "(" seq-range SP partial-results ")"
       ;; <seq-range> is the requested range.
       ;; <seq-range> from [IMAP]

NEW:
   ret-data-partial    = "PARTIAL"
                         SP "(" partial-range SP partial-results ")"
       ;; <partial-range> is the requested range.

  partial-range        =  nz-number ":" nz-number
       ;; A range 500:400 is the same as 400:500