Subject: Re: [lemonade] Why we should let the IMAP specification become more rich, rather than poor

From: Philip Van Hoof <[email-masked]>
Date: Tue, 24 Jun 2008 19:19:31 +0200

On Tue, 2008-06-24 at 06:55 -0700, Dan Karp wrote:
> > Would it make sense to claim in the RFC that you MUST NOT call
> > yourself an IMAP server if you advertise capabilities that are
> > not publicized as either RFC or in proposal at IETF?
> 
> Nope.  RFC 3501 is pretty clear that servers can advertise any
> X-capabilities that they want; only ones that don't start with
> "X" are constrained in the way you desire:
> 
>       Capability names MUST either begin with "X" or be standard or
>       standards-track IMAP4rev1 extensions, revisions, or amendments
>       registered with IANA.  A server MUST NOT offer unregistered or
>       non-standard capability names, unless such names are prefixed with
>       an "X".

Aha, that indeed justifies a capability name like XYZZY. I rest my case.

-- 
Philip Van Hoof, freelance software developer
home: me at pvanhoof dot be 
gnome: pvanhoof at gnome dot org 
http://pvanhoof.be/blog
http://codeminded.be

_______________________________________________
lemonade mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/lemonade
Supplemental Web Site:
http://www.standardstrack.com/ietf/lemonade

---

From: <[email-masked]>
Date: Wed, 25 Jun 2008 11:17:32 +0300

Hi all,
IMHO, supporting dozens of proprietary (X) extensions does not make a server IMAP or Lemonade compliant.
Proper implementation of standards track RFCs does.

Best regards: Zoltán Ördögh
E-mail: zoltan dot ordogh at nokia dot com
Phone: +358 50 386 0566

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of ext Philip Van Hoof
Sent: 24 June, 2008 20:20
To: Dan Karp
Cc: Enhancements to Internet email to support diverse service enivronments
Subject: Re: [lemonade] Why we should let the IMAP specification become morerich, rather than poor

On Tue, 2008-06-24 at 06:55 -0700, Dan Karp wrote:
> > yourself an IMAP server if you advertise capabilities that are not 
> > publicized as either RFC or in proposal at IETF?
> 
> X-capabilities that they want; only ones that don't start with "X" are 
> constrained in the way you desire:
>