Subject: [link-relations] NEW RELATION REQUEST: Relation name: "next"

From: "Michael(tm) Smith" <[email-masked]>
Date: Thu, 2 Sep 2010 17:14:11 +0900

Relation Name:
  next

Description:
  Indicates that the current document is a part of a series, and
  that the next document in the series is the referenced document.

Reference:
  http://www.w3.org/TR/html5/links.html#link-type-next

Notes:
  Template to be added to W3C HTML5 specification before
  publication of next Working Draft

-- 
Michael(tm) Smith
http://people.w3.org/mike

---

From: Mark Nottingham <[email-masked]>
Date: Thu, 2 Sep 2010 21:34:41 +1000

Hi Mike,

Just to start discussion, I'll give initial thoughts in one e-mail, for now.

One general observation - relations that are potentially usable in formats other than HTML should be defined in such a way that they're not HTML specific. The only reason I mention this is that the specification links go directly into HTML-specific text, without any definition of semantics, etc.

E.g., with 'alternate', the link goes to:

> 4.12.3.1 Link type "alternate"
> 
> The alternate keyword may be used with link, a, and area elements.
> 
> The meaning of this keyword depends on the values of the other attributes.
> 
> If the element is a link element and the rel attribute also contains the keyword stylesheet
[...]

It would be helpful (especially since alternate is already used by Atom) if this were rewritten to something like:

> 4.12.3.1 Link type "alternate"
> 
> The 'alternate' link type gives alternate representations of the current document.
> 
> In HTML documents, the alternate keyword may be used with link, a, and area elements.
> 
> The meaning of this keyword depends on the values of the other attributes.
> 
> If the element is a link element and the rel attribute also contains the keyword stylesheet
[...]

See what I mean?

Beyond that, I see three groups of relations here;

1) Updating HTML4 registrations, including:
  next / alternate / bookmark / index / prev / stylesheet / help

There shouldn't be any issues with these. The only thing I'd note is that 'alternate' is also used by Atom, but it's already registered by HTML4, so it shouldn't be a problem. 

2) Registering new relations, including:
  archives / icon / noreferer / tag / pingback / prefetch / sidebar / external / author / nofollow / search 

'pingback' and 'search' refer to external specifications. We'll need to talk through the implications of that.

3) Updating registrations from other sources, including:
  license / up / last / first

These might need a bit more discussion, especially license, which is currently defined by RFC4946. Is there any reason that its definition isn't adequate for HTML5?

The others need to be coordinated with the individuals who originally registered the relations -- Noah Slater for up, and myself for first and last. I don't think there will be any problem for mine, at least.

Cheers,

On 02/09/2010, at 6:14 PM, Michael(tm) Smith wrote:

> _______________________________________________
> link-relations mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/link-relations

--
Mark Nottingham     http://www.mnot.net/

---

From: Leif Halvard Silli <[email-masked]>
Date: Thu, 2 Sep 2010 14:12:33 +0200

Mark Nottingham, Thu, 2 Sep 2010 21:34:41 +1000:
> One general observation - relations that are potentially usable in 
> formats other than HTML should be defined in such a way that they're 
> not HTML specific. The only reason I mention this is that the 
> specification links go directly into HTML-specific text, without any 
> definition of semantics, etc.
> 
> It would be helpful (especially since alternate is already used by 
> Atom) if this were rewritten to something like:
> 
> There shouldn't be any issues with these. The only thing I'd note is 
> that 'alternate' is also used by Atom, but it's already registered by 
> HTML4, so it shouldn't be a problem. 
> 
> 'pingback' and 'search' refer to external specifications. We'll need 
> to talk through the implications of that.
> 
> These might need a bit more discussion, especially license, which is 
> currently defined by RFC4946. Is there any reason that its definition 
> isn't adequate for HTML5?
> 
> The others need to be coordinated with the individuals who originally 
> registered the relations -- Noah Slater for up, and myself for first 
> and last. I don't think there will be any problem for mine, at least.

There is bug and tracker request w.r.t. to 'first' and some other 
relations in the HTMLwg. Thus I think that Mike was to early in sending 
registration requests for some of these link relations.

http://www.w3.org/Bugs/Public/show_bug.cgi?id=7475
-- 
leif halvard silli

---

From: "Michael(tm) Smith" <[email-masked]>
Date: Fri, 3 Sep 2010 07:15:09 +0900

Hi Mark,

> @2010-09-02 21:34 +1000:
> One general observation - relations that are potentially usable
> in formats other than HTML should be defined in such a way that
> they're not HTML specific.

That's a good point.

> The only reason I mention this is
> that the specification links go directly into HTML-specific
> text, without any definition of semantics, etc.
> 
[...]
> It would be helpful (especially since alternate is already used
> by Atom) if this were rewritten to something like:
> 

Yep

So as far as HTML WG process goes, the way to address this would
be for somebody to raise a bug proposing that the first paragraph
of each link-type section should be a general description of the
semantics of that link type, without specific reference to HTML.

I will either raise such a bug myself, or will work with other
members of the group to get it raised.

> There shouldn't be any issues with these. The only thing I'd
> note is that 'alternate' is also used by Atom, but it's already
> registered by HTML4, so it shouldn't be a problem. 

OK

> 'pingback' and 'search' refer to external specifications. We'll need to talk through the implications of that.

Yeah, agreed

> These might need a bit more discussion, especially license,
> which is currently defined by RFC4946. Is there any reason that
> its definition isn't adequate for HTML5?

No, I personally don’t think there is. So this is another for
which I will make sure we get a bug raised.

> The others need to be coordinated with the individuals who
> originally registered the relations -- Noah Slater for up, and
> myself for first and last. I don't think there will be any
> problem for mine, at least.

OK, so I’ll take that as an action item on me to contact Noah and
give him a heads-up about this.

  --Mike