Subject: Re: [lmap] draft-ietf-lmap-information-model-06: Instructions and measurement suppression

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 23 Sep 2015 16:25:26 +0200

On Mon, Jul 27, 2015 at 08:46:12PM +0000, Carey, Timothy (Timothy) wrote:
> Juergen,
> 
> In IETF93 you asked if instruction object had any meaning.
> Well they are used to hold measurement suppression. So if we remove the Instruction object we need a place to hold the instructions measurement suppression.
> 

I believe this is a misunderstanding. As far as I recall, my question
concerned the term Instruction Task. And I still think we should go
through the document to see whether we can remove this term (as well
as the other 'specialist tasks' mentioned under 2.B. on page 8). I
think this should actually become:

       B.  Control Tasks implement the Control Protocol and
           communicate with the Controller.

We also don't detail that reporting tasks could be more complex
internally since this does not matter from the information model's
point of view.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Fri, 25 Sep 2015 12:45:04 +0000

Juergen,

Oh - sorry just so long as we don't remove the Instruction object.
Instruction task as a term - Yes it doesn't add much; a Task is a task.

BR,
Tim

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]] 
Sent: Wednesday, September 23, 2015 9:25 AM
To: Carey, Timothy (Timothy)
Cc: [email-masked]
Subject: Re: [lmap] draft-ietf-lmap-information-model-06: Instructions and measurement suppression

> Well they are used to hold measurement suppression. So if we remove the Instruction object we need a place to hold the instructions measurement suppression.

I believe this is a misunderstanding. As far as I recall, my question concerned the term Instruction Task. And I still think we should go through the document to see whether we can remove this term (as well as the other 'specialist tasks' mentioned under 2.B. on page 8). I think this should actually become:

We also don't detail that reporting tasks could be more complex internally since this does not matter from the information model's point of view.

/js