Subject: Re: [lmap] draft-ietf-lmap-information-model-06: Report - Task problems

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 23 Sep 2015 17:20:22 +0200

On Tue, Jul 28, 2015 at 03:57:47PM +0000, Carey, Timothy (Timothy) wrote:
> Juergen,
> 
> 
> 1)    In the ma-report-task-obj, you have the [ma-option-obj       ma-report-scheduled-task-options<0..*>]. So do we mean options for MA, the Action or the Task? I think we mean the Task here. We also need Action conditions for the report right?

The ma-report-task-obj looks like this:

     object {
         string              ma-report-task-name;
        [uri                 ma-report-task-registry-entries<1..*>;]
        [ma-option-obj       ma-report-task-options<0..*>];
        [ma-option-obj       ma-report-task-action-options<0..*>];
        [string              ma-report-task-cycle-id;]
        [string              ma-report-task-column-labels<0..*>;]
        [ma-report-row-obj   ma-report-task-rows<0..*>;]
     } ma-report-task-obj;

It carries both the task options as well as the action options. I do
not understand what you mean with 'Action conditions'.
 
> 2)    Use of Registry entry in the Report task; Is this really for a metric (RegistryEntry) in the task (probably); what about Role of the metric; do we report on each role/registryentry for the task? (probably) .

My understanding is that the registry entry identifies the role and
hence reporting the registry entry should be sufficient.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Fri, 25 Sep 2015 14:09:06 +0000

Juergen,

For the conditions - I must have been looking at something else - You are indeed correct - Sorry.

For the registry question - I will wait on the resolution to MA-Task-Role in the other thread.

BR,
Tim
-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]] 
Sent: Wednesday, September 23, 2015 10:20 AM
To: Carey, Timothy (Timothy)
Cc: [email-masked]
Subject: Re: [lmap] draft-ietf-lmap-information-model-06: Report - Task problems

     object {

It carries both the task options as well as the action options. I do not understand what you mean with 'Action conditions'.
 
> 2)    Use of Registry entry in the Report task; Is this really for a metric (RegistryEntry) in the task (probably); what about Role of the metric; do we report on each role/registryentry for the ta…

My understanding is that the registry entry identifies the role and hence reporting the registry entry should be sufficient.

/js