Subject: [lmap] Standard for coordination between MAs

From: Holger Wiehen <[email-masked]>
Date: Wed, 16 Sep 2015 16:03:47 -0300

Hi.

At NIC.br <http://nic.br/>, Brazilian’s network information center, we are constructing a measurement system that performs active traffic measurement, to monitor broadband access networks. In this context, we are migrating to an LMAP architecture. Beyond LMAP’s scope our use case requires some control and reporting between pairs of MAs.

We would like to architect this inter-MA coordination in an standards compliant way. Our evaluation of IPPM standards like OWAMP and TWAMP showed that currently there is no control or report protocol between MA’s solving this problem in a sufficiently generic way, as the former 2 standards are tied to specific measurement models.

We think a standard for inter-MA communication, is a missing piece to deliver on LMAP’s vision of coordinated large scale measurements.      

Would it be possible to work on such a standard in the LMAP WG, to ensure a consistent point of view? 
Our team would like to initiate this effort and to collaborate with the WG.

Please comment on our suggestion.

Regards,

Holger Wiehen.

 Holger Wiehen 
Project Analyst
SIMET - Internet Traffic Measurement Systems 
+55 11 5509-3537 R.: 4114 
www.nic.br <http://nic.br/>

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Wed, 16 Sep 2015 16:00:09 -0400

Hi Holger,

Can you give a specific example of MA to MA communication that:

-   cannot be accomplished through parallel Controller/Reporter to MA Communications

-   cannot be accomplished by extending OWAMP or TWAMP Control and Fetch

protocols

If so, that’s a starting place for discussion of the problem.
thanks,
Al

From: lmap [mailto:[email-masked]] On Behalf Of Holger Wiehen
Sent: Wednesday, September 16, 2015 3:04 PM
To: [email-masked]
Cc: Fabricio Tamusiunas
Subject: [lmap] Standard for coordination between MAs

Hi.

At NIC.br<http://NIC.br>, Brazilian’s network information center, we are constructing a measurement system that performs active traffic measurement, to monitor broadband access networks. In this context, we are migrating to an LMAP architecture. Beyond LMAP’s scope our use case requires some control and reporting between pairs of MAs.

Regards,

Holger Wiehen.

[http://nic.br/assinatura/assinatura-nic-lg.png]Holger Wiehen
Project Analyst
SIMET - Internet Traffic Measurement Systems
+55 11 5509-3537 R.: 4114
www.nic.br<http://nic.br>

---

From: Holger Wiehen <[email-masked]>
Date: Thu, 17 Sep 2015 19:03:14 -0300

Hi Al.

Thank's for your reply.

I will try illustrate our idea of MA Communications with 2 example use cases.

One example would be a MA initiated by a human user, executing measurements against a remote MA. Results obtained on the remote MA should be presented to the end user (local MA), with low delay.

I understand that pushing results to a MA could not be solved with the report flow specified by LMAP. In an end user focused use case, exchanging reports directly between MAs, would allow for quick and resilient reporting to users. This reporting would be in addition to the usual report submission to the LMAP collector.

A second use case is a MA responding active measurements initiated by another MA. Our responding MA receives its configuration from the LMAP controller, but once it is set up, it does not depend on the control channel in order to respond to measurements initiated by a remote MA. The responding MA receives parameters specific to a single measurement session, from the initiating MA. Coordinating active measurements directly between MAs would increase resilience and reduce timing issues.

A limitation I see with OWAMP is the requirement of synchronised clocks, not guaranteed with MAs executed on arbitrary devices, controlled by an end user. Also its concepts like a send schedule, with pre-defined send intervals, and tracking of individual packages, are tailored towards latency and loss measurement. I am not able to identify an extension for bandwidth measurements, based on these concepts. 

A protocol for MA Communications, on top of LMAP’s current scope, would provide a solution following LMAP’s concepts and extend its information model in a consistent way.

Your opinion would be very welcome.

Thank’s.

Holger.

> On Sep 16, 2015, at 5:00 PM, MORTON, ALFRED C (AL) <[email-masked]> wrote:
> 
> Hi Holger,
>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Mon, 21 Sep 2015 10:39:28 +0200

> I understand that pushing results to a MA could not be solved with the report flow specified by LMAP. In an end user focused use case, exchanging reports directly between MAs, would allow for quick…

Can you provide a concrete example where this is useful? Can anyone on the
Internet use the MA for measurements? If not, how do you establish a trust
relationship?

> A second use case is a MA responding active measurements initiated by another MA. Our responding MA receives its configuration from the LMAP controller, but once it is set up, it does not depend on…

Can you provide a concrete example where this is useful? How do you
establish a trust relationship?

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: Holger Wiehen <[email-masked]>
Date: Wed, 23 Sep 2015 18:21:30 -0300

Jürgen,

Thank's for your comments. 
Your comment regarding the trust relationship, has been very valuable for our work.

Since the WG has put its focus on the chartered work items and the interim meeting, I will hold back with the discussion about a standard for communication between MAs.

Holger Wiehen.

> On Sep 21, 2015, at 5:39 AM, Juergen Schoenwaelder <[email-masked]> wrote:
>