Subject: Re: [lmap] draft-ietf-lmap-information-model-06: Actions

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 23 Sep 2015 16:06:59 +0200

On Mon, Jul 27, 2015 at 07:41:10PM +0000, Carey, Timothy (Timothy) wrote:
> Juergen,
> 
> If Actions are now considered stand-alone entities outside the schedule. Shouldn't the MA have a list of Actions available like Tasks and CommunicationChannels?
>

I do not think that actions are considered stand-alone
entities. Actions exist as part of a schedule.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Fri, 25 Sep 2015 12:13:09 +0000

Juergen,

Ok thanks - that was my hope as well.
The current IM draft has some verbiage that could be interpreted otherwise.

"It should be clear that the top-level behavior of an MA is simply to
execute Schedules. Every Action referenced by a Schedule is defined
as a Task. As such, these Actions are configured through Task
Configurations and executed according to the Event object referenced
by the Schedule in which they appear. Note, however, that Actions
can have Action specific parameters."

Perhaps we should say "Every Action contained by a Schedule".

Also:
3.7 Common Objects: Schedules
Multiple Actions in the list of a single Measurement Schedule will be
executed according to the execution mode of the Schedule.

Perhaps we should say " Multiple Actions contained as an ordered list within a single Measurement Schedule ".

Finally:
Actions in different Schedules execute in
parallel with such conflicts being reported in the Reporting
Information where necessary.

Perhaps we should say "Actions contained in different Schedules ".

P.S. Also the draft as lowercase action instead of uppercase Action is some instances.

BR,
Tim

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]] 
Sent: Wednesday, September 23, 2015 9:07 AM
To: Carey, Timothy (Timothy)
Cc: [email-masked]
Subject: Re: [lmap] draft-ietf-lmap-information-model-06: Actions

> If Actions are now considered stand-alone entities outside the schedule. Shouldn't the MA have a list of Actions available like Tasks and CommunicationChannels?

I do not think that actions are considered stand-alone entities. Actions exist as part of a schedule.

/js

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 29 Sep 2015 15:19:24 +0200

Tim,

your suggested changes look good to me.

/js