Subject: Re: [lmap] Review of draft-ietf-lmap-information-model-06: Action Destinations and tie with the Regisrry output

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 23 Sep 2015 17:44:38 +0200

Tim,

the information model currently assumes that results are tagged. A
task producing multiple 'outputs' would tag them to distinguish them.

How all this links to the registry is, honestly speaking, somewhat
unclear to me since I do not really understand how the registry itself
works. It would help me a lot if draft-ietf-ippm-metric-registry-04
would contain a collection of example registry entries.

/js

On Wed, Aug 05, 2015 at 02:06:24PM +0000, Carey, Timothy (Timothy) wrote:
> Juergen,
> 
> In previous information models we linked the Registry's outputs with the downstream tasks.
> 
> In LMAP IM-06 draft we now have a concept of an ActionDestination which describes which schedules are invoked based on the task's output selection. However we do not link back the task output to the ActionDestination via parameter in the ActionDestination object (maybe called Output?). Did I miss understand the intent of the ActionDestination and its linkage?
> 
> BR,
> Tim

> _______________________________________________
> lmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lmap

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Fri, 25 Sep 2015 14:23:21 +0000

Al,

So what do you think about how to link the ActionDestination of another Schedule with the results of this Schedules Action?

BR,
Tim

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]] 
Sent: Wednesday, September 23, 2015 10:45 AM
To: Carey, Timothy (Timothy)
Cc: [email-masked]
Subject: Re: [lmap] Review of draft-ietf-lmap-information-model-06: Action Destinations and tie with the Regisrry output

Tim,

the information model currently assumes that results are tagged. A task producing multiple 'outputs' would tag them to distinguish them.

How all this links to the registry is, honestly speaking, somewhat unclear to me since I do not really understand how the registry itself works. It would help me a lot if draft-ietf-ippm-metric-registry-04
would contain a collection of example registry entries.

/js

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Fri, 25 Sep 2015 21:37:46 -0400

Hi Tim,

I agree we need to sort-out the schedule aspects,
but as a first step I want to be sure we all 
understand how the IPPM Registry would be used
by measurement Tasks and Reporting Tasks.

Once we have that level of understanding, then
I think we can work-out the kinks in the different
Schedules, Events, Actions and Destinations Schedules...

           Schedule
              |------> Event
              |------> Action 1
              |            |------> Task Configuration
              |            `------> Destination Schedule
              :
              :
              `------> Action N
                           |------> Task Configuration
                           `------> Destination Schedule
(and see if this diagram is still correct).

I don't think I'll really understand the Models and the Registry
until I work through some examples of the Models (As I said, we
already have examples of registry entries). I've been working on
the task part of an example tonight.  I'll make some mistakes, but then
we'll all understand the use of the model better (*Everybody* wants
examples, and a nice hat to wear in the Sun).

regards,
Al

> From: Carey, Timothy (Timothy) [mailto:[email-masked]]
> Sent: Friday, September 25, 2015 10:23 AM
> To: Juergen Schoenwaelder
> Cc: [email-masked]; MORTON, ALFRED C (AL)
> Subject: RE: [lmap] Review of draft-ietf-lmap-information-model-06:
> Action Destinations and tie with the Regisrry output
> 
> Al,
> 
> So what do you think about how to link the ActionDestination of another
> Schedule with the results of this Schedules Action?
> 
> BR,
> Tim
> 
> Subject: Re: [lmap] Review of draft-ietf-lmap-information-model-06:
> Action Destinations and tie with the Regisrry output
> 
> Tim,
> 
> the information model currently assumes that results are tagged. A task
> producing multiple 'outputs' would tag them to distinguish them.
> 
> > In LMAP IM-06 draft we now have a concept of an ActionDestination
> which describes which schedules are invoked based on the task's output
> selection. However we do not link back the task output to the
> ActionDestination via parameter in the ActionDestination object (maybe
> called Output?). Did I miss understand the intent of the
> ActionDestination and its linkage?
> >
> > BR,
> > Tim
>

---

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Sat, 26 Sep 2015 16:06:53 +0000

Al,

Great - FYI  the structure for a Scheduled Action "list of destinations" not just one...

object {
string ma-action-name;
string ma-action-task-name;
[ma-option-obj ma-action-task-options<0..*>];
[string ma-action-destinations<0..*>;]
} ma-action-obj;

BR,
Tim

-----Original Message-----
From: MORTON, ALFRED C (AL) [mailto:[email-masked]] 
Sent: Friday, September 25, 2015 8:38 PM
To: Carey, Timothy (Timothy); Juergen Schoenwaelder
Cc: [email-masked]
Subject: RE: [lmap] Review of draft-ietf-lmap-information-model-06: Action Destinations and tie with the Regisrry output

Hi Tim,

I agree we need to sort-out the schedule aspects, but as a first step I want to be sure we all understand how the IPPM Registry would be used by measurement Tasks and Reporting Tasks.

Once we have that level of understanding, then I think we can work-out the kinks in the different Schedules, Events, Actions and Destinations Schedules...

           Schedule
              |------> Event
              |------> Action 1
              |            |------> Task Configuration
              |            `------> Destination Schedule
              :
              :
              `------> Action N
                           |------> Task Configuration
                           `------> Destination Schedule (and see if this diagram is still correct).

I don't think I'll really understand the Models and the Registry until I work through some examples of the Models (As I said, we already have examples of registry entries). I've been working on the task part of an example tonight.  I'll make some mistakes, but then we'll all understand the use of the model better (*Everybody* wants examples, and a nice hat to wear in the Sun).

regards,
Al

> From: Carey, Timothy (Timothy) 
> [mailto:[email-masked]]
> So what do you think about how to link the ActionDestination of 
> another Schedule with the results of this Schedules Action?
> 
> BR,
> Tim
>

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Tue, 29 Sep 2015 15:35:19 +0200

Tim,

I think I do not understand your question. An action can choose to
send its output to other schedules. In other words, we have forward
pointers indicating the data flow. You seem to ask for a backwards
pointer which in my view does not make much sense. But as I said,
I am not sure I understand your question.

/js

---

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Wed, 30 Sep 2015 11:43:51 +0000

Juergen and Al,

So given the results of the virtual meeting. Again thanks Al for the for examples. I think we can resolve this activity with the following understanding.

A Metric in a registry entry will have at most 1 output. A task can have multiple registry entries so a scheduled action can have multiple outputs which, as Juergen noted in yesterday's meeting, will proceed to be inputs in the initial action(s) of the destination schedule.

Is this a correct understanding?

BR,
Tim

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]] 
Sent: Tuesday, September 29, 2015 8:35 AM
To: Carey, Timothy (Timothy)
Cc: [email-masked]; MORTON, ALFRED C (AL)
Subject: Re: [lmap] Review of draft-ietf-lmap-information-model-06: Action Destinations and tie with the Regisrry output

Tim,

I think I do not understand your question. An action can choose to send its output to other schedules. In other words, we have forward pointers indicating the data flow. You seem to ask for a backwards pointer which in my view does not make much sense. But as I said, I am not sure I understand your question.

/js

On Fri, Sep 25, 2015 at 02:23:21PM +0000, Carey, Timothy (Timothy) wrote:
> From: Juergen Schoenwaelder 
> [mailto:[email-masked]]

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 30 Sep 2015 15:57:55 +0200

> Is this a correct understanding?

I think so. And going a bit further, my understanding is that a single
metric output can consist of a varying number of primitive values.

/js