Subject: Re: [lmap] Review of draft-ietf-lmap-information-model-06: Disabling schedules on controller timeout

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Wed, 16 Sep 2015 10:12:24 +0000

Hi,

In light of the Virtual meeting next week I thought I would regenerate an open issue I have with the latest information model that I haven't seen discussion on.

BR,
Tim

From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, July 28, 2015 2:37 AM
To: Carey, Timothy (Timothy); [email-masked]
Subject: RE: Review of draft-ietf-lmap-information-model-06: Disabling schedules on controller timeout

I think this isn't possible. The Control and Instruction schedules are held separately and the Control schedules cannot be suppressed.

Trevor.

From: lmap [mailto:[email-masked]] On Behalf Of Carey, Timothy (Timothy)
Sent: 27 July 2015 20:20
To: [email-masked]<mailto:[email-masked]>
Subject: [lmap] Review of draft-ietf-lmap-information-model-06: Disabling schedules on controller timeout

Juergen,

I was updating the TR-069 model and still have some questions about the disabling of schedules.

What happens if I disable a schedule but the schedule references an action that is MA communication specific AND say an instruction?

It really sounds like we are disabling actions not schedules... It certainly would be much easier.

BR,
Tim

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 23 Sep 2015 15:47:24 +0200

Hi,

we (Vaibhav and me) looked into the issue and it seems one possible
solution is to handle lost communication to a controller similar to
the default suppression. Hence our proposal is to add a boolean flag
to the ma-task-obj that indicates whether the task will be disabled if
communication to the controller has stopped. The default will be true.

ma-task-auto-disable:  A boolean flag indicating whether the task
		       will be disabled if the communication with
		       the controller has timed out. The default
		       value of the flag is true.

The description of ma-controller-timeout will then be updated to say
that all actions refering to tasks where ma-task-auto-disable is
true will not be executed anymore.

/js

> _______________________________________________
> lmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lmap

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Fri, 25 Sep 2015 11:54:26 +0000

Ok - that's a good approach.

Thanks!

Tim

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]] 
Sent: Wednesday, September 23, 2015 8:47 AM
To: Carey, Timothy (Timothy)
Cc: [email-masked]
Subject: Re: [lmap] Review of draft-ietf-lmap-information-model-06: Disabling schedules on controller timeout

Hi,

we (Vaibhav and me) looked into the issue and it seems one possible solution is to handle lost communication to a controller similar to the default suppression. Hence our proposal is to add a boolean flag to the ma-task-obj that indicates whether the task will be disabled if communication to the controller has stopped. The default will be true.

The description of ma-controller-timeout will then be updated to say that all actions refering to tasks where ma-task-auto-disable is true will not be executed anymore.

/js

On Wed, Sep 16, 2015 at 10:12:24AM +0000, Carey, Timothy (Timothy) wrote:
> Subject: [lmap] Review of draft-ietf-lmap-information-model-06: 
> Disabling schedules on controller timeout
> 
> Juergen,
>