Subject: Re: [lmap] Review of draft-ietf-lmap-information-model-06: Action Execution Mode questions

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 23 Sep 2015 15:59:43 +0200

On Mon, Jul 27, 2015 at 07:29:47PM +0000, Carey, Timothy (Timothy) wrote:
> Juergen,
> 
> In reviewing this draft for the TR-069 model update I had a question on the Execution mode.
> We say there are 3 modes - Sequential, Parallel and Pipelined.
> For sequential - What is the value that orders the list? I don't see an ordering the action or indication that this is an ordered list of actions.
>

Yes, it is an ordered list. We searched through the document and it
turns out we sometimes use 'list' when we mean 'ordered list' but we
also use 'list' sometimes where all we need is an 'unordered set'.
Our proposal is that we go through the whole document replacing 'list'
with either 'ordered list' or ''unordered set' to make the distinction
clear.

> For pipelining - I don't understand this mode - are we saying that this is a Sequential mode plus all the outputs for executing Action are inputted to the next Action in the Sequence or is the Pipeline mode somehow relevant for Output destinations? If so why wouldn't pipeline simply be sequential or paralled with output destinations?
>

The former. A pipelined schedule with actions a1, a2, and a3 means
that a1 is executed and feeds its output as input to a2 which feeds
its output as input to a3. Note that pipelined does not imply
sequential execution; all actions can run concurrently and the
pipeline controls the data flow and thus the progress they can make.
Like in a Unix shell pipeline.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Fri, 25 Sep 2015 11:57:16 +0000

Juergen,

Ok - both answers are fine with me. If we could update the information model with the definition for pipelining that would be great.

Thanks!

Tim

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]] 
Sent: Wednesday, September 23, 2015 9:00 AM
To: Carey, Timothy (Timothy)
Cc: [email-masked]
Subject: Re: [lmap] Review of draft-ietf-lmap-information-model-06: Action Execution Mode questions

> For sequential - What is the value that orders the list? I don't see an ordering the action or indication that this is an ordered list of actions.

Yes, it is an ordered list. We searched through the document and it turns out we sometimes use 'list' when we mean 'ordered list' but we also use 'list' sometimes where all we need is an 'unordered set'.
Our proposal is that we go through the whole document replacing 'list'
with either 'ordered list' or ''unordered set' to make the distinction clear.

> For pipelining - I don't understand this mode - are we saying that this is a Sequential mode plus all the outputs for executing Action are inputted to the next Action in the Sequence or is the Pipe…

The former. A pipelined schedule with actions a1, a2, and a3 means that a1 is executed and feeds its output as input to a2 which feeds its output as input to a3. Note that pipelined does not imply sequential execution; all actions can run concurrently and the pipeline controls the data flow and thus the progress they can make.
Like in a Unix shell pipeline.

/js