Subject: [lmap] draft agenda for the 9/29 LMAP WG interim meeting

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 23 Sep 2015 09:37:21 +0000

Hi,

I have uploaded the draft agenda of for the 9/29 LMAP WG interim meeting at https://www.ietf.org/proceedings/interim/2015/09/29/lmap/agenda/agenda-interim-2015-lmap-3.

The scope of the interim should be on the three chartered work items:

3. LMAP Information Model - (Trevor, Juergen, 50 min)

4. LMAP YANG Data Model - (Juergen, 20 min)

5. LMAP Protocol - (Juergen, 20 min)

I do not see however much progress or discussions on the mail list on this, with the exception of the comments made by Tim Carey which need to be addressed. No new I-Ds where submitted since IETF 93. Jason and me would like to hear from the authors and the other editors what are their plans and how they would like to use the meeting time.

Thanks and Regards,

Dan

---

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 23 Sep 2015 18:25:27 +0200

> I do not see however much progress or discussions on the mail list on this, with the exception of the comments made by Tim Carey which need to be addressed. No new I-Ds where submitted since IETF 9…

I was hoping NETMOD would not take so much of my time anymore but I
was wrong with that prediction. I am doing priority queuing now and
unfortunately this affects progress in LMAP (but other IETF related
stuff is even more affected).

Concerning the agenda, I do not think we need much time for the data
model or the protocol work since there were no discussions on the
list. There will be updates coming to align with information model
updates but I do not think we need to discuss these edits during
the interim.

We should focus on the information model related questions, mostly
raised by Tim. And I like to thank Tim for raising these questions -
reviews and questions are a valuable contribution to make things
better and I apologize for late responses.

In addition, it would really help me if some IPPM people can explain
how the registry actually works.  A few example registry entries would
help me a lot. I know this request comes a bit late so I am not sure
we can get registry co-authors into the call. But it would really help
me to figure out how the bits and pieces fit together. So perhaps
reallocate the data model and protocol time to a discussion how the
IPPM registry works together with the information model.

/js

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Wed, 23 Sep 2015 13:30:59 -0400

Another chime from Al follows:

> -----Original Message-----
Juergen wrote:
...
> model or the protocol work since there were no discussions on the list.
> There will be updates coming to align with information model updates but
> I do not think we need to discuss these edits during the interim.
[ACM] 
I agree, if you align to cover my registry related comment from a few minutes ago ;-)
> reviews and questions are a valuable contribution to make things better
> and I apologize for late responses.
[ACM] 
+1
> 
> In addition, it would really help me if some IPPM people can explain how
> the registry actually works.  
[ACM] 
The reality is that the registry IPPM people are also LMAP people,
for the most part.

> A few example registry entries would help
> me a lot. I know this request comes a bit late so I am not sure we can
> get registry co-authors into the call. 
[ACM] 
Ask and you shall receive:
https://tools.ietf.org/html/draft-morton-ippm-initial-registry-00
We've been working on versions of initial registry entries since the Interim
meeting in Dublin last year.  No one has commented yet.

In fact, only Barbara has commented on the registry itself:
https://tools.ietf.org/html/draft-ietf-ippm-metric-registry-04

> But it would really help me to
> figure out how the bits and pieces fit together. So perhaps reallocate
> the data model and protocol time to a discussion how the IPPM registry
> works together with the information model.
> 

[ACM] That's fine with me. 
I wonder who will get the action item/agenda assignment. =80

regards,
Al

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Wed, 23 Sep 2015 17:32:08 +0000

> From: MORTON, ALFRED C (AL) [mailto:[email-masked]]

What about Al Morton? 

Dan

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Wed, 23 Sep 2015 13:56:55 -0400

> > > figure out how the bits and pieces fit together. So perhaps
[ACM] 
I'll ask him if I see him.

---

From: "Weil, Jason" <[email-masked]>
Date: Wed, 23 Sep 2015 18:00:55 +0000

The IPPM Registry discussion is a great suggestion that Dan and I were
just talking about today on a call.

Al,Marcelo, or other presenter, we will give you a spot on the agenda to
go over progress and overlap between the Registry and Information Model
during next week¹s Interim call.

Thanks,

Jason

On 9/23/15, 1:30 PM, "lmap on behalf of MORTON, ALFRED C (AL)"
<[email-masked] on behalf of [email-masked]> wrote:

>_______________________________________________
>lmap mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/lmap

________________________________

This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: "MORTON, ALFRED C (AL)" <[email-masked]>
Date: Wed, 23 Sep 2015 14:19:48 -0400

> From: Weil, Jason [mailto:[email-masked]]
> Sent: Wednesday, September 23, 2015 2:01 PM
> To: MORTON, ALFRED C (AL); Juergen Schoenwaelder; Romascanu, Dan (Dan)
> Cc: [email-masked]
> Subject: Re: [lmap] draft agenda for the 9/29 LMAP WG interim meeting
> 
...
[ACM] 
That's fine, but folks should come prepared having *read the registry* 
drafts below AND this thread, plus a related thread on ippm list last week:
https://mailarchive.ietf.org/arch/msg/ippm/XWxR_Pqo7OTxUIqtEZwtsbwoxfU

It's most important to understand that the LMAP *-models depend on
Registry Entries defining Performance Metrics to have *anything* 
to measure and report on. So, we'll talk about the Registry Format
AND the proposed initial entries as examples of the Format in action.

see registry draft URLs below,
Al

...
> >> A few example registry entries would help me a lot. I know this
> >> request comes a bit late so I am not sure we can get registry
> >> co-authors into the call.
> >[ACM]

> >We've been working on versions of initial registry entries since the
> >Interim meeting in Dublin last year.  No one has commented yet.
> >

---

From: marcelo bagnulo <[email-masked]>
Date: Wed, 23 Sep 2015 20:30:43 +0200

I can also attend for the first 50 mins or so.

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Thu, 24 Sep 2015 11:16:54 +0000

I updated the agenda at https://www.ietf.org/proceedings/interim/2015/09/29/lmap/agenda/agenda-interim-2015-lmap-3 to reflect the changes that you requested. 

Al - please confirm that you can drive the IPPM section. I put it first in the agenda because Marcelo said that he can attend only the first 50 min. 

Thanks and Regards,

Dan

> From: Juergen Schoenwaelder [mailto:j.schoenwaelder@jacobs-
> university.de]
> Sent: Wednesday, September 23, 2015 7:25 PM
> To: Romascanu, Dan (Dan)
> Cc: [email-masked]
> > I have uploaded the draft agenda of for the 9/29 LMAP WG interim
> meeting at https://urldefense.proofpoint.com/v2/url?u=https-
> 3A__www.ietf.org_proceedings_interim_2015_09_29_lmap_agenda_agend
> a-2Dinterim-2D2015-2Dlmap-
> 2D3&d=BQIBAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31OcNXCJfQzvlsiL
> QfucBXRucPvdrphpBsFA&m=0OdW9CNquRYyYh-9qP2-
> 7g6OPxhpLPz7bxvfC5-ChV0&s=MEMGHKOttYilRlhR_-ccqwxd-
> ssMaKAXj9M_6p4MFa8&e= .
> >
> > I do not see however much progress or discussions on the mail list on this,
> with the exception of the comments made by Tim Carey which need to be
> addressed. No new I-Ds where submitted since IETF 93. Jason and me would
> like to hear from the authors and the other editors what are their plans and
> how they would like to use the meeting time.
> >
> 
> I was hoping NETMOD would not take so much of my time anymore but I was
> wrong with that prediction. I am doing priority queuing now and
> unfortunately this affects progress in LMAP (but other IETF related stuff is
> even more affected).
> 
> model or the protocol work since there were no discussions on the list. There
> will be updates coming to align with information model updates but I do not
> think we need to discuss these edits during the interim.
> 
> We should focus on the information model related questions, mostly raised
> by Tim. And I like to thank Tim for raising these questions - reviews and
> questions are a valuable contribution to make things better and I apologize
> for late responses.
> 
> In addition, it would really help me if some IPPM people can explain how the
> registry actually works.  A few example registry entries would help me a lot. I
> know this request comes a bit late so I am not sure we can get registry co-
> authors into the call. But it would really help me to figure out how the bits
> and pieces fit together. So perhaps reallocate the data model and protocol
> time to a discussion how the IPPM registry works together with the
> information model.
> 
> /js
> 
> --
> Fax:   +49 421 200 3103
> <https://urldefense.proofpoint.com/v2/url?u=http-3A__www.jacobs-
> 2Duniversity.de_&d=BQIBAg&c=BFpWQw8bsuKpl1SgiZH64Q&r=I4dzGxR31O
> cNXCJfQzvlsiLQfucBXRucPvdrphpBsFA&m=0OdW9CNquRYyYh-9qP2-
> 7g6OPxhpLPz7bxvfC5-ChV0&s=kFNlNmHGI6REi9GUIcB65rA-
> SxCYWWB7CE4aNrN5TLc&e= >