Subject: Re: [lmap] draft-ietf-lmap-information-model-06: New additions for Schedule Object

From: Juergen Schoenwaelder <[email-masked]>
Date: Wed, 23 Sep 2015 17:38:29 +0200

Tim,

I agree that we should add more status objects that report the state
of things that can have a state. In the current model, schedules can
be suppressed so that should be reported.

/js

On Tue, Jul 28, 2015 at 06:08:04PM +0000, Carey, Timothy (Timothy) wrote:
> Juergen,
> 
> To help with the controller timeout, I added an indicator to the schedule in TR-069 that shows if the Schedule should be used for MA Control actions. Likewise I added a status parameter to tell if the Schedule is currently operationally disabled.
> 
> Do you think we can add these to the information model?
> 
> Status
> 
> string
> 
> -
> 
> The current operational state of the Schedule. Enumeration of:
> 
>   *   Enabled
>   *   Disabled-MA-ControllerTimout
>   *   Disabled-Other
>   *   Error (OPTIONAL)
> The Error value MAY be used by the CPE to indicate a locally defined error condition.
> 
> 
> 
> UseForMAControl
> 
> boolean
> 
> W
> 
> This parameter defines if the Schedule is to be used for Actions that specific to the
> 
> 
> BR,
> Tim

> _______________________________________________
> lmap mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lmap

-- 
Juergen Schoenwaelder           Jacobs University Bremen gGmbH
Phone: +49 421 200 3587         Campus Ring 1 | 28759 Bremen | Germany
Fax:   +49 421 200 3103         <http://www.jacobs-university.de/>

---

From: "Carey, Timothy (Timothy)" <[email-masked]>
Date: Fri, 25 Sep 2015 14:10:45 +0000

Ok - I added the below to the Schedule as a Status attributes and will await what the IM includes.

BR,
Tim

-----Original Message-----
From: Juergen Schoenwaelder [mailto:[email-masked]] 
Sent: Wednesday, September 23, 2015 10:38 AM
To: Carey, Timothy (Timothy)
Cc: [email-masked]
Subject: Re: [lmap] draft-ietf-lmap-information-model-06: New additions for Schedule Object

Tim,

I agree that we should add more status objects that report the state of things that can have a state. In the current model, schedules can be suppressed so that should be reported.

/js