Subject: [lp-wan] LPWAN Architecture names

From: Ana Minaburo <[email-masked]>
Date: Wed, 21 Sep 2016 10:22:28 +0200

Hello everybody,

I hope you are fine!, Here I’m again after some weeks off.

I started working on the architecture for the LPWAN. Based on the
presentation made during the Berlin BoF, We need to agree on how we name
each device on the LPWAN architecture. As you can see in the following
table, each technology gives a different name to the same functionality
device.  Which could be the best name at IETF for these devices, are you
agree in my proposition?

Thanks

Ana

⎮
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------⎮

⎮      Function⧹ Technology     ⎮       LORAWAN       ⎮            NB-IOT
                        ⎮            SIGFOX             ⎮           IETF
                  ⎮

⎮
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------⎮

⎮     Sensor, Actuator, object   ⎮       End Device       ⎮           User
Equipment            ⎮          End Point             ⎮            NODE
            ⎮

⎮
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------⎮

⎮    Transceiver, Antenna        ⎮          Gateway        ⎮
           Evolved Node B           ⎮         Base Station          ⎮
 RADIO GATEWAY       ⎮

⎮
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------⎮

⎮          Network  Server         ⎮   Network Server    ⎮
           Serving-Gateway          ⎮       Service Center         ⎮
NETWORK GATEWAY ⎮

⎮
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------⎮

⎮  Registar, Security Server   ⎮       Join Server       ⎮     Home
Subscriber Server     ⎮   Registration Authority  ⎮ REGISTRAR (As in SIP) ⎮

⎮                                              ⎮
     ⎮                                                  ⎮
                    ⎮   or AAA (as Mobile-IP)   ⎮

⎮
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------⎮

⎮      Application Server          ⎮  Application Server ⎮  Packet Data
Node Gateway  ⎮   Network Application     ⎮   APPLICATION SERVER ⎮

⎮
------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------⎮

---

From: Thomas Watteyne <[email-masked]>
Date: Wed, 21 Sep 2016 10:25:41 +0200

I don't undertsand the different between radio GW and network GW. Maybe
"non-routing node" (intead of node), "routing node" (instead of node) and
"gateway" (instead of newtwork GW)?
PLease point out if I'm missing something

On Wed, Sep 21, 2016 at 10:22 AM, Ana Minaburo <[email-masked]> wrote:

> ⎮ ------------------------------------------------------------
> ------------------------------------------------------------
> ----------------------------------------------------------⎮
>
> ⎮ ------------------------------------------------------------
> ------------------------------------------------------------
> ----------------------------------------------------------⎮
>
> ⎮ ------------------------------------------------------------
> ------------------------------------------------------------
> ----------------------------------------------------------⎮
>
> ⎮ ------------------------------------------------------------
> ------------------------------------------------------------
> ----------------------------------------------------------⎮
>
> ⎮ ------------------------------------------------------------
> ------------------------------------------------------------
> ----------------------------------------------------------⎮
>
> ⎮ ------------------------------------------------------------
> ------------------------------------------------------------
> ------------------------------------------------------------⎮
>
> ⎮ ------------------------------------------------------------
> ------------------------------------------------------------
> ------------------------------------------------------------⎮
>
>
>
> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan
>
>

-- 
_______________________________________

Thomas Watteyne, PhD
Research Scientist & Innovator, Inria
Sr Networking Design Eng, Linear Tech
Founder & co-lead, UC Berkeley OpenWSN
Co-chair, IETF 6TiSCH

www.thomaswatteyne.com
_______________________________________

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 21 Sep 2016 09:28:58 +0000

Hello Thomas and Ana:

I think that the IETF ‘node’ in the first row is really a ‘host’, since it is an end point. The classical name for the router is a (network) gateway, so I’m happy with what Ana placed there, but I’d add ‘router’ to that entry.
The radio gateway may or may not go all the way to L3, IOW it could be a translating bridge, to be determined. And even if it reforms IP packets, it really acts like a bus in a PC that relays packets from the radio adapter, it does not route, just passes on. Then again I’m happy with the terminology.

What do others think?

Pascal

From: lp-wan [mailto:[email-masked]] On Behalf Of Thomas Watteyne
Sent: mercredi 21 septembre 2016 10:26
To: Ana Minaburo <[email-masked]>
Cc: lp-wan <[email-masked]>
Subject: Re: [lp-wan] LPWAN Architecture names

I don't undertsand the different between radio GW and network GW. Maybe "non-routing node" (intead of node), "routing node" (instead of node) and "gateway" (instead of newtwork GW)?
PLease point out if I'm missing something

On Wed, Sep 21, 2016 at 10:22 AM, Ana Minaburo <[email-masked]<mailto:[email-masked]>> wrote:

Hello everybody,

I started working on the architecture for the LPWAN. Based on the presentation made during the Berlin BoF, We need to agree on how we name each device on the LPWAN architecture. As you can see in the following table, each technology gives a different name to the same functionality device.  Which could be the best name at IETF for these devices, are you agree in my proposition?

Thanks

Ana

⎮ ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------⎮

⎮      Function⧹ Technology     ⎮       LORAWAN       ⎮            NB-IOT                         ⎮            SIGFOX             ⎮           IETF                     ⎮

⎮ ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------⎮

⎮     Sensor, Actuator, object   ⎮       End Device       ⎮           User Equipment            ⎮          End Point             ⎮            NODE                 ⎮

⎮ ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------⎮

⎮    Transceiver, Antenna        ⎮          Gateway        ⎮            Evolved Node B           ⎮         Base Station          ⎮  RADIO GATEWAY       ⎮

⎮ ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------⎮

⎮          Network  Server         ⎮   Network Server    ⎮            Serving-Gateway          ⎮       Service Center         ⎮ NETWORK GATEWAY ⎮

⎮ ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------⎮

⎮  Registar, Security Server   ⎮       Join Server       ⎮     Home Subscriber Server     ⎮   Registration Authority  ⎮ REGISTRAR (As in SIP) ⎮

⎮                                              ⎮                                ⎮                                                  ⎮                                       ⎮   or AAA (as Mobile-IP)   ⎮

⎮ ------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------⎮

⎮      Application Server          ⎮  Application Server ⎮  Packet Data Node Gateway  ⎮   Network Application     ⎮   APPLICATION SERVER ⎮

⎮ ------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------⎮

_______________________________________________
lp-wan mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lp-wan

Thomas Watteyne, PhD

www.thomaswatteyne.com<http://www.thomaswatteyne.com>
_______________________________________

---

From: Juan Carlos Zuniga <[email-masked]>
Date: Wed, 21 Sep 2016 13:44:54 +0000

Hi all,

I like the analysis made by Pascal.

Some comments in-line:

From: lp-wan [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: September 21, 2016 5:29 AM
To: Thomas Watteyne <[email-masked]>; Ana Minaburo <[email-masked]>
Cc: lp-wan <[email-masked]>
Subject: Re: [lp-wan] LPWAN Architecture names

Hello Thomas and Ana:

I think that the IETF ‘node’ in the first row is really a ‘host’, since it is an end point.
[JCZ] This is true. I’m just wondering if host is a fair definition for all types of LPWAN devices, since some of them may be running a full IP stack, but some others may be extremely simple (like a sensor with just a microcontroller and a radio). End Device seems to be generic enough.
The classical name for the router is a (network) gateway, so I’m happy with what Ana placed there, but I’d add ‘router’ to that entry.
[JCZ] I agree. It is a Network Gateway.
The radio gateway may or may not go all the way to L3, IOW it could be a translating bridge, to be determined. And even if it reforms IP packets, it really acts like a bus in a PC that relays packets from the radio adapter, it does not route, just passes on.
[JCZ] True. I think calling it gateway may be confusing. In IEEE this type of node is called Point of Attachment, Access Point, or Base Station, depending on the radio technology.

Best,

Juan Carlos

Then again I’m happy with the terminology.

What do others think?

Pascal

From: lp-wan [mailto:[email-masked]] On Behalf Of Thomas Watteyne
Sent: mercredi 21 septembre 2016 10:26
To: Ana Minaburo <[email-masked]<mailto:[email-masked]>>
Cc: lp-wan <[email-masked]<mailto:[email-masked]>>
Subject: Re: [lp-wan] LPWAN Architecture names

Hello everybody,

Thanks

Ana

Thomas Watteyne, PhD

---

From: Ana Minaburo <[email-masked]>
Date: Wed, 21 Sep 2016 16:21:58 +0200

Hello,

see comment ...

On Wed, Sep 21, 2016 at 3:44 PM, Juan Carlos Zuniga <
[email-masked]> wrote:

> *From:* lp-wan [mailto:[email-masked]] *On Behalf Of *Pascal
> Thubert (pthubert)
> *Sent:* September 21, 2016 5:29 AM
> *To:* Thomas Watteyne <[email-masked]>; Ana Minaburo <
> [email-masked]>
> *Cc:* lp-wan <[email-masked]>
> *Subject:* Re: [lp-wan] LPWAN Architecture names
>
>
>
> Hello Thomas and Ana:
>
>
>
> *[JCZ] This is true. I’m just wondering if host is a fair definition for
> all types of LPWAN devices, since some of them may be running a full IP
> stack, but some others may be extremely simple (like a sensor with just a
> microcontroller and a radio). End Device seems to be generic enough.*
>

 [Ana] But the problem with 'end device' is that it could also means edge
router in and end to end communication. So I really prefer host or endpoint

The classical name for the router is a (network) gateway, so I’m happy with
> what Ana placed there, but I’d add ‘router’ to that entry.
>
> *[JCZ] I agree. It is a Network Gateway.*
>
[Ana] I've leave Network Gateway and put or Router

> The radio gateway may or may not go all the way to L3, IOW it could be a
> translating bridge, to be determined. And even if it reforms IP packets, it
> really acts like a bus in a PC that relays packets from the radio adapter,
> it does not route, just passes on.
>
> *[JCZ] True. I think calling it gateway may be confusing. In IEEE this
> type of node is called Point of Attachment, Access Point, or Base Station,
> depending on the radio technology.*
>
[Ana] Why not Bridge

thanks
Ana

> *Best,*
> *Juan Carlos *
> *From:* lp-wan [mailto:[email-masked] <[email-masked]>] *On
> Behalf Of *Thomas Watteyne
> *Sent:* mercredi 21 septembre 2016 10:26
> *To:* Ana Minaburo <[email-masked]>
> *Cc:* lp-wan <[email-masked]>
> *Subject:* Re: [lp-wan] LPWAN Architecture names
>
>
>
> ⎮     Sensor, Actuator, object   ⎮       End Device       ⎮
>           User Equipment            ⎮          End Point             ⎮
>            NODE                 ⎮
>

---

From: ""Pieter De Mil (allóra Factory)"" <[email-masked]>
Date: Wed, 21 Sep 2016 16:31:20 +0200

sensor, end device, actuator, object: let’s do something funny and call it Thing

> On 21 Sep 2016, at 16:21, Ana Minaburo <[email-masked]> wrote:
> 
> Hello,
> 
> see comment ...
> 
> On Wed, Sep 21, 2016 at 3:44 PM, Juan Carlos Zuniga <[email-masked] <mailto:[email-masked]>> wrote:
> Hi all,
> 
>  
> 
> From: lp-wan [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Pascal Thubert (pthubert)
> To: Thomas Watteyne <[email-masked] <mailto:[email-masked]>>; Ana Minaburo <[email-masked] <mailto:[email-masked]>>
> Cc: lp-wan <[email-masked] <mailto:[email-masked]>>
>  [Ana] But the problem with 'end device' is that it could also means edge router in and end to end communication. So I really prefer host or endpoint
> 
> 
> From: lp-wan [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Thomas Watteyne
> To: Ana Minaburo <[email-masked] <mailto:[email-masked]>>
> Cc: lp-wan <[email-masked] <mailto:[email-masked]>>
> On Wed, Sep 21, 2016 at 10:22 AM, Ana Minaburo <[email-masked] <mailto:[email-masked]>> wrote:
> 
> Hello everybody,
> 
>  
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/lp-wan <https://www.ietf.org/mailman/listinfo/lp-wan>
> 
> 
>  
> 
> -- 
> 
> www.thomaswatteyne.com <http://www.thomaswatteyne.com/>

---

From: Alexander Pelov <[email-masked]>
Date: Wed, 21 Sep 2016 16:38:30 +0200

Dear all,

On the Radio-GW and Network-GW, and why use "Gateway" in the name:
- In the LoRa world (unfortunately) the term Gateway has been used for the Radio-GW, which could lead to ambiguity when considering a larger scope. The ambiguity comes from the fact that we’re quite used to having application-level gateways, or at least not call the Access Points / Bridges / Base Stations as such.

For me it seems that having Radio-GW and Network-GW removes the ambiguity with respect of the LoRa community, which is one of the baseline technologies for us.

Best,
Alexander

> Le 21 sept. 2016 à 16:21, Ana Minaburo <[email-masked]> a écrit :
> 
> Hello,
> 
> see comment ...
>

---

From: Juan Carlos Zuniga <[email-masked]>
Date: Wed, 21 Sep 2016 15:34:21 +0000

Hi,

I’m all for Pieter’s “Thing” proposal ☺

Some more responses to Ana below:

From: [email-masked] [mailto:[email-masked]] On Behalf Of Ana Minaburo
Sent: September 21, 2016 10:22 AM
To: Juan Carlos Zuniga <[email-masked]>
Cc: Pascal Thubert (pthubert) <[email-masked]>; Thomas Watteyne <[email-masked]>; lp-wan <[email-masked]>
Subject: Re: [lp-wan] LPWAN Architecture names

Hello,

see comment ...

On Wed, Sep 21, 2016 at 3:44 PM, Juan Carlos Zuniga <[email-masked]<mailto:[email-masked]>> wrote:
Hi all,

Some comments in-line:

From: lp-wan [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Pascal Thubert (pthubert)
Sent: September 21, 2016 5:29 AM
To: Thomas Watteyne <[email-masked]<mailto:[email-masked]>>; Ana Minaburo <[email-masked]<mailto:[email-masked]>>
Cc: lp-wan <[email-masked]<mailto:[email-masked]>>
Subject: Re: [lp-wan] LPWAN Architecture names

Hello Thomas and Ana:

 [Ana] But the problem with 'end device' is that it could also means edge router in and end to end communication. So I really prefer host or endpoint
[JCZ] End Point would also work for me.

[JCZ] Both are fine.
[JCZ] Bridge, just like router, has a very specific meaning, as it is an IEEE 802.1 function, connecting 2 L2 domains, and forwarding only packets from one domain to the other when the destination address is not in the same domain as the source address. In our case this function is simply relaying packets, sometimes it performs some L2 functions, sometimes some L3 functions, and it is always a radio/wireless device.

thanks
Ana

Best,

Juan Carlos

What do others think?

Pascal

Hello everybody,

Thanks

Ana

Thomas Watteyne, PhD

---

From: Laurent Toutain <[email-masked]>
Date: Wed, 21 Sep 2016 18:08:19 +0200

Hi,

Why not put LPWAN in front of each name:
- LPWAN-Host (LH)
- LPWAN-Radio-GW (LR)
- LPWAN-Gateway (LG)

> microcontroller and a radio). End Device seems to be generic enough. *
>

For me it is optimization to say that some sensor (LH) will be extremely
simple. The IETF model must be preserved. A node should be have the
capability to forward packets.

Laurent

> The classical name for the router is a (network) gateway, so I’m happy
> with what Ana placed there, but I’d add ‘router’ to that entry.
>
>
>
> *Juan Carlos *
>
>
>

-- 
Laurent Toutain
+--- VoIP (recommended) ---+----------- Télécom Bretagne -----------+
| Tel: +33 2 22 06 8156    | Tel: + 33 2 99 12 7026                 | Visit
:
| Mob: +33 6 800 75 900    |                                        |
| Fax: +33 2 22 06 8445    | Fax: +33 2 99 12 7030                  |
http://class.touta.in
| [email-masked]         | [email-masked]    |
+--------------------------+----------------------------------------+