Subject: [lp-wan] IPv6 SCHC dispatch header

From: Rahul Jadhav <[email-masked]>
Date: Sat, 19 Nov 2016 21:39:26 +0900

Dear SCHC authors,

During the meet, there was a question whether dispatch header for SCHC
would be required for LPWAN.
And the general mood in the room was to not to have it.
Imo it has bigger implications and the primary one been that it wont be
possible to have different capability (for e.g. SCHC + 6Lo) devices in the
same LPWAN connected to the same gateway on the same wireless interface.
While this makes sense for a SIGFOX or LoRaWAN like network, I feel for
NB-IoT or Wi-Sun where there is a possibility that different capability
nodes connect to the gateway on the same interface, the presence of
dispatch header might help.

My opinion is, a dispatch header defined for SCHC-IPv6 might actually help
and the deployment may chose to use it or not.  If the deployment is a pure
SCHC based then the dispatch hdr could be omitted (nodes/gw know after it
as part of commissioning or something)

Regards,
Rahul

---

From: Laurent Toutain <[email-masked]>
Date: Sun, 20 Nov 2016 16:26:34 +0100

Hi Rahul,

A dispatch can be a good idea to mix LPWAN and 6lo and is not incompatible
with what we propose. In fact, we don't want to impose global values for
coding a rule, since it leads to large identifiers (in some technologies,
the rule ID can be few bits long). Since the rule id is a convention
between both ends, we can imagine that some values are reserved for this
dispatch value.

Laurent

On Sat, Nov 19, 2016 at 1:39 PM, Rahul Jadhav <[email-masked]> wrote:

> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan
>
>

-- 
Laurent Toutain
+--- VoIP (recommended) ---+----------- Télécom Bretagne -----------+
| Tel: +33 2 22 06 8156    | Tel: + 33 2 99 12 7026                 | Visit
:
| Mob: +33 6 800 75 900    |                                        |
| Fax: +33 2 22 06 8445    | Fax: +33 2 99 12 7030                  |
http://class.touta.in
| [email-masked]         | [email-masked]    |
+--------------------------+----------------------------------------+

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Sun, 20 Nov 2016 13:11:34 -0300

Laurent, Rahul:
                       Then creating a new rule with the dispatch header
is possible using the method explained on the SCHC. Do you mean
that we have to modify an existing rule to add the dispatch header?
Regards,

                                        Diego

2016-11-20 12:26 GMT-03:00 Laurent Toutain <
[email-masked]>:

>> My opinion is, a dispatch header defined for SCHC-IPv6 might actually
>> help and the deployment may chose to use it or not.  If the deployment is a
>> pure SCHC based then the dispatch hdr could be omitted (nodes/gw know after
>> it as part of commissioning or something)
>>
>> Regards,
>> Rahul
>>
> | Tel: +33 2 22 06 8156    | Tel: + 33 2 99 12 7026                 |
> Visit :

-- 
DIEGO DUJOVNE
Profesor Asociado
Escuela de Informática y Telecomunicaciones
Facultad de Ingeniería - Universidad Diego Portales - Chile
www.ingenieria.udp.cl
(56 2) 676 8125

---

From: Rahul Jadhav <[email-masked]>
Date: Mon, 21 Nov 2016 14:03:48 +0900

I think there is some confusion regarding what i intend to say.
My intent is to allow a dispatch header for SCHC-IPv6. Using this, a
gateway receiving a SCHC-compressed packet or a 6Lo compressed packet or a
regular IPv6 packet would be able to differentiate between what its
receiving and then processing accordingly.

@Diego, The dispatch header cannot be clubbed with the SCHC rules i.e. I
don't mean that we modify an existing rule to add dispatch header. This
would not make sense.

@Laurent, As you mentioned, i agree that a dispatch is not incompatible
with what you proposed. I just meant that it makes sense to define a
dispatch header.

Regards,
Rahul

On 20 Nov 2016 9:41 p.m., "Prof. Diego Dujovne" <[email-masked]>
wrote:

> 2016-11-20 12:26 GMT-03:00 Laurent Toutain <Laurent.Toutain@telecom-
> bretagne.eu>:
>
>> Hi Rahul,
>>
>> A dispatch can be a good idea to mix LPWAN and 6lo and is not
>> incompatible with what we propose. In fact, we don't want to impose global
>> values for coding a rule, since it leads to large identifiers (in some
>> technologies, the rule ID can be few bits long). Since the rule id is a
>> convention between both ends, we can imagine that some values are reserved
>> for this dispatch value.
>>
>> Laurent
>>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 21 Nov 2016 10:00:38 +0000

I read that this boils down to saying is rule is rule 0 then whatever comes next is not what’s specified in SCHC (Can we agree to pronounce is shic (chic in French) as Carsten proposed BTW), and equivalent to 6LoWPAN’s NALP, in this case that would be non-SCHC.

The difference is that we have not documented any reason/need to define whatever goes in case of non-SCHC (do we?), so let us not do that now.

Cheers,

Pascal

From: lp-wan [mailto:[email-masked]] On Behalf Of Rahul Jadhav
Sent: lundi 21 novembre 2016 06:04
To: Prof. Diego Dujovne <[email-masked]>
Cc: lp-wan <[email-masked]>; Laurent Toutain <[email-masked]>
Subject: Re: [lp-wan] IPv6 SCHC dispatch header

I think there is some confusion regarding what i intend to say.
My intent is to allow a dispatch header for SCHC-IPv6. Using this, a gateway receiving a SCHC-compressed packet or a 6Lo compressed packet or a regular IPv6 packet would be able to differentiate between what its receiving and then processing accordingly.

@Diego, The dispatch header cannot be clubbed with the SCHC rules i.e. I don't mean that we modify an existing rule to add dispatch header. This would not make sense.

@Laurent, As you mentioned, i agree that a dispatch is not incompatible with what you proposed. I just meant that it makes sense to define a dispatch header.

Regards,
Rahul

On 20 Nov 2016 9:41 p.m., "Prof. Diego Dujovne" <[email-masked]<mailto:[email-masked]>> wrote:
Laurent, Rahul:
                       Then creating a new rule with the dispatch header
is possible using the method explained on the SCHC. Do you mean
that we have to modify an existing rule to add the dispatch header?
Regards,
                                        Diego

2016-11-20 12:26 GMT-03:00 Laurent Toutain <[email-masked]<mailto:[email-masked]>>:
Hi Rahul,
A dispatch can be a good idea to mix LPWAN and 6lo and is not incompatible with what we propose. In fact, we don't want to impose global values for coding a rule, since it leads to large identifiers (in some technologies, the rule ID can be few bits long). Since the rule id is a convention between both ends, we can imagine that some values are reserved for this dispatch value.
Laurent

On Sat, Nov 19, 2016 at 1:39 PM, Rahul Jadhav <[email-masked]<mailto:[email-masked]>> wrote:
Dear SCHC authors,

During the meet, there was a question whether dispatch header for SCHC would be required for LPWAN.
And the general mood in the room was to not to have it.
Imo it has bigger implications and the primary one been that it wont be possible to have different capability (for e.g. SCHC + 6Lo) devices in the same LPWAN connected to the same gateway on the same wireless interface.
While this makes sense for a SIGFOX or LoRaWAN like network, I feel for NB-IoT or Wi-Sun where there is a possibility that different capability nodes connect to the gateway on the same interface, the presence of dispatch header might help.

My opinion is, a dispatch header defined for SCHC-IPv6 might actually help and the deployment may chose to use it or not.  If the deployment is a pure SCHC based then the dispatch hdr could be omitted (nodes/gw know after it as part of commissioning or something)

Regards,
Rahul

_______________________________________________
lp-wan mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lp-wan

--
Laurent Toutain
+--- VoIP (recommended) ---+----------- Télécom Bretagne -----------+
| Tel: +33 2 22 06 8156<tel:%2B33%202%2022%2006%208156>    | Tel: + 33 2 99 12 7026<tel:%2B%2033%202%2099%2012%207026>                 | Visit :
| Mob: +33 6 800 75 900    |                                        |
| Fax: +33 2 22 06 8445<tel:%2B33%202%2022%2006%208445>    | Fax: +33 2 99 12 7030<tel:%2B33%202%2099%2012%207030>                  |  http://class.touta.in
| [email-masked]<mailto:[email-masked]>         | [email-masked]<http://ne.eu>    |
+--------------------------+----------------------------------------+

_______________________________________________
lp-wan mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lp-wan

--
DIEGO DUJOVNE
Profesor Asociado
Escuela de Informática y Telecomunicaciones
Facultad de Ingeniería - Universidad Diego Portales - Chile
www.ingenieria.udp.cl<http://www.ingenieria.udp.cl>
(56 2) 676 8125

---

From: Rahul Jadhav <[email-masked]>
Date: Mon, 21 Nov 2016 19:35:51 +0900

Yep, that's totally fine. We can wait till the time arise for such a
need/reason.

Regards,
Rahul

On 21 Nov 2016 3:30 p.m., "Pascal Thubert (pthubert)" <[email-masked]>
wrote:

> I read that this boils down to saying is rule is rule 0 then whatever
> comes next is not what’s specified in SCHC (Can we agree to pronounce is
> shic (chic in French) as Carsten proposed BTW), and equivalent to 6LoWPAN’s
> NALP, in this case that would be non-SCHC.
>
>
>
> The difference is that we have not documented any reason/need to define
> whatever goes in case of non-SCHC (do we?), so let us not do that now.
>
>
>
> Cheers,
>
>
>
> Pascal
>
>
>
> *From:* lp-wan [mailto:[email-masked]] *On Behalf Of *Rahul
> Jadhav
> *Sent:* lundi 21 novembre 2016 06:04
> *To:* Prof. Diego Dujovne <[email-masked]>
> *Cc:* lp-wan <[email-masked]>; Laurent Toutain <Laurent.Toutain@telecom-
> bretagne.eu>
> *Subject:* Re: [lp-wan] IPv6 SCHC dispatch header
>
>
>

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Mon, 21 Nov 2016 07:56:06 -0300

That was what I meant. You have a rule, you need a new header, you can add
it after without modifying the rule scheme.
Regards,

                 Diego

---

From: Laurent Toutain <[email-masked]>
Date: Mon, 21 Nov 2016 15:02:27 +0100

Hi Rahul,

> with what you proposed. I just meant that it makes sense to define a

Ok, let's work on it to see how we can put it into a rule definition.

>> 2016-11-20 12:26 GMT-03:00 Laurent Toutain <Laurent.Toutain@telecom-breta
>> gne.eu>:
>>
>>> Hi Rahul,
>>>