Subject: Re: [lp-wan] Fwd: New Version Notification for draft-farrell-lpwan-overview-04.txt

From: Alexander Pelov <[email-masked]>
Date: Wed, 2 Nov 2016 00:20:08 +0100

Dear Stephen,

Thanks for managing to organize and publish the LPWAN overview draft under such a short notice! I’d also like to thank all co-authors who contributed invaluable pieces of their drafts to this first document which will give us a solid base for our future work.

@all: please, read the latest version (there is a single sentence difference between the datatracker and the editor’s copy, so I imagine you’ll be OK reading any one of them). Your input to the Editor and to the co-authours will be invaluable. 

@all: we’ll have a call for adoption as WG item of this document in Seoul. There could be many modifications after the adoption, but we really need to discuss the approach, the structure and your recommendations. 

Best,
Alexander

> Le 31 oct. 2016 à 23:53, Stephen Farrell <[email-masked]> a écrit :
> 
> 
> Change made to editor's copy [1]
> 
> S
> 
> [1] https://github.com/sftcd/lpwan-ov
> 
> On 31/10/16 22:50, Juan Carlos Zuniga wrote:
>> Hi Stephen,
>> 
>> Thanks for generating this!
>> 
>> I just found one quick correction to be considered for the next revision (whenever this comes).
>> 
>>> From the new text added in 2.3.2:
>> "...which can vary from sending less than one message per device per day to about ten messages per device per day."
>> 
>> Change to:
>> "...which can vary from sending less than one message per device per day to dozens of messages per device per day."
>> 
>> I think that's a better characterization of the more demanding use cases. 
>> 
>> Cheers,
>> 
>> Juan Carlos 
>> 
>>> -----Original Message-----
>>> From: lp-wan [mailto:[email-masked]] On Behalf Of Stephen Farrell
>>> Sent: October 31, 2016 6:14 PM
>>> To: lp-wan <[email-masked]>
>>> Subject: [lp-wan] Fwd: New Version Notification for draft-farrell-lpwan-
>>> overview-04.txt
>>> 
>>> 
>>> Hiya,
>>> 
>>> Version -03 was the one that I think had all the input text provided so far,
>>> more-or-less exactly as provided.
>>> 
>>> This -04 version is the result of a first pass at editing all of that in one lump.
>>> 
>>> This is the last version I'll post before the cutoff so is the one to read before
>>> IETF97. If you are one of the providers of input text, checking that I didn't muck
>>> up too badly via the diff between -03 and -04 may be a good thing for you to
>>> do. Those and any other comments are most welcome.
>>> 
>>> Cheers,
>>> S.
>>> 
>>> 
>>> -------- Forwarded Message --------
>>> Subject: New Version Notification for draft-farrell-lpwan-overview-04.txt
>>> Date: Mon, 31 Oct 2016 15:09:26 -0700
>>> From: [email-masked]
>>> To: Stephen Farrell <[email-masked]>
>>> 
>>> 
>>> A new version of I-D, draft-farrell-lpwan-overview-04.txt
>>> has been successfully submitted by Stephen Farrell and posted to the IETF
>>> repository.
>>> 
>>> Name:		draft-farrell-lpwan-overview
>>> Revision:	04
>>> Title:		LPWAN Overview
>>> Document date:	2016-10-31
>>> Group:		Individual Submission
>>> Pages:		35
>>> URL:
>>> https://www.ietf.org/internet-drafts/draft-farrell-lpwan-overview-04.txt
>>> Status:
>>> https://datatracker.ietf.org/doc/draft-farrell-lpwan-overview/
>>> Htmlized:       https://tools.ietf.org/html/draft-farrell-lpwan-overview-04
>>> Diff:
>>> https://www.ietf.org/rfcdiff?url2=draft-farrell-lpwan-overview-04
>>> 
>>> Abstract:
>>>   Low Power Wide Area Networks (LPWAN) are wireless technologies with
>>>   characteristics such as large coverage areas, low bandwidth, possibly
>>>   very small packet and application layer data sizes and long battery
>>>   life operation.  This memo is an informational overview of the set of
>>>   LPWAN technologies being considered in the IETF and of the gaps that
>>>   exist between the needs of those technologies and the goal of running
>>>   IP in LPWANs.
>>> 
>>> 
>>> 
>>> 
>>> Please note that it may take a couple of minutes from the time of submission
>>> until the htmlized version and diff are available at tools.ietf.org.
>>> 
>>> The IETF Secretariat
>>> 
>> 
>> _______________________________________________
>> lp-wan mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/lp-wan
>> 
> 
> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan

---

From: Alper Yegin <[email-masked]>
Date: Wed, 2 Nov 2016 22:16:38 +0200

Hello,

Quick feedback: I recommend we keep this I-D as "overview of LPWAN
technologies" (as the name suggests) and tackle the gap analysis in a
separate document.

Alper

On Wed, Nov 2, 2016 at 1:20 AM, Alexander Pelov <[email-masked]> wrote:

> Dear Stephen,
>
> Thanks for managing to organize and publish the LPWAN overview draft under
> such a short notice! I’d also like to thank all co-authors who contributed
> invaluable pieces of their drafts to this first document which will give us
> a solid base for our future work.
>
> @all: please, read the latest version (there is a single sentence
> difference between the datatracker and the editor’s copy, so I imagine
> you’ll be OK reading any one of them). Your input to the Editor and to the
> co-authours will be invaluable.
>
> @all: we’ll have a call for adoption as WG item of this document in Seoul.
> There could be many modifications after the adoption, but we really need to
> discuss the approach, the structure and your recommendations.
>
> Best,
> Alexander
>
>
>
> >> "...which can vary from sending less than one message per device per
> day to about ten messages per device per day."
> >>
> >> Change to:
> >> "...which can vary from sending less than one message per device per
> day to dozens of messages per device per day."
> >>

---

From: "Carles Gomez Montenegro" <[email-masked]>
Date: Wed, 2 Nov 2016 21:39:56 +0100

Hi Alper,

No doubt that the "overview" part is fundamental here.

However, item 1 in the WG charter also includes:

   "This work will document the common characteristics and highlight actual
    needs that the IETF could serve"

I understand that this component of item 1 is covered by the "gap
analysis" content.

Cheers,

Carles

>> > Le 31 oct. 2016 à 23:53, Stephen Farrell <[email-masked]>
>> a
>> écrit :
>> >
>> >
>> >>> This -04 version is the result of a first pass at editing all of
>> that
>> in one lump.
>> >>>
>> >>> This is the last version I'll post before the cutoff so is the one
>> to
>> read before
>> >>> IETF97. If you are one of the providers of input text, checking that
>> I
>> didn't muck
>> >>> up too badly via the diff between -03 and -04 may be a good thing
>> for
>> you to

---

From: Alper Yegin <[email-masked]>
Date: Wed, 2 Nov 2016 22:58:13 +0200

Hi Carles,

LPWAN tech overview, by itself, is something we can complete much faster,
it is self-contained and has a lot of value on its own.

Gap analysis would take longer, requiring lot of analysis and deeper
understanding of each technology.

I'd still "suggest" we not bundle up the overview and the gap analysis,
even though the charter suggests otherwise.

Alper

---

From: Alexander Pelov <[email-masked]>
Date: Wed, 2 Nov 2016 23:22:34 +0100

Dear Alper, Carles,

As with the other tech I-Ds, I think that the LPWAN overview will not take the whole content of the Gap analysis document (this is my personal opinion - it actually depends on the editor and the discussions on the mailing list). 

We must deliver what our charter indicates. 

I am under the impression that it would be pretty straightforward for Stephen, Ana, Carles and the rest of the co-authors to identify which parts to keep in the LPWAN overview and which to leave for the Gap analysis document, and confirm this with the WG. I agree with you, Alper, that the whole Gap analysis document may not be suitable for the LPWAN overview. I also agree with you that we do not want to spend years on it. It seems to me that the best way to advance in this direction is the current one - take the existing and cut out the parts which are too much (if any). The Gap analysis is the fruit of almost an year of work over the mailing list and I feel that it will take much more time rewriting the relevant parts from scratch.

Does this sound reasonable to you?

Best,
Alexander

> Le 2 nov. 2016 à 21:58, Alper Yegin <[email-masked]> a écrit :
> 
> Hi Carles,
> 
> LPWAN tech overview, by itself, is something we can complete much faster, it is self-contained and has a lot of value on its own. 
> 
> Gap analysis would take longer, requiring lot of analysis and deeper understanding of each technology.
> 
> I'd still "suggest" we not bundle up the overview and the gap analysis, even though the charter suggests otherwise.
> 
> Alper
> 
> 
> 
> 
> 
> On Wed, Nov 2, 2016 at 10:39 PM, Carles Gomez Montenegro <[email-masked] <mailto:[email-masked]>> wrote:
> Hi Alper,
> 
> > On Wed, Nov 2, 2016 at 1:20 AM, Alexander Pelov <[email-masked] <mailto:[email-masked]>> wrote:
> >
> >> Dear Stephen,
> >>
> >> > Le 31 oct. 2016 à 23:53, Stephen Farrell <[email-masked] <mailto:[email-masked]>>
> >> a
> >> écrit :
> >> >
> >> >
> >> > [1] https://github.com/sftcd/lpwan-ov <https://github.com/sftcd/lpwan-ov>
> >> >
> >> >>> From: lp-wan [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Stephen
> >> Farrell
> >> >>> To: lp-wan <[email-masked] <mailto:[email-masked]>>
> >> >>> From: [email-masked] <mailto:[email-masked]>
> >> >>> To: Stephen Farrell <[email-masked] <mailto:[email-masked]>>
> >> >>>
> >> >>>
> >> >>> https://www.ietf.org/internet-drafts/draft-farrell-lpwan- <https://www.ietf.org/internet-drafts/draft-farrell-lpwan->
> >> overview-04.txt
> >> >>> Status:
> >> >>> https://datatracker.ietf.org/doc/draft-farrell-lpwan-overview/ <https://datatracker.ietf.org/doc/draft-farrell-lpwan-overview/>
> >> >>> Htmlized:       https://tools.ietf.org/html/ <https://tools.ietf.org/html/>
> >> draft-farrell-lpwan-overview-04
> >> >>> Diff:
> >> >>> https://www.ietf.org/rfcdiff?url2=draft-farrell-lpwan-overview-04 <https://www.ietf.org/rfcdiff?url2=draft-farrell-lpwan-overview-04>
> >> >>>
> >> >>> Abstract:
> >> >>> until the htmlized version and diff are available at tools.ietf.org <http://tools.ietf.org/>.
> >> >>>
> >> >>> The IETF Secretariat
> >> >>>
> >> >>
> >> >> [email-masked] <mailto:[email-masked]>
> >> >> https://www.ietf.org/mailman/listinfo/lp-wan <https://www.ietf.org/mailman/listinfo/lp-wan>
> >> >>
> >> >
> >> > [email-masked] <mailto:[email-masked]>
> >> > https://www.ietf.org/mailman/listinfo/lp-wan <https://www.ietf.org/mailman/listinfo/lp-wan>
> >>
> >> [email-masked] <mailto:[email-masked]>
> >> https://www.ietf.org/mailman/listinfo/lp-wan <https://www.ietf.org/mailman/listinfo/lp-wan>
> >>
> > [email-masked] <mailto:[email-masked]>
> > https://www.ietf.org/mailman/listinfo/lp-wan <https://www.ietf.org/mailman/listinfo/lp-wan>
> >
> 
> 
>

---

From: Alper Yegin <[email-masked]>
Date: Thu, 3 Nov 2016 08:48:25 +0200

Hi Alexander,

Here's what we have right now:

- There are individual I-Ds per LPWAN tech, providing "overview."
- Then there's an I-D titled "LPWAN Overview", which imports some text from
somewhat bigger overviews (see above), but then proceeds to discussing "gap
analysis".

We need to untangle this.

I was suggesting each tech has its own I-D, which proceeds to informational
RFCs.

We talked about that, and I think people favored to have a single combined
overview I-D, which is fine.
But, that I-D has now gap analysis too.

(btw, let's also decide what happens to the individual documents.)

Now I'm suggesting, we split that I-D into two, one is "overview", and the
other is "gap analysis".

OK, if the group favors keeping them in a single document, so be it, but at
least let's rename the document properly :-)

Cheers,

Alper

On Thu, Nov 3, 2016 at 12:22 AM, Alexander Pelov <[email-masked]> wrote:

> Dear Alper, Carles,
>
> As with the other tech I-Ds, I think that the LPWAN overview will not take
> the whole content of the Gap analysis document (this is my personal opinion
> - it actually depends on the editor and the discussions on the mailing
> list).
>
> I am under the impression that it would be pretty straightforward for
> Stephen, Ana, Carles and the rest of the co-authors to identify which parts
> to keep in the LPWAN overview and which to leave for the Gap analysis
> document, and confirm this with the WG. I agree with you, Alper, that the
> whole Gap analysis document may not be suitable for the LPWAN overview. I
> also agree with you that we do not want to spend years on it. It seems to
> me that the best way to advance in this direction is the current one - take
> the existing and cut out the parts which are too much (if any). The Gap
> analysis is the fruit of almost an year of work over the mailing list and I
> feel that it will take much more time rewriting the relevant parts from
> scratch.
>
>> >> invaluable pieces of their drafts to this first document which will
>> give
>> >> us
>> >> There could be many modifications after the adoption, but we really
>> need
>> >> to
>> >> >>> Version -03 was the one that I think had all the input text
>> provided
>> >> so far,
>> >> >>> has been successfully submitted by Stephen Farrell and posted to
>> the
>> >> IETF
>> >> >>> repository.
>> >> >>>
>> >> >>>   life operation.  This memo is an informational overview of the
>> set
>> >> of

---

From: Alexander Pelov <[email-masked]>
Date: Thu, 3 Nov 2016 08:43:59 +0100

Hi Alper,

I think that you present the situation perfectly well and I agree with your analysis.

For me, the current "LPWAN overview" document (which can be renamed with no problems) is the starting point. Also agree with you that the individual I-Ds (including the Gap analysis) can (and probably will) continue to live their lives. 

One of the things where the current gap analysis document seems very useful to me is the common architecture and terminology section (there are potentially much more). It is of course none of our business to tell the different technology providers how to name their entities :) But, we must ensure that when we put a term in a draft/RFC there are no ambiguities.

So, to recap - I feel that the issues you point are very relevant and that we must take care to address them. I’d suggest that we wait for the next iteration of the « LPWAN overview » before getting deeper in the subject. In the mean time we can work with Stephen to identify which parts go where and how to have a more homogeneous document. 

Best,
Alexander

> Le 3 nov. 2016 à 07:48, Alper Yegin <[email-masked]> a écrit :
> 
> Hi Alexander,
> 
> - Then there's an I-D titled "LPWAN Overview", which imports some text from somewhat bigger overviews (see above), but then proceeds to discussing "gap analysis".
> 
> I was suggesting each tech has its own I-D, which proceeds to informational RFCs.
> 
> We talked about that, and I think people favored to have a single combined overview I-D, which is fine. 
> Now I'm suggesting, we split that I-D into two, one is "overview", and the other is "gap analysis". 
> 
> OK, if the group favors keeping them in a single document, so be it, but at least let's rename the document properly :-)
> 
> Cheers,
> 
> Alper
> 
> 
> 
> 
> On Thu, Nov 3, 2016 at 12:22 AM, Alexander Pelov <[email-masked] <mailto:[email-masked]>> wrote:
> Dear Alper, Carles,
> 
>> Le 2 nov. 2016 à 21:58, Alper Yegin <[email-masked] <mailto:[email-masked]>> a écrit :
>> 
>> Hi Carles,
>>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 3 Nov 2016 07:58:19 +0000

Hello Alper :

The charter is a contract with the IESG and that contract says one doc, with a very, very tight schedule. This is in line with the trend at the IETF to *not* publish many informational RFCs on requirements and such like. IOW; It is quite unclear that these many documents would end up published as RFCs, even if we tried. Going to 5 docs is a very big step vs. that contract, and will not meet the schedule constraints.

And I for one am very wary of the risk of a beauty contest; we want to help grow the whole LPWAN world so that everyone benefits, not an intestine dispute between technologies that would hurt them all; with the single document and an impartial editor, as we have now, this risk is greatly alleviated.

The document that we are mandated to write is an introduction to what LPWAN is and what the IETF can do about it. I agree with Alexander, Stephen’s document has the right shape, and that includes an overview of the gaps which Ana and the others can readily help extract.

So I’m really happy with the current status vs. the very aggressive schedule that the IESG has placed on us ; we have already a great document, good enough for adoption call.

I’m supportive on having personal submissions for the individual deep dives, very useful for the community, but publication as RFC is another matter. It will not happen with our current charter. A most probable path is that we observe the progress on the personal submissions and, based on that progress, we decide whether those documents can safely be taken all the way to RFC when time for rechartering comes. In particular, we must convince the IESG that the informational work will not slow down the standard track work.

Take care,

Pascal

From: lp-wan [mailto:[email-masked]] On Behalf Of Alper Yegin
Sent: jeudi 3 novembre 2016 07:48
To: Alexander Pelov <[email-masked]>
Cc: lp-wan <[email-masked]>; Juan Carlos Zuniga <[email-masked]>; Carles Gomez Montenegro <[email-masked]>; Stephen Farrell <[email-masked]>
Subject: Re: [lp-wan] Fwd: New Version Notification for draft-farrell-lpwan-overview-04.txt

Hi Alexander,

Cheers,

Alper

On Thu, Nov 3, 2016 at 12:22 AM, Alexander Pelov <[email-masked]<mailto:[email-masked]>> wrote:
Dear Alper, Carles,

Best,
Alexander

Le 2 nov. 2016 à 21:58, Alper Yegin <[email-masked]<mailto:[email-masked]>> a écrit :

Hi Carles,

Alper

On Wed, Nov 2, 2016 at 10:39 PM, Carles Gomez Montenegro <[email-masked]<mailto:[email-masked]>> wrote:
Hi Alper,

Cheers,

Carles

> On Wed, Nov 2, 2016 at 1:20 AM, Alexander Pelov <[email-masked]<mailto:[email-masked]>> wrote:
>
>> Dear Stephen,
>>
>> > Le 31 oct. 2016 à 23:53, Stephen Farrell <[email-masked]<mailto:[email-masked]>>
>> a
>> écrit :
>> >
>> >
>> >>> From: lp-wan [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Stephen
>> Farrell
>> >>> To: lp-wan <[email-masked]<mailto:[email-masked]>>
>> >>> From: [email-masked]<mailto:[email-masked]>
>> >>> To: Stephen Farrell <[email-masked]<mailto:[email-masked]>>
>> >>>
>> >>>
>> >>> until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org/>.
>> >>>
>> >>> The IETF Secretariat
>> >>>
>> >>
>> >> [email-masked]<mailto:[email-masked]>
>> > [email-masked]<mailto:[email-masked]>
>> [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]>

_______________________________________________
lp-wan mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lp-wan