Subject: [lp-wan] FW: LoRa Wireshark dissector at IETF97 hackathon

From: <[email-masked]>
Date: Thu, 10 Nov 2016 08:40:11 +0000

For your information.
Please join me if you're in town and are willing to contribute a little time or expertise.
See you there

Dominique

De : Dominique Barthel <[email-masked]<mailto:[email-masked]>>
Date : Thursday 10 November 2016 09:33
À : "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Objet : LoRa Wireshark dissector at IETF97 hackathon

Hello all,

I'll be attending the IETF97 hackathon (Saturday only) and welcome contributions to writing a Wireshark dissector for LoRaWAN.
LoRaWAN (http://www.lora-alliance.org/What-Is-LoRa/Technology) is one of the trending transmission technologies for the Internet of Things, and is one of the four technologies considered at the LPWA IETF Working Group.
Oddly enough, there doesn't seem to exist any (publicly known) Wireshark dissector for LoRa.
Such a dissector would be very useful for the LPWA Working Group going forward.
The closest I came across is
https://www.thethingsnetwork.org/forum/t/wireshark-lorawan-dissector/748/3
https://github.com/JiapengLi/lorawan-parser
At the hackathon, based on contributors expertise, we can

  *   discuss the various options for writing a Wireshark dissector (see e.g. http://sharkfest.wireshark.org/sharkfest.13/presentations/PA-10_Writing-a-Wireshark-Dissector_Graham-Bloice.zip )
  *   get started on one implementation, hoping to get something working, even if incomplete.

Please come and join me, even for a short time, if you have expertise or time to contribute.
Saturday only.
Best regards

Dominique

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Laurent Toutain <[email-masked]>
Date: Thu, 10 Nov 2016 09:50:31 +0100

Hi Dominique,

I'm arriving saturday at 0800 at Seoul, I can join in the afternoon.

Laurent

On Thu, Nov 10, 2016 at 9:40 AM, <[email-masked]> wrote:

> De : Dominique Barthel <[email-masked]>
> À : "[email-masked]" <[email-masked]>
> I'll be attending the IETF97 hackathon (Saturday only) and welcome
> contributions to writing a Wireshark dissector for LoRaWAN.
> LoRaWAN (http://www.lora-alliance.org/What-Is-LoRa/Technology) is one of
> the trending transmission technologies for the Internet of Things, and is
> one of the four technologies considered at the LPWA IETF Working Group.
>    - discuss the various options for writing a Wireshark dissector (see
>    e.g. http://sharkfest.wireshark.org/sharkfest.13/
>    presentations/PA-10_Writing-a-Wireshark-Dissector_Graham-Bloice.zip
>    <http://sharkfest.wireshark.org/sharkfest.13/presentations/PA-10_Writing-a-Wireshark-Dissector_Graham-Bloice.zip>
>     )
>    - get started on one implementation, hoping to get something working,
>    even if incomplete.
>
> _______________________________________________
> lp-wan mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lp-wan
>
>

-- 
Laurent Toutain
+--- VoIP (recommended) ---+----------- Télécom Bretagne -----------+
| Tel: +33 2 22 06 8156    | Tel: + 33 2 99 12 7026                 | Visit
:
| Mob: +33 6 800 75 900    |                                        |
| Fax: +33 2 22 06 8445    | Fax: +33 2 99 12 7030                  |
http://class.touta.in
| [email-masked]         | [email-masked]    |
+--------------------------+----------------------------------------+

---

From: Remy Leone <[email-masked]>
Date: Mon, 14 Nov 2016 09:02:40 +0000

Could you put the outcome of this hackathon online? I would like to test it
and help contribute it upstream to wireshark if the licence allows it.

Best regards

Rémy

Le jeu. 10 nov. 2016 à 09:51, Laurent Toutain <
[email-masked]> a écrit :

>    e.g.
>    http://sharkfest.wireshark.org/sharkfest.13/presentations/PA-10_Writing-a-Wireshark-Dissector_Graham-Bloice.zip
>     )
> | Tel: +33 2 22 06 8156 <02%2022%2006%2081%2056>    | Tel: + 33 2 99 12
> 7026 <02%2099%2012%2070%2026>                 | Visit :
> | Fax: +33 2 22 06 8445 <02%2022%2006%2084%2045>    | Fax: +33 2 99 12
> 7030 <02%2099%2012%2070%2030>                  |  http://class.touta.in

---

From: <[email-masked]>
Date: Mon, 14 Nov 2016 09:41:19 +0000

Hello all,

As promised, here's a little write-up of our progress.
We started from an earlier code provided by Leo (https://github.com/Ekleog/wireshark). We got to know about this code thanks to the announcement on the hackathon mailing list.
Laurent and myself worked on the code on Saturday, fixed a few issues and got the basic stuff working.
We can now successfully dissect the basic fields in the LoRaWAN 1.0.1 headers.
We still have to process some optional, variable length fields, as well as further dissect some fields into detailed bit fields.
We will continue this development during the IETF97 meeting.
One aspect I don't have a clear vision on yet is how to handle MIC checking and payload encryption. I''look at how this is handled in the 802.15.4 dissector. Your thoughts welcome.
Do we assume that the dissector sees the initial JoinRequest and JoinAccept exchange and is therefore able to derive and memorize the session keys by itself? Or do we assume that these keys will handed to it off-band?
Regarding code availability, right now the code is on a private repo.
It will shortly be made available to the public via GitHub.
Remy, when did you intend to contribute? Were you thinking this week, or later? Are you physically in Seoul?
Best regards

Dominique

De : Remy Leone <[email-masked]<mailto:[email-masked]>>
Date : Monday 14 November 2016 18:02
À : "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Dominique Barthel <[email-masked]<mailto:[email-masked]>>
Cc : "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Objet : Re: [lp-wan] FW: LoRa Wireshark dissector at IETF97 hackathon

Could you put the outcome of this hackathon online? I would like to test it and help contribute it upstream to wireshark if the licence allows it.

Best regards

Rémy

Le jeu. 10 nov. 2016 à 09:51, Laurent Toutain <[email-masked]<mailto:[email-masked]>> a écrit :
Hi Dominique,

Laurent

On Thu, Nov 10, 2016 at 9:40 AM, <[email-masked]<mailto:[email-masked]>> wrote:
For your information.
Please join me if you're in town and are willing to contribute a little time or expertise.
See you there

Dominique

Hello all,

Dominique

_______________________________________________
lp-wan mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lp-wan

--
Laurent Toutain
+--- VoIP (recommended) ---+----------- Télécom Bretagne -----------+
| Tel: +33 2 22 06 8156<tel:02%2022%2006%2081%2056>    | Tel: + 33 2 99 12 7026<tel:02%2099%2012%2070%2026>                 | Visit :
| Mob: +33 6 800 75 900    |                                        |
| Fax: +33 2 22 06 8445<tel:02%2022%2006%2084%2045>    | Fax: +33 2 99 12 7030<tel:02%2099%2012%2070%2030>                  |  http://class.touta.in
| [email-masked]<mailto:[email-masked]>         | [email-masked]<mailto:[email-masked]>    |
+--------------------------+----------------------------------------+
_______________________________________________
lp-wan mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/lp-wan

---

From: Remy Leone <[email-masked]>
Date: Mon, 14 Nov 2016 10:47:28 +0000

Thanks for sharing. I'm not in Seoul but I can try to test it on a LoRaWAN
gateway that I got here. For the timeline I can get started once it's
public and we will see from there.

Le lun. 14 nov. 2016 à 10:41, <[email-masked]> a écrit :

> We started from an earlier code provided by Leo (
> https://github.com/Ekleog/wireshark). We got to know about this code
> thanks to the announcement on the hackathon mailing list.
> We still have to process some optional, variable length fields, as well as
> further dissect some fields into detailed bit fields.
> One aspect I don't have a clear vision on yet is how to handle MIC
> checking and payload encryption. I''look at how this is handled in the
> 802.15.4 dissector. Your thoughts welcome.
> Do we assume that the dissector sees the initial JoinRequest and
> JoinAccept exchange and is therefore able to derive and memorize the
> session keys by itself? Or do we assume that these keys will handed to it
> off-band?
> De : Remy Leone <[email-masked]>
> À : "[email-masked]" <
> [email-masked]>, Dominique Barthel <
> [email-masked]>
> Cc : "[email-masked]" <[email-masked]>
> Could you put the outcome of this hackathon online? I would like to test
> it and help contribute it upstream to wireshark if the licence allows it.
>
> Best regards
>
> Rémy
>

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Mon, 14 Nov 2016 08:08:44 -0300

Dear all,
            I am also interested in the dissector implementation,
we have a couple of LoRaWAN gateways and several nodes
where to test them and collaborate with the dissector.
Regards,

                                  Diego

2016-11-14 7:47 GMT-03:00 Remy Leone <[email-masked]>:

>> We still have to process some optional, variable length fields, as well
>> as further dissect some fields into detailed bit fields.
>> À : "[email-masked]" <Laurent.Toutain@telecom-
>> bretagne.eu>, Dominique Barthel <[email-masked]>
>> Le jeu. 10 nov. 2016 à 09:51, Laurent Toutain <Laurent.Toutain@telecom-
>> bretagne.eu> a écrit :
>>
>> Hi Dominique,
>>

-- 
DIEGO DUJOVNE
Profesor Asociado
Escuela de Informática y Telecomunicaciones
Facultad de Ingeniería - Universidad Diego Portales - Chile
www.ingenieria.udp.cl
(56 2) 676 8125